All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH linux-next] nvdimm/namespace:Use the function kobj_to_dev()
@ 2022-08-11  1:31 cgel.zte
  2022-09-02  3:21 ` Ira Weiny
  0 siblings, 1 reply; 3+ messages in thread
From: cgel.zte @ 2022-08-11  1:31 UTC (permalink / raw)
  To: dan.j.williams
  Cc: vishal.l.verma, dave.jiang, ira.weiny, nvdimm, ye xingchen, Zeal Robot

From: ye xingchen <ye.xingchen@zte.com.cn>

Use kobj_to_dev() instead of open-coding it.

Reported-by: Zeal Robot <zealci@zte.com.cn>
Signed-off-by: ye xingchen <ye.xingchen@zte.com.cn>
---
 drivers/nvdimm/namespace_devs.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/nvdimm/namespace_devs.c b/drivers/nvdimm/namespace_devs.c
index dfade66bab73..fd2e8ca67001 100644
--- a/drivers/nvdimm/namespace_devs.c
+++ b/drivers/nvdimm/namespace_devs.c
@@ -1372,7 +1372,7 @@ static struct attribute *nd_namespace_attributes[] = {
 static umode_t namespace_visible(struct kobject *kobj,
 		struct attribute *a, int n)
 {
-	struct device *dev = container_of(kobj, struct device, kobj);
+	struct device *dev = kobj_to_dev(kobj);
 
 	if (is_namespace_pmem(dev)) {
 		if (a == &dev_attr_size.attr)
-- 
2.25.1

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH linux-next] nvdimm/namespace:Use the function kobj_to_dev()
  2022-08-11  1:31 [PATCH linux-next] nvdimm/namespace:Use the function kobj_to_dev() cgel.zte
@ 2022-09-02  3:21 ` Ira Weiny
  2022-09-20 17:25   ` Dan Williams
  0 siblings, 1 reply; 3+ messages in thread
From: Ira Weiny @ 2022-09-02  3:21 UTC (permalink / raw)
  To: cgel.zte
  Cc: dan.j.williams, vishal.l.verma, dave.jiang, nvdimm, ye xingchen,
	Zeal Robot

On Thu, Aug 11, 2022 at 01:31:06AM +0000, cgel.zte@gmail.com wrote:
> From: ye xingchen <ye.xingchen@zte.com.cn>
> 
> Use kobj_to_dev() instead of open-coding it.

I see at least 5 other places where this pattern applies in drivers/nvdimm.  Is
this some general conversion being done on the entire kernel?  If so why not
convert entire drivers at a time?

Ira

> 
> Reported-by: Zeal Robot <zealci@zte.com.cn>
> Signed-off-by: ye xingchen <ye.xingchen@zte.com.cn>
> ---
>  drivers/nvdimm/namespace_devs.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/nvdimm/namespace_devs.c b/drivers/nvdimm/namespace_devs.c
> index dfade66bab73..fd2e8ca67001 100644
> --- a/drivers/nvdimm/namespace_devs.c
> +++ b/drivers/nvdimm/namespace_devs.c
> @@ -1372,7 +1372,7 @@ static struct attribute *nd_namespace_attributes[] = {
>  static umode_t namespace_visible(struct kobject *kobj,
>  		struct attribute *a, int n)
>  {
> -	struct device *dev = container_of(kobj, struct device, kobj);
> +	struct device *dev = kobj_to_dev(kobj);
>  
>  	if (is_namespace_pmem(dev)) {
>  		if (a == &dev_attr_size.attr)
> -- 
> 2.25.1

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH linux-next] nvdimm/namespace:Use the function kobj_to_dev()
  2022-09-02  3:21 ` Ira Weiny
@ 2022-09-20 17:25   ` Dan Williams
  0 siblings, 0 replies; 3+ messages in thread
From: Dan Williams @ 2022-09-20 17:25 UTC (permalink / raw)
  To: Ira Weiny, cgel.zte
  Cc: dan.j.williams, vishal.l.verma, dave.jiang, nvdimm, ye xingchen,
	Zeal Robot

Ira Weiny wrote:
> On Thu, Aug 11, 2022 at 01:31:06AM +0000, cgel.zte@gmail.com wrote:
> > From: ye xingchen <ye.xingchen@zte.com.cn>
> > 
> > Use kobj_to_dev() instead of open-coding it.
> 
> I see at least 5 other places where this pattern applies in drivers/nvdimm.  Is
> this some general conversion being done on the entire kernel?  If so why not
> convert entire drivers at a time?

Yes, please convert all of these at once:

drivers/nvdimm/bus.c:693:	struct device *dev = container_of(kobj, typeof(*dev), kobj);
drivers/nvdimm/core.c:469:	struct device *dev = container_of(kobj, typeof(*dev), kobj);
drivers/nvdimm/dimm_devs.c:412:	struct device *dev = container_of(kobj, typeof(*dev), kobj);
drivers/nvdimm/dimm_devs.c:528:	struct device *dev = container_of(kobj, typeof(*dev), kobj);
drivers/nvdimm/namespace_devs.c:1383:	struct device *dev = container_of(kobj, struct device, kobj);
drivers/nvdimm/region_devs.c:610:	struct device *dev = container_of(kobj, typeof(*dev), kobj);
drivers/nvdimm/region_devs.c:724:	struct device *dev = container_of(kobj, struct device, kobj);

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-09-20 17:26 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-08-11  1:31 [PATCH linux-next] nvdimm/namespace:Use the function kobj_to_dev() cgel.zte
2022-09-02  3:21 ` Ira Weiny
2022-09-20 17:25   ` Dan Williams

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.