All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] ANDROID: binder: rename parameter to resolve name collision.
@ 2018-05-30  4:58 kuangrufan
       [not found] ` <CAHRSSEySzqTb-m5Rjv23PuUHi2q4OY485JJjFi1AeLiKL1KJQQ@mail.gmail.com>
  0 siblings, 1 reply; 2+ messages in thread
From: kuangrufan @ 2018-05-30  4:58 UTC (permalink / raw)
  To: linux-kernel
  Cc: Kuang Rufan, Greg Kroah-Hartman, Arve Hjønnevåg,
	Todd Kjos, Martijn Coenen, devel

From: Kuang Rufan <kuangrufan@iauto.com>

both bind.c & binder_alloc.c define the same kernel parameter 'debug_mask',
rename the one in binder_alloc.c to 'alloc_debug_mask'.

Signed-off-by: Kuang Rufan <kuangrufan@iauto.com>
---
 drivers/android/binder_alloc.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/android/binder_alloc.c b/drivers/android/binder_alloc.c
index 5a426c877dfb..3850dab493d4 100644
--- a/drivers/android/binder_alloc.c
+++ b/drivers/android/binder_alloc.c
@@ -42,7 +42,7 @@ enum {
 };
 static uint32_t binder_alloc_debug_mask;
 
-module_param_named(debug_mask, binder_alloc_debug_mask,
+module_param_named(alloc_debug_mask, binder_alloc_debug_mask,
 		   uint, 0644);
 
 #define binder_alloc_debug(mask, x...) \
-- 
2.15.1 (Apple Git-101)

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] ANDROID: binder: rename parameter to resolve name collision.
       [not found] ` <CAHRSSEySzqTb-m5Rjv23PuUHi2q4OY485JJjFi1AeLiKL1KJQQ@mail.gmail.com>
@ 2018-05-31  3:15   ` kuangrufan
  0 siblings, 0 replies; 2+ messages in thread
From: kuangrufan @ 2018-05-31  3:15 UTC (permalink / raw)
  To: Todd Kjos
  Cc: LKML, Greg Kroah-Hartman, Arve Hjønnevåg, Todd Kjos,
	Martijn Coenen, open list:ANDROID DRIVERS

> Why is this needed? These don't collide in the namespace:
Sorry, I check it again, you’re right. my bad.

PS:
I need to change the binder API between 32bit & 64bit dynamically.
So I was trying to compile binder as a “.ko”. I compiled the 2
files into the same kernel module, which causes problem.

Best Regards,

> 在 2018年5月30日,下午11:54,Todd Kjos <tkjos@google.com> 写道:
> 
> Why is this needed? These don't collide in the namespace:
> 
> /sys/module/binder/parameters/debug_mask
> 
> and
> 
> /sys/module/binder_alloc/parameters/debug_mask.
> 
> On Tue, May 29, 2018 at 9:58 PM <kuangrufan@iauto.com> wrote:
> From: Kuang Rufan <kuangrufan@iauto.com>
> 
> both bind.c & binder_alloc.c define the same kernel parameter 'debug_mask',
> rename the one in binder_alloc.c to 'alloc_debug_mask'.
> 
> Signed-off-by: Kuang Rufan <kuangrufan@iauto.com>
> ---
>  drivers/android/binder_alloc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/android/binder_alloc.c b/drivers/android/binder_alloc.c
> index 5a426c877dfb..3850dab493d4 100644
> --- a/drivers/android/binder_alloc.c
> +++ b/drivers/android/binder_alloc.c
> @@ -42,7 +42,7 @@ enum {
>  };
>  static uint32_t binder_alloc_debug_mask;
> 
> -module_param_named(debug_mask, binder_alloc_debug_mask,
> +module_param_named(alloc_debug_mask, binder_alloc_debug_mask,
>                    uint, 0644);
> 
>  #define binder_alloc_debug(mask, x...) \
> -- 
> 2.15.1 (Apple Git-101)
> 

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2018-05-31  3:15 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-05-30  4:58 [PATCH] ANDROID: binder: rename parameter to resolve name collision kuangrufan
     [not found] ` <CAHRSSEySzqTb-m5Rjv23PuUHi2q4OY485JJjFi1AeLiKL1KJQQ@mail.gmail.com>
2018-05-31  3:15   ` kuangrufan

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.