All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/2] have net drivers use a standard map file name format
@ 2017-09-14 15:57 Bruce Richardson
  2017-09-14 15:57 ` [PATCH 1/2] net/bonding: rename map file to standard name Bruce Richardson
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Bruce Richardson @ 2017-09-14 15:57 UTC (permalink / raw)
  To: ferruh.yigit, jianfeng.tan, declan.doherty; +Cc: dev, Bruce Richardson

rename some of the version.map files that don't match the standard naming
convention. For future meson build system, this will save us having to
specify for each driver what the filename of its map file is.

Bruce Richardson (2):
  net/bonding: rename map file to standard name
  net/xenvirt: rename map file to standard name

 drivers/net/bonding/Makefile                                            | 2 +-
 .../net/bonding/{rte_eth_bond_version.map => rte_pmd_bond_version.map}  | 0
 drivers/net/xenvirt/Makefile                                            | 2 +-
 .../{rte_eth_xenvirt_version.map => rte_pmd_xenvirt_version.map}        | 0
 4 files changed, 2 insertions(+), 2 deletions(-)
 rename drivers/net/bonding/{rte_eth_bond_version.map => rte_pmd_bond_version.map} (100%)
 rename drivers/net/xenvirt/{rte_eth_xenvirt_version.map => rte_pmd_xenvirt_version.map} (100%)

-- 
2.13.5

^ permalink raw reply	[flat|nested] 7+ messages in thread

* [PATCH 1/2] net/bonding: rename map file to standard name
  2017-09-14 15:57 [PATCH 0/2] have net drivers use a standard map file name format Bruce Richardson
@ 2017-09-14 15:57 ` Bruce Richardson
  2017-09-20 13:42   ` Ferruh Yigit
  2017-09-14 15:57 ` [PATCH 2/2] net/xenvirt: " Bruce Richardson
  2017-09-14 16:34 ` [PATCH 0/2] have net drivers use a standard map file name format Ferruh Yigit
  2 siblings, 1 reply; 7+ messages in thread
From: Bruce Richardson @ 2017-09-14 15:57 UTC (permalink / raw)
  To: ferruh.yigit, jianfeng.tan, declan.doherty; +Cc: dev, Bruce Richardson

Naming convention for net drivers is "rte_pmd_<name>_version.map"

Signed-off-by: Bruce Richardson <bruce.richardson@intel.com>
---
 drivers/net/bonding/Makefile                                            | 2 +-
 .../net/bonding/{rte_eth_bond_version.map => rte_pmd_bond_version.map}  | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/net/bonding/{rte_eth_bond_version.map => rte_pmd_bond_version.map} (100%)

diff --git a/drivers/net/bonding/Makefile b/drivers/net/bonding/Makefile
index 910c932da..ab8b6894a 100644
--- a/drivers/net/bonding/Makefile
+++ b/drivers/net/bonding/Makefile
@@ -39,7 +39,7 @@ LIB = librte_pmd_bond.a
 CFLAGS += -O3
 CFLAGS += $(WERROR_FLAGS)
 
-EXPORT_MAP := rte_eth_bond_version.map
+EXPORT_MAP := rte_pmd_bond_version.map
 
 LIBABIVER := 1
 
diff --git a/drivers/net/bonding/rte_eth_bond_version.map b/drivers/net/bonding/rte_pmd_bond_version.map
similarity index 100%
rename from drivers/net/bonding/rte_eth_bond_version.map
rename to drivers/net/bonding/rte_pmd_bond_version.map
-- 
2.13.5

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* [PATCH 2/2] net/xenvirt: rename map file to standard name
  2017-09-14 15:57 [PATCH 0/2] have net drivers use a standard map file name format Bruce Richardson
  2017-09-14 15:57 ` [PATCH 1/2] net/bonding: rename map file to standard name Bruce Richardson
@ 2017-09-14 15:57 ` Bruce Richardson
  2017-09-20 13:42   ` Ferruh Yigit
  2017-09-14 16:34 ` [PATCH 0/2] have net drivers use a standard map file name format Ferruh Yigit
  2 siblings, 1 reply; 7+ messages in thread
From: Bruce Richardson @ 2017-09-14 15:57 UTC (permalink / raw)
  To: ferruh.yigit, jianfeng.tan, declan.doherty; +Cc: dev, Bruce Richardson

Naming convention for net drivers is "rte_pmd_<name>_version.map"

Signed-off-by: Bruce Richardson <bruce.richardson@intel.com>
---
 drivers/net/xenvirt/Makefile                                            | 2 +-
 .../{rte_eth_xenvirt_version.map => rte_pmd_xenvirt_version.map}        | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/net/xenvirt/{rte_eth_xenvirt_version.map => rte_pmd_xenvirt_version.map} (100%)

diff --git a/drivers/net/xenvirt/Makefile b/drivers/net/xenvirt/Makefile
index 8b4b8f037..bf5db050f 100644
--- a/drivers/net/xenvirt/Makefile
+++ b/drivers/net/xenvirt/Makefile
@@ -40,7 +40,7 @@ CFLAGS += -O3
 CFLAGS += $(WERROR_FLAGS)
 LDLIBS += -lxenstore
 
-EXPORT_MAP := rte_eth_xenvirt_version.map
+EXPORT_MAP := rte_pmd_xenvirt_version.map
 
 LIBABIVER := 1
 
diff --git a/drivers/net/xenvirt/rte_eth_xenvirt_version.map b/drivers/net/xenvirt/rte_pmd_xenvirt_version.map
similarity index 100%
rename from drivers/net/xenvirt/rte_eth_xenvirt_version.map
rename to drivers/net/xenvirt/rte_pmd_xenvirt_version.map
-- 
2.13.5

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH 0/2] have net drivers use a standard map file name format
  2017-09-14 15:57 [PATCH 0/2] have net drivers use a standard map file name format Bruce Richardson
  2017-09-14 15:57 ` [PATCH 1/2] net/bonding: rename map file to standard name Bruce Richardson
  2017-09-14 15:57 ` [PATCH 2/2] net/xenvirt: " Bruce Richardson
@ 2017-09-14 16:34 ` Ferruh Yigit
  2017-09-14 16:36   ` Richardson, Bruce
  2 siblings, 1 reply; 7+ messages in thread
From: Ferruh Yigit @ 2017-09-14 16:34 UTC (permalink / raw)
  To: Bruce Richardson, jianfeng.tan, declan.doherty; +Cc: dev

On 9/14/2017 4:57 PM, Bruce Richardson wrote:
> rename some of the version.map files that don't match the standard naming
> convention. For future meson build system, this will save us having to
> specify for each driver what the filename of its map file is.
> 
> Bruce Richardson (2):
>   net/bonding: rename map file to standard name
>   net/xenvirt: rename map file to standard name

+1 for bonding,
but xenvirt is going away in this release, can we drop that one?

> 
>  drivers/net/bonding/Makefile                                            | 2 +-
>  .../net/bonding/{rte_eth_bond_version.map => rte_pmd_bond_version.map}  | 0
>  drivers/net/xenvirt/Makefile                                            | 2 +-
>  .../{rte_eth_xenvirt_version.map => rte_pmd_xenvirt_version.map}        | 0
>  4 files changed, 2 insertions(+), 2 deletions(-)
>  rename drivers/net/bonding/{rte_eth_bond_version.map => rte_pmd_bond_version.map} (100%)
>  rename drivers/net/xenvirt/{rte_eth_xenvirt_version.map => rte_pmd_xenvirt_version.map} (100%)
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH 0/2] have net drivers use a standard map file name format
  2017-09-14 16:34 ` [PATCH 0/2] have net drivers use a standard map file name format Ferruh Yigit
@ 2017-09-14 16:36   ` Richardson, Bruce
  0 siblings, 0 replies; 7+ messages in thread
From: Richardson, Bruce @ 2017-09-14 16:36 UTC (permalink / raw)
  To: Yigit, Ferruh, Tan, Jianfeng, Doherty, Declan; +Cc: dev



> -----Original Message-----
> From: Yigit, Ferruh
> Sent: Thursday, September 14, 2017 5:34 PM
> To: Richardson, Bruce <bruce.richardson@intel.com>; Tan, Jianfeng
> <jianfeng.tan@intel.com>; Doherty, Declan <declan.doherty@intel.com>
> Cc: dev@dpdk.org
> Subject: Re: [PATCH 0/2] have net drivers use a standard map file name
> format
> 
> On 9/14/2017 4:57 PM, Bruce Richardson wrote:
> > rename some of the version.map files that don't match the standard
> > naming convention. For future meson build system, this will save us
> > having to specify for each driver what the filename of its map file is.
> >
> > Bruce Richardson (2):
> >   net/bonding: rename map file to standard name
> >   net/xenvirt: rename map file to standard name
> 
> +1 for bonding,
> but xenvirt is going away in this release, can we drop that one?
> 
Good point. Please ignore patch 2, and take only patch 1.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH 1/2] net/bonding: rename map file to standard name
  2017-09-14 15:57 ` [PATCH 1/2] net/bonding: rename map file to standard name Bruce Richardson
@ 2017-09-20 13:42   ` Ferruh Yigit
  0 siblings, 0 replies; 7+ messages in thread
From: Ferruh Yigit @ 2017-09-20 13:42 UTC (permalink / raw)
  To: Bruce Richardson, jianfeng.tan, declan.doherty; +Cc: dev

On 9/14/2017 4:57 PM, Bruce Richardson wrote:
> Naming convention for net drivers is "rte_pmd_<name>_version.map"
> 
> Signed-off-by: Bruce Richardson <bruce.richardson@intel.com>

Applied to dpdk-next-net/master, thanks.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH 2/2] net/xenvirt: rename map file to standard name
  2017-09-14 15:57 ` [PATCH 2/2] net/xenvirt: " Bruce Richardson
@ 2017-09-20 13:42   ` Ferruh Yigit
  0 siblings, 0 replies; 7+ messages in thread
From: Ferruh Yigit @ 2017-09-20 13:42 UTC (permalink / raw)
  To: Bruce Richardson, jianfeng.tan, declan.doherty; +Cc: dev

On 9/14/2017 4:57 PM, Bruce Richardson wrote:
> Naming convention for net drivers is "rte_pmd_<name>_version.map"
> 
> Signed-off-by: Bruce Richardson <bruce.richardson@intel.com>

This one not get, because xenvirt will be removed this release.

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2017-09-20 13:43 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-09-14 15:57 [PATCH 0/2] have net drivers use a standard map file name format Bruce Richardson
2017-09-14 15:57 ` [PATCH 1/2] net/bonding: rename map file to standard name Bruce Richardson
2017-09-20 13:42   ` Ferruh Yigit
2017-09-14 15:57 ` [PATCH 2/2] net/xenvirt: " Bruce Richardson
2017-09-20 13:42   ` Ferruh Yigit
2017-09-14 16:34 ` [PATCH 0/2] have net drivers use a standard map file name format Ferruh Yigit
2017-09-14 16:36   ` Richardson, Bruce

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.