All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v3 0/3] Add Hynitron cstxxx Touchscreen
@ 2022-10-10 15:35 Chris Morgan
  2022-10-10 15:35 ` [PATCH v3 1/3] dt-bindings: vendor-prefixes: add Hynitron vendor prefix Chris Morgan
                   ` (2 more replies)
  0 siblings, 3 replies; 10+ messages in thread
From: Chris Morgan @ 2022-10-10 15:35 UTC (permalink / raw)
  To: linux-input
  Cc: devicetree, jeff, neil.armstrong, arnd, robert.jarzmik,
	Jonathan.Cameron, christianshewitt, stano.jakubek, rydberg,
	krzysztof.kozlowski+dt, robh+dt, dmitry.torokhov, Chris Morgan

From: Chris Morgan <macromorgan@hotmail.com>

This series adds support for the Hynitron cstxxx (specifically
the cst3xx series). The cst3xx supports 5 point multitouch with
hardware tracking of touch points.

Note that a datasheet was unavailable for this device, so it was
built based on vendor provided source code that was tagged as GPLv2.
Some of the register functions were discovered via trial and error
and labelled as such.

Changes from V2:
 - Fix issue identified by Intel Kernel Test Robot. Changed functions
   in driver to static. Reported-by: kernel test robot <lkp@intel.com>

Changes from V1:
 - Updated binding to specify cst340 instead of generic cst3xx.
 - Defined various registers and commands to enhance code readability.
 - Changed name of chip specific struct to hynitron_ts_chip_data.
 - Removed unused and redundant values from driver data.
 - Switch to gpiod cansleep functions in reset.
 - Refactored read/write i2c functions.
 - Changed variable names of ret to err in certain functions and added
   additional error handling in input registration function.

Chris Morgan (3):
  dt-bindings: vendor-prefixes: add Hynitron vendor prefix
  dt-bindings: input: touchscreen: Add Hynitron cstxxx
  input/touchscreen: Add Hynitron cstxxx touchscreen

 .../input/touchscreen/hynitron,cstxxx.yaml    |  65 +++
 .../devicetree/bindings/vendor-prefixes.yaml  |   2 +
 drivers/input/touchscreen/Kconfig             |  12 +
 drivers/input/touchscreen/Makefile            |   1 +
 drivers/input/touchscreen/hynitron_cstxxx.c   | 508 ++++++++++++++++++
 5 files changed, 588 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/input/touchscreen/hynitron,cstxxx.yaml
 create mode 100644 drivers/input/touchscreen/hynitron_cstxxx.c

-- 
2.25.1


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2022-10-28 20:10 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-10-10 15:35 [PATCH v3 0/3] Add Hynitron cstxxx Touchscreen Chris Morgan
2022-10-10 15:35 ` [PATCH v3 1/3] dt-bindings: vendor-prefixes: add Hynitron vendor prefix Chris Morgan
2022-10-10 15:35 ` [PATCH v3 2/3] dt-bindings: input: touchscreen: Add Hynitron cstxxx Chris Morgan
2022-10-10 15:35 ` [PATCH v3 3/3] input/touchscreen: Add Hynitron cstxxx touchscreen Chris Morgan
2022-10-21 13:56   ` Mattijs Korpershoek
2022-10-26 19:24     ` Chris Morgan
2022-10-27  8:13       ` Mattijs Korpershoek
2022-10-28 19:49         ` Chris Morgan
2022-10-28 20:01           ` Dmitry Torokhov
2022-10-28 20:10     ` Dmitry Torokhov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.