All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix
@ 2020-11-21 16:09 Vlad Buslov
  2020-11-23  0:11 ` Jamal Hadi Salim
  2020-11-23 21:22 ` Jakub Kicinski
  0 siblings, 2 replies; 7+ messages in thread
From: Vlad Buslov @ 2020-11-21 16:09 UTC (permalink / raw)
  To: netdev, davem, kuba; +Cc: jhs, xiyou.wangcong, jiri, Vlad Buslov

Currently both filter and action flags use same "TCA_" prefix which makes
them hard to distinguish to code and confusing for users. Create aliases
for existing action flags constants with "TCA_ACT_" prefix.

Signed-off-by: Vlad Buslov <vlad@buslov.dev>
---
 include/uapi/linux/rtnetlink.h | 11 +++++++----
 net/sched/act_api.c            | 10 +++++-----
 2 files changed, 12 insertions(+), 9 deletions(-)

diff --git a/include/uapi/linux/rtnetlink.h b/include/uapi/linux/rtnetlink.h
index 2ffbef5da6c1..91db081e5360 100644
--- a/include/uapi/linux/rtnetlink.h
+++ b/include/uapi/linux/rtnetlink.h
@@ -768,16 +768,19 @@ enum {
 #define TA_PAYLOAD(n) NLMSG_PAYLOAD(n,sizeof(struct tcamsg))
 /* tcamsg flags stored in attribute TCA_ROOT_FLAGS
  *
- * TCA_FLAG_LARGE_DUMP_ON user->kernel to request for larger than TCA_ACT_MAX_PRIO
- * actions in a dump. All dump responses will contain the number of actions
- * being dumped stored in for user app's consumption in TCA_ROOT_COUNT
+ * TCA_ACT_FLAG_LARGE_DUMP_ON user->kernel to request for larger than
+ * TCA_ACT_MAX_PRIO actions in a dump. All dump responses will contain the
+ * number of actions being dumped stored in for user app's consumption in
+ * TCA_ROOT_COUNT
  *
- * TCA_FLAG_TERSE_DUMP user->kernel to request terse (brief) dump that only
+ * TCA_ACT_FLAG_TERSE_DUMP user->kernel to request terse (brief) dump that only
  * includes essential action info (kind, index, etc.)
  *
  */
 #define TCA_FLAG_LARGE_DUMP_ON		(1 << 0)
+#define TCA_ACT_FLAG_LARGE_DUMP_ON	TCA_FLAG_LARGE_DUMP_ON
 #define TCA_FLAG_TERSE_DUMP		(1 << 1)
+#define TCA_ACT_FLAG_TERSE_DUMP		TCA_FLAG_TERSE_DUMP
 
 /* New extended info filters for IFLA_EXT_MASK */
 #define RTEXT_FILTER_VF		(1 << 0)
diff --git a/net/sched/act_api.c b/net/sched/act_api.c
index fc23f46a315c..99db1c77426b 100644
--- a/net/sched/act_api.c
+++ b/net/sched/act_api.c
@@ -278,7 +278,7 @@ static int tcf_dump_walker(struct tcf_idrinfo *idrinfo, struct sk_buff *skb,
 			index--;
 			goto nla_put_failure;
 		}
-		err = (act_flags & TCA_FLAG_TERSE_DUMP) ?
+		err = (act_flags & TCA_ACT_FLAG_TERSE_DUMP) ?
 			tcf_action_dump_terse(skb, p, true) :
 			tcf_action_dump_1(skb, p, 0, 0);
 		if (err < 0) {
@@ -288,7 +288,7 @@ static int tcf_dump_walker(struct tcf_idrinfo *idrinfo, struct sk_buff *skb,
 		}
 		nla_nest_end(skb, nest);
 		n_i++;
-		if (!(act_flags & TCA_FLAG_LARGE_DUMP_ON) &&
+		if (!(act_flags & TCA_ACT_FLAG_LARGE_DUMP_ON) &&
 		    n_i >= TCA_ACT_MAX_PRIO)
 			goto done;
 	}
@@ -298,7 +298,7 @@ static int tcf_dump_walker(struct tcf_idrinfo *idrinfo, struct sk_buff *skb,
 
 	mutex_unlock(&idrinfo->lock);
 	if (n_i) {
-		if (act_flags & TCA_FLAG_LARGE_DUMP_ON)
+		if (act_flags & TCA_ACT_FLAG_LARGE_DUMP_ON)
 			cb->args[1] = n_i;
 	}
 	return n_i;
@@ -1473,8 +1473,8 @@ static int tcf_action_add(struct net *net, struct nlattr *nla,
 }
 
 static const struct nla_policy tcaa_policy[TCA_ROOT_MAX + 1] = {
-	[TCA_ROOT_FLAGS] = NLA_POLICY_BITFIELD32(TCA_FLAG_LARGE_DUMP_ON |
-						 TCA_FLAG_TERSE_DUMP),
+	[TCA_ROOT_FLAGS] = NLA_POLICY_BITFIELD32(TCA_ACT_FLAG_LARGE_DUMP_ON |
+						 TCA_ACT_FLAG_TERSE_DUMP),
 	[TCA_ROOT_TIME_DELTA]      = { .type = NLA_U32 },
 };
 
-- 
2.29.1


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix
  2020-11-21 16:09 [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix Vlad Buslov
@ 2020-11-23  0:11 ` Jamal Hadi Salim
  2020-11-23 21:22 ` Jakub Kicinski
  1 sibling, 0 replies; 7+ messages in thread
From: Jamal Hadi Salim @ 2020-11-23  0:11 UTC (permalink / raw)
  To: Vlad Buslov, netdev, davem, kuba; +Cc: xiyou.wangcong, jiri

On 2020-11-21 11:09 a.m., Vlad Buslov wrote:
> Currently both filter and action flags use same "TCA_" prefix which makes
> them hard to distinguish to code and confusing for users. Create aliases
> for existing action flags constants with "TCA_ACT_" prefix.
> 
> Signed-off-by: Vlad Buslov <vlad@buslov.dev>

LGTM, thanks for the effort
.
Acked-by: Jamal Hadi Salim <jhs@mojatatu.com>

cheers,
jamal

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix
  2020-11-21 16:09 [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix Vlad Buslov
  2020-11-23  0:11 ` Jamal Hadi Salim
@ 2020-11-23 21:22 ` Jakub Kicinski
  2020-11-24  9:28   ` Vlad Buslov
  1 sibling, 1 reply; 7+ messages in thread
From: Jakub Kicinski @ 2020-11-23 21:22 UTC (permalink / raw)
  To: Vlad Buslov; +Cc: netdev, davem, jhs, xiyou.wangcong, jiri

On Sat, 21 Nov 2020 18:09:02 +0200 Vlad Buslov wrote:
> Currently both filter and action flags use same "TCA_" prefix which makes
> them hard to distinguish to code and confusing for users. Create aliases
> for existing action flags constants with "TCA_ACT_" prefix.
> 
> Signed-off-by: Vlad Buslov <vlad@buslov.dev>

Are we expecting to add both aliases for all new flags?

TCA_FLAG_TERSE_DUMP exists only in net-next, we could rename it, right?

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix
  2020-11-23 21:22 ` Jakub Kicinski
@ 2020-11-24  9:28   ` Vlad Buslov
  2020-11-24 13:39     ` Jamal Hadi Salim
  2020-11-24 16:24     ` Jakub Kicinski
  0 siblings, 2 replies; 7+ messages in thread
From: Vlad Buslov @ 2020-11-24  9:28 UTC (permalink / raw)
  To: Jakub Kicinski; +Cc: netdev, davem, jhs, xiyou.wangcong, jiri

On Mon 23 Nov 2020 at 23:22, Jakub Kicinski <kuba@kernel.org> wrote:
> On Sat, 21 Nov 2020 18:09:02 +0200 Vlad Buslov wrote:
>> Currently both filter and action flags use same "TCA_" prefix which makes
>> them hard to distinguish to code and confusing for users. Create aliases
>> for existing action flags constants with "TCA_ACT_" prefix.
>> 
>> Signed-off-by: Vlad Buslov <vlad@buslov.dev>
>
> Are we expecting to add both aliases for all new flags?

I don't think it makes sense to have both aliases for any new flags.

>
> TCA_FLAG_TERSE_DUMP exists only in net-next, we could rename it, right?

You are right. I'll send a fix.


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix
  2020-11-24  9:28   ` Vlad Buslov
@ 2020-11-24 13:39     ` Jamal Hadi Salim
  2020-11-24 16:24     ` Jakub Kicinski
  1 sibling, 0 replies; 7+ messages in thread
From: Jamal Hadi Salim @ 2020-11-24 13:39 UTC (permalink / raw)
  To: Vlad Buslov, Jakub Kicinski; +Cc: netdev, davem, xiyou.wangcong, jiri

On 2020-11-24 4:28 a.m., Vlad Buslov wrote:
> On Mon 23 Nov 2020 at 23:22, Jakub Kicinski <kuba@kernel.org> wrote:
>> On Sat, 21 Nov 2020 18:09:02 +0200 Vlad Buslov wrote:
>>> Currently both filter and action flags use same "TCA_" prefix which makes
>>> them hard to distinguish to code and confusing for users. Create aliases
>>> for existing action flags constants with "TCA_ACT_" prefix.
>>>
>>> Signed-off-by: Vlad Buslov <vlad@buslov.dev>
>>
>> Are we expecting to add both aliases for all new flags?
> 
> I don't think it makes sense to have both aliases for any new flags.
> 

Agreed.

cheers,
jamal

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix
  2020-11-24  9:28   ` Vlad Buslov
  2020-11-24 13:39     ` Jamal Hadi Salim
@ 2020-11-24 16:24     ` Jakub Kicinski
  2020-11-24 16:39       ` Vlad Buslov
  1 sibling, 1 reply; 7+ messages in thread
From: Jakub Kicinski @ 2020-11-24 16:24 UTC (permalink / raw)
  To: Vlad Buslov; +Cc: netdev, davem, jhs, xiyou.wangcong, jiri

On Tue, 24 Nov 2020 11:28:37 +0200 Vlad Buslov wrote:
> > TCA_FLAG_TERSE_DUMP exists only in net-next, we could rename it, right?  
> 
> You are right. I'll send a fix.

You mean v2, not a follow up, right? :)

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix
  2020-11-24 16:24     ` Jakub Kicinski
@ 2020-11-24 16:39       ` Vlad Buslov
  0 siblings, 0 replies; 7+ messages in thread
From: Vlad Buslov @ 2020-11-24 16:39 UTC (permalink / raw)
  To: Jakub Kicinski; +Cc: netdev, davem, jhs, xiyou.wangcong, jiri

On Tue 24 Nov 2020 at 18:24, Jakub Kicinski <kuba@kernel.org> wrote:
> On Tue, 24 Nov 2020 11:28:37 +0200 Vlad Buslov wrote:
>> > TCA_FLAG_TERSE_DUMP exists only in net-next, we could rename it, right?  
>> 
>> You are right. I'll send a fix.
>
> You mean v2, not a follow up, right? :)

Yes. Sending the v2.


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2020-11-24 16:40 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-21 16:09 [PATCH net-next] net: sched: alias action flags with TCA_ACT_ prefix Vlad Buslov
2020-11-23  0:11 ` Jamal Hadi Salim
2020-11-23 21:22 ` Jakub Kicinski
2020-11-24  9:28   ` Vlad Buslov
2020-11-24 13:39     ` Jamal Hadi Salim
2020-11-24 16:24     ` Jakub Kicinski
2020-11-24 16:39       ` Vlad Buslov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.