All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
To: Mark Brown <broonie@kernel.org>
Cc: Linux-ALSA <alsa-devel@alsa-project.org>,
	Liam Girdwood <lgirdwood@gmail.com>, Simon <horms@verge.net.au>,
	<linux-renesas-soc@vger.kernel.org>
Subject: [PATCH 39/39 v2] ASoC: rsrc-card: rename rsrc-card to simple-dpcm-card phase3
Date: Tue, 31 May 2016 09:14:37 +0000	[thread overview]
Message-ID: <87vb1uppc0.wl%kuninori.morimoto.gx@renesas.com> (raw)
In-Reply-To: <87fusysjam.wl%kuninori.morimoto.gx@renesas.com>

rsrc-card which is using DPCM feature was created for Renesas sound.
But not only Renesas, but many SoC can use this driver, because
it is based on simple-card driver.
To use it as more open driver, rsrc-card should be renamed to
simple-dpcm-card. In order to easy patch review, as 3rd step,
this patch moves rsrc-card driver to generic folder.

Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
---
 .../bindings/sound/{renesas,rsrc-card.txt => simple-dpcm-card.txt}  | 0
 sound/soc/generic/Kconfig                                           | 6 ++++++
 sound/soc/generic/Makefile                                          | 2 ++
 sound/soc/{sh/rcar/rsrc-card.c => generic/simple-dpcm-card.c}       | 0
 sound/soc/sh/Kconfig                                                | 6 ------
 sound/soc/sh/rcar/Makefile                                          | 3 ---
 6 files changed, 8 insertions(+), 9 deletions(-)
 rename Documentation/devicetree/bindings/sound/{renesas,rsrc-card.txt => simple-dpcm-card.txt} (100%)
 rename sound/soc/{sh/rcar/rsrc-card.c => generic/simple-dpcm-card.c} (100%)

diff --git a/Documentation/devicetree/bindings/sound/renesas,rsrc-card.txt b/Documentation/devicetree/bindings/sound/simple-dpcm-card.txt
similarity index 100%
rename from Documentation/devicetree/bindings/sound/renesas,rsrc-card.txt
rename to Documentation/devicetree/bindings/sound/simple-dpcm-card.txt
diff --git a/sound/soc/generic/Kconfig b/sound/soc/generic/Kconfig
index c01c5dd..bb35494 100644
--- a/sound/soc/generic/Kconfig
+++ b/sound/soc/generic/Kconfig
@@ -6,3 +6,9 @@ config SND_SIMPLE_CARD
 	select SND_SIMPLE_CARD_UTILS
 	help
 	  This option enables generic simple sound card support
+
+config SND_SIMPLE_DPCM_CARD
+	tristate "ASoC Simple DPCM sound card support"
+	select SND_SIMPLE_CARD_UTILS
+	help
+	  This option enables generic simple DPCM sound card support
diff --git a/sound/soc/generic/Makefile b/sound/soc/generic/Makefile
index 45602ca..b82640a 100644
--- a/sound/soc/generic/Makefile
+++ b/sound/soc/generic/Makefile
@@ -1,5 +1,7 @@
 obj-$(CONFIG_SND_SIMPLE_CARD_UTILS) := simple-card-utils.o
 
 snd-soc-simple-card-objs	:= simple-card.o
+snd-soc-simple-dpcm-card-objs	:= simple-dpcm-card.o
 
 obj-$(CONFIG_SND_SIMPLE_CARD)	+= snd-soc-simple-card.o
+obj-$(CONFIG_SND_SIMPLE_DPCM_CARD)	+= snd-soc-simple-dpcm-card.o
diff --git a/sound/soc/sh/rcar/rsrc-card.c b/sound/soc/generic/simple-dpcm-card.c
similarity index 100%
rename from sound/soc/sh/rcar/rsrc-card.c
rename to sound/soc/generic/simple-dpcm-card.c
diff --git a/sound/soc/sh/Kconfig b/sound/soc/sh/Kconfig
index 9311f11..6db6405 100644
--- a/sound/soc/sh/Kconfig
+++ b/sound/soc/sh/Kconfig
@@ -42,12 +42,6 @@ config SND_SOC_RCAR
 	help
 	  This option enables R-Car SRU/SCU/SSIU/SSI sound support
 
-config SND_SOC_RSRC_CARD
-	tristate "Renesas Sampling Rate Convert Sound Card"
-	select SND_SIMPLE_CARD_UTILS
-	help
-	  This option enables simple sound if you need sampling rate convert
-
 ##
 ## Boards
 ##
diff --git a/sound/soc/sh/rcar/Makefile b/sound/soc/sh/rcar/Makefile
index a89ddf7..9c3d5ae 100644
--- a/sound/soc/sh/rcar/Makefile
+++ b/sound/soc/sh/rcar/Makefile
@@ -1,5 +1,2 @@
 snd-soc-rcar-objs	:= core.o gen.o dma.o adg.o ssi.o ssiu.o src.o ctu.o mix.o dvc.o cmd.o
 obj-$(CONFIG_SND_SOC_RCAR)	+= snd-soc-rcar.o
-
-snd-soc-rsrc-card-objs	:= rsrc-card.o
-obj-$(CONFIG_SND_SOC_RSRC_CARD)	+= snd-soc-rsrc-card.o
-- 
1.9.1

WARNING: multiple messages have this Message-ID (diff)
From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
To: Mark Brown <broonie@kernel.org>
Cc: Linux-ALSA <alsa-devel@alsa-project.org>,
	Liam Girdwood <lgirdwood@gmail.com>, Simon <horms@verge.net.au>,
	linux-renesas-soc@vger.kernel.org
Subject: [PATCH 39/39 v2] ASoC: rsrc-card: rename rsrc-card to simple-dpcm-card phase3
Date: Tue, 31 May 2016 09:14:37 +0000	[thread overview]
Message-ID: <87vb1uppc0.wl%kuninori.morimoto.gx@renesas.com> (raw)
In-Reply-To: <87fusysjam.wl%kuninori.morimoto.gx@renesas.com>

rsrc-card which is using DPCM feature was created for Renesas sound.
But not only Renesas, but many SoC can use this driver, because
it is based on simple-card driver.
To use it as more open driver, rsrc-card should be renamed to
simple-dpcm-card. In order to easy patch review, as 3rd step,
this patch moves rsrc-card driver to generic folder.

Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
---
 .../bindings/sound/{renesas,rsrc-card.txt => simple-dpcm-card.txt}  | 0
 sound/soc/generic/Kconfig                                           | 6 ++++++
 sound/soc/generic/Makefile                                          | 2 ++
 sound/soc/{sh/rcar/rsrc-card.c => generic/simple-dpcm-card.c}       | 0
 sound/soc/sh/Kconfig                                                | 6 ------
 sound/soc/sh/rcar/Makefile                                          | 3 ---
 6 files changed, 8 insertions(+), 9 deletions(-)
 rename Documentation/devicetree/bindings/sound/{renesas,rsrc-card.txt => simple-dpcm-card.txt} (100%)
 rename sound/soc/{sh/rcar/rsrc-card.c => generic/simple-dpcm-card.c} (100%)

diff --git a/Documentation/devicetree/bindings/sound/renesas,rsrc-card.txt b/Documentation/devicetree/bindings/sound/simple-dpcm-card.txt
similarity index 100%
rename from Documentation/devicetree/bindings/sound/renesas,rsrc-card.txt
rename to Documentation/devicetree/bindings/sound/simple-dpcm-card.txt
diff --git a/sound/soc/generic/Kconfig b/sound/soc/generic/Kconfig
index c01c5dd..bb35494 100644
--- a/sound/soc/generic/Kconfig
+++ b/sound/soc/generic/Kconfig
@@ -6,3 +6,9 @@ config SND_SIMPLE_CARD
 	select SND_SIMPLE_CARD_UTILS
 	help
 	  This option enables generic simple sound card support
+
+config SND_SIMPLE_DPCM_CARD
+	tristate "ASoC Simple DPCM sound card support"
+	select SND_SIMPLE_CARD_UTILS
+	help
+	  This option enables generic simple DPCM sound card support
diff --git a/sound/soc/generic/Makefile b/sound/soc/generic/Makefile
index 45602ca..b82640a 100644
--- a/sound/soc/generic/Makefile
+++ b/sound/soc/generic/Makefile
@@ -1,5 +1,7 @@
 obj-$(CONFIG_SND_SIMPLE_CARD_UTILS) := simple-card-utils.o
 
 snd-soc-simple-card-objs	:= simple-card.o
+snd-soc-simple-dpcm-card-objs	:= simple-dpcm-card.o
 
 obj-$(CONFIG_SND_SIMPLE_CARD)	+= snd-soc-simple-card.o
+obj-$(CONFIG_SND_SIMPLE_DPCM_CARD)	+= snd-soc-simple-dpcm-card.o
diff --git a/sound/soc/sh/rcar/rsrc-card.c b/sound/soc/generic/simple-dpcm-card.c
similarity index 100%
rename from sound/soc/sh/rcar/rsrc-card.c
rename to sound/soc/generic/simple-dpcm-card.c
diff --git a/sound/soc/sh/Kconfig b/sound/soc/sh/Kconfig
index 9311f11..6db6405 100644
--- a/sound/soc/sh/Kconfig
+++ b/sound/soc/sh/Kconfig
@@ -42,12 +42,6 @@ config SND_SOC_RCAR
 	help
 	  This option enables R-Car SRU/SCU/SSIU/SSI sound support
 
-config SND_SOC_RSRC_CARD
-	tristate "Renesas Sampling Rate Convert Sound Card"
-	select SND_SIMPLE_CARD_UTILS
-	help
-	  This option enables simple sound if you need sampling rate convert
-
 ##
 ## Boards
 ##
diff --git a/sound/soc/sh/rcar/Makefile b/sound/soc/sh/rcar/Makefile
index a89ddf7..9c3d5ae 100644
--- a/sound/soc/sh/rcar/Makefile
+++ b/sound/soc/sh/rcar/Makefile
@@ -1,5 +1,2 @@
 snd-soc-rcar-objs	:= core.o gen.o dma.o adg.o ssi.o ssiu.o src.o ctu.o mix.o dvc.o cmd.o
 obj-$(CONFIG_SND_SOC_RCAR)	+= snd-soc-rcar.o
-
-snd-soc-rsrc-card-objs	:= rsrc-card.o
-obj-$(CONFIG_SND_SOC_RSRC_CARD)	+= snd-soc-rsrc-card.o
-- 
1.9.1

  parent reply	other threads:[~2016-05-31  9:14 UTC|newest]

Thread overview: 128+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-05-31  8:56 [PATCH 00/39 v2] ASoC: add simple-card-core and standardize "simple" card Kuninori Morimoto
2016-05-31  8:56 ` Kuninori Morimoto
2016-05-31  8:58 ` [PATCH 01/39 v2] ASoC: rsrc-card: remove unused dai_num Kuninori Morimoto
2016-05-31  8:58   ` Kuninori Morimoto
2016-05-31  8:59 ` [PATCH 02/39 v2] ASoC: simple-card: use common PREFIX for each DT property Kuninori Morimoto
2016-05-31  8:59   ` Kuninori Morimoto
2016-06-13 15:47   ` Applied "ASoC: simple-card: use common PREFIX for each DT property" to the asoc tree Mark Brown
2016-06-13 15:47     ` Mark Brown
2016-05-31  8:59 ` [PATCH 03/39 v2] ASoC: simple-card: add new asoc_simple_jack and use it Kuninori Morimoto
2016-05-31  8:59   ` Kuninori Morimoto
2016-06-29 18:20   ` Applied "ASoC: simple-card: add new asoc_simple_jack and use it" to the asoc tree Mark Brown
2016-06-29 18:20     ` Mark Brown
2016-05-31  9:00 ` [PATCH 04/39 v2] ASoC: add new simple-card-utils.c Kuninori Morimoto
2016-05-31  9:00   ` Kuninori Morimoto
2016-06-29 18:20   ` Applied "ASoC: add new simple-card-utils.c" to the asoc tree Mark Brown
2016-06-29 18:20     ` Mark Brown
2016-05-31  9:00 ` [PATCH 05/39 v2] ASoC: simple-card-utils: add asoc_simple_card_parse_tdm() Kuninori Morimoto
2016-05-31  9:00   ` Kuninori Morimoto
2016-06-29 18:11   ` Mark Brown
2016-06-30  0:03     ` Kuninori Morimoto
2016-06-30  0:03       ` Kuninori Morimoto
2016-05-31  9:01 ` [PATCH 06/39 v2] ASoC: simple-card-utils: add asoc_simple_card_parse_dailink_name() Kuninori Morimoto
2016-05-31  9:01   ` Kuninori Morimoto
2016-06-29 18:14   ` Mark Brown
2016-06-30  5:32     ` Kuninori Morimoto
2016-06-30  5:32       ` Kuninori Morimoto
2016-05-31  9:01 ` [PATCH 07/39 v2] ASoC: simple-card-utils: add asoc_simple_card_parse_card_name() Kuninori Morimoto
2016-05-31  9:01   ` Kuninori Morimoto
2016-06-29 18:15   ` Mark Brown
2016-06-29 18:15     ` Mark Brown
2016-06-30  2:55     ` Kuninori Morimoto
2016-06-30  2:55       ` Kuninori Morimoto
2016-07-01  9:52       ` Mark Brown
2016-07-03 23:54         ` Kuninori Morimoto
2016-07-03 23:54           ` Kuninori Morimoto
2016-07-04  0:20           ` Kuninori Morimoto
2016-07-04  0:20             ` Kuninori Morimoto
2016-07-04  8:50             ` Mark Brown
2016-07-04  8:59               ` Kuninori Morimoto
2016-07-04  8:59                 ` Kuninori Morimoto
2016-07-05 12:10                 ` Mark Brown
2016-07-05 12:10                   ` Mark Brown
2016-07-05 23:12                   ` Kuninori Morimoto
2016-07-05 23:12                     ` Kuninori Morimoto
2016-05-31  9:01 ` [PATCH 08/39 v2] ASoC: simple-card-utils: add asoc_simple_card_parse_card_prefix() Kuninori Morimoto
2016-05-31  9:01   ` Kuninori Morimoto
2016-06-29 18:17   ` Mark Brown
2016-05-31  9:02 ` [PATCH 09/39 v2] ASoC: simple-card-utils: add asoc_simple_card_parse_clk() Kuninori Morimoto
2016-05-31  9:02   ` Kuninori Morimoto
2016-06-29 18:18   ` Mark Brown
2016-06-30  0:25     ` Kuninori Morimoto
2016-06-30  0:25       ` Kuninori Morimoto
2016-06-30  0:39       ` Kuninori Morimoto
2016-06-30  0:39         ` Kuninori Morimoto
2016-07-01  9:55         ` Mark Brown
2016-07-01  9:55           ` Mark Brown
2016-07-03 23:58           ` Kuninori Morimoto
2016-07-03 23:58             ` Kuninori Morimoto
2016-05-31  9:03 ` [PATCH 10/39 v2] ASoC: simple-card-utils: add asoc_simple_card_parse_endpoint() Kuninori Morimoto
2016-05-31  9:03   ` Kuninori Morimoto
2016-06-29 18:34   ` Mark Brown
2016-05-31  9:03 ` [PATCH 11/39 v2] ASoC: simple-card-utils: add asoc_simple_card_init_dai() Kuninori Morimoto
2016-05-31  9:03   ` Kuninori Morimoto
2016-05-31  9:03 ` [PATCH 12/39 v2] ASoC: simple-card-utils: add asoc_simple_card_canonicalize_dailink() Kuninori Morimoto
2016-05-31  9:03   ` Kuninori Morimoto
2016-05-31  9:04 ` [PATCH 13/39 v2] ASoC: simple-card-utils: add asoc_simple_card_canonicalize_cpu() Kuninori Morimoto
2016-05-31  9:04   ` Kuninori Morimoto
2016-05-31  9:04 ` [PATCH 14/39 v2] ASoC: simple-card-utils: add asoc_simple_card_clean_reference() Kuninori Morimoto
2016-05-31  9:04   ` Kuninori Morimoto
2016-05-31  9:05 ` [PATCH 15/39 v2] ASoC: simple-card: use asoc_simple_card_parse_daifmt() Kuninori Morimoto
2016-05-31  9:05   ` Kuninori Morimoto
2016-05-31  9:05 ` [PATCH 16/39 v2] ASoC: simple-card: use asoc_simple_card_parse_clk() Kuninori Morimoto
2016-05-31  9:05   ` Kuninori Morimoto
2016-05-31  9:05 ` [PATCH 17/39 v2] ASoC: simple-card: use asoc_simple_card_parse_endpoint() Kuninori Morimoto
2016-05-31  9:05   ` Kuninori Morimoto
2016-05-31  9:06 ` [PATCH 18/39 v2] ASoC: simple-card: use asoc_simple_card_parse_tdm() Kuninori Morimoto
2016-05-31  9:06   ` Kuninori Morimoto
2016-05-31  9:06 ` [PATCH 19/39 v2] ASoC: simple-card: use asoc_simple_card_parse_card_name() Kuninori Morimoto
2016-05-31  9:06   ` Kuninori Morimoto
2016-07-16 12:03   ` Applied "ASoC: simple-card: use asoc_simple_card_parse_card_name()" to the asoc tree Mark Brown
2016-07-16 12:03     ` Mark Brown
2016-05-31  9:07 ` [PATCH 20/39 v2] ASoC: simple-card: use asoc_simple_card_parse_dailink_name() Kuninori Morimoto
2016-05-31  9:07   ` Kuninori Morimoto
2016-05-31  9:07 ` [PATCH 21/39 v2] ASoC: simple-card: use asoc_simple_card_init_dai() Kuninori Morimoto
2016-05-31  9:07   ` Kuninori Morimoto
2016-05-31  9:07 ` [PATCH 22/39 v2] ASoC: simple-card: use asoc_simple_card_canonicalize_dailink() Kuninori Morimoto
2016-05-31  9:07   ` Kuninori Morimoto
2016-05-31  9:08 ` [PATCH 23/39 v2] ASoC: simple-card: use asoc_simple_card_canonicalize_cpu() Kuninori Morimoto
2016-05-31  9:08   ` Kuninori Morimoto
2016-05-31  9:08 ` [PATCH 24/39 v2] ASoC: simple-card: use asoc_simple_card_clean_reference() Kuninori Morimoto
2016-05-31  9:08   ` Kuninori Morimoto
2016-05-31  9:09 ` [PATCH 25/39 v2] ASoC: rsrc-card: use asoc_simple_card_parse_daifmt() Kuninori Morimoto
2016-05-31  9:09   ` Kuninori Morimoto
2016-07-01 15:59   ` Applied "ASoC: rsrc-card: use asoc_simple_card_parse_daifmt()" to the asoc tree Mark Brown
2016-07-01 15:59     ` Mark Brown
2016-05-31  9:09 ` [PATCH 26/39 v2] ASoC: rsrc-card: use asoc_simple_card_parse_dailink_name() Kuninori Morimoto
2016-05-31  9:09   ` Kuninori Morimoto
2016-05-31  9:09 ` [PATCH 27/39 v2] ASoC: rsrc-card: use asoc_simple_dai instead of rsrc_card_dai Kuninori Morimoto
2016-05-31  9:09   ` Kuninori Morimoto
2016-05-31  9:10 ` [PATCH 28/39 v2] ASoC: rsrc-card: use asoc_simple_card_parse_clk() Kuninori Morimoto
2016-05-31  9:10   ` Kuninori Morimoto
2016-05-31  9:10 ` [PATCH 29/39 v2] ASoC: rsrc-card: use asoc_simple_card_parse_endpoint() Kuninori Morimoto
2016-05-31  9:10   ` Kuninori Morimoto
2016-05-31  9:11 ` [PATCH 30/39 v2] ASoC: rsrc-card: use asoc_simple_card_parse_card_name() Kuninori Morimoto
2016-05-31  9:11   ` Kuninori Morimoto
2016-05-31  9:11 ` [PATCH 31/39 v2] ASoC: rsrc-card: use asoc_simple_card_parse_card_prefix() Kuninori Morimoto
2016-05-31  9:11   ` Kuninori Morimoto
2016-05-31  9:11 ` [PATCH 32/39 v2] ASoC: rsrc-card: use asoc_simple_card_parse_tdm() Kuninori Morimoto
2016-05-31  9:11   ` Kuninori Morimoto
2016-05-31  9:12 ` [PATCH 33/39 v2] ASoC: rsrc-card: use asoc_simple_card_init_dai() Kuninori Morimoto
2016-05-31  9:12   ` Kuninori Morimoto
2016-05-31  9:12 ` [PATCH 34/39 v2] ASoC: rsrc-card: use asoc_simple_card_canonicalize_cpu() Kuninori Morimoto
2016-05-31  9:12   ` Kuninori Morimoto
2016-05-31  9:13 ` [PATCH 35/39 v2] ASoC: rsrc-card: use asoc_simple_card_canonicalize_dailink() Kuninori Morimoto
2016-05-31  9:13   ` Kuninori Morimoto
2016-05-31  9:13 ` [PATCH 36/39 v2] ASoC: rsrc-card: use asoc_simple_card_clean_reference() Kuninori Morimoto
2016-05-31  9:13   ` Kuninori Morimoto
2016-05-31  9:13 ` [PATCH 37/39 v2] ASoC: rsrc-card: rename rsrc-card to simple-dpcm-card phase1 Kuninori Morimoto
2016-05-31  9:13   ` Kuninori Morimoto
2016-05-31  9:14 ` [PATCH 38/39 v2] ASoC: rsrc-card: rename rsrc-card to simple-dpcm-card phase2 Kuninori Morimoto
2016-05-31  9:14   ` Kuninori Morimoto
2016-05-31  9:14 ` Kuninori Morimoto [this message]
2016-05-31  9:14   ` [PATCH 39/39 v2] ASoC: rsrc-card: rename rsrc-card to simple-dpcm-card phase3 Kuninori Morimoto
2016-06-20  1:49 ` [PATCH 00/39 v2] ASoC: add simple-card-core and standardize "simple" card Kuninori Morimoto
2016-06-20  1:49   ` Kuninori Morimoto
2016-06-29 18:16 ` Mark Brown
2016-06-30  5:34   ` Kuninori Morimoto
2016-06-30  5:34     ` Kuninori Morimoto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87vb1uppc0.wl%kuninori.morimoto.gx@renesas.com \
    --to=kuninori.morimoto.gx@renesas.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=horms@verge.net.au \
    --cc=lgirdwood@gmail.com \
    --cc=linux-renesas-soc@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.