All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v3] mm: get rid of odd jump labels in find_mergeable_anon_vma()
@ 2019-11-18  6:39 linmiaohe
  2019-11-18  9:45 ` David Hildenbrand
  0 siblings, 1 reply; 3+ messages in thread
From: linmiaohe @ 2019-11-18  6:39 UTC (permalink / raw)
  To: akpm, richardw.yang, sfr, rppt, jannh, steve.capper,
	catalin.marinas, aarcange, chenjianhong2, walken, dave.hansen,
	tiny.windzz, jhubbard, david
  Cc: linmiaohe, linux-mm, linux-kernel

From: Miaohe Lin <linmiaohe@huawei.com>

The jump labels try_prev and none are not really needed
in find_mergeable_anon_vma(), eliminate them to improve
readability.

Reviewed-by: David Hildenbrand <david@redhat.com>
Reviewed-by: John Hubbard <jhubbard@nvidia.com>
Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
---
-v2:
	Fix commit descriptions and further simplify the code
	as suggested by David Hildenbrand and John Hubbard.
-v3:
	Rewrite patch version info. Don't show this in commit log.
---
 mm/mmap.c | 27 +++++++++++++--------------
 1 file changed, 13 insertions(+), 14 deletions(-)

diff --git a/mm/mmap.c b/mm/mmap.c
index 4d4db76a07da..ff02c23fd375 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -1276,26 +1276,25 @@ static struct anon_vma *reusable_anon_vma(struct vm_area_struct *old, struct vm_
  */
 struct anon_vma *find_mergeable_anon_vma(struct vm_area_struct *vma)
 {
-	struct anon_vma *anon_vma;
+	struct anon_vma *anon_vma = NULL;
 	struct vm_area_struct *near;
 
+	/* Try next first. */
 	near = vma->vm_next;
-	if (!near)
-		goto try_prev;
+	if (near) {
+		anon_vma = reusable_anon_vma(near, vma, near);
+		if (anon_vma)
+			return anon_vma;
+	}
 
-	anon_vma = reusable_anon_vma(near, vma, near);
-	if (anon_vma)
-		return anon_vma;
-try_prev:
+	/* Try prev next. */
 	near = vma->vm_prev;
-	if (!near)
-		goto none;
+	if (near)
+		anon_vma = reusable_anon_vma(near, near, vma);
 
-	anon_vma = reusable_anon_vma(near, near, vma);
-	if (anon_vma)
-		return anon_vma;
-none:
 	/*
+	 * We might reach here with anon_vma == NULL if we can't find
+	 * any reusable anon_vma.
 	 * There's no absolute need to look only at touching neighbours:
 	 * we could search further afield for "compatible" anon_vmas.
 	 * But it would probably just be a waste of time searching,
@@ -1303,7 +1302,7 @@ struct anon_vma *find_mergeable_anon_vma(struct vm_area_struct *vma)
 	 * We're trying to allow mprotect remerging later on,
 	 * not trying to minimize memory used for anon_vmas.
 	 */
-	return NULL;
+	return anon_vma;
 }
 
 /*
-- 
2.19.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH v3] mm: get rid of odd jump labels in find_mergeable_anon_vma()
  2019-11-18  6:39 [PATCH v3] mm: get rid of odd jump labels in find_mergeable_anon_vma() linmiaohe
@ 2019-11-18  9:45 ` David Hildenbrand
  0 siblings, 0 replies; 3+ messages in thread
From: David Hildenbrand @ 2019-11-18  9:45 UTC (permalink / raw)
  To: linmiaohe, akpm, richardw.yang, sfr, rppt, jannh, steve.capper,
	catalin.marinas, aarcange, chenjianhong2, walken, dave.hansen,
	tiny.windzz, jhubbard
  Cc: linux-mm, linux-kernel

On 18.11.19 07:39, linmiaohe wrote:
> From: Miaohe Lin <linmiaohe@huawei.com>
> 
> The jump labels try_prev and none are not really needed
> in find_mergeable_anon_vma(), eliminate them to improve
> readability.
> 
> Reviewed-by: David Hildenbrand <david@redhat.com>
> Reviewed-by: John Hubbard <jhubbard@nvidia.com>
> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
> ---
> -v2:
> 	Fix commit descriptions and further simplify the code
> 	as suggested by David Hildenbrand and John Hubbard.
> -v3:
> 	Rewrite patch version info. Don't show this in commit log.
> ---
>   mm/mmap.c | 27 +++++++++++++--------------
>   1 file changed, 13 insertions(+), 14 deletions(-)
> 
> diff --git a/mm/mmap.c b/mm/mmap.c
> index 4d4db76a07da..ff02c23fd375 100644
> --- a/mm/mmap.c
> +++ b/mm/mmap.c
> @@ -1276,26 +1276,25 @@ static struct anon_vma *reusable_anon_vma(struct vm_area_struct *old, struct vm_
>    */
>   struct anon_vma *find_mergeable_anon_vma(struct vm_area_struct *vma)
>   {
> -	struct anon_vma *anon_vma;
> +	struct anon_vma *anon_vma = NULL;
>   	struct vm_area_struct *near;
>   
> +	/* Try next first. */
>   	near = vma->vm_next;
> -	if (!near)
> -		goto try_prev;
> +	if (near) {
> +		anon_vma = reusable_anon_vma(near, vma, near);
> +		if (anon_vma)
> +			return anon_vma;
> +	}

I think you can get rid of near completely as well

	if (vma->vm_next) {
		anon_vma = reusable_anon_vma(near, vma, vma->vm_next);
		if (anon_vma)
			return anon_vma;
	}

...

Apart from  that looks good to me.

>   
> -	anon_vma = reusable_anon_vma(near, vma, near);
> -	if (anon_vma)
> -		return anon_vma;
> -try_prev:
> +	/* Try prev next. */
>   	near = vma->vm_prev;
> -	if (!near)
> -		goto none;
> +	if (near)
> +		anon_vma = reusable_anon_vma(near, near, vma);
>   
> -	anon_vma = reusable_anon_vma(near, near, vma);
> -	if (anon_vma)
> -		return anon_vma;
> -none:
>   	/*
> +	 * We might reach here with anon_vma == NULL if we can't find
> +	 * any reusable anon_vma.
>   	 * There's no absolute need to look only at touching neighbours:
>   	 * we could search further afield for "compatible" anon_vmas.
>   	 * But it would probably just be a waste of time searching,
> @@ -1303,7 +1302,7 @@ struct anon_vma *find_mergeable_anon_vma(struct vm_area_struct *vma)
>   	 * We're trying to allow mprotect remerging later on,
>   	 * not trying to minimize memory used for anon_vmas.
>   	 */
> -	return NULL;
> +	return anon_vma;
>   }
>   
>   /*
> 


-- 

Thanks,

David / dhildenb


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v3] mm: get rid of odd jump labels in find_mergeable_anon_vma()
@ 2019-11-18 11:31 linmiaohe
  0 siblings, 0 replies; 3+ messages in thread
From: linmiaohe @ 2019-11-18 11:31 UTC (permalink / raw)
  To: David Hildenbrand, akpm, richardw.yang, sfr, rppt, jannh,
	steve.capper, catalin.marinas, aarcange, walken, dave.hansen,
	tiny.windzz, jhubbard
  Cc: linux-mm, linux-kernel

David Hildenbrand wrote:
> On 18.11.19 07:39, linmiaohe wrote:
>> From: Miaohe Lin <linmiaohe@huawei.com>
>> 
>> The jump labels try_prev and none are not really needed in 
>> find_mergeable_anon_vma(), eliminate them to improve readability.
>
>I think you can get rid of near completely as well
>
>	if (vma->vm_next) {
>		anon_vma = reusable_anon_vma(near, vma, vma->vm_next);
>		if (anon_vma)
>			return anon_vma;
>	}
>
>...
>
>Apart from  that looks good to me.
>
>>   
>> -	anon_vma = reusable_anon_vma(near, vma, near);
>> -	if (anon_vma)
>> -		return anon_vma;
>> -try_prev:
>> +	/* Try prev next. */
>>   	near = vma->vm_prev;
>> -	if (!near)

Thanks for your advice again. I will get rid of near completely in v4. Thanks a lot.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2019-11-18 11:31 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-11-18  6:39 [PATCH v3] mm: get rid of odd jump labels in find_mergeable_anon_vma() linmiaohe
2019-11-18  9:45 ` David Hildenbrand
2019-11-18 11:31 linmiaohe

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.