All of lore.kernel.org
 help / color / mirror / Atom feed
* [docs][PATCH] ref-manual: Clarify recommended operator for PROVIDES
@ 2021-01-19 15:57 Joshua Watt
  2021-01-19 16:00 ` Robert P. J. Day
                   ` (2 more replies)
  0 siblings, 3 replies; 5+ messages in thread
From: Joshua Watt @ 2021-01-19 15:57 UTC (permalink / raw)
  To: docs; +Cc: quentin.schulz, richard.purdie, rpjday, Joshua Watt

Updates the documentation for PROVIDES so that it recommends "+="
instead of "=".

Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
---
 documentation/ref-manual/variables.rst | 16 +++++-----------
 1 file changed, 5 insertions(+), 11 deletions(-)

diff --git a/documentation/ref-manual/variables.rst b/documentation/ref-manual/variables.rst
index 4ce264813..2ea0cc36c 100644
--- a/documentation/ref-manual/variables.rst
+++ b/documentation/ref-manual/variables.rst
@@ -5915,23 +5915,17 @@ system and gives an overview of their function and contents.
       file ``eudev_3.2.9.bb``:
       ::
 
-         PROVIDES = "udev"
+         PROVIDES += "udev"
 
       The ``PROVIDES`` statement
       results in the "eudev" recipe also being available as simply "udev".
 
       .. note::
 
-         Given that a recipe's own recipe name is already implicitly in its
-         own PROVIDES list, it is unnecessary to add aliases with the "+=" operator;
-         using a simple assignment will be sufficient. In other words,
-         while you could write:
-         ::
-
-                 PROVIDES += "udev"
-
-
-         in the above, the "+=" is overkill and unnecessary.
+         A recipe's own recipe name (:term:`${PN}`) is always implicitly
+         included in the recipe aliases, so while using "+=" in the above
+         example may not be strictly necessary it is recommend to avoid
+         confusion.
 
       In addition to providing recipes under alternate names, the
       ``PROVIDES`` mechanism is also used to implement virtual targets. A
-- 
2.30.0


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [docs][PATCH] ref-manual: Clarify recommended operator for PROVIDES
  2021-01-19 15:57 [docs][PATCH] ref-manual: Clarify recommended operator for PROVIDES Joshua Watt
@ 2021-01-19 16:00 ` Robert P. J. Day
  2021-01-19 16:03 ` Quentin Schulz
  2021-01-19 16:42 ` [docs][PATCH v2] " Joshua Watt
  2 siblings, 0 replies; 5+ messages in thread
From: Robert P. J. Day @ 2021-01-19 16:00 UTC (permalink / raw)
  To: Joshua Watt; +Cc: docs, quentin.schulz, richard.purdie

On Tue, 19 Jan 2021, Joshua Watt wrote:

> Updates the documentation for PROVIDES so that it recommends "+="
> instead of "=".
>
> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
> ---
>  documentation/ref-manual/variables.rst | 16 +++++-----------
>  1 file changed, 5 insertions(+), 11 deletions(-)
>
> diff --git a/documentation/ref-manual/variables.rst b/documentation/ref-manual/variables.rst
> index 4ce264813..2ea0cc36c 100644
> --- a/documentation/ref-manual/variables.rst
> +++ b/documentation/ref-manual/variables.rst
> @@ -5915,23 +5915,17 @@ system and gives an overview of their function and contents.
>        file ``eudev_3.2.9.bb``:
>        ::
>
> -         PROVIDES = "udev"
> +         PROVIDES += "udev"
>
>        The ``PROVIDES`` statement
>        results in the "eudev" recipe also being available as simply "udev".
>
>        .. note::
>
> -         Given that a recipe's own recipe name is already implicitly in its
> -         own PROVIDES list, it is unnecessary to add aliases with the "+=" operator;
> -         using a simple assignment will be sufficient. In other words,
> -         while you could write:
> -         ::
> -
> -                 PROVIDES += "udev"
> -
> -
> -         in the above, the "+=" is overkill and unnecessary.
> +         A recipe's own recipe name (:term:`${PN}`) is always implicitly
> +         included in the recipe aliases, so while using "+=" in the above
> +         example may not be strictly necessary it is recommend to avoid
                                                        recommended

rday

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [docs][PATCH] ref-manual: Clarify recommended operator for PROVIDES
  2021-01-19 15:57 [docs][PATCH] ref-manual: Clarify recommended operator for PROVIDES Joshua Watt
  2021-01-19 16:00 ` Robert P. J. Day
@ 2021-01-19 16:03 ` Quentin Schulz
  2021-01-19 16:12   ` Joshua Watt
  2021-01-19 16:42 ` [docs][PATCH v2] " Joshua Watt
  2 siblings, 1 reply; 5+ messages in thread
From: Quentin Schulz @ 2021-01-19 16:03 UTC (permalink / raw)
  To: Joshua Watt; +Cc: docs, richard.purdie, rpjday

Hi Joshua,

On Tue, Jan 19, 2021 at 09:57:51AM -0600, Joshua Watt wrote:
> Updates the documentation for PROVIDES so that it recommends "+="
> instead of "=".
> 
> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
> ---
>  documentation/ref-manual/variables.rst | 16 +++++-----------
>  1 file changed, 5 insertions(+), 11 deletions(-)
> 
> diff --git a/documentation/ref-manual/variables.rst b/documentation/ref-manual/variables.rst
> index 4ce264813..2ea0cc36c 100644
> --- a/documentation/ref-manual/variables.rst
> +++ b/documentation/ref-manual/variables.rst
> @@ -5915,23 +5915,17 @@ system and gives an overview of their function and contents.
>        file ``eudev_3.2.9.bb``:
>        ::
>  
> -         PROVIDES = "udev"
> +         PROVIDES += "udev"
>  
>        The ``PROVIDES`` statement
>        results in the "eudev" recipe also being available as simply "udev".
>  
>        .. note::
>  
> -         Given that a recipe's own recipe name is already implicitly in its
> -         own PROVIDES list, it is unnecessary to add aliases with the "+=" operator;
> -         using a simple assignment will be sufficient. In other words,
> -         while you could write:
> -         ::
> -
> -                 PROVIDES += "udev"
> -
> -
> -         in the above, the "+=" is overkill and unnecessary.
> +         A recipe's own recipe name (:term:`${PN}`) is always implicitly
> +         included in the recipe aliases, so while using "+=" in the above

s/included in the recipe aliases/included in its own PROVIDES list/ ?

Just a suggestion.

> +         example may not be strictly necessary it is recommend to avoid

s/recommend/recommended/

Thanks,
Quentin

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [docs][PATCH] ref-manual: Clarify recommended operator for PROVIDES
  2021-01-19 16:03 ` Quentin Schulz
@ 2021-01-19 16:12   ` Joshua Watt
  0 siblings, 0 replies; 5+ messages in thread
From: Joshua Watt @ 2021-01-19 16:12 UTC (permalink / raw)
  To: Quentin Schulz; +Cc: docs, richard.purdie, rpjday


On 1/19/21 10:03 AM, Quentin Schulz wrote:
> Hi Joshua,
>
> On Tue, Jan 19, 2021 at 09:57:51AM -0600, Joshua Watt wrote:
>> Updates the documentation for PROVIDES so that it recommends "+="
>> instead of "=".
>>
>> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
>> ---
>>   documentation/ref-manual/variables.rst | 16 +++++-----------
>>   1 file changed, 5 insertions(+), 11 deletions(-)
>>
>> diff --git a/documentation/ref-manual/variables.rst b/documentation/ref-manual/variables.rst
>> index 4ce264813..2ea0cc36c 100644
>> --- a/documentation/ref-manual/variables.rst
>> +++ b/documentation/ref-manual/variables.rst
>> @@ -5915,23 +5915,17 @@ system and gives an overview of their function and contents.
>>         file ``eudev_3.2.9.bb``:
>>         ::
>>   
>> -         PROVIDES = "udev"
>> +         PROVIDES += "udev"
>>   
>>         The ``PROVIDES`` statement
>>         results in the "eudev" recipe also being available as simply "udev".
>>   
>>         .. note::
>>   
>> -         Given that a recipe's own recipe name is already implicitly in its
>> -         own PROVIDES list, it is unnecessary to add aliases with the "+=" operator;
>> -         using a simple assignment will be sufficient. In other words,
>> -         while you could write:
>> -         ::
>> -
>> -                 PROVIDES += "udev"
>> -
>> -
>> -         in the above, the "+=" is overkill and unnecessary.
>> +         A recipe's own recipe name (:term:`${PN}`) is always implicitly
>> +         included in the recipe aliases, so while using "+=" in the above
> s/included in the recipe aliases/included in its own PROVIDES list/ ?
>
> Just a suggestion.

Hmm, yes. I was trying to avoid saying ${PN} was in PROVIDES because I 
though it wasn't, but I see that it is (using _prepend).


>
>> +         example may not be strictly necessary it is recommend to avoid
> s/recommend/recommended/
>
> Thanks,
> Quentin

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [docs][PATCH v2] ref-manual: Clarify recommended operator for PROVIDES
  2021-01-19 15:57 [docs][PATCH] ref-manual: Clarify recommended operator for PROVIDES Joshua Watt
  2021-01-19 16:00 ` Robert P. J. Day
  2021-01-19 16:03 ` Quentin Schulz
@ 2021-01-19 16:42 ` Joshua Watt
  2 siblings, 0 replies; 5+ messages in thread
From: Joshua Watt @ 2021-01-19 16:42 UTC (permalink / raw)
  To: docs; +Cc: quentin.schulz, richard.purdie, rpjday, Joshua Watt

Updates the documentation for PROVIDES so that it recommends "+="
instead of "=".

Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
---
 documentation/ref-manual/variables.rst | 15 ++++-----------
 1 file changed, 4 insertions(+), 11 deletions(-)

diff --git a/documentation/ref-manual/variables.rst b/documentation/ref-manual/variables.rst
index 4ce264813..1bbc5cbca 100644
--- a/documentation/ref-manual/variables.rst
+++ b/documentation/ref-manual/variables.rst
@@ -5915,23 +5915,16 @@ system and gives an overview of their function and contents.
       file ``eudev_3.2.9.bb``:
       ::
 
-         PROVIDES = "udev"
+         PROVIDES += "udev"
 
       The ``PROVIDES`` statement
       results in the "eudev" recipe also being available as simply "udev".
 
       .. note::
 
-         Given that a recipe's own recipe name is already implicitly in its
-         own PROVIDES list, it is unnecessary to add aliases with the "+=" operator;
-         using a simple assignment will be sufficient. In other words,
-         while you could write:
-         ::
-
-                 PROVIDES += "udev"
-
-
-         in the above, the "+=" is overkill and unnecessary.
+         A recipe's own recipe name (:term:`PN`) is always implicitly prepended
+         to `PROVIDES`, so while using "+=" in the above example may not be
+         strictly necessary it is recommended to avoid confusion.
 
       In addition to providing recipes under alternate names, the
       ``PROVIDES`` mechanism is also used to implement virtual targets. A
-- 
2.30.0


^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-01-19 16:42 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-19 15:57 [docs][PATCH] ref-manual: Clarify recommended operator for PROVIDES Joshua Watt
2021-01-19 16:00 ` Robert P. J. Day
2021-01-19 16:03 ` Quentin Schulz
2021-01-19 16:12   ` Joshua Watt
2021-01-19 16:42 ` [docs][PATCH v2] " Joshua Watt

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.