All of lore.kernel.org
 help / color / mirror / Atom feed
From: luto@amacapital.net (Andy Lutomirski)
To: linux-security-module@vger.kernel.org
Subject: [PATCH V3 05/10] capabilities: use intuitive names for id changes
Date: Fri, 25 Aug 2017 12:45:15 -0700	[thread overview]
Message-ID: <9465A086-A2C8-41E6-994E-34C7B1B9F0F9@amacapital.net> (raw)
In-Reply-To: <20170825185127.GB26620@mail.hallyn.com>




--Andy
> On Aug 25, 2017, at 11:51 AM, Serge E. Hallyn <serge@hallyn.com> wrote:
> 
> Quoting Andy Lutomirski (luto at kernel.org):
>>> On Wed, Aug 23, 2017 at 3:12 AM, Richard Guy Briggs <rgb@redhat.com> wrote:
>>> Introduce a number of inlines to make the use of the negation of
>>> uid_eq() easier to read and analyse.
>>> 
>>> Signed-off-by: Richard Guy Briggs <rgb@redhat.com>
>>> ---
>>> security/commoncap.c |   26 +++++++++++++++++++++-----
>>> 1 files changed, 21 insertions(+), 5 deletions(-)
>>> 
>>> diff --git a/security/commoncap.c b/security/commoncap.c
>>> index 36c38a1..1af7dec 100644
>>> --- a/security/commoncap.c
>>> +++ b/security/commoncap.c
>>> @@ -483,6 +483,15 @@ static int get_file_caps(struct linux_binprm *bprm, bool *effective, bool *has_f
>>> 
>>> static inline bool root_privileged(void) { return !issecure(SECURE_NOROOT); }
>>> 
>>> +static inline bool is_real(kuid_t uid, struct cred *cred)
>>> +{ return uid_eq(cred->uid, uid); }
>> 
>> OK I guess, but this just seems like a way to obfuscate the code a bit
>> and save typing "->uid".
> 
> Personally I find the new to be far more readable.  In the old, the
> distinction between uid and euid is one character hidden in the middle
> of the expression.

Would real_uid_eq be better?

> 
>>> +
>>> +static inline bool is_eff(kuid_t uid, struct cred *cred)
>>> +{ return uid_eq(cred->euid, uid); }
>> 
>> Ditto.
>> 
>>> +
>>> +static inline bool is_suid(kuid_t uid, struct cred *cred)
>>> +{ return !is_real(uid, cred) && is_eff(uid, cred); }
>> 
>> Please no.  This is IMO insane.  You're hiding really weird,
>> nonintuitive logic in an oddly named helper.
> 
> How is it nonintuitive?  It's very precisely checking that a
> nonroot user is executing something that results in euid=0.

I can think of several sensible predicated:

1. Are we execing a setuid-root program, where the setuod bit wasn't suppressed by nnp, mount options, trace, etc?

2. Same as 1, but also require that we weren't root.

3. Is the new euid 0 and old uid != 0?

4. Does suid == 0?

This helper checks something equivalent to 3, but only once were far enough through exec and before user code starts.  This is probably equivalent to 2 as well.  This is quite subtle and deserves an open-coded check, a much more carefully named helper, or, better yet, something that looks at binprm instead of cred.

is_suid sounds like #4.

> That's what it's checking for, the name of the new helper makes
> that clear, and the code becomes clearer because we only see the
> thing we care about checking for rather than the intent being
> hidden.


> 
>> Also, this is going to cause massive confusion and severe bugs: given
>> the same, the only remotely sensible guess as to what this function
>> does is uid_eq(cred->suid, uid).  So NAK to this.
>> 
>>> +
>>> void handle_privileged_root(struct linux_binprm *bprm, bool has_fcap, bool *effective, kuid_t root_uid)
>>> {
>>>        const struct cred *old = current_cred();
>>> @@ -493,7 +502,7 @@ void handle_privileged_root(struct linux_binprm *bprm, bool has_fcap, bool *effe
>>>         * for a setuid root binary run by a non-root user.  Do set it
>>>         * for a root user just to cause least surprise to an admin.
>>>         */
>>> -       if (has_fcap && !uid_eq(new->uid, root_uid) && uid_eq(new->euid, root_uid)) {
>>> +       if (has_fcap && is_suid(root_uid, new)) {
>> 
>> e.g. this.  The logic used to be obviously slightly dicey.  Now it
>> looks sane but doesn't do what you'd naively expect it to do, which is
>> far worse.
> 
> In what way does not do what you'd expect?

It doesn't look at cred->suid.--
To unsubscribe from this list: send the line "unsubscribe linux-security-module" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

WARNING: multiple messages have this Message-ID (diff)
From: Andy Lutomirski <luto@amacapital.net>
To: "Serge E. Hallyn" <serge@hallyn.com>
Cc: Andy Lutomirski <luto@kernel.org>,
	Richard Guy Briggs <rgb@redhat.com>,
	LSM List <linux-security-module@vger.kernel.org>,
	linux-audit@redhat.com,
	"Serge E. Hallyn" <serge.hallyn@ubuntu.com>,
	Kees Cook <keescook@chromium.org>,
	James Morris <james.l.morris@oracle.com>,
	Eric Paris <eparis@redhat.com>, Paul Moore <pmoore@redhat.com>,
	Steve Grubb <sgrubb@redhat.com>
Subject: Re: [PATCH V3 05/10] capabilities: use intuitive names for id changes
Date: Fri, 25 Aug 2017 12:45:15 -0700	[thread overview]
Message-ID: <9465A086-A2C8-41E6-994E-34C7B1B9F0F9@amacapital.net> (raw)
In-Reply-To: <20170825185127.GB26620@mail.hallyn.com>




--Andy
> On Aug 25, 2017, at 11:51 AM, Serge E. Hallyn <serge@hallyn.com> wrote:
> 
> Quoting Andy Lutomirski (luto@kernel.org):
>>> On Wed, Aug 23, 2017 at 3:12 AM, Richard Guy Briggs <rgb@redhat.com> wrote:
>>> Introduce a number of inlines to make the use of the negation of
>>> uid_eq() easier to read and analyse.
>>> 
>>> Signed-off-by: Richard Guy Briggs <rgb@redhat.com>
>>> ---
>>> security/commoncap.c |   26 +++++++++++++++++++++-----
>>> 1 files changed, 21 insertions(+), 5 deletions(-)
>>> 
>>> diff --git a/security/commoncap.c b/security/commoncap.c
>>> index 36c38a1..1af7dec 100644
>>> --- a/security/commoncap.c
>>> +++ b/security/commoncap.c
>>> @@ -483,6 +483,15 @@ static int get_file_caps(struct linux_binprm *bprm, bool *effective, bool *has_f
>>> 
>>> static inline bool root_privileged(void) { return !issecure(SECURE_NOROOT); }
>>> 
>>> +static inline bool is_real(kuid_t uid, struct cred *cred)
>>> +{ return uid_eq(cred->uid, uid); }
>> 
>> OK I guess, but this just seems like a way to obfuscate the code a bit
>> and save typing "->uid".
> 
> Personally I find the new to be far more readable.  In the old, the
> distinction between uid and euid is one character hidden in the middle
> of the expression.

Would real_uid_eq be better?

> 
>>> +
>>> +static inline bool is_eff(kuid_t uid, struct cred *cred)
>>> +{ return uid_eq(cred->euid, uid); }
>> 
>> Ditto.
>> 
>>> +
>>> +static inline bool is_suid(kuid_t uid, struct cred *cred)
>>> +{ return !is_real(uid, cred) && is_eff(uid, cred); }
>> 
>> Please no.  This is IMO insane.  You're hiding really weird,
>> nonintuitive logic in an oddly named helper.
> 
> How is it nonintuitive?  It's very precisely checking that a
> nonroot user is executing something that results in euid=0.

I can think of several sensible predicated:

1. Are we execing a setuid-root program, where the setuod bit wasn't suppressed by nnp, mount options, trace, etc?

2. Same as 1, but also require that we weren't root.

3. Is the new euid 0 and old uid != 0?

4. Does suid == 0?

This helper checks something equivalent to 3, but only once were far enough through exec and before user code starts.  This is probably equivalent to 2 as well.  This is quite subtle and deserves an open-coded check, a much more carefully named helper, or, better yet, something that looks at binprm instead of cred.

is_suid sounds like #4.

> That's what it's checking for, the name of the new helper makes
> that clear, and the code becomes clearer because we only see the
> thing we care about checking for rather than the intent being
> hidden.


> 
>> Also, this is going to cause massive confusion and severe bugs: given
>> the same, the only remotely sensible guess as to what this function
>> does is uid_eq(cred->suid, uid).  So NAK to this.
>> 
>>> +
>>> void handle_privileged_root(struct linux_binprm *bprm, bool has_fcap, bool *effective, kuid_t root_uid)
>>> {
>>>        const struct cred *old = current_cred();
>>> @@ -493,7 +502,7 @@ void handle_privileged_root(struct linux_binprm *bprm, bool has_fcap, bool *effe
>>>         * for a setuid root binary run by a non-root user.  Do set it
>>>         * for a root user just to cause least surprise to an admin.
>>>         */
>>> -       if (has_fcap && !uid_eq(new->uid, root_uid) && uid_eq(new->euid, root_uid)) {
>>> +       if (has_fcap && is_suid(root_uid, new)) {
>> 
>> e.g. this.  The logic used to be obviously slightly dicey.  Now it
>> looks sane but doesn't do what you'd naively expect it to do, which is
>> far worse.
> 
> In what way does not do what you'd expect?

It doesn't look at cred->suid.

  reply	other threads:[~2017-08-25 19:45 UTC|newest]

Thread overview: 114+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-23 10:12 [PATCH V3 00/10] capabilities: do not audit log BPRM_FCAPS on set*id Richard Guy Briggs
2017-08-23 10:12 ` Richard Guy Briggs
2017-08-23 10:12 ` [PATCH V3 01/10] capabilities: factor out cap_bprm_set_creds privileged root Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 15:42   ` Serge E. Hallyn
2017-08-24 15:42     ` Serge E. Hallyn
2017-08-25  5:55   ` James Morris
2017-08-25  5:55     ` James Morris
2017-08-25 10:49     ` Richard Guy Briggs
2017-08-25 10:49       ` Richard Guy Briggs
2017-08-23 10:12 ` [PATCH V3 02/10] capabilities: intuitive names for cap gain status Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:03   ` Serge E. Hallyn
2017-08-24 16:03     ` Serge E. Hallyn
2017-08-24 16:19     ` Richard Guy Briggs
2017-08-24 16:19       ` Richard Guy Briggs
2017-08-24 16:37       ` Serge E. Hallyn
2017-08-24 16:37         ` Serge E. Hallyn
2017-08-24 19:06         ` Kees Cook
2017-08-24 19:06           ` Kees Cook
2017-08-24 21:17           ` Paul Moore
2017-08-24 21:17             ` Paul Moore
2017-08-28  9:19           ` Richard Guy Briggs
2017-08-28  9:19             ` Richard Guy Briggs
2017-08-28 11:08             ` Richard Guy Briggs
2017-08-28 11:08               ` Richard Guy Briggs
2017-09-01 10:18               ` Richard Guy Briggs
2017-09-01 10:18                 ` Richard Guy Briggs
2017-09-02  5:37                 ` Serge E. Hallyn
2017-09-02  5:37                   ` Serge E. Hallyn
2017-09-04  6:57                   ` Richard Guy Briggs
2017-09-04  6:57                     ` Richard Guy Briggs
2017-09-05  6:45                     ` Richard Guy Briggs
2017-09-05  6:45                       ` Richard Guy Briggs
2017-08-25  5:56   ` James Morris
2017-08-25  5:56     ` James Morris
2017-08-25 15:08   ` Andy Lutomirski
2017-08-25 15:08     ` Andy Lutomirski
2017-08-25 18:47     ` Serge E. Hallyn
2017-08-25 18:47       ` Serge E. Hallyn
2017-08-23 10:12 ` [PATCH V3 03/10] capabilities: rename has_cap to has_fcap Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:10   ` Serge E. Hallyn
2017-08-24 16:10     ` Serge E. Hallyn
2017-08-25  5:56   ` James Morris
2017-08-25  5:56     ` James Morris
2017-08-23 10:12 ` [PATCH V3 04/10] capabilities: use root_priveleged inline to clarify logic Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:14   ` Serge E. Hallyn
2017-08-24 16:14     ` Serge E. Hallyn
2017-08-25  5:58   ` James Morris
2017-08-25  5:58     ` James Morris
2017-08-28 12:03     ` Richard Guy Briggs
2017-08-28 12:03       ` Richard Guy Briggs
2017-08-31 14:49       ` Serge E. Hallyn
2017-08-31 14:49         ` Serge E. Hallyn
2017-08-23 10:12 ` [PATCH V3 05/10] capabilities: use intuitive names for id changes Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:17   ` Serge E. Hallyn
2017-08-24 16:17     ` Serge E. Hallyn
2017-08-25  5:59   ` James Morris
2017-08-25  5:59     ` James Morris
2017-08-25 15:06   ` Andy Lutomirski
2017-08-25 15:06     ` Andy Lutomirski
2017-08-25 18:51     ` Serge E. Hallyn
2017-08-25 18:51       ` Serge E. Hallyn
2017-08-25 19:45       ` Andy Lutomirski [this message]
2017-08-25 19:45         ` Andy Lutomirski
2017-08-25 20:06         ` Serge E. Hallyn
2017-08-25 20:06           ` Serge E. Hallyn
2017-08-28  1:32           ` James Morris
2017-08-28  1:32             ` James Morris
2017-08-28  9:12           ` Richard Guy Briggs
2017-08-28  9:12             ` Richard Guy Briggs
2017-08-28 20:12             ` Andy Lutomirski
2017-08-28 20:12               ` Andy Lutomirski
2017-08-23 10:12 ` [PATCH V3 06/10] capabilities: move audit log decision to function Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:18   ` Serge E. Hallyn
2017-08-24 16:18     ` Serge E. Hallyn
2017-08-25  6:01   ` James Morris
2017-08-25  6:01     ` James Morris
2017-08-23 10:12 ` [PATCH V3 07/10] capabilities: remove a layer of conditional logic Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:20   ` Serge E. Hallyn
2017-08-24 16:20     ` Serge E. Hallyn
2017-08-25  5:47   ` James Morris
2017-08-25  5:47     ` James Morris
2017-08-25 15:11   ` Andy Lutomirski
2017-08-25 15:11     ` Andy Lutomirski
2017-08-25 18:53     ` Serge E. Hallyn
2017-08-25 18:53       ` Serge E. Hallyn
2017-08-23 10:12 ` [PATCH V3 08/10] capabilities: invert logic for clarity Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:23   ` Serge E. Hallyn
2017-08-24 16:23     ` Serge E. Hallyn
2017-08-25  5:47   ` James Morris
2017-08-25  5:47     ` James Morris
2017-08-23 10:13 ` [PATCH V3 09/10] capabilities: fix logic for effective root or real root Richard Guy Briggs
2017-08-23 10:13   ` Richard Guy Briggs
2017-08-24 16:29   ` Serge E. Hallyn
2017-08-24 16:29     ` Serge E. Hallyn
2017-08-24 16:44     ` Richard Guy Briggs
2017-08-24 16:44       ` Richard Guy Briggs
2017-08-24 16:47       ` Serge E. Hallyn
2017-08-24 16:47         ` Serge E. Hallyn
2017-08-25  5:48   ` James Morris
2017-08-25  5:48     ` James Morris
2017-08-23 10:13 ` [PATCH V3 10/10] capabilities: audit log other surprising conditions Richard Guy Briggs
2017-08-23 10:13   ` Richard Guy Briggs
2017-08-24 16:35   ` Serge E. Hallyn
2017-08-24 16:35     ` Serge E. Hallyn
2017-08-25  5:50   ` James Morris
2017-08-25  5:50     ` James Morris

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9465A086-A2C8-41E6-994E-34C7B1B9F0F9@amacapital.net \
    --to=luto@amacapital.net \
    --cc=linux-security-module@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.