All of lore.kernel.org
 help / color / mirror / Atom feed
From: Javier Martinez Canillas <javierm@redhat.com>
To: Maxime Ripard <maxime@cerno.tech>,
	Daniel Vetter <daniel@ffwll.ch>,
	Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	Maxime Ripard <mripard@kernel.org>,
	David Airlie <airlied@gmail.com>,
	Thomas Zimmermann <tzimmermann@suse.de>
Cc: "David Gow" <davidgow@google.com>,
	"Maíra Canal" <mairacanal@riseup.net>,
	"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
	"Dave Stevenson" <dave.stevenson@raspberrypi.com>,
	linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org,
	linaro-mm-sig@lists.linaro.org,
	"Brendan Higgins" <brendan.higgins@linux.dev>,
	linux-kselftest@vger.kernel.org, kunit-dev@googlegroups.com,
	linux-media@vger.kernel.org
Subject: Re: [PATCH v2 15/17] drm/vc4: tests: Introduce a mocking infrastructure
Date: Wed, 30 Nov 2022 10:59:37 +0100	[thread overview]
Message-ID: <98d47486-d04c-b81a-6ae4-fa7f62828a0e@redhat.com> (raw)
In-Reply-To: <20221123-rpi-kunit-tests-v2-15-efe5ed518b63@cerno.tech>

On 11/28/22 15:53, Maxime Ripard wrote:
> In order to test the current atomic_check hooks we need to have a DRM
> device that has roughly the same capabilities and layout that the actual
> hardware. We'll also need a bunch of functions to create arbitrary
> atomic states.
> 
> Let's create some helpers to create a device that behaves like the real
> one, and some helpers to maintain the atomic state we want to check.
> 
> Signed-off-by: Maxime Ripard <maxime@cerno.tech>
> ---

[...]

> +
> +config DRM_VC4_KUNIT_TEST
> +	bool "KUnit tests for VC4" if !KUNIT_ALL_TESTS
> +	depends on DRM_VC4 && KUNIT

shouldn't this depend on DRM_KUNIT_TEST instead ?

[...]

> +static struct vc4_dev *__mock_device(struct kunit *test, bool is_vc5)
> +{
> +	struct drm_device *drm;
> +	const struct drm_driver *drv = is_vc5 ? &vc5_drm_driver : &vc4_drm_driver;
> +	const struct vc4_mock_desc *desc = is_vc5 ? &vc5_mock : &vc4_mock;
> +	struct vc4_dev *vc4;

Since it could be vc4 or vc5, maybe can be renamed to just struct vc_dev *vc ?

> +struct vc4_dummy_plane *vc4_dummy_plane(struct kunit *test,
> +					struct drm_device *drm,
> +					enum drm_plane_type type)
> +{
> +	struct vc4_dummy_plane *dummy_plane;
> +	struct drm_plane *plane;
> +
> +	dummy_plane = drmm_universal_plane_alloc(drm,
> +						 struct vc4_dummy_plane, plane.base,
> +						 0,
> +						 &vc4_dummy_plane_funcs,
> +						 vc4_dummy_plane_formats,
> +						 ARRAY_SIZE(vc4_dummy_plane_formats),
> +						 NULL,
> +						 DRM_PLANE_TYPE_PRIMARY,
> +						 NULL);
> +	KUNIT_ASSERT_NOT_ERR_OR_NULL(test, dummy_plane);
> +
> +	plane = &dummy_plane->plane.base;
> +	drm_plane_helper_add(plane, &vc4_dummy_plane_helper_funcs);
> +
> +	return dummy_plane;
> +}

I guess many of these helpers could grow to be generic, like this one since
most drivers support the DRM_FORMAT_XRGB8888 format for their primary plane.

[...]

>  
> +extern const struct vc4_pv_data bcm2835_pv0_data;
> +extern const struct vc4_pv_data bcm2835_pv1_data;
> +extern const struct vc4_pv_data bcm2835_pv2_data;
> +extern const struct vc4_pv_data bcm2711_pv0_data;
> +extern const struct vc4_pv_data bcm2711_pv1_data;
> +extern const struct vc4_pv_data bcm2711_pv2_data;
> +extern const struct vc4_pv_data bcm2711_pv3_data;
> +extern const struct vc4_pv_data bcm2711_pv4_data;
> +

Maybe the driver could expose a helper function to get the pixelvalve data
and avoid having to expose all of these variables? For example you could
define an enum vc4_pixelvalve type and have something like the following:

const struct vc4_pv_data *vc4_crtc_get_pixelvalve_data(enum vc4_pixelvalve pv);

All these are small nits though, the patch looks great to me and I think is
awesome to have this level of testing with KUnit. Hope other drivers follow
your lead.

Reviewed-by: Javier Martinez Canillas <javierm@redhat.com>

-- 
Best regards,

Javier Martinez Canillas
Core Platforms
Red Hat


WARNING: multiple messages have this Message-ID (diff)
From: Javier Martinez Canillas <javierm@redhat.com>
To: Maxime Ripard <maxime@cerno.tech>,
	Daniel Vetter <daniel@ffwll.ch>,
	Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	Maxime Ripard <mripard@kernel.org>,
	David Airlie <airlied@gmail.com>,
	Thomas Zimmermann <tzimmermann@suse.de>
Cc: dri-devel@lists.freedesktop.org,
	"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
	kunit-dev@googlegroups.com, linux-media@vger.kernel.org,
	linux-kselftest@vger.kernel.org, linaro-mm-sig@lists.linaro.org,
	"Brendan Higgins" <brendan.higgins@linux.dev>,
	"Maíra Canal" <mairacanal@riseup.net>,
	"Dave Stevenson" <dave.stevenson@raspberrypi.com>,
	linux-kernel@vger.kernel.org, "David Gow" <davidgow@google.com>
Subject: Re: [PATCH v2 15/17] drm/vc4: tests: Introduce a mocking infrastructure
Date: Wed, 30 Nov 2022 10:59:37 +0100	[thread overview]
Message-ID: <98d47486-d04c-b81a-6ae4-fa7f62828a0e@redhat.com> (raw)
In-Reply-To: <20221123-rpi-kunit-tests-v2-15-efe5ed518b63@cerno.tech>

On 11/28/22 15:53, Maxime Ripard wrote:
> In order to test the current atomic_check hooks we need to have a DRM
> device that has roughly the same capabilities and layout that the actual
> hardware. We'll also need a bunch of functions to create arbitrary
> atomic states.
> 
> Let's create some helpers to create a device that behaves like the real
> one, and some helpers to maintain the atomic state we want to check.
> 
> Signed-off-by: Maxime Ripard <maxime@cerno.tech>
> ---

[...]

> +
> +config DRM_VC4_KUNIT_TEST
> +	bool "KUnit tests for VC4" if !KUNIT_ALL_TESTS
> +	depends on DRM_VC4 && KUNIT

shouldn't this depend on DRM_KUNIT_TEST instead ?

[...]

> +static struct vc4_dev *__mock_device(struct kunit *test, bool is_vc5)
> +{
> +	struct drm_device *drm;
> +	const struct drm_driver *drv = is_vc5 ? &vc5_drm_driver : &vc4_drm_driver;
> +	const struct vc4_mock_desc *desc = is_vc5 ? &vc5_mock : &vc4_mock;
> +	struct vc4_dev *vc4;

Since it could be vc4 or vc5, maybe can be renamed to just struct vc_dev *vc ?

> +struct vc4_dummy_plane *vc4_dummy_plane(struct kunit *test,
> +					struct drm_device *drm,
> +					enum drm_plane_type type)
> +{
> +	struct vc4_dummy_plane *dummy_plane;
> +	struct drm_plane *plane;
> +
> +	dummy_plane = drmm_universal_plane_alloc(drm,
> +						 struct vc4_dummy_plane, plane.base,
> +						 0,
> +						 &vc4_dummy_plane_funcs,
> +						 vc4_dummy_plane_formats,
> +						 ARRAY_SIZE(vc4_dummy_plane_formats),
> +						 NULL,
> +						 DRM_PLANE_TYPE_PRIMARY,
> +						 NULL);
> +	KUNIT_ASSERT_NOT_ERR_OR_NULL(test, dummy_plane);
> +
> +	plane = &dummy_plane->plane.base;
> +	drm_plane_helper_add(plane, &vc4_dummy_plane_helper_funcs);
> +
> +	return dummy_plane;
> +}

I guess many of these helpers could grow to be generic, like this one since
most drivers support the DRM_FORMAT_XRGB8888 format for their primary plane.

[...]

>  
> +extern const struct vc4_pv_data bcm2835_pv0_data;
> +extern const struct vc4_pv_data bcm2835_pv1_data;
> +extern const struct vc4_pv_data bcm2835_pv2_data;
> +extern const struct vc4_pv_data bcm2711_pv0_data;
> +extern const struct vc4_pv_data bcm2711_pv1_data;
> +extern const struct vc4_pv_data bcm2711_pv2_data;
> +extern const struct vc4_pv_data bcm2711_pv3_data;
> +extern const struct vc4_pv_data bcm2711_pv4_data;
> +

Maybe the driver could expose a helper function to get the pixelvalve data
and avoid having to expose all of these variables? For example you could
define an enum vc4_pixelvalve type and have something like the following:

const struct vc4_pv_data *vc4_crtc_get_pixelvalve_data(enum vc4_pixelvalve pv);

All these are small nits though, the patch looks great to me and I think is
awesome to have this level of testing with KUnit. Hope other drivers follow
your lead.

Reviewed-by: Javier Martinez Canillas <javierm@redhat.com>

-- 
Best regards,

Javier Martinez Canillas
Core Platforms
Red Hat


  parent reply	other threads:[~2022-11-30  9:59 UTC|newest]

Thread overview: 60+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-11-28 14:53 [PATCH v2 00/17] drm: Introduce Kunit Tests to VC4 Maxime Ripard
2022-11-28 14:53 ` [PATCH v2 01/17] drm/tests: helpers: Move the helper header to include/drm Maxime Ripard
2022-11-30  8:00   ` Javier Martinez Canillas
2022-11-30  8:00     ` Javier Martinez Canillas
2022-12-01 10:27     ` Maxime Ripard
2022-12-01 10:27       ` Maxime Ripard
2022-12-01 10:38       ` Javier Martinez Canillas
2022-12-01 10:38         ` Javier Martinez Canillas
2022-11-28 14:53 ` [PATCH v2 02/17] drm/tests: helpers: Document drm_kunit_device_init() Maxime Ripard
2022-11-28 19:30   ` Maíra Canal
2022-11-28 19:30     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 03/17] drm/tests: helpers: Rename the device init helper Maxime Ripard
2022-11-28 20:36   ` Maíra Canal
2022-11-28 20:36     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 04/17] drm/tests: helpers: Remove the name parameter Maxime Ripard
2022-11-28 19:37   ` Maíra Canal
2022-11-28 19:37     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 05/17] drm/tests: helpers: Create the device in another function Maxime Ripard
2022-11-28 19:48   ` Maíra Canal
2022-11-28 19:48     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 06/17] drm/tests: helpers: Switch to a platform_device Maxime Ripard
2022-11-28 20:01   ` Maíra Canal
2022-11-28 20:01     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 07/17] drm/tests: helpers: Make sure the device is bound Maxime Ripard
2022-11-28 20:09   ` Maíra Canal
2022-11-28 20:09     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 08/17] drm/tests: helpers: Allow for a custom device struct to be allocated Maxime Ripard
2022-11-30  9:13   ` Javier Martinez Canillas
2022-11-30  9:13     ` Javier Martinez Canillas
2022-11-28 14:53 ` [PATCH v2 09/17] drm/tests: helpers: Allow to pass a custom drm_driver Maxime Ripard
2022-11-30  9:27   ` Javier Martinez Canillas
2022-11-30  9:27     ` Javier Martinez Canillas
2022-11-28 14:53 ` [PATCH v2 10/17] drm/tests: Add a test for DRM managed actions Maxime Ripard
2022-11-28 20:14   ` Maíra Canal
2022-11-28 20:14     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 11/17] drm/vc4: Move HVS state to main header Maxime Ripard
2022-11-28 20:16   ` Maíra Canal
2022-11-28 20:16     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 12/17] drm/vc4: crtc: Introduce a lower-level crtc init helper Maxime Ripard
2022-11-28 20:23   ` Maíra Canal
2022-11-28 20:23     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 13/17] drm/vc4: crtc: Make encoder lookup helper public Maxime Ripard
2022-11-28 20:26   ` Maíra Canal
2022-11-28 20:26     ` Maíra Canal
2022-11-28 14:53 ` [PATCH v2 14/17] drm/vc4: hvs: Provide a function to initialize the HVS structure Maxime Ripard
2022-11-28 14:53 ` [PATCH v2 15/17] drm/vc4: tests: Introduce a mocking infrastructure Maxime Ripard
2022-11-28 20:35   ` Maíra Canal
2022-11-28 20:35     ` Maíra Canal
2022-11-30  9:59   ` Javier Martinez Canillas [this message]
2022-11-30  9:59     ` Javier Martinez Canillas
2022-12-01 13:03     ` Maxime Ripard
2022-12-01 13:03       ` Maxime Ripard
2022-11-28 14:53 ` [PATCH v2 16/17] drm/vc4: tests: Fail the current test if we access a register Maxime Ripard
2022-11-30 10:09   ` Javier Martinez Canillas
2022-11-30 10:09     ` Javier Martinez Canillas
2022-11-28 14:53 ` [PATCH v2 17/17] drm/vc4: tests: Add unit test suite for the PV muxing Maxime Ripard
2022-11-30 10:15   ` Javier Martinez Canillas
2022-11-30 10:15     ` Javier Martinez Canillas
2022-11-28 20:48 ` [PATCH v2 00/17] drm: Introduce Kunit Tests to VC4 Maíra Canal
2022-11-28 20:48   ` Maíra Canal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=98d47486-d04c-b81a-6ae4-fa7f62828a0e@redhat.com \
    --to=javierm@redhat.com \
    --cc=airlied@gmail.com \
    --cc=brendan.higgins@linux.dev \
    --cc=daniel@ffwll.ch \
    --cc=dave.stevenson@raspberrypi.com \
    --cc=davidgow@google.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=kunit-dev@googlegroups.com \
    --cc=linaro-mm-sig@lists.linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mairacanal@riseup.net \
    --cc=maxime@cerno.tech \
    --cc=mripard@kernel.org \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.