All of lore.kernel.org
 help / color / mirror / Atom feed
From: Maxim Osipov <maxim.osipov@gmail.com>
To: Ryan Mallon <ryan@bluewatersys.com>
Cc: Russell King <linux@arm.linux.org.uk>,
	Andrew Victor <linux@maxim.org.za>,
	Nicolas Ferre <nicolas.ferre@atmel.com>,
	Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>,
	"Antonio R. Costa" <costa.antonior@gmail.com>,
	Ernst Schwab <eschwab@online.de>,
	Andrew Morton <akpm@linux-foundation.org>,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2] AT91: Add flexibity board support
Date: Tue, 14 Sep 2010 09:57:27 +0400	[thread overview]
Message-ID: <AANLkTi=-n0_uFMKGED-aOtuLEfUyVeMcm5FWX5xM_BT1@mail.gmail.com> (raw)
In-Reply-To: <4C8E8F31.2050108@bluewatersys.com>

Please see my comments below...

On Tue, Sep 14, 2010 at 12:53 AM, Ryan Mallon <ryan@bluewatersys.com> wrote:
> On 09/13/2010 10:18 PM, Maxim Osipov wrote:
>
>> +static void __init flexibity_board_init(void)
>> +{
>> +     /* Serial */
>> +     at91_add_device_serial();
>> +     /* USB Host */
>> +     at91_add_device_usbh(&flexibity_usbh_data);
>> +     /* USB Device */
>> +     at91_add_device_udc(&flexibity_udc_data);
>> +     /* SPI */
>> +     at91_add_device_spi(flexibity_spi_devices,
>> +             ARRAY_SIZE(flexibity_spi_devices));
>> +     /* MMC */
>> +     at91_add_device_mmc(0, &flexibity_mmc_data);
>> +     /* LEDs */
>> +     at91_gpio_leds(flexibity_leds, ARRAY_SIZE(flexibity_leds));
>
> Can we drop all the comments inside this function please. They don't add
> any information and they make it harder to read the actual code.
>

Ryan, thank you for the review. However I would like to keep these
comments - for some devices, like UDC - it really provides
clarification. Reading the code is not a problem with proper
highlighting scheme.

Kind regards,
Maxim

WARNING: multiple messages have this Message-ID (diff)
From: maxim.osipov@gmail.com (Maxim Osipov)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v2] AT91: Add flexibity board support
Date: Tue, 14 Sep 2010 09:57:27 +0400	[thread overview]
Message-ID: <AANLkTi=-n0_uFMKGED-aOtuLEfUyVeMcm5FWX5xM_BT1@mail.gmail.com> (raw)
In-Reply-To: <4C8E8F31.2050108@bluewatersys.com>

Please see my comments below...

On Tue, Sep 14, 2010 at 12:53 AM, Ryan Mallon <ryan@bluewatersys.com> wrote:
> On 09/13/2010 10:18 PM, Maxim Osipov wrote:
>
>> +static void __init flexibity_board_init(void)
>> +{
>> + ? ? /* Serial */
>> + ? ? at91_add_device_serial();
>> + ? ? /* USB Host */
>> + ? ? at91_add_device_usbh(&flexibity_usbh_data);
>> + ? ? /* USB Device */
>> + ? ? at91_add_device_udc(&flexibity_udc_data);
>> + ? ? /* SPI */
>> + ? ? at91_add_device_spi(flexibity_spi_devices,
>> + ? ? ? ? ? ? ARRAY_SIZE(flexibity_spi_devices));
>> + ? ? /* MMC */
>> + ? ? at91_add_device_mmc(0, &flexibity_mmc_data);
>> + ? ? /* LEDs */
>> + ? ? at91_gpio_leds(flexibity_leds, ARRAY_SIZE(flexibity_leds));
>
> Can we drop all the comments inside this function please. They don't add
> any information and they make it harder to read the actual code.
>

Ryan, thank you for the review. However I would like to keep these
comments - for some devices, like UDC - it really provides
clarification. Reading the code is not a problem with proper
highlighting scheme.

Kind regards,
Maxim

  reply	other threads:[~2010-09-14  5:57 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-09-13 10:18 [PATCH v2] AT91: Add flexibity board support Maxim Osipov
2010-09-13 10:18 ` Maxim Osipov
2010-09-13 10:56 ` Marek Vasut
2010-09-13 10:56   ` Marek Vasut
2010-09-13 11:02   ` Maxim Osipov
2010-09-13 11:02     ` Maxim Osipov
2010-09-13 12:42     ` Marek Vasut
2010-09-13 12:42       ` Marek Vasut
2010-09-13 11:37 ` Jean-Christophe PLAGNIOL-VILLARD
2010-09-13 11:37   ` Jean-Christophe PLAGNIOL-VILLARD
2010-09-13 20:53 ` Ryan Mallon
2010-09-13 20:53   ` Ryan Mallon
2010-09-14  5:57   ` Maxim Osipov [this message]
2010-09-14  5:57     ` Maxim Osipov
2010-09-14  7:00     ` Jean-Christophe PLAGNIOL-VILLARD
2010-09-14  7:00       ` Jean-Christophe PLAGNIOL-VILLARD
2010-09-14 20:48     ` Ryan Mallon
2010-09-14 20:48       ` Ryan Mallon
  -- strict thread matches above, loose matches on Subject: below --
2010-09-12 12:23 Maxim Osipov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='AANLkTi=-n0_uFMKGED-aOtuLEfUyVeMcm5FWX5xM_BT1@mail.gmail.com' \
    --to=maxim.osipov@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=costa.antonior@gmail.com \
    --cc=eschwab@online.de \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@arm.linux.org.uk \
    --cc=linux@maxim.org.za \
    --cc=nicolas.ferre@atmel.com \
    --cc=plagnioj@jcrosoft.com \
    --cc=ryan@bluewatersys.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.