All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Nori, Sekhar" <nsekhar@ti.com>
To: Ryan Mallon <rmallon@gmail.com>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"Hilman, Kevin" <khilman@ti.com>,
	Grant Likely <grant.likely@secretlab.ca>,
	"Chemparathy, Cyril" <cyril@ti.com>,
	"linux-arm-kernel@lists.infradead.org" 
	<linux-arm-kernel@lists.infradead.org>,
	"davinci-linux-open-source@linux.davincidsp.com" 
	<davinci-linux-open-source@linux.davincidsp.com>
Subject: RE: [RFC/RFT 1/2] gpio/basic_mmio: add support for enable register
Date: Tue, 5 Jul 2011 14:02:00 +0530	[thread overview]
Message-ID: <B85A65D85D7EB246BE421B3FB0FBB593024D91A45E@dbde02.ent.ti.com> (raw)
In-Reply-To: <4E12AC10.9020206@gmail.com>

Hi Ryan,

On Tue, Jul 05, 2011 at 11:45:44, Ryan Mallon wrote:
> On 05/07/11 15:10, Sekhar Nori wrote:
> > Some GPIO controllers have an enable register
> > which needs to be written to before a GPIO
> > can be used.
> >
> > Add support for enabling the GPIO. At this
> > time inverted logic for enabling the GPIO
> > is not supported. This can be done by adding
> > a disable register as and when a controller
> > with this comes along.
> >
> > Signed-off-by: Sekhar Nori<nsekhar@ti.com>
> > ---
> >
> <snip>
> 
> > static int bgpio_setup_io(struct bgpio_chip *bgc,
> >   			  void __iomem *dat,
> > @@ -369,6 +401,7 @@ int __devinit bgpio_init(struct bgpio_chip *bgc,
> >   			 void __iomem *clr,
> >   			 void __iomem *dirout,
> >   			 void __iomem *dirin,
> > +			 void __iomem *en,
> >   			 bool big_endian)
> 
> The arguments to this function are getting a bit unwieldy :-). Maybe we 
> need to introduce something like:
> 
> struct bgpio_chip_info {
>      struct device *dev;
>      unsigned long sz;
>      void __iomem *dat;
>      void __iomem *set;
>      void __iomem *clr;
>      void __iomem *dirout;
>      void __iomem *dirin;
>      void __iomem *en;
>      bool big_endian;
> };
> 
> and pass that to bgpio_init instead. It would have the added benefits of 
> making the drivers more readable and that bgpio_chip_info structs in the 
> drivers can probably be marked __initdata also.
> 
> Since you are already having to touch all of the call sites for 
> bgpio_init this could be done as a separate patch along with this series.

Agreed. I can do this if Grant too thinks this is a
pre-requisite to adding new functionality.

Thanks,
Sekhar


WARNING: multiple messages have this Message-ID (diff)
From: nsekhar@ti.com (Nori, Sekhar)
To: linux-arm-kernel@lists.infradead.org
Subject: [RFC/RFT 1/2] gpio/basic_mmio: add support for enable register
Date: Tue, 5 Jul 2011 14:02:00 +0530	[thread overview]
Message-ID: <B85A65D85D7EB246BE421B3FB0FBB593024D91A45E@dbde02.ent.ti.com> (raw)
In-Reply-To: <4E12AC10.9020206@gmail.com>

Hi Ryan,

On Tue, Jul 05, 2011 at 11:45:44, Ryan Mallon wrote:
> On 05/07/11 15:10, Sekhar Nori wrote:
> > Some GPIO controllers have an enable register
> > which needs to be written to before a GPIO
> > can be used.
> >
> > Add support for enabling the GPIO. At this
> > time inverted logic for enabling the GPIO
> > is not supported. This can be done by adding
> > a disable register as and when a controller
> > with this comes along.
> >
> > Signed-off-by: Sekhar Nori<nsekhar@ti.com>
> > ---
> >
> <snip>
> 
> > static int bgpio_setup_io(struct bgpio_chip *bgc,
> >   			  void __iomem *dat,
> > @@ -369,6 +401,7 @@ int __devinit bgpio_init(struct bgpio_chip *bgc,
> >   			 void __iomem *clr,
> >   			 void __iomem *dirout,
> >   			 void __iomem *dirin,
> > +			 void __iomem *en,
> >   			 bool big_endian)
> 
> The arguments to this function are getting a bit unwieldy :-). Maybe we 
> need to introduce something like:
> 
> struct bgpio_chip_info {
>      struct device *dev;
>      unsigned long sz;
>      void __iomem *dat;
>      void __iomem *set;
>      void __iomem *clr;
>      void __iomem *dirout;
>      void __iomem *dirin;
>      void __iomem *en;
>      bool big_endian;
> };
> 
> and pass that to bgpio_init instead. It would have the added benefits of 
> making the drivers more readable and that bgpio_chip_info structs in the 
> drivers can probably be marked __initdata also.
> 
> Since you are already having to touch all of the call sites for 
> bgpio_init this could be done as a separate patch along with this series.

Agreed. I can do this if Grant too thinks this is a
pre-requisite to adding new functionality.

Thanks,
Sekhar

  reply	other threads:[~2011-07-05  8:32 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-07-05  5:10 [RFC/RFT 0/2] gpio: move tnetv107x gpio support to drivers/gpio Sekhar Nori
2011-07-05  5:10 ` Sekhar Nori
2011-07-05  5:10 ` [RFC/RFT 1/2] gpio/basic_mmio: add support for enable register Sekhar Nori
2011-07-05  6:15   ` Ryan Mallon
2011-07-05  6:15     ` Ryan Mallon
2011-07-05  8:32     ` Nori, Sekhar [this message]
2011-07-05  8:32       ` Nori, Sekhar
2011-07-06 21:10     ` Grant Likely
2011-07-06 21:10       ` Grant Likely
2011-07-07 16:45       ` Nori, Sekhar
2011-07-07 16:45         ` Nori, Sekhar
2011-07-07 18:37         ` Grant Likely
2011-07-07 18:37           ` Grant Likely
2011-07-07 21:23           ` Ryan Mallon
2011-07-07 21:23             ` Ryan Mallon
2011-07-05  5:11 ` [RFC/RFT 2/2] davinci: use generic memory mapped gpio for tnetv107x Sekhar Nori
2011-07-06 22:02   ` Grant Likely
2011-07-06 22:02     ` Grant Likely
2011-07-07 12:18     ` Nori, Sekhar
2011-07-07 12:18       ` Nori, Sekhar
2011-07-13 14:46     ` Anton Vorontsov
2011-07-13 14:46       ` Anton Vorontsov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=B85A65D85D7EB246BE421B3FB0FBB593024D91A45E@dbde02.ent.ti.com \
    --to=nsekhar@ti.com \
    --cc=cyril@ti.com \
    --cc=davinci-linux-open-source@linux.davincidsp.com \
    --cc=grant.likely@secretlab.ca \
    --cc=khilman@ti.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rmallon@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.