All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] drm/amd/display: fix DCC settings for DCN3
@ 2021-09-30 15:50 Marek Olšák
  2021-09-30 16:06 ` Alex Deucher
  0 siblings, 1 reply; 6+ messages in thread
From: Marek Olšák @ 2021-09-30 15:50 UTC (permalink / raw)
  To: amd-gfx mailing list


[-- Attachment #1.1: Type: text/plain, Size: 62 bytes --]

Hi,

Just discovered this typo. Please review.

Thanks,
Marek

[-- Attachment #1.2: Type: text/html, Size: 156 bytes --]

[-- Attachment #2: 0001-drm-amd-display-fix-DCC-settings-for-DCN3.patch --]
[-- Type: text/x-patch, Size: 2288 bytes --]

From 3abee824223e214d8a74c3f1b47a24e5ea9a9a34 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marek=20Ol=C5=A1=C3=A1k?= <marek.olsak@amd.com>
Date: Thu, 30 Sep 2021 11:13:59 -0400
Subject: [PATCH] drm/amd/display: fix DCC settings for DCN3
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

ind_block_64b_no_128bcl means INDEP_64B && INDEP_128B &&
MAX_COMPRESSED_BLOCK_SIZE == 64B. Only used by gfx10.3.

ind_block_64b means INDEP_64B && !INDEP_128B &&
MAX_COMPRESSED_BLOCK_SIZE == 64B. Only used by gfx9 and gfx10.

Signed-off-by: Marek Olšák <marek.olsak@amd.com>
---
 drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c           | 1 +
 drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 ++--
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
index df83b1f438b6..ebdb959f4e1f 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
@@ -97,6 +97,7 @@
  * - 3.41.0 - Add video codec query
  * - 3.42.0 - Add 16bpc fixed point display support
  * - 3.43.0 - Add device hot plug/unplug support
+ * - 3.44.0 - DCN3 supports DCC independent block settings: !64B && 128B, 64B && 128B
  */
 #define KMS_DRIVER_MAJOR	3
 #define KMS_DRIVER_MINOR	43
diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
index a399a984b8a6..49be531d68ae 100644
--- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
+++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
@@ -5105,11 +5105,11 @@ fill_gfx9_plane_attributes_from_modifiers(struct amdgpu_device *adev,
 		dcc->independent_64b_blks = independent_64b_blks;
 		if (AMD_FMT_MOD_GET(TILE_VERSION, modifier) == AMD_FMT_MOD_TILE_VER_GFX10_RBPLUS) {
 			if (independent_64b_blks && independent_128b_blks)
-				dcc->dcc_ind_blk = hubp_ind_block_64b;
+				dcc->dcc_ind_blk = hubp_ind_block_64b_no_128bcl;
 			else if (independent_128b_blks)
 				dcc->dcc_ind_blk = hubp_ind_block_128b;
 			else if (independent_64b_blks && !independent_128b_blks)
-				dcc->dcc_ind_blk = hubp_ind_block_64b_no_128bcl;
+				dcc->dcc_ind_blk = hubp_ind_block_64b;
 			else
 				dcc->dcc_ind_blk = hubp_ind_block_unconstrained;
 		} else {
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] drm/amd/display: fix DCC settings for DCN3
  2021-09-30 15:50 [PATCH] drm/amd/display: fix DCC settings for DCN3 Marek Olšák
@ 2021-09-30 16:06 ` Alex Deucher
  2021-09-30 16:14   ` Marek Olšák
  0 siblings, 1 reply; 6+ messages in thread
From: Alex Deucher @ 2021-09-30 16:06 UTC (permalink / raw)
  To: Marek Olšák; +Cc: amd-gfx mailing list

Acked-by: Alex Deucher <alexander.deucher@amd.com>

On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák <maraeo@gmail.com> wrote:
>
> Hi,
>
> Just discovered this typo. Please review.
>
> Thanks,
> Marek

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] drm/amd/display: fix DCC settings for DCN3
  2021-09-30 16:06 ` Alex Deucher
@ 2021-09-30 16:14   ` Marek Olšák
  2021-09-30 16:35     ` Joshua Ashton
  0 siblings, 1 reply; 6+ messages in thread
From: Marek Olšák @ 2021-09-30 16:14 UTC (permalink / raw)
  To: Alex Deucher; +Cc: amd-gfx mailing list

[-- Attachment #1: Type: text/plain, Size: 453 bytes --]

I've also amended the version bump that I forgot to do:

-#define KMS_DRIVER_MINOR       43
+#define KMS_DRIVER_MINOR       44

Marek

On Thu, Sep 30, 2021 at 12:06 PM Alex Deucher <alexdeucher@gmail.com> wrote:

> Acked-by: Alex Deucher <alexander.deucher@amd.com>
>
> On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák <maraeo@gmail.com> wrote:
> >
> > Hi,
> >
> > Just discovered this typo. Please review.
> >
> > Thanks,
> > Marek
>

[-- Attachment #2: Type: text/html, Size: 973 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] drm/amd/display: fix DCC settings for DCN3
  2021-09-30 16:14   ` Marek Olšák
@ 2021-09-30 16:35     ` Joshua Ashton
  2021-09-30 17:33       ` Marek Olšák
  0 siblings, 1 reply; 6+ messages in thread
From: Joshua Ashton @ 2021-09-30 16:35 UTC (permalink / raw)
  To: amd-gfx

Can we please add documentation for this enum?

This was not necessarily a typo, but me misunderstanding and stuff it 
working in my testing.

I guess I don't understand why hubp_ind_block_64b_no_128bcl is for 64b 
&& 128b when it specifically says "no_128" in the name.

Is there something about it I am missing or is it just misleading naming?

- Joshie 🐸✨

On 9/30/21 17:14, Marek Olšák wrote:
> I've also amended the version bump that I forgot to do:
> 
> -#define KMS_DRIVER_MINOR       43
> +#define KMS_DRIVER_MINOR       44
> 
> Marek
> 
> On Thu, Sep 30, 2021 at 12:06 PM Alex Deucher <alexdeucher@gmail.com 
> <mailto:alexdeucher@gmail.com>> wrote:
> 
>     Acked-by: Alex Deucher <alexander.deucher@amd.com
>     <mailto:alexander.deucher@amd.com>>
> 
>     On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák <maraeo@gmail.com
>     <mailto:maraeo@gmail.com>> wrote:
>      >
>      > Hi,
>      >
>      > Just discovered this typo. Please review.
>      >
>      > Thanks,
>      > Marek
> 


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] drm/amd/display: fix DCC settings for DCN3
  2021-09-30 16:35     ` Joshua Ashton
@ 2021-09-30 17:33       ` Marek Olšák
  2021-09-30 17:37         ` Joshua Ashton
  0 siblings, 1 reply; 6+ messages in thread
From: Marek Olšák @ 2021-09-30 17:33 UTC (permalink / raw)
  To: Joshua Ashton; +Cc: amd-gfx mailing list

[-- Attachment #1: Type: text/plain, Size: 1424 bytes --]

The name is kind of correct. It means "64B with no 128B cache line
straddling", which really means just 64B independent blocks with a small
modification to support DCC image stores.  They are not true 128B
independent blocks.

Marek

On Thu, Sep 30, 2021 at 12:35 PM Joshua Ashton <joshua@froggi.es> wrote:

> Can we please add documentation for this enum?
>
> This was not necessarily a typo, but me misunderstanding and stuff it
> working in my testing.
>
> I guess I don't understand why hubp_ind_block_64b_no_128bcl is for 64b
> && 128b when it specifically says "no_128" in the name.
>
> Is there something about it I am missing or is it just misleading naming?
>
> - Joshie 🐸✨
>
> On 9/30/21 17:14, Marek Olšák wrote:
> > I've also amended the version bump that I forgot to do:
> >
> > -#define KMS_DRIVER_MINOR       43
> > +#define KMS_DRIVER_MINOR       44
> >
> > Marek
> >
> > On Thu, Sep 30, 2021 at 12:06 PM Alex Deucher <alexdeucher@gmail.com
> > <mailto:alexdeucher@gmail.com>> wrote:
> >
> >     Acked-by: Alex Deucher <alexander.deucher@amd.com
> >     <mailto:alexander.deucher@amd.com>>
> >
> >     On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák <maraeo@gmail.com
> >     <mailto:maraeo@gmail.com>> wrote:
> >      >
> >      > Hi,
> >      >
> >      > Just discovered this typo. Please review.
> >      >
> >      > Thanks,
> >      > Marek
> >
>
>

[-- Attachment #2: Type: text/html, Size: 2374 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] drm/amd/display: fix DCC settings for DCN3
  2021-09-30 17:33       ` Marek Olšák
@ 2021-09-30 17:37         ` Joshua Ashton
  0 siblings, 0 replies; 6+ messages in thread
From: Joshua Ashton @ 2021-09-30 17:37 UTC (permalink / raw)
  To: Marek Olšák; +Cc: amd-gfx mailing list

Thanks for the info!

- Joshie 🐸✨

On 9/30/21 18:33, Marek Olšák wrote:
> The name is kind of correct. It means "64B with no 128B cache line 
> straddling", which really means just 64B independent blocks with a small 
> modification to support DCC image stores.  They are not true 128B 
> independent blocks.
> 
> Marek
> 
> On Thu, Sep 30, 2021 at 12:35 PM Joshua Ashton <joshua@froggi.es 
> <mailto:joshua@froggi.es>> wrote:
> 
>     Can we please add documentation for this enum?
> 
>     This was not necessarily a typo, but me misunderstanding and stuff it
>     working in my testing.
> 
>     I guess I don't understand why hubp_ind_block_64b_no_128bcl is for 64b
>     && 128b when it specifically says "no_128" in the name.
> 
>     Is there something about it I am missing or is it just misleading
>     naming?
> 
>     - Joshie 🐸✨
> 
>     On 9/30/21 17:14, Marek Olšák wrote:
>      > I've also amended the version bump that I forgot to do:
>      >
>      > -#define KMS_DRIVER_MINOR       43
>      > +#define KMS_DRIVER_MINOR       44
>      >
>      > Marek
>      >
>      > On Thu, Sep 30, 2021 at 12:06 PM Alex Deucher
>     <alexdeucher@gmail.com <mailto:alexdeucher@gmail.com>
>      > <mailto:alexdeucher@gmail.com <mailto:alexdeucher@gmail.com>>> wrote:
>      >
>      >     Acked-by: Alex Deucher <alexander.deucher@amd.com
>     <mailto:alexander.deucher@amd.com>
>      >     <mailto:alexander.deucher@amd.com
>     <mailto:alexander.deucher@amd.com>>>
>      >
>      >     On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák
>     <maraeo@gmail.com <mailto:maraeo@gmail.com>
>      >     <mailto:maraeo@gmail.com <mailto:maraeo@gmail.com>>> wrote:
>      >      >
>      >      > Hi,
>      >      >
>      >      > Just discovered this typo. Please review.
>      >      >
>      >      > Thanks,
>      >      > Marek
>      >
> 

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2021-09-30 17:37 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-30 15:50 [PATCH] drm/amd/display: fix DCC settings for DCN3 Marek Olšák
2021-09-30 16:06 ` Alex Deucher
2021-09-30 16:14   ` Marek Olšák
2021-09-30 16:35     ` Joshua Ashton
2021-09-30 17:33       ` Marek Olšák
2021-09-30 17:37         ` Joshua Ashton

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.