All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/2] x86: Add an enum name for the GNVS firmware type
@ 2022-02-28 22:18 Simon Glass
  2022-02-28 22:18 ` [PATCH 2/2] x86: Correct the coreboot header file in MAINTAINERS Simon Glass
  2022-03-03  8:49 ` [PATCH 1/2] x86: Add an enum name for the GNVS firmware type Bin Meng
  0 siblings, 2 replies; 6+ messages in thread
From: Simon Glass @ 2022-02-28 22:18 UTC (permalink / raw)
  To: U-Boot Mailing List; +Cc: Bin Meng, Simon Glass

This enum is currently anonymous. Add a name so it can be used in the
code.

Signed-off-by: Simon Glass <sjg@chromium.org>
---

 arch/x86/include/asm/intel_gnvs.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/x86/include/asm/intel_gnvs.h b/arch/x86/include/asm/intel_gnvs.h
index fc743dc928..b12d7f9485 100644
--- a/arch/x86/include/asm/intel_gnvs.h
+++ b/arch/x86/include/asm/intel_gnvs.h
@@ -47,7 +47,7 @@ enum {
 	BINF_RW_B = 2
 };
 
-enum {
+enum cros_fw_type_t {
 	FIRMWARE_TYPE_AUTO_DETECT = -1,
 	FIRMWARE_TYPE_RECOVERY = 0,
 	FIRMWARE_TYPE_NORMAL = 1,
-- 
2.35.1.574.g5d30c73bfb-goog


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 2/2] x86: Correct the coreboot header file in MAINTAINERS
  2022-02-28 22:18 [PATCH 1/2] x86: Add an enum name for the GNVS firmware type Simon Glass
@ 2022-02-28 22:18 ` Simon Glass
  2022-03-03  8:50   ` Bin Meng
  2022-03-03  8:49 ` [PATCH 1/2] x86: Add an enum name for the GNVS firmware type Bin Meng
  1 sibling, 1 reply; 6+ messages in thread
From: Simon Glass @ 2022-02-28 22:18 UTC (permalink / raw)
  To: U-Boot Mailing List; +Cc: Bin Meng, Simon Glass

This board has its own config header file. Correct it.

Signed-off-by: Simon Glass <sjg@chromium.org>
---

 board/coreboot/coreboot/MAINTAINERS | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/board/coreboot/coreboot/MAINTAINERS b/board/coreboot/coreboot/MAINTAINERS
index a05673bb0b..ee12d32ce7 100644
--- a/board/coreboot/coreboot/MAINTAINERS
+++ b/board/coreboot/coreboot/MAINTAINERS
@@ -2,12 +2,12 @@ COREBOOT BOARD
 M:	Simon Glass <sjg@chromium.org>
 S:	Maintained
 F:	board/coreboot/coreboot/
-F:	include/configs/chromebook_link.h
+F:	include/configs/coreboot.h
 F:	configs/coreboot_defconfig
 
 COREBOOT64 BOARD
 M:	Simon Glass <sjg@chromium.org>
 S:	Maintained
 F:	board/coreboot/coreboot/
-F:	include/configs/chromebook_link.h
+F:	include/configs/coreboot.h
 F:	configs/coreboot64_defconfig
-- 
2.35.1.574.g5d30c73bfb-goog


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/2] x86: Add an enum name for the GNVS firmware type
  2022-02-28 22:18 [PATCH 1/2] x86: Add an enum name for the GNVS firmware type Simon Glass
  2022-02-28 22:18 ` [PATCH 2/2] x86: Correct the coreboot header file in MAINTAINERS Simon Glass
@ 2022-03-03  8:49 ` Bin Meng
  2022-03-04  2:37   ` Simon Glass
  1 sibling, 1 reply; 6+ messages in thread
From: Bin Meng @ 2022-03-03  8:49 UTC (permalink / raw)
  To: Simon Glass; +Cc: U-Boot Mailing List

Hi Simon,

On Tue, Mar 1, 2022 at 6:18 AM Simon Glass <sjg@chromium.org> wrote:
>
> This enum is currently anonymous. Add a name so it can be used in the
> code.
>
> Signed-off-by: Simon Glass <sjg@chromium.org>
> ---
>
>  arch/x86/include/asm/intel_gnvs.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/x86/include/asm/intel_gnvs.h b/arch/x86/include/asm/intel_gnvs.h
> index fc743dc928..b12d7f9485 100644
> --- a/arch/x86/include/asm/intel_gnvs.h
> +++ b/arch/x86/include/asm/intel_gnvs.h
> @@ -47,7 +47,7 @@ enum {
>         BINF_RW_B = 2
>  };
>
> -enum {
> +enum cros_fw_type_t {

The name indicates this is chrome os only, but it should be a generic name, no?

>         FIRMWARE_TYPE_AUTO_DETECT = -1,
>         FIRMWARE_TYPE_RECOVERY = 0,
>         FIRMWARE_TYPE_NORMAL = 1,


Regards,
Bin

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 2/2] x86: Correct the coreboot header file in MAINTAINERS
  2022-02-28 22:18 ` [PATCH 2/2] x86: Correct the coreboot header file in MAINTAINERS Simon Glass
@ 2022-03-03  8:50   ` Bin Meng
  0 siblings, 0 replies; 6+ messages in thread
From: Bin Meng @ 2022-03-03  8:50 UTC (permalink / raw)
  To: Simon Glass; +Cc: U-Boot Mailing List

On Tue, Mar 1, 2022 at 6:18 AM Simon Glass <sjg@chromium.org> wrote:
>
> This board has its own config header file. Correct it.
>
> Signed-off-by: Simon Glass <sjg@chromium.org>
> ---
>
>  board/coreboot/coreboot/MAINTAINERS | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>

Reviewed-by: Bin Meng <bmeng.cn@gmail.com>

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/2] x86: Add an enum name for the GNVS firmware type
  2022-03-03  8:49 ` [PATCH 1/2] x86: Add an enum name for the GNVS firmware type Bin Meng
@ 2022-03-04  2:37   ` Simon Glass
  2022-03-04 10:57     ` Bin Meng
  0 siblings, 1 reply; 6+ messages in thread
From: Simon Glass @ 2022-03-04  2:37 UTC (permalink / raw)
  To: Bin Meng; +Cc: U-Boot Mailing List

Hi Bin,

On Thu, 3 Mar 2022 at 01:49, Bin Meng <bmeng.cn@gmail.com> wrote:
>
> Hi Simon,
>
> On Tue, Mar 1, 2022 at 6:18 AM Simon Glass <sjg@chromium.org> wrote:
> >
> > This enum is currently anonymous. Add a name so it can be used in the
> > code.
> >
> > Signed-off-by: Simon Glass <sjg@chromium.org>
> > ---
> >
> >  arch/x86/include/asm/intel_gnvs.h | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/arch/x86/include/asm/intel_gnvs.h b/arch/x86/include/asm/intel_gnvs.h
> > index fc743dc928..b12d7f9485 100644
> > --- a/arch/x86/include/asm/intel_gnvs.h
> > +++ b/arch/x86/include/asm/intel_gnvs.h
> > @@ -47,7 +47,7 @@ enum {
> >         BINF_RW_B = 2
> >  };
> >
> > -enum {
> > +enum cros_fw_type_t {
>
> The name indicates this is chrome os only, but it should be a generic name, no?
>
> >         FIRMWARE_TYPE_AUTO_DETECT = -1,
> >         FIRMWARE_TYPE_RECOVERY = 0,
> >         FIRMWARE_TYPE_NORMAL = 1,

Well, this field is only used on Chromium OS. It has its own section
of the GNVS.

Regards,
Simon

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/2] x86: Add an enum name for the GNVS firmware type
  2022-03-04  2:37   ` Simon Glass
@ 2022-03-04 10:57     ` Bin Meng
  0 siblings, 0 replies; 6+ messages in thread
From: Bin Meng @ 2022-03-04 10:57 UTC (permalink / raw)
  To: Simon Glass; +Cc: U-Boot Mailing List

Hi Simon,

On Fri, Mar 4, 2022 at 10:38 AM Simon Glass <sjg@chromium.org> wrote:
>
> Hi Bin,
>
> On Thu, 3 Mar 2022 at 01:49, Bin Meng <bmeng.cn@gmail.com> wrote:
> >
> > Hi Simon,
> >
> > On Tue, Mar 1, 2022 at 6:18 AM Simon Glass <sjg@chromium.org> wrote:
> > >
> > > This enum is currently anonymous. Add a name so it can be used in the
> > > code.
> > >
> > > Signed-off-by: Simon Glass <sjg@chromium.org>
> > > ---
> > >
> > >  arch/x86/include/asm/intel_gnvs.h | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/arch/x86/include/asm/intel_gnvs.h b/arch/x86/include/asm/intel_gnvs.h
> > > index fc743dc928..b12d7f9485 100644
> > > --- a/arch/x86/include/asm/intel_gnvs.h
> > > +++ b/arch/x86/include/asm/intel_gnvs.h
> > > @@ -47,7 +47,7 @@ enum {
> > >         BINF_RW_B = 2
> > >  };
> > >
> > > -enum {
> > > +enum cros_fw_type_t {
> >
> > The name indicates this is chrome os only, but it should be a generic name, no?
> >
> > >         FIRMWARE_TYPE_AUTO_DETECT = -1,
> > >         FIRMWARE_TYPE_RECOVERY = 0,
> > >         FIRMWARE_TYPE_NORMAL = 1,
>
> Well, this field is only used on Chromium OS. It has its own section
> of the GNVS.

Better put some comments.

Reviewed-by: Bin Meng <bmeng.cn@gmail.com>

Regards,
Bin

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2022-03-04 10:57 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-02-28 22:18 [PATCH 1/2] x86: Add an enum name for the GNVS firmware type Simon Glass
2022-02-28 22:18 ` [PATCH 2/2] x86: Correct the coreboot header file in MAINTAINERS Simon Glass
2022-03-03  8:50   ` Bin Meng
2022-03-03  8:49 ` [PATCH 1/2] x86: Add an enum name for the GNVS firmware type Bin Meng
2022-03-04  2:37   ` Simon Glass
2022-03-04 10:57     ` Bin Meng

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.