All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH] target-arm: rename c1_coproc to cpacr_el1
@ 2015-03-17 15:33 Sergey Fedorov
  2015-03-17 16:23 ` Peter Maydell
  0 siblings, 1 reply; 4+ messages in thread
From: Sergey Fedorov @ 2015-03-17 15:33 UTC (permalink / raw)
  To: qemu-devel; +Cc: Sergey Fedorov, Peter Maydell

Rename the field holding CPACR_EL1 system register state in AArch64
naming style.

Signed-off-by: Sergey Fedorov <serge.fdrv@gmail.com>
---
 hw/arm/pxa2xx.c     | 2 +-
 target-arm/cpu.h    | 4 ++--
 target-arm/helper.c | 4 ++--
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/hw/arm/pxa2xx.c b/hw/arm/pxa2xx.c
index 165ba2a..f921a56 100644
--- a/hw/arm/pxa2xx.c
+++ b/hw/arm/pxa2xx.c
@@ -274,7 +274,7 @@ static void pxa2xx_pwrmode_write(CPUARMState *env, const ARMCPRegInfo *ri,
         s->cpu->env.uncached_cpsr = ARM_CPU_MODE_SVC;
         s->cpu->env.daif = PSTATE_A | PSTATE_F | PSTATE_I;
         s->cpu->env.cp15.sctlr_ns = 0;
-        s->cpu->env.cp15.c1_coproc = 0;
+        s->cpu->env.cp15.cpacr_el1 = 0;
         s->cpu->env.cp15.ttbr0_el[1] = 0;
         s->cpu->env.cp15.dacr_ns = 0;
         s->pm_regs[PSSR >> 2] |= 0x8; /* Set STS */
diff --git a/target-arm/cpu.h b/target-arm/cpu.h
index 083211c..d63d9b2 100644
--- a/target-arm/cpu.h
+++ b/target-arm/cpu.h
@@ -201,7 +201,7 @@ typedef struct CPUARMState {
             };
             uint64_t sctlr_el[4];
         };
-        uint64_t c1_coproc; /* Coprocessor access register.  */
+        uint64_t cpacr_el1; /* Architectural feature access control register */
         uint32_t c1_xscaleauxcr; /* XScale auxiliary control register.  */
         uint64_t sder; /* Secure debug enable register. */
         uint32_t nsacr; /* Non-secure access control register. */
@@ -1813,7 +1813,7 @@ static inline void cpu_get_tb_cpu_state(CPUARMState *env, target_ulong *pc,
     int fpen;
 
     if (arm_feature(env, ARM_FEATURE_V6)) {
-        fpen = extract32(env->cp15.c1_coproc, 20, 2);
+        fpen = extract32(env->cp15.cpacr_el1, 20, 2);
     } else {
         /* CPACR doesn't exist before v6, so VFP is always accessible */
         fpen = 3;
diff --git a/target-arm/helper.c b/target-arm/helper.c
index 10886c5..7c54dcf 100644
--- a/target-arm/helper.c
+++ b/target-arm/helper.c
@@ -589,7 +589,7 @@ static void cpacr_write(CPUARMState *env, const ARMCPRegInfo *ri,
         }
         value &= mask;
     }
-    env->cp15.c1_coproc = value;
+    env->cp15.cpacr_el1 = value;
 }
 
 static const ARMCPRegInfo v6_cp_reginfo[] = {
@@ -615,7 +615,7 @@ static const ARMCPRegInfo v6_cp_reginfo[] = {
       .access = PL1_RW, .type = ARM_CP_CONST, .resetvalue = 0, },
     { .name = "CPACR", .state = ARM_CP_STATE_BOTH, .opc0 = 3,
       .crn = 1, .crm = 0, .opc1 = 0, .opc2 = 2,
-      .access = PL1_RW, .fieldoffset = offsetof(CPUARMState, cp15.c1_coproc),
+      .access = PL1_RW, .fieldoffset = offsetof(CPUARMState, cp15.cpacr_el1),
       .resetvalue = 0, .writefn = cpacr_write },
     REGINFO_SENTINEL
 };
-- 
2.3.1

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [Qemu-devel] [PATCH] target-arm: rename c1_coproc to cpacr_el1
  2015-03-17 15:33 [Qemu-devel] [PATCH] target-arm: rename c1_coproc to cpacr_el1 Sergey Fedorov
@ 2015-03-17 16:23 ` Peter Maydell
  2015-04-21 13:49   ` Peter Maydell
  0 siblings, 1 reply; 4+ messages in thread
From: Peter Maydell @ 2015-03-17 16:23 UTC (permalink / raw)
  To: Sergey Fedorov; +Cc: QEMU Developers

On 17 March 2015 at 15:33, Sergey Fedorov <serge.fdrv@gmail.com> wrote:
> Rename the field holding CPACR_EL1 system register state in AArch64
> naming style.
>
> Signed-off-by: Sergey Fedorov <serge.fdrv@gmail.com>

Reviewed-by: Peter Maydell <peter.maydell@linaro.org>

Mostly I've been renaming these only where we needed to
touch them for some other reason, but this one is particularly
confusing as a name, I think, and it doesn't touch too many
lines to change it.

Not for 2.3, though.

-- PMM

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [Qemu-devel] [PATCH] target-arm: rename c1_coproc to cpacr_el1
  2015-03-17 16:23 ` Peter Maydell
@ 2015-04-21 13:49   ` Peter Maydell
  2015-04-21 15:39     ` Sergey Fedorov
  0 siblings, 1 reply; 4+ messages in thread
From: Peter Maydell @ 2015-04-21 13:49 UTC (permalink / raw)
  To: Sergey Fedorov; +Cc: QEMU Developers

On 17 March 2015 at 16:23, Peter Maydell <peter.maydell@linaro.org> wrote:
> On 17 March 2015 at 15:33, Sergey Fedorov <serge.fdrv@gmail.com> wrote:
>> Rename the field holding CPACR_EL1 system register state in AArch64
>> naming style.
>>
>> Signed-off-by: Sergey Fedorov <serge.fdrv@gmail.com>
>
> Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
>
> Mostly I've been renaming these only where we needed to
> touch them for some other reason, but this one is particularly
> confusing as a name, I think, and it doesn't touch too many
> lines to change it.
>
> Not for 2.3, though.

I'm adding this to target-arm.next for 2.4 now, and I
just noticed that you missed the occurrences in cpu.c.
If you'd built the linux-user emulators you'd have found
this because they wouldn't have built :-)

I'll fix this up as I apply the patch.

thanks
-- PMM

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [Qemu-devel] [PATCH] target-arm: rename c1_coproc to cpacr_el1
  2015-04-21 13:49   ` Peter Maydell
@ 2015-04-21 15:39     ` Sergey Fedorov
  0 siblings, 0 replies; 4+ messages in thread
From: Sergey Fedorov @ 2015-04-21 15:39 UTC (permalink / raw)
  To: Peter Maydell; +Cc: QEMU Developers

On 21.04.2015 06:49, Peter Maydell wrote:
> On 17 March 2015 at 16:23, Peter Maydell <peter.maydell@linaro.org> wrote:
>> On 17 March 2015 at 15:33, Sergey Fedorov <serge.fdrv@gmail.com> wrote:
>>> Rename the field holding CPACR_EL1 system register state in AArch64
>>> naming style.
>>>
>>> Signed-off-by: Sergey Fedorov <serge.fdrv@gmail.com>
>> Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
>>
>> Mostly I've been renaming these only where we needed to
>> touch them for some other reason, but this one is particularly
>> confusing as a name, I think, and it doesn't touch too many
>> lines to change it.
>>
>> Not for 2.3, though.
> I'm adding this to target-arm.next for 2.4 now, and I
> just noticed that you missed the occurrences in cpu.c.
> If you'd built the linux-user emulators you'd have found
> this because they wouldn't have built :-)
>
> I'll fix this up as I apply the patch.
>
> thanks
> -- PMM

Oh, my fault. Thanks!

Sergey

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2015-04-21 15:40 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-03-17 15:33 [Qemu-devel] [PATCH] target-arm: rename c1_coproc to cpacr_el1 Sergey Fedorov
2015-03-17 16:23 ` Peter Maydell
2015-04-21 13:49   ` Peter Maydell
2015-04-21 15:39     ` Sergey Fedorov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.