All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PULL v2 00/38] Block layer patches
@ 2018-03-05 17:51 Kevin Wolf
  2018-03-06 10:09 ` Peter Maydell
  2018-03-06 12:12 ` Peter Maydell
  0 siblings, 2 replies; 5+ messages in thread
From: Kevin Wolf @ 2018-03-05 17:51 UTC (permalink / raw)
  To: qemu-block; +Cc: kwolf, peter.maydell, qemu-devel

The following changes since commit 86f4c7e05b1c44dbe1b329a51f311f10aef6ff34:

  Merge remote-tracking branch 'remotes/pmaydell/tags/pull-target-arm-20180302' into staging (2018-03-02 14:37:10 +0000)

are available in the git repository at:

  git://repo.or.cz/qemu/kevin.git tags/for-upstream

for you to fetch changes up to bfe1a14c180ec44c033be12b9151252ffda69292:

  block: Fix NULL dereference on empty drive error (2018-03-05 18:45:32 +0100)

----------------------------------------------------------------
Block layer patches

----------------------------------------------------------------
Alberto Garcia (3):
      specs/qcow2: Fix documentation of the compressed cluster descriptor
      docs: document how to use the l2-cache-entry-size parameter
      qcow2: Replace align_offset() with ROUND_UP()

Anton Nefedov (2):
      block: fix write with zero flag set and iovector provided
      iotest 033: add misaligned write-zeroes test via truncate

Eric Blake (21):
      block: Add .bdrv_co_block_status() callback
      nvme: Drop pointless .bdrv_co_get_block_status()
      block: Switch passthrough drivers to .bdrv_co_block_status()
      file-posix: Switch to .bdrv_co_block_status()
      gluster: Switch to .bdrv_co_block_status()
      iscsi: Switch cluster_sectors to byte-based
      iscsi: Switch iscsi_allocmap_update() to byte-based
      iscsi: Switch to .bdrv_co_block_status()
      null: Switch to .bdrv_co_block_status()
      parallels: Switch to .bdrv_co_block_status()
      qcow: Switch to .bdrv_co_block_status()
      qcow2: Switch to .bdrv_co_block_status()
      qed: Switch to .bdrv_co_block_status()
      raw: Switch to .bdrv_co_block_status()
      sheepdog: Switch to .bdrv_co_block_status()
      vdi: Avoid bitrot of debugging code
      vdi: Switch to .bdrv_co_block_status()
      vmdk: Switch to .bdrv_co_block_status()
      vpc: Switch to .bdrv_co_block_status()
      vvfat: Switch to .bdrv_co_block_status()
      block: Drop unused .bdrv_co_get_block_status()

Kevin Wolf (3):
      block: test blk_aio_flush() with blk->root == NULL
      Merge remote-tracking branch 'mreitz/tags/pull-block-2018-03-02' into queue-block
      block: Fix NULL dereference on empty drive error

Max Reitz (4):
      qemu-img: Make resize error message more general
      block/ssh: Pull ssh_grow_file() from ssh_create()
      block/ssh: Make ssh_grow_file() blocking
      block/ssh: Add basic .bdrv_truncate()

Stefan Hajnoczi (6):
      aio: rename aio_context_in_iothread() to in_aio_context_home_thread()
      block: extract AIO_WAIT_WHILE() from BlockDriverState
      block: add BlockBackend->in_flight counter
      Revert "IDE: Do not flush empty CDROM drives"
      block: rename .bdrv_create() to .bdrv_co_create_opts()
      qcow2: make qcow2_co_create2() a coroutine_fn

 qapi/block-core.json       |   6 +-
 docs/interop/qcow2.txt     |  16 ++++-
 docs/qcow2-cache.txt       |  46 ++++++++++++-
 block/qcow2.h              |   6 --
 include/block/aio-wait.h   | 116 ++++++++++++++++++++++++++++++++
 include/block/aio.h        |   7 +-
 include/block/block.h      |  54 ++++-----------
 include/block/block_int.h  |  61 ++++++++++-------
 block.c                    |  11 ++-
 block/blkdebug.c           |  20 +++---
 block/block-backend.c      |  65 +++++++++++++++---
 block/commit.c             |   2 +-
 block/crypto.c             |   8 +--
 block/file-posix.c         |  79 +++++++++++-----------
 block/file-win32.c         |   5 +-
 block/gluster.c            |  83 ++++++++++++-----------
 block/io.c                 |  98 +++++++++++----------------
 block/iscsi.c              | 164 ++++++++++++++++++++++++---------------------
 block/mirror.c             |   2 +-
 block/nfs.c                |   5 +-
 block/null.c               |  23 ++++---
 block/nvme.c               |  14 ----
 block/parallels.c          |  28 +++++---
 block/qcow.c               |  32 +++++----
 block/qcow2-bitmap.c       |   4 +-
 block/qcow2-cluster.c      |   4 +-
 block/qcow2-refcount.c     |   4 +-
 block/qcow2-snapshot.c     |  10 +--
 block/qcow2.c              |  60 +++++++++--------
 block/qed.c                |  82 ++++++++---------------
 block/raw-format.c         |  21 +++---
 block/rbd.c                |   6 +-
 block/sheepdog.c           |  36 +++++-----
 block/ssh.c                |  66 +++++++++++++++---
 block/throttle.c           |   2 +-
 block/vdi.c                |  50 +++++++-------
 block/vhdx.c               |   5 +-
 block/vmdk.c               |  43 +++++-------
 block/vpc.c                |  50 +++++++-------
 block/vvfat.c              |  16 ++---
 hw/ide/core.c              |  10 +--
 qemu-img.c                 |   2 +-
 tests/test-block-backend.c |  82 +++++++++++++++++++++++
 util/aio-wait.c            |  40 +++++++++++
 tests/Makefile.include     |   2 +
 tests/qemu-iotests/033     |  29 ++++++++
 tests/qemu-iotests/033.out |  13 ++++
 util/Makefile.objs         |   2 +-
 48 files changed, 980 insertions(+), 610 deletions(-)
 create mode 100644 include/block/aio-wait.h
 create mode 100644 tests/test-block-backend.c
 create mode 100644 util/aio-wait.c

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PULL v2 00/38] Block layer patches
  2018-03-05 17:51 [Qemu-devel] [PULL v2 00/38] Block layer patches Kevin Wolf
@ 2018-03-06 10:09 ` Peter Maydell
  2018-03-06 10:24   ` Kevin Wolf
  2018-03-06 12:12 ` Peter Maydell
  1 sibling, 1 reply; 5+ messages in thread
From: Peter Maydell @ 2018-03-06 10:09 UTC (permalink / raw)
  To: Kevin Wolf; +Cc: Qemu-block, QEMU Developers

On 5 March 2018 at 17:51, Kevin Wolf <kwolf@redhat.com> wrote:
> The following changes since commit 86f4c7e05b1c44dbe1b329a51f311f10aef6ff34:
>
>   Merge remote-tracking branch 'remotes/pmaydell/tags/pull-target-arm-20180302' into staging (2018-03-02 14:37:10 +0000)
>
> are available in the git repository at:
>
>   git://repo.or.cz/qemu/kevin.git tags/for-upstream
>
> for you to fetch changes up to bfe1a14c180ec44c033be12b9151252ffda69292:
>
>   block: Fix NULL dereference on empty drive error (2018-03-05 18:45:32 +0100)
>
> ----------------------------------------------------------------
> Block layer patches
>
> ----------------------------------------------------------------

This pull turns out to add a bunch of tests that end in the name "error",
which triggers my buildlog scanning scripts that look for "error:".
Could we rename those?

thanks
-- PMM

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PULL v2 00/38] Block layer patches
  2018-03-06 10:09 ` Peter Maydell
@ 2018-03-06 10:24   ` Kevin Wolf
  2018-03-06 10:29     ` Peter Maydell
  0 siblings, 1 reply; 5+ messages in thread
From: Kevin Wolf @ 2018-03-06 10:24 UTC (permalink / raw)
  To: Peter Maydell; +Cc: Qemu-block, QEMU Developers

Am 06.03.2018 um 11:09 hat Peter Maydell geschrieben:
> On 5 March 2018 at 17:51, Kevin Wolf <kwolf@redhat.com> wrote:
> > The following changes since commit 86f4c7e05b1c44dbe1b329a51f311f10aef6ff34:
> >
> >   Merge remote-tracking branch 'remotes/pmaydell/tags/pull-target-arm-20180302' into staging (2018-03-02 14:37:10 +0000)
> >
> > are available in the git repository at:
> >
> >   git://repo.or.cz/qemu/kevin.git tags/for-upstream
> >
> > for you to fetch changes up to bfe1a14c180ec44c033be12b9151252ffda69292:
> >
> >   block: Fix NULL dereference on empty drive error (2018-03-05 18:45:32 +0100)
> >
> > ----------------------------------------------------------------
> > Block layer patches
> >
> > ----------------------------------------------------------------
> 
> This pull turns out to add a bunch of tests that end in the name "error",
> which triggers my buildlog scanning scripts that look for "error:".
> Could we rename those?

Wouldn't it make more sense to change your script so that it considers
"error" only if it's a whole word rather than part of an identifier?
These test cases concern error paths, so it's kind of expected that
their name contains "error" as a substring.

Kevin

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PULL v2 00/38] Block layer patches
  2018-03-06 10:24   ` Kevin Wolf
@ 2018-03-06 10:29     ` Peter Maydell
  0 siblings, 0 replies; 5+ messages in thread
From: Peter Maydell @ 2018-03-06 10:29 UTC (permalink / raw)
  To: Kevin Wolf; +Cc: Qemu-block, QEMU Developers

On 6 March 2018 at 10:24, Kevin Wolf <kwolf@redhat.com> wrote:
> Am 06.03.2018 um 11:09 hat Peter Maydell geschrieben:
>> On 5 March 2018 at 17:51, Kevin Wolf <kwolf@redhat.com> wrote:
>> > The following changes since commit 86f4c7e05b1c44dbe1b329a51f311f10aef6ff34:
>> >
>> >   Merge remote-tracking branch 'remotes/pmaydell/tags/pull-target-arm-20180302' into staging (2018-03-02 14:37:10 +0000)
>> >
>> > are available in the git repository at:
>> >
>> >   git://repo.or.cz/qemu/kevin.git tags/for-upstream
>> >
>> > for you to fetch changes up to bfe1a14c180ec44c033be12b9151252ffda69292:
>> >
>> >   block: Fix NULL dereference on empty drive error (2018-03-05 18:45:32 +0100)
>> >
>> > ----------------------------------------------------------------
>> > Block layer patches
>> >
>> > ----------------------------------------------------------------
>>
>> This pull turns out to add a bunch of tests that end in the name "error",
>> which triggers my buildlog scanning scripts that look for "error:".
>> Could we rename those?
>
> Wouldn't it make more sense to change your script so that it considers
> "error" only if it's a whole word rather than part of an identifier?
> These test cases concern error paths, so it's kind of expected that
> their name contains "error" as a substring.

Mmm, yes, that turns out not to be too difficult. I've done that.

thanks
-- PMM

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [Qemu-devel] [PULL v2 00/38] Block layer patches
  2018-03-05 17:51 [Qemu-devel] [PULL v2 00/38] Block layer patches Kevin Wolf
  2018-03-06 10:09 ` Peter Maydell
@ 2018-03-06 12:12 ` Peter Maydell
  1 sibling, 0 replies; 5+ messages in thread
From: Peter Maydell @ 2018-03-06 12:12 UTC (permalink / raw)
  To: Kevin Wolf; +Cc: Qemu-block, QEMU Developers

On 5 March 2018 at 17:51, Kevin Wolf <kwolf@redhat.com> wrote:
> The following changes since commit 86f4c7e05b1c44dbe1b329a51f311f10aef6ff34:
>
>   Merge remote-tracking branch 'remotes/pmaydell/tags/pull-target-arm-20180302' into staging (2018-03-02 14:37:10 +0000)
>
> are available in the git repository at:
>
>   git://repo.or.cz/qemu/kevin.git tags/for-upstream
>
> for you to fetch changes up to bfe1a14c180ec44c033be12b9151252ffda69292:
>
>   block: Fix NULL dereference on empty drive error (2018-03-05 18:45:32 +0100)
>
> ----------------------------------------------------------------
> Block layer patches
>

Applied, thanks.

-- PMM

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2018-03-06 12:12 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-03-05 17:51 [Qemu-devel] [PULL v2 00/38] Block layer patches Kevin Wolf
2018-03-06 10:09 ` Peter Maydell
2018-03-06 10:24   ` Kevin Wolf
2018-03-06 10:29     ` Peter Maydell
2018-03-06 12:12 ` Peter Maydell

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.