All of lore.kernel.org
 help / color / mirror / Atom feed
From: Roy Franz <roy.franz@linaro.org>
To: Matt Fleming <matt@console-pimps.org>
Cc: linux-kernel@vger.kernel.org, linux-efi@vger.kernel.org,
	"linux-arm-kernel@lists.infradead.org" 
	<linux-arm-kernel@lists.infradead.org>,
	matt.fleming@intel.com,
	Russell King - ARM Linux <linux@arm.linux.org.uk>,
	Leif Lindholm <leif.lindholm@linaro.org>,
	Dave Martin <dave.martin@arm.com>
Subject: Re: [PATCH 12/17] Add proper definitions for some EFI function pointers.
Date: Wed, 7 Aug 2013 10:20:42 -0700	[thread overview]
Message-ID: <CAFECyb_ZoCCMs75FLtGewfFQy1m5aVw6s5Jv1H1vaxg976qFNA@mail.gmail.com> (raw)
In-Reply-To: <20130807130950.GF2515@console-pimps.org>

On Wed, Aug 7, 2013 at 6:09 AM, Matt Fleming <matt@console-pimps.org> wrote:
> On Tue, 06 Aug, at 08:45:08PM, Roy Franz wrote:
>> The x86/AMD64 EFI stubs must us a call wrapper to convert between
>> the Linux and EFI ABIs, so void pointers are sufficient.  For ARM,
>> the ABIs are compatible, so we can directly invoke the function
>> pointers.  The functions that are used by the ARM stub are updated
>> to match the EFI definitions.
>>
>> Signed-off-by: Roy Franz <roy.franz@linaro.org>
>> ---
>>  include/linux/efi.h |   42 +++++++++++++++++++++++++-----------------
>>  1 file changed, 25 insertions(+), 17 deletions(-)
>>
>> diff --git a/include/linux/efi.h b/include/linux/efi.h
>> index 51f5641..96bb866 100644
>> --- a/include/linux/efi.h
>> +++ b/include/linux/efi.h
>> @@ -39,6 +39,8 @@
>>  typedef unsigned long efi_status_t;
>>  typedef u8 efi_bool_t;
>>  typedef u16 efi_char16_t;            /* UNICODE character */
>> +typedef u64 efi_physical_addr_t;
>> +typedef void *efi_handle_t;
>>
>>
>>  typedef struct {
>> @@ -96,6 +98,7 @@ typedef     struct {
>>  #define EFI_MEMORY_DESCRIPTOR_VERSION        1
>>
>>  #define EFI_PAGE_SHIFT               12
>> +#define EFI_PAGE_SIZE                (1UL << EFI_PAGE_SHIFT)
>
> It would be worth getting rid of the EFI_PAGE_SIZE definition in
> arch/x86/boot/compressed/eboot.h now that we have one here.
>
> --
> Matt Fleming, Intel Open Source Technology Center

I'll get this in the next version.

Thanks,
Roy

WARNING: multiple messages have this Message-ID (diff)
From: Roy Franz <roy.franz-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
To: Matt Fleming <matt-HNK1S37rvNbeXh+fF434Mdi2O/JbrIOy@public.gmane.org>
Cc: linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	linux-efi-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	"linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org"
	<linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org>,
	matt.fleming-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org,
	Russell King - ARM Linux
	<linux-lFZ/pmaqli7XmaaqVzeoHQ@public.gmane.org>,
	Leif Lindholm
	<leif.lindholm-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>,
	Dave Martin <dave.martin-5wv7dgnIgG8@public.gmane.org>
Subject: Re: [PATCH 12/17] Add proper definitions for some EFI function pointers.
Date: Wed, 7 Aug 2013 10:20:42 -0700	[thread overview]
Message-ID: <CAFECyb_ZoCCMs75FLtGewfFQy1m5aVw6s5Jv1H1vaxg976qFNA@mail.gmail.com> (raw)
In-Reply-To: <20130807130950.GF2515-HNK1S37rvNbeXh+fF434Mdi2O/JbrIOy@public.gmane.org>

On Wed, Aug 7, 2013 at 6:09 AM, Matt Fleming <matt-HNK1S37rvNbeXh+fF434Mdi2O/JbrIOy@public.gmane.org> wrote:
> On Tue, 06 Aug, at 08:45:08PM, Roy Franz wrote:
>> The x86/AMD64 EFI stubs must us a call wrapper to convert between
>> the Linux and EFI ABIs, so void pointers are sufficient.  For ARM,
>> the ABIs are compatible, so we can directly invoke the function
>> pointers.  The functions that are used by the ARM stub are updated
>> to match the EFI definitions.
>>
>> Signed-off-by: Roy Franz <roy.franz-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
>> ---
>>  include/linux/efi.h |   42 +++++++++++++++++++++++++-----------------
>>  1 file changed, 25 insertions(+), 17 deletions(-)
>>
>> diff --git a/include/linux/efi.h b/include/linux/efi.h
>> index 51f5641..96bb866 100644
>> --- a/include/linux/efi.h
>> +++ b/include/linux/efi.h
>> @@ -39,6 +39,8 @@
>>  typedef unsigned long efi_status_t;
>>  typedef u8 efi_bool_t;
>>  typedef u16 efi_char16_t;            /* UNICODE character */
>> +typedef u64 efi_physical_addr_t;
>> +typedef void *efi_handle_t;
>>
>>
>>  typedef struct {
>> @@ -96,6 +98,7 @@ typedef     struct {
>>  #define EFI_MEMORY_DESCRIPTOR_VERSION        1
>>
>>  #define EFI_PAGE_SHIFT               12
>> +#define EFI_PAGE_SIZE                (1UL << EFI_PAGE_SHIFT)
>
> It would be worth getting rid of the EFI_PAGE_SIZE definition in
> arch/x86/boot/compressed/eboot.h now that we have one here.
>
> --
> Matt Fleming, Intel Open Source Technology Center

I'll get this in the next version.

Thanks,
Roy

WARNING: multiple messages have this Message-ID (diff)
From: roy.franz@linaro.org (Roy Franz)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 12/17] Add proper definitions for some EFI function pointers.
Date: Wed, 7 Aug 2013 10:20:42 -0700	[thread overview]
Message-ID: <CAFECyb_ZoCCMs75FLtGewfFQy1m5aVw6s5Jv1H1vaxg976qFNA@mail.gmail.com> (raw)
In-Reply-To: <20130807130950.GF2515@console-pimps.org>

On Wed, Aug 7, 2013 at 6:09 AM, Matt Fleming <matt@console-pimps.org> wrote:
> On Tue, 06 Aug, at 08:45:08PM, Roy Franz wrote:
>> The x86/AMD64 EFI stubs must us a call wrapper to convert between
>> the Linux and EFI ABIs, so void pointers are sufficient.  For ARM,
>> the ABIs are compatible, so we can directly invoke the function
>> pointers.  The functions that are used by the ARM stub are updated
>> to match the EFI definitions.
>>
>> Signed-off-by: Roy Franz <roy.franz@linaro.org>
>> ---
>>  include/linux/efi.h |   42 +++++++++++++++++++++++++-----------------
>>  1 file changed, 25 insertions(+), 17 deletions(-)
>>
>> diff --git a/include/linux/efi.h b/include/linux/efi.h
>> index 51f5641..96bb866 100644
>> --- a/include/linux/efi.h
>> +++ b/include/linux/efi.h
>> @@ -39,6 +39,8 @@
>>  typedef unsigned long efi_status_t;
>>  typedef u8 efi_bool_t;
>>  typedef u16 efi_char16_t;            /* UNICODE character */
>> +typedef u64 efi_physical_addr_t;
>> +typedef void *efi_handle_t;
>>
>>
>>  typedef struct {
>> @@ -96,6 +98,7 @@ typedef     struct {
>>  #define EFI_MEMORY_DESCRIPTOR_VERSION        1
>>
>>  #define EFI_PAGE_SHIFT               12
>> +#define EFI_PAGE_SIZE                (1UL << EFI_PAGE_SHIFT)
>
> It would be worth getting rid of the EFI_PAGE_SIZE definition in
> arch/x86/boot/compressed/eboot.h now that we have one here.
>
> --
> Matt Fleming, Intel Open Source Technology Center

I'll get this in the next version.

Thanks,
Roy

  reply	other threads:[~2013-08-07 17:20 UTC|newest]

Thread overview: 88+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-08-07  3:44 [PATCH V2 00/17] EFI stub for ARM Roy Franz
2013-08-07  3:44 ` Roy Franz
2013-08-07  3:44 ` [PATCH 01/17] EFI stub documentation updates Roy Franz
2013-08-07  3:44   ` Roy Franz
2013-08-07  3:44   ` Roy Franz
2013-08-07  3:44 ` [PATCH 02/17] Move common EFI stub code from x86 arch code to common location Roy Franz
2013-08-07  3:44   ` Roy Franz
2013-08-07  3:44 ` [PATCH 03/17] Add system pointer argument to shared EFI stub related functions so they no longer use global system table pointer as they did when part of eboot.c Roy Franz
2013-08-07  3:44   ` Roy Franz
2013-08-07  3:44   ` Roy Franz
2013-08-07 13:08   ` Matt Fleming
2013-08-07 13:08     ` Matt Fleming
2013-08-07 13:08     ` Matt Fleming
2013-08-07 17:10     ` Roy Franz
2013-08-07 17:10       ` Roy Franz
2013-08-07 17:10       ` Roy Franz
2013-08-07 21:55       ` Matt Fleming
2013-08-07 21:55         ` Matt Fleming
2013-08-07  3:45 ` [PATCH 04/17] Rename memory allocation/free functions Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07 13:09   ` Matt Fleming
2013-08-07 13:09     ` Matt Fleming
2013-08-07 17:12     ` Roy Franz
2013-08-07 17:12       ` Roy Franz
2013-08-07 17:12       ` Roy Franz
2013-08-07  3:45 ` [PATCH 05/17] Add minimum address parameter to efi_low_alloc() Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 06/17] rename __get_map() to efi_get_memory_map(), add parameter to optionally return mmap key. The mmap key is required to exit EFI boot services, and allows efi_get_memory_map() to be used for getting final memory map Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 07/17] Enforce minimum alignment of 1 page on allocations. The efi_high_alloc() and efi_low_alloc() functions use the EFI_ALLOCATE_ADDRESS option to the EFI function allocate_pages(), which requires a minimum of page alignment, and rejects all other requests Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 08/17] Allow efi_free() to be called with size of 0, and do nothing in that case Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 09/17] Generalize handle_ramdisks() and rename to handle_cmdline_files() Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 10/17] Renames in handle_cmdline_files() to complete generalization Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07 13:09   ` Matt Fleming
2013-08-07 13:09     ` Matt Fleming
2013-08-07  3:45 ` [PATCH 11/17] Move EFI_READ_CHUNK_SIZE define to shared location Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 12/17] Add proper definitions for some EFI function pointers Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07 13:09   ` Matt Fleming
2013-08-07 13:09     ` Matt Fleming
2013-08-07 13:09     ` Matt Fleming
2013-08-07 17:20     ` Roy Franz [this message]
2013-08-07 17:20       ` Roy Franz
2013-08-07 17:20       ` Roy Franz
2013-08-09 14:10   ` Mark Salter
2013-08-09 14:10     ` Mark Salter
2013-08-09 14:10     ` Mark Salter
2013-08-09 14:13     ` Roy Franz
2013-08-09 14:13       ` Roy Franz
2013-08-09 14:13       ` Roy Franz
2013-08-07  3:45 ` [PATCH 13/17] Fix types in EFI calls to match EFI function definitions Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 14/17] resolve warnings found on ARM compile Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 15/17] Add strstr to compressed string.c for ARM Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45 ` [PATCH 16/17] Add EFI stub " Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07 18:05   ` Dave Martin
2013-08-07 18:05     ` Dave Martin
2013-08-07 18:05     ` Dave Martin
2013-08-07 18:33     ` Leif Lindholm
2013-08-07 18:33       ` Leif Lindholm
2013-08-08 21:57     ` Roy Franz
2013-08-08 21:57       ` Roy Franz
2013-08-08 21:57       ` Roy Franz
2013-08-09  0:53       ` Roy Franz
2013-08-09  0:53         ` Roy Franz
2013-08-09  0:53         ` Roy Franz
2013-08-13 14:21       ` Dave P Martin
2013-08-13 14:21         ` Dave P Martin
2013-08-13 14:21         ` Dave P Martin
2013-08-07  3:45 ` [PATCH 17/17] Add config EFI_STUB for ARM to Kconfig Roy Franz
2013-08-07  3:45   ` Roy Franz
2013-08-07  7:44 ` [PATCH V2 00/17] EFI stub for ARM Matt Fleming
2013-08-07  7:44   ` Matt Fleming

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAFECyb_ZoCCMs75FLtGewfFQy1m5aVw6s5Jv1H1vaxg976qFNA@mail.gmail.com \
    --to=roy.franz@linaro.org \
    --cc=dave.martin@arm.com \
    --cc=leif.lindholm@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-efi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@arm.linux.org.uk \
    --cc=matt.fleming@intel.com \
    --cc=matt@console-pimps.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.