All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ulf Magnusson <ulfalizer@gmail.com>
To: Masahiro Yamada <yamada.masahiro@socionext.com>
Cc: Linux Kbuild mailing list <linux-kbuild@vger.kernel.org>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Sam Ravnborg <sam@ravnborg.org>,
	"Luis R . Rodriguez" <mcgrof@kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Nicholas Piggin <npiggin@gmail.com>,
	Kees Cook <keescook@chromium.org>,
	Emese Revfy <re.emese@gmail.com>, X86 ML <x86@kernel.org>
Subject: Re: [PATCH v4 03/31] kconfig: reference environment variables directly and remove 'option env='
Date: Mon, 21 May 2018 13:06:56 +0200	[thread overview]
Message-ID: <CAFkk2KT0PAS8=bqHeSux3XwUx4fwKKqQoJkGeXRo8DHtEQNrDQ@mail.gmail.com> (raw)
In-Reply-To: <CAK7LNARP2b=jN_ioj3dT=3yiSTv7Ezu-MSPuh0vO30irN5D1nA@mail.gmail.com>

On Mon, May 21, 2018 at 6:43 AM, Masahiro Yamada
<yamada.masahiro@socionext.com> wrote:
> Hi.
>
>
>
> 2018-05-21 0:46 GMT+09:00 Ulf Magnusson <ulfalizer@gmail.com>:
>
>> s/environments/environment variables/
>
> Will fix.
>
>
>>
>>> +        * They will be written out to include/config/auto.conf.cmd
>>> +        */
>>> +       env_add(name, value);
>>> +
>>> +       return xstrdup(value);
>>> +}
>>> +
>>> +void env_write_dep(FILE *f, const char *autoconfig_name)
>>> +{
>>> +       struct env *e, *tmp;
>>> +
>>> +       list_for_each_entry_safe(e, tmp, &env_list, node) {
>>> +               fprintf(f, "ifneq \"$(%s)\" \"%s\"\n", e->name, e->value);
>>> +               fprintf(f, "%s: FORCE\n", autoconfig_name);
>>> +               fprintf(f, "endif\n");
>>> +               env_del(e);
>>> +       }
>>> +}
>>> +
>>> +static char *eval_clause(const char *in)
>>> +{
>>> +       char *res, *name;
>>> +
>>> +       /*
>>> +        * Returns an empty string because '$()' should be evaluated
>>> +        * to a null string.
>>> +        */
>>
>> Do you know of cases where this is more useful than erroring out?
>>
>> Not saying it doesn't make sense. Just curious.
>
>
> I just followed how Make works.
>
> Anyway, eval_clause() will return null string for null input.
> I will remove that hunk.
>
>
>
>
>>> +       if (!*in)
>>> +               return xstrdup("");
>>> +
>>> +       name = expand_string(in);
>>> +
>>> +       res = env_expand(name);
>>> +       free(name);
>>> +
>>> +       return res;
>>> +}
>>> +
>>> +/*
>>> + * Expand a string that follows '$'
>>> + *
>>> + * For example, if the input string is
>>> + *     ($(FOO)$($(BAR)))$(BAZ)
>>> + * this helper evaluates
>>> + *     $($(FOO)$($(BAR)))
>>> + * and returns the resulted string, then updates 'str' to point to the next
>>
>> s/resulted/resulting/
>>
>> Maybe something like this would make the behavior a bit clearer:
>>
>>   ...and returns a new string containing the expansion, also advancing
>>   'str' to point to the next character after... (note that this function does
>>   a recursive expansion) ...
>
>
> Is this OK?
>
> /*
>  * Expand a string that follows '$'
>  *
>  * For example, if the input string is
>  *     ($(FOO)$($(BAR)))$(BAZ)
>  * this helper evaluates
>  *     $($(FOO)$($(BAR)))
>  * and returns a new string containing the expansion (note that the string is
>  * recursively expanded), also advancing 'str' to point to the next character
>  * after the corresponding closing parenthesis, in this case, *str will be
>  *     $(BAR)
>  */

Looks fine to me.

>
>
>
>>> + * character after the corresponding closing parenthesis, in this case, *str
>>> + * will be
>>> + *     $(BAR)
>>> + */
>>> +char *expand_dollar(const char **str)
>>> +{
>>> +       const char *p = *str;
>>> +       const char *q;
>>> +       char *tmp, *out;
>>> +       int nest = 0;
>>> +
>>> +       /* '$$' represents an escaped '$' */
>>> +       if (*p == '$') {
>>> +               *str = p + 1;
>>> +               return xstrdup("$");
>>> +       }
>>> +
>>> +       /*
>>> +        * Kconfig does not support single-letter variable as in $A
>>> +        * or curly braces as in ${CC}.
>>> +        */
>>> +       if (*p != '(')
>>> +               pperror("syntax error: '$' not followed by '('", p);
>>
>> Could say "not followed by '(' by or '$'".
>
> Will do.
>
>
>>> +
>>> +       p++;
>>> +       q = p;
>>> +       while (*q) {
>>> +               if (*q == '(') {
>>> +                       nest++;
>>> +               } else if (*q == ')') {
>>> +                       if (nest-- == 0)
>>> +                               break;
>>> +               }
>>> +               q++;
>>> +       }
>>> +
>>> +       if (!*q)
>>> +               pperror("unterminated reference to '%s': missing ')'", p);
>>> +
>>> +       tmp = xmalloc(q - p + 1);
>>> +       memcpy(tmp, p, q - p);
>>> +       tmp[q - p] = 0;
>>> +       *str = q + 1;
>>> +       out = eval_clause(tmp);
>>> +       free(tmp);
>>> +
>>> +       return out;
>>
>> This might be a bit clearer, since the 'str' update and the expansion
>> are independent:
>
> Indeed, will do.
>
>>
>>   /* Advance 'str' to after the expanded initial portion of the string */
>>   *str = q + 1;
>>
>>   /* Save the "FOO" part of "(FOO)" into 'tmp' and expand it recursively */
>>   tmp = xmalloc(q - p + 1);
>>   memcpy(tmp, p, q - p);
>>   tmp[q - p] = '\0';
>>   out = eval_clause(tmp);
>>   free(tmp);
>>
>>   return out;
>>
>> ...or switched around, but thought putting the 'str' bit first might
>> emphasize that it isn't modified.
>
>
> I prefer advancing the pointer at last.

Yeah, it's a bit less weird in a way...

>
>
>
>
>>> +}
>>> +
>>> +/*
>>> + * Expand variables in the given string.  Undefined variables
>>> + * expand to an empty string.
>>
>> I wonder what the tradeoffs are vs. erroring out here (or leaving
>> undefined variables as-is).
>
>
> I want to stick to the Make-like behavior here and exploit it in some cases.
> We can set some variables in some arch/*/Kconfig,
> but unset in the others.
>
>
>
>
> In some arch/*/Kconfig:
>
> min-gcc-version := 40900
>
>
>
>
> In init/Kconfig:
>
> # GCC 4.5 is required to build Linux Kernel.
> # Some architectures may override it (from arch/*/Kconfig) for their
> requirement.
> min-gcc-version := $(if,$(min-gcc-version),$(min-gcc-version),40500)
>
> ... check the gcc version, then show error
> if it is older than $(min-gcc-version).

OK, makes sense. Fine by me.

>>> + * The returned string must be freed when done.
>>> + */
>>> +char *expand_string(const char *in)
>>> +{
>>> +       const char *prev_in, *p;
>>> +       char *new, *out;
>>> +       size_t outlen;
>>> +
>>> +       out = xmalloc(1);
>>> +       *out = 0;
>>> +
>>> +       while ((p = strchr(in, '$'))) {
>>> +               prev_in = in;
>>> +               in = p + 1;
>>> +               new = expand_dollar(&in);
>>> +               outlen = strlen(out) + (p - prev_in) + strlen(new) + 1;
>>> +               out = xrealloc(out, outlen);
>>> +               strncat(out, prev_in, p - prev_in);
>>> +               strcat(out, new);
>>> +               free(new);
>>
>> Some code duplication with expand_one_token() here. Do you think
>> something could be factored out/reorganized?
>
>
> Yes.  For example, the following would work.
> If you prefer that, I can update it in v5.
>
>
>
>
> static char *__expand_string(const char **str, bool (*is_end)(const char *))
> {
>         const char *in, *prev_in, *p;
>         char *new, *out;
>         size_t outlen;
>
>         out = xmalloc(1);
>         *out = 0;
>
>         p = in = *str;
>
>         while (1) {
>                 if (*p == '$') {
>                         prev_in = in;
>                         in = p + 1;
>                         new = expand_dollar(&in);
>                         outlen = strlen(out) + (p - prev_in) + strlen(new) + 1;
>                         out = xrealloc(out, outlen);
>                         strncat(out, prev_in, p - prev_in);
>                         strcat(out, new);
>                         free(new);
>                         p = in;
>                         continue;
>                 }
>
>                 if (is_end(p))
>                         break;
>
>                 p++;
>         }
>
>         outlen = strlen(out) + (p - in) + 1;
>         out = xrealloc(out, outlen);
>         strncat(out, in, p - in);
>
>         *str = p;
>
>         return out;
> }
>
> static bool is_end_of_str(const char *s)
> {
>         return !*s;
> }
>
> char *expand_string(const char *in)
> {
>         return __expand_string(&in, is_end_of_str);
> }
>
> static bool is_end_of_token(const char *s)
> {
>         return !(isalnum(*s) || *s == '_' || *s == '-' || *s == '.' ||
> *s == '/');
> }
>
> char *expand_one_token(const char **str)
> {
>         return __expand_string(str, is_end_of_token);
> }

Yep, something like that would be nicer I think.

This variant might work too (untested):

  dollar_i = p;
  p++;
  expansion = expand_dollar(&p);

  out = xrealloc(out, strlen(out) + (dollar_i - in)
                      + strlen(expansion) + 1);
  strncat(out, in, dollar_i - in);
  strcat(out, expansion);
  free(expansion);

  in = p;

  continue;

The p++ would disappear if expand_dollar() took a pointer to the '$'.

Having some string buffer helpers might be nice, but definitely out of scope.

>
>
>
>
>
>> I wonder if it might be cleaner to have expand_dollar() take a pointer
>> to the '$'. Might even out in terms of the +1's you'd have to add, as
>> all callers manually bump the pointer before the call now. I haven't
>> tried implementing it though, so hard to say.
>
>
> If I do this, I'd want to add a sanity check to expand_dollar().
> I'd rather like to avoid unneeded code.
>
>
> static char *expand_dollar(...)
> {
>         assert(*p == '$');
>         p++;
>
>         /* '$$' represents an escaped '$' */
>         if (*p == '$') {
>                *str = p + 1;
>                return xstrdup("$");
>         }
>
>          ...
>
>
> }

Felt a bit more direct to have it point to the start of the thing
being expanded, and the assert() doesn't seem horrible there to me,
but your call.

>
>
>>
>> Some short inline comments similar to above would help too I think.
>>
>
>
>
> --
> Best Regards
> Masahiro Yamada

Cheers,
Ulf

  reply	other threads:[~2018-05-21 11:06 UTC|newest]

Thread overview: 69+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-17  6:16 [PATCH v4 00/31] kconfig: move compiler capability tests to Kconfig Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 01/31] kbuild: remove kbuild cache Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 02/31] kbuild: remove CONFIG_CROSS_COMPILE support Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 03/31] kconfig: reference environment variables directly and remove 'option env=' Masahiro Yamada
2018-05-20 15:46   ` Ulf Magnusson
2018-05-21  4:43     ` Masahiro Yamada
2018-05-21 11:06       ` Ulf Magnusson [this message]
2018-05-21 11:11         ` Ulf Magnusson
2018-05-24  4:45         ` Masahiro Yamada
2018-05-26 20:47           ` Ulf Magnusson
2018-05-17  6:16 ` [PATCH v4 04/31] kconfig: remove string expansion in file_lookup() Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 05/31] kconfig: remove string expansion for mainmenu after yyparse() Masahiro Yamada
2018-05-20 14:39   ` Sam Ravnborg
2018-05-21  5:38     ` Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 06/31] kconfig: remove sym_expand_string_value() Masahiro Yamada
2018-05-17  6:28   ` Kees Cook
2018-05-17  6:16 ` [PATCH v4 07/31] kconfig: add built-in function support Masahiro Yamada
2018-05-20 14:50   ` Sam Ravnborg
2018-05-21  5:18     ` Masahiro Yamada
2018-05-21  6:16       ` Sam Ravnborg
2018-05-21  6:41         ` Masahiro Yamada
2018-05-21  7:14           ` Sam Ravnborg
2018-05-21 14:23     ` Ulf Magnusson
2018-05-21 14:32       ` Ulf Magnusson
2018-05-21 15:10         ` Ulf Magnusson
2018-05-22  3:11           ` Masahiro Yamada
2018-05-22  4:50             ` Ulf Magnusson
2018-05-22  4:58               ` Ulf Magnusson
2018-05-17  6:16 ` [PATCH v4 08/31] kconfig: add 'shell' built-in function Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 09/31] kconfig: replace $(UNAME_RELEASE) with function call Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 10/31] kconfig: begin PARAM state only when seeing a command keyword Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 11/31] kconfig: support user-defined function and recursively expanded variable Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 12/31] kconfig: support simply " Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 13/31] kconfig: support append assignment operator Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 14/31] kconfig: expand lefthand side of assignment statement Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 15/31] kconfig: add 'info', 'warning', and 'error' built-in functions Masahiro Yamada
2018-05-17  6:38   ` Kees Cook
2018-05-17  6:16 ` [PATCH v4 16/31] kconfig: add 'if' built-in function Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 17/31] kconfig: add 'filename' and 'lineno' built-in variables Masahiro Yamada
2018-05-17  6:39   ` Kees Cook
2018-05-17  6:16 ` [PATCH v4 18/31] kconfig: error out if a recursive variable references itself Masahiro Yamada
2018-05-17  6:16 ` [PATCH v4 19/31] Documentation: kconfig: document a new Kconfig macro language Masahiro Yamada
2018-05-17  6:38   ` Kees Cook
2018-05-17  6:38     ` Kees Cook
2018-05-17  6:55     ` Masahiro Yamada
2018-05-17  6:55       ` Masahiro Yamada
2018-05-26  2:14   ` Randy Dunlap
2018-05-17  6:16 ` [PATCH v4 20/31] kconfig: test: add Kconfig macro language tests Masahiro Yamada
2018-05-17  6:41   ` Kees Cook
2018-05-17  6:48     ` Masahiro Yamada
2018-05-17  6:17 ` [PATCH v4 21/31] kconfig: show compiler version text in the top comment Masahiro Yamada
2018-05-17  6:17 ` [PATCH v4 22/31] kconfig: add basic helper macros to scripts/Kconfig.include Masahiro Yamada
2018-05-17  6:17 ` [PATCH v4 23/31] stack-protector: test compiler capability in Kconfig and drop AUTO mode Masahiro Yamada
2018-05-17  6:26   ` Kees Cook
2018-05-17  6:17 ` [PATCH v4 24/31] kconfig: add CC_IS_GCC and GCC_VERSION Masahiro Yamada
2018-05-17  6:17 ` [PATCH v4 25/31] kconfig: add CC_IS_CLANG and CLANG_VERSION Masahiro Yamada
2018-05-17  6:17 ` [PATCH v4 26/31] gcov: remove CONFIG_GCOV_FORMAT_AUTODETECT Masahiro Yamada
2018-05-17  6:17 ` [PATCH v4 27/31] kcov: test compiler capability in Kconfig and correct dependency Masahiro Yamada
2018-05-17  6:33   ` Kees Cook
2018-05-17  6:17 ` [PATCH v4 28/31] gcc-plugins: move GCC version check for PowerPC to Kconfig Masahiro Yamada
2018-05-17  6:29   ` Kees Cook
2018-05-17  6:17 ` [PATCH v4 29/31] gcc-plugins: test plugin support in Kconfig and clean up Makefile Masahiro Yamada
2018-05-17  6:32   ` Kees Cook
2018-05-17  6:17 ` [PATCH v4 30/31] gcc-plugins: allow to enable GCC_PLUGINS for COMPILE_TEST Masahiro Yamada
2018-05-17  6:27   ` Kees Cook
2018-05-17  6:17 ` [PATCH v4 31/31] arm64: move GCC version check for ARCH_SUPPORTS_INT128 to Kconfig Masahiro Yamada
2018-05-17  7:51 ` [PATCH v4 00/31] kconfig: move compiler capability tests " Nicholas Piggin
2018-05-17 14:22   ` Masahiro Yamada
2018-05-22  5:37     ` Masahiro Yamada

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAFkk2KT0PAS8=bqHeSux3XwUx4fwKKqQoJkGeXRo8DHtEQNrDQ@mail.gmail.com' \
    --to=ulfalizer@gmail.com \
    --cc=keescook@chromium.org \
    --cc=linux-kbuild@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mcgrof@kernel.org \
    --cc=npiggin@gmail.com \
    --cc=re.emese@gmail.com \
    --cc=sam@ravnborg.org \
    --cc=torvalds@linux-foundation.org \
    --cc=x86@kernel.org \
    --cc=yamada.masahiro@socionext.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.