All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chen-Yu Tsai <wens@csie.org>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH v5 0/8] ARMv7: PSCI: add PSCI v1.0 support
Date: Wed, 15 Jun 2016 15:16:08 +0800	[thread overview]
Message-ID: <CAGb2v64pxeNw7G5Wqsmz-HNRkT0wbtp3XO1p-mivo4hsP9wAKA@mail.gmail.com> (raw)
In-Reply-To: <1465887683-27492-1-git-send-email-hongbo.zhang@nxp.com>

Hi,

On Tue, Jun 14, 2016 at 3:01 PM,  <macro.wave.z@gmail.com> wrote:
> From: Hongbo Zhang <hongbo.zhang@nxp.com>
>
> v5 changes:
> - Give up fixing the potential bug of PSCI stack overlap with secure text end
> when there is more CPUs in system. Because I just want to keep this series as
> simple as it could be: adding basic PSCI v1.0 support and adding more PSCI
> v1.0 implements of our platform.
> While too compplicated patches in assembly language won't call for effective
> reviews, even I think there is potential bug of PSCI stack, let's fix it in
> sepetated patch later.

I've done some patches fixing the stack allocation issue:

https://github.com/wens/u-boot-sunxi/commits/c-psci-part2

These patches are ready, but I want to add a secure data section still.
The data section will be for variables such as target PC, core/cluster
power status, context ID, etc.. IMHO this is better than putting stuff
at the top or bottom of the stack, and can also be referenced directly.

Regards
ChenYu

> - Move the patch of factoring out psci_cpu_on_common to earlier place 2/8, so
> that the following patches can only update the psci_cpu_on_common instead of
> touching each platform's psci_cpu_on, this reduces patches size obviously and
> make it easier for review.
>
> v4 changes:
> - since there is already PSCI v0.2 function IDs definition merged in 5a07abb,
> I give up my previous patches 1/11 and 2/11, and move previous 7/11 "ARMv7:
> PSCI: add PSCI v1.0 functions skeleton" as current first one 1/9
> - accept Andre's comment to add the missed "arm,psci-0,2" into compatible
> string
>
> v3 changes:
> - patch 3/11, re-init the stack pointer to address like start of page instead
> of page end, because for ARM push operation, the stack pointer is encreased
> before storing data.
> - patch 10/11, delete the previous un-implemented cpu_suspend function for ls1
> platform, because there is default blank functions for all those are not
> implemented in specific platform.
>
>
> v2 changes:
> - re-organize psci_cpu_on_common, this code should be called by each platform's
> psci_cpu_on, should not be a function calling each psci_cpu_on, all related
> functions are updated due to this change
> - update some registers usage, e.g. if r10 is used without push/pop, u-boot
> cannot launch rt-kernel
> - update some comments to be clearer, re-organize all patches for easier review
> - add patch to check already_on or on_pending for LS102XA
>
> This patch set contains two parts:
> ARMv7 PSCI common framework: fix some issues and add v1.0 support
> NXP (was Freescale) LS102XA: codes enhancement and add v1.0 implementation
> And this patch set was initially created by Dongsheng Wang.
>
> Hongbo Zhang (8):
>   ARMv7: PSCI: add PSCI v1.0 functions skeleton
>   ARMv7: PSCI: factor out reusable psci_cpu_on_common
>   ARMv7: PSCI: update the place of saving target PC
>   ARMv7: PSCI: add codes to save context ID for CPU_ON
>   ARMv7: PSCI: ls102xa: check target CPU ID before further operations
>   ARMv7: PSCI: ls102xa: check ALREADY_ON or ON_PENDING for CPU_ON
>   ARMv7: PSCI: ls102xa: add more PSCI v1.0 functions implemention
>   ARMv7: PSCI: ls102xa: move secure text section into OCRAM
>
>  arch/arm/cpu/armv7/ls102xa/psci.S          | 169 +++++++++++++++++++++++++++--
>  arch/arm/cpu/armv7/mx7/psci.S              |   5 +-
>  arch/arm/cpu/armv7/nonsec_virt.S           |   7 ++
>  arch/arm/cpu/armv7/psci.S                  |  99 ++++++++++++++++-
>  arch/arm/cpu/armv7/sunxi/psci_sun6i.S      |   5 +-
>  arch/arm/cpu/armv7/sunxi/psci_sun7i.S      |   5 +-
>  arch/arm/cpu/armv7/virt-dt.c               |  10 +-
>  arch/arm/include/asm/arch-ls102xa/config.h |   3 +-
>  arch/arm/include/asm/psci.h                |  31 ++++++
>  arch/arm/mach-tegra/psci.S                 |   5 +-
>  board/freescale/ls1021aqds/Makefile        |   1 +
>  board/freescale/ls1021aqds/psci.S          |  36 ++++++
>  board/freescale/ls1021atwr/Makefile        |   1 +
>  board/freescale/ls1021atwr/psci.S          |  28 +++++
>  include/configs/ls1021aqds.h               |   3 +
>  include/configs/ls1021atwr.h               |   3 +
>  16 files changed, 383 insertions(+), 28 deletions(-)
>  create mode 100644 board/freescale/ls1021aqds/psci.S
>  create mode 100644 board/freescale/ls1021atwr/psci.S
>
> --
> 2.1.4
>

  parent reply	other threads:[~2016-06-15  7:16 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-06-14  7:01 [U-Boot] [PATCH v5 0/8] ARMv7: PSCI: add PSCI v1.0 support macro.wave.z at gmail.com
2016-06-14  7:01 ` [U-Boot] [PATCH v5 1/8] ARMv7: PSCI: add PSCI v1.0 functions skeleton macro.wave.z at gmail.com
2016-06-14  7:01 ` [U-Boot] [PATCH v5 2/8] ARMv7: PSCI: factor out reusable psci_cpu_on_common macro.wave.z at gmail.com
2016-06-28  2:49   ` Chen-Yu Tsai
2016-06-28  3:50     ` Hongbo Zhang
2016-06-14  7:01 ` [U-Boot] [PATCH v5 3/8] ARMv7: PSCI: update the place of saving target PC macro.wave.z at gmail.com
2016-06-28  3:24   ` Chen-Yu Tsai
2016-06-28  9:23     ` Hongbo Zhang
2016-06-28  9:48       ` Chen-Yu Tsai
2016-06-14  7:01 ` [U-Boot] [PATCH v5 4/8] ARMv7: PSCI: add codes to save context ID for CPU_ON macro.wave.z at gmail.com
2016-06-28  3:15   ` Chen-Yu Tsai
2016-06-28 10:29     ` Hongbo Zhang
2016-06-14  7:01 ` [U-Boot] [PATCH v5 5/8] ARMv7: PSCI: ls102xa: check target CPU ID before further operations macro.wave.z at gmail.com
2016-06-28  4:10   ` Chen-Yu Tsai
2016-06-28 10:39     ` Hongbo Zhang
2016-06-14  7:01 ` [U-Boot] [PATCH v5 6/8] ARMv7: PSCI: ls102xa: check ALREADY_ON or ON_PENDING for CPU_ON macro.wave.z at gmail.com
2016-06-28  4:30   ` Chen-Yu Tsai
2016-06-30  4:24     ` Hongbo Zhang
2016-06-30 14:47       ` Chen-Yu Tsai
2016-06-14  7:01 ` [U-Boot] [PATCH v5 7/8] ARMv7: PSCI: ls102xa: add more PSCI v1.0 functions implemention macro.wave.z at gmail.com
2016-06-30 14:45   ` Chen-Yu Tsai
2016-06-14  7:01 ` [U-Boot] [PATCH v5 8/8] ARMv7: PSCI: ls102xa: move secure text section into OCRAM macro.wave.z at gmail.com
2016-06-28  4:16   ` Chen-Yu Tsai
2016-06-28 10:45     ` Hongbo Zhang
2016-06-15  7:16 ` Chen-Yu Tsai [this message]
2016-06-15  7:39   ` [U-Boot] [PATCH v5 0/8] ARMv7: PSCI: add PSCI v1.0 support Marc Zyngier
2016-06-15  8:08   ` Hongbo Zhang
2016-06-24 15:26   ` york sun
2016-06-30  5:28     ` Hongbo Zhang
2016-07-04  7:20       ` Hongbo Zhang
2016-07-04 13:11         ` Hans de Goede
2016-07-05  2:26           ` Hongbo Zhang
2016-07-19 20:34             ` york sun
2016-07-21  4:21               ` Hongbo Zhang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAGb2v64pxeNw7G5Wqsmz-HNRkT0wbtp3XO1p-mivo4hsP9wAKA@mail.gmail.com \
    --to=wens@csie.org \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.