All of lore.kernel.org
 help / color / mirror / Atom feed
From: Rob Herring <robh+dt@kernel.org>
To: Jakub Kicinski <kuba@kernel.org>
Cc: Andrew Lunn <andrew@lunn.ch>, David Miller <davem@davemloft.net>,
	netdev <netdev@vger.kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Saravana Kannan <saravanak@google.com>,
	Marcin Wojtas <mw@semihalf.com>,
	Jeremy Linton <jeremy.linton@arm.com>,
	Heiner Kallweit <hkallweit1@gmail.com>,
	Russell King <linux@armlinux.org.uk>,
	Frank Rowand <frowand.list@gmail.com>,
	Heikki Krogerus <heikki.krogerus@linux.intel.com>,
	devicetree@vger.kernel.org
Subject: Re: [PATCH net-next v2 1/9] of: net: move of_net under net/
Date: Wed, 6 Oct 2021 14:02:42 -0500	[thread overview]
Message-ID: <CAL_JsqK81knMX5i2DJDsxEALFjwoj3pijjT9ZMJ73aOCjYFhMQ@mail.gmail.com> (raw)
In-Reply-To: <20211006101203.4337e9a4@kicinski-fedora-pc1c0hjn.dhcp.thefacebook.com>

On Wed, Oct 6, 2021 at 12:12 PM Jakub Kicinski <kuba@kernel.org> wrote:
>
> On Wed, 6 Oct 2021 11:58:07 -0500 Rob Herring wrote:
> > On Wed, Oct 6, 2021 at 11:34 AM Andrew Lunn <andrew@lunn.ch> wrote:
> > >
> > > On Wed, Oct 06, 2021 at 11:18:19AM -0500, Rob Herring wrote:
> > > > The OF_NET kconfig should move or disappear too. I imagine you can do just:
> > >
> > > It is used in a few places:
> >
> > Okay, then just move it for now.
> >
> > I suspect though that most of these can either be dropped or replaced
> > with just 'OF' dependency.
>
> I have something that builds with allmodconfig :) see below.

Sparc is the arch to try. That's generally we we get tripped up with OF options.

> > > net/ethernet/litex/Kconfig:     depends on OF_NET
> > > net/ethernet/amd/Kconfig:       depends on ((OF_NET && OF_ADDRESS) || ACPI || PCI) && HAS_IOMEM
> >
> > If the driver depends on OF or ACPI, then the dependency should just
> > be removed because one of those is almost always enabled.
>
> I assumed any OF_* implies OF so just dropping OF_NET.
>
> > > net/ethernet/mscc/Kconfig:      depends on OF_NET
> > > net/ethernet/ezchip/Kconfig:    depends on OF_IRQ && OF_NET
> > > net/ethernet/arc/Kconfig:       depends on OF_IRQ && OF_NET
> > > net/ethernet/arc/Kconfig:       depends on OF_IRQ && OF_NET && REGULATOR
> >
> > I don't see any OF_IRQ dependency (which would be odd). The OF_NET
> > dependency is just of_get_phy_mode() from a quick glance and we have a
> > stub for it.
>
> Hm. Indeed on the OF_IRQ.
>
> net/ethernet/arc/ has irq_of_parse_and_map()

Ah right, but there is a stub for that. The preference is to use
platform_get_irq() instead of irq_of_parse_and_map(), then the OF_IRQ
dependency would really be gone.

> but I don't see the need in ezchip, but that seems like a separate matter...

  reply	other threads:[~2021-10-06 19:02 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-06 15:44 [PATCH net-next v2 0/9] net: add a helpers for loading netdev->dev_addr from FW Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 1/9] of: net: move of_net under net/ Jakub Kicinski
2021-10-06 16:18   ` Rob Herring
2021-10-06 16:34     ` Andrew Lunn
2021-10-06 16:58       ` Rob Herring
2021-10-06 17:12         ` Jakub Kicinski
2021-10-06 19:02           ` Rob Herring [this message]
2021-10-06 19:49             ` Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 2/9] of: net: add a helper for loading netdev->dev_addr Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 3/9] ethernet: use of_get_ethdev_address() Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 4/9] device property: move mac addr helpers to eth.c Jakub Kicinski
2021-10-06 16:06   ` Greg KH
2021-10-06 15:44 ` [PATCH net-next v2 5/9] eth: fwnode: change the return type of mac address helpers Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 6/9] eth: fwnode: remove the addr len from mac helpers Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 7/9] eth: fwnode: add a helper for loading netdev->dev_addr Jakub Kicinski
2021-10-06 18:13   ` Shannon Nelson
2021-10-06 15:44 ` [PATCH net-next v2 8/9] ethernet: use device_get_ethdev_address() Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 9/9] ethernet: make more use of device_get_ethdev_address() Jakub Kicinski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAL_JsqK81knMX5i2DJDsxEALFjwoj3pijjT9ZMJ73aOCjYFhMQ@mail.gmail.com \
    --to=robh+dt@kernel.org \
    --cc=andrew@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=devicetree@vger.kernel.org \
    --cc=frowand.list@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=heikki.krogerus@linux.intel.com \
    --cc=hkallweit1@gmail.com \
    --cc=jeremy.linton@arm.com \
    --cc=kuba@kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=mw@semihalf.com \
    --cc=netdev@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=saravanak@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.