All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andrew Lunn <andrew@lunn.ch>
To: Rob Herring <robh+dt@kernel.org>
Cc: Jakub Kicinski <kuba@kernel.org>,
	David Miller <davem@davemloft.net>,
	netdev <netdev@vger.kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Saravana Kannan <saravanak@google.com>,
	Marcin Wojtas <mw@semihalf.com>,
	Jeremy Linton <jeremy.linton@arm.com>,
	Heiner Kallweit <hkallweit1@gmail.com>,
	Russell King <linux@armlinux.org.uk>,
	Frank Rowand <frowand.list@gmail.com>,
	Heikki Krogerus <heikki.krogerus@linux.intel.com>,
	devicetree@vger.kernel.org
Subject: Re: [PATCH net-next v2 1/9] of: net: move of_net under net/
Date: Wed, 6 Oct 2021 18:34:11 +0200	[thread overview]
Message-ID: <YV3QAzAWiYdKFB3m@lunn.ch> (raw)
In-Reply-To: <CAL_JsqK6YzaD0wB0BsP5tghnYMbZzDHq2p6Z_ZGr99EFWhWggw@mail.gmail.com>

On Wed, Oct 06, 2021 at 11:18:19AM -0500, Rob Herring wrote:
> On Wed, Oct 6, 2021 at 10:45 AM Jakub Kicinski <kuba@kernel.org> wrote:
> >
> > Rob suggests to move of_net.c from under drivers/of/ somewhere
> > to the networking code.
> >
> > Suggested-by: Rob Herring <robh@kernel.org>
> > Signed-off-by: Jakub Kicinski <kuba@kernel.org>
> > ---
> > v2: new patch
> > ---
> >  drivers/of/Makefile               | 1 -
> >  net/core/Makefile                 | 1 +
> >  {drivers/of => net/core}/of_net.c | 0
> >  3 files changed, 1 insertion(+), 1 deletion(-)
> >  rename {drivers/of => net/core}/of_net.c (100%)
> >
> > diff --git a/drivers/of/Makefile b/drivers/of/Makefile
> > index c13b982084a3..e0360a44306e 100644
> > --- a/drivers/of/Makefile
> > +++ b/drivers/of/Makefile
> > @@ -7,7 +7,6 @@ obj-$(CONFIG_OF_EARLY_FLATTREE) += fdt_address.o
> >  obj-$(CONFIG_OF_PROMTREE) += pdt.o
> >  obj-$(CONFIG_OF_ADDRESS)  += address.o
> >  obj-$(CONFIG_OF_IRQ)    += irq.o
> > -obj-$(CONFIG_OF_NET)   += of_net.o
> >  obj-$(CONFIG_OF_UNITTEST) += unittest.o
> >  obj-$(CONFIG_OF_RESERVED_MEM) += of_reserved_mem.o
> >  obj-$(CONFIG_OF_RESOLVE)  += resolver.o
> > diff --git a/net/core/Makefile b/net/core/Makefile
> > index 35ced6201814..37b1befc39aa 100644
> > --- a/net/core/Makefile
> > +++ b/net/core/Makefile
> > @@ -36,3 +36,4 @@ obj-$(CONFIG_FAILOVER) += failover.o
> >  obj-$(CONFIG_NET_SOCK_MSG) += skmsg.o
> >  obj-$(CONFIG_BPF_SYSCALL) += sock_map.o
> >  obj-$(CONFIG_BPF_SYSCALL) += bpf_sk_storage.o
> > +obj-$(CONFIG_OF_NET)   += of_net.o
> 
> The OF_NET kconfig should move or disappear too. I imagine you can do just:

It is used in a few places:

net/ethernet/litex/Kconfig:	depends on OF_NET
net/ethernet/amd/Kconfig:	depends on ((OF_NET && OF_ADDRESS) || ACPI || PCI) && HAS_IOMEM
net/ethernet/mscc/Kconfig:	depends on OF_NET
net/ethernet/ezchip/Kconfig:	depends on OF_IRQ && OF_NET
net/ethernet/arc/Kconfig:	depends on OF_IRQ && OF_NET
net/ethernet/arc/Kconfig:	depends on OF_IRQ && OF_NET && REGULATOR

so it cannot just disappear. These will need reviewing and changing as
well.

	Andrew

  reply	other threads:[~2021-10-06 16:34 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-06 15:44 [PATCH net-next v2 0/9] net: add a helpers for loading netdev->dev_addr from FW Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 1/9] of: net: move of_net under net/ Jakub Kicinski
2021-10-06 16:18   ` Rob Herring
2021-10-06 16:34     ` Andrew Lunn [this message]
2021-10-06 16:58       ` Rob Herring
2021-10-06 17:12         ` Jakub Kicinski
2021-10-06 19:02           ` Rob Herring
2021-10-06 19:49             ` Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 2/9] of: net: add a helper for loading netdev->dev_addr Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 3/9] ethernet: use of_get_ethdev_address() Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 4/9] device property: move mac addr helpers to eth.c Jakub Kicinski
2021-10-06 16:06   ` Greg KH
2021-10-06 15:44 ` [PATCH net-next v2 5/9] eth: fwnode: change the return type of mac address helpers Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 6/9] eth: fwnode: remove the addr len from mac helpers Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 7/9] eth: fwnode: add a helper for loading netdev->dev_addr Jakub Kicinski
2021-10-06 18:13   ` Shannon Nelson
2021-10-06 15:44 ` [PATCH net-next v2 8/9] ethernet: use device_get_ethdev_address() Jakub Kicinski
2021-10-06 15:44 ` [PATCH net-next v2 9/9] ethernet: make more use of device_get_ethdev_address() Jakub Kicinski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YV3QAzAWiYdKFB3m@lunn.ch \
    --to=andrew@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=devicetree@vger.kernel.org \
    --cc=frowand.list@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=heikki.krogerus@linux.intel.com \
    --cc=hkallweit1@gmail.com \
    --cc=jeremy.linton@arm.com \
    --cc=kuba@kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=mw@semihalf.com \
    --cc=netdev@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=robh+dt@kernel.org \
    --cc=saravanak@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.