All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bartosz Golaszewski <brgl@bgdev.pl>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: Yoshinori Sato <ysato@users.sourceforge.jp>,
	Rich Felker <dalias@libc.org>, Lee Jones <lee.jones@linaro.org>,
	Daniel Thompson <daniel.thompson@linaro.org>,
	Jingoo Han <jingoohan1@gmail.com>,
	Bartlomiej Zolnierkiewicz <b.zolnierkie@samsung.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	linux-sh@vger.kernel.org,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	dri-devel@lists.freedesktop.org, linux-fbdev@vger.kernel.org,
	Bartosz Golaszewski <bgolaszewski@baylibre.com>
Subject: Re: [PATCH v2 7/7] backlight: gpio: use a helper variable for &pdev->dev
Date: Tue, 23 Jul 2019 06:29:52 +0000	[thread overview]
Message-ID: <CAMRc=McGTk+i0SzWN7AvGu3deYbXX_rJX=7+dKRpKFPKM_qxDA@mail.gmail.com> (raw)
In-Reply-To: <20190722160908.GZ9224@smile.fi.intel.com>

pon., 22 lip 2019 o 18:09 Andy Shevchenko
<andriy.shevchenko@linux.intel.com> napisał(a):
>
> On Mon, Jul 22, 2019 at 05:03:02PM +0200, Bartosz Golaszewski wrote:
> > From: Bartosz Golaszewski <bgolaszewski@baylibre.com>
> >
> > Instead of dereferencing pdev each time, use a helper variable for
> > the associated device pointer.
>
> >  static int gpio_backlight_probe(struct platform_device *pdev)
> >  {
> > -     struct gpio_backlight_platform_data *pdata =
> > -             dev_get_platdata(&pdev->dev);
> > +     struct gpio_backlight_platform_data *pdata;
> >       struct backlight_properties props;
> >       struct backlight_device *bl;
> >       struct gpio_backlight *gbl;
> >       enum gpiod_flags flags;
> > +     struct device *dev;
>
> Can't we do
>
>         struct device dev = &pdev->dev;
>         struct gpio_backlight_platform_data *pdata = dev_get_platdata(dev);
>
> ? It fits 80 nicely.
>

IMO it's more readable like that with the reverse christmas tree layout.

Bart

WARNING: multiple messages have this Message-ID (diff)
From: Bartosz Golaszewski <brgl@bgdev.pl>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: Yoshinori Sato <ysato@users.sourceforge.jp>,
	Rich Felker <dalias@libc.org>, Lee Jones <lee.jones@linaro.org>,
	Daniel Thompson <daniel.thompson@linaro.org>,
	Jingoo Han <jingoohan1@gmail.com>,
	Bartlomiej Zolnierkiewicz <b.zolnierkie@samsung.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	linux-sh@vger.kernel.org,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	dri-devel@lists.freedesktop.org, linux-fbdev@vger.kernel.org,
	Bartosz Golaszewski <bgolaszewski@baylibre.com>
Subject: Re: [PATCH v2 7/7] backlight: gpio: use a helper variable for &pdev->dev
Date: Tue, 23 Jul 2019 08:29:52 +0200	[thread overview]
Message-ID: <CAMRc=McGTk+i0SzWN7AvGu3deYbXX_rJX=7+dKRpKFPKM_qxDA@mail.gmail.com> (raw)
In-Reply-To: <20190722160908.GZ9224@smile.fi.intel.com>

pon., 22 lip 2019 o 18:09 Andy Shevchenko
<andriy.shevchenko@linux.intel.com> napisał(a):
>
> On Mon, Jul 22, 2019 at 05:03:02PM +0200, Bartosz Golaszewski wrote:
> > From: Bartosz Golaszewski <bgolaszewski@baylibre.com>
> >
> > Instead of dereferencing pdev each time, use a helper variable for
> > the associated device pointer.
>
> >  static int gpio_backlight_probe(struct platform_device *pdev)
> >  {
> > -     struct gpio_backlight_platform_data *pdata =
> > -             dev_get_platdata(&pdev->dev);
> > +     struct gpio_backlight_platform_data *pdata;
> >       struct backlight_properties props;
> >       struct backlight_device *bl;
> >       struct gpio_backlight *gbl;
> >       enum gpiod_flags flags;
> > +     struct device *dev;
>
> Can't we do
>
>         struct device dev = &pdev->dev;
>         struct gpio_backlight_platform_data *pdata = dev_get_platdata(dev);
>
> ? It fits 80 nicely.
>

IMO it's more readable like that with the reverse christmas tree layout.

Bart

  reply	other threads:[~2019-07-23  6:29 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-22 15:02 [PATCH v2 0/7] backlight: gpio: simplify the driver Bartosz Golaszewski
2019-07-22 15:02 ` Bartosz Golaszewski
2019-07-22 15:02 ` [PATCH v2 1/7] sh: ecovec24: add additional properties to the backlight device Bartosz Golaszewski
2019-07-22 15:02   ` Bartosz Golaszewski
2019-08-05  9:53   ` Linus Walleij
2019-08-05  9:53     ` Linus Walleij
2019-07-22 15:02 ` [PATCH v2 2/7] backlight: gpio: simplify the platform data handling Bartosz Golaszewski
2019-07-22 15:02   ` Bartosz Golaszewski
2019-07-22 15:17   ` Daniel Thompson
2019-07-22 15:17     ` Daniel Thompson
2019-07-22 16:06   ` Andy Shevchenko
2019-07-22 16:06     ` Andy Shevchenko
2019-07-23  6:28     ` Bartosz Golaszewski
2019-07-23  6:28       ` Bartosz Golaszewski
2019-07-23 15:32       ` Andy Shevchenko
2019-07-23 15:32         ` Andy Shevchenko
2019-07-24  8:26         ` Bartosz Golaszewski
2019-07-24  8:26           ` Bartosz Golaszewski
2019-07-22 15:02 ` [PATCH v2 3/7] sh: ecovec24: don't set unused fields in platform data Bartosz Golaszewski
2019-07-22 15:02   ` Bartosz Golaszewski
2019-07-22 15:02 ` [PATCH v2 4/7] backlight: gpio: remove unused fields from " Bartosz Golaszewski
2019-07-22 15:02   ` Bartosz Golaszewski
2019-07-22 15:18   ` Daniel Thompson
2019-07-22 15:18     ` Daniel Thompson
2019-07-22 15:03 ` [PATCH v2 5/7] backlight: gpio: remove dev from struct gpio_backlight Bartosz Golaszewski
2019-07-22 15:03   ` Bartosz Golaszewski
2019-07-22 15:20   ` Daniel Thompson
2019-07-22 15:20     ` Daniel Thompson
2019-07-22 15:03 ` [PATCH v2 6/7] backlight: gpio: remove def_value " Bartosz Golaszewski
2019-07-22 15:03   ` Bartosz Golaszewski
2019-07-22 15:22   ` Daniel Thompson
2019-07-22 15:22     ` Daniel Thompson
2019-07-22 15:22     ` Daniel Thompson
2019-07-22 15:03 ` [PATCH v2 7/7] backlight: gpio: use a helper variable for &pdev->dev Bartosz Golaszewski
2019-07-22 15:03   ` Bartosz Golaszewski
2019-07-22 15:23   ` Daniel Thompson
2019-07-22 15:23     ` Daniel Thompson
2019-07-22 16:09   ` Andy Shevchenko
2019-07-22 16:09     ` Andy Shevchenko
2019-07-23  6:29     ` Bartosz Golaszewski [this message]
2019-07-23  6:29       ` Bartosz Golaszewski
2019-07-23 13:40       ` Daniel Thompson
2019-07-23 13:40         ` Daniel Thompson
2019-07-23 15:34       ` Andy Shevchenko
2019-07-23 15:34         ` Andy Shevchenko
2019-07-24  8:26         ` Bartosz Golaszewski
2019-07-24  8:26           ` Bartosz Golaszewski
2019-07-22 16:09 ` [PATCH v2 0/7] backlight: gpio: simplify the driver Andy Shevchenko
2019-07-22 16:09   ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAMRc=McGTk+i0SzWN7AvGu3deYbXX_rJX=7+dKRpKFPKM_qxDA@mail.gmail.com' \
    --to=brgl@bgdev.pl \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=b.zolnierkie@samsung.com \
    --cc=bgolaszewski@baylibre.com \
    --cc=dalias@libc.org \
    --cc=daniel.thompson@linaro.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jingoohan1@gmail.com \
    --cc=lee.jones@linaro.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-fbdev@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-sh@vger.kernel.org \
    --cc=ysato@users.sourceforge.jp \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.