All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] clk: renesas: rcar-usb2-clock-sel: Replace devm_reset_control_array_get()
@ 2020-11-03  3:44 Yejune Deng
  2020-11-03  8:13 ` Geert Uytterhoeven
  0 siblings, 1 reply; 2+ messages in thread
From: Yejune Deng @ 2020-11-03  3:44 UTC (permalink / raw)
  To: geert+renesas, mturquette, sboyd, p.zabel
  Cc: linux-renesas-soc, linux-clk, linux-kernel, yejune.deng

devm_reset_control_array_get_shared() looks more readable

Signed-off-by: Yejune Deng <yejune.deng@gmail.com>
---
 drivers/clk/renesas/rcar-usb2-clock-sel.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/clk/renesas/rcar-usb2-clock-sel.c b/drivers/clk/renesas/rcar-usb2-clock-sel.c
index d4c0298..3abafd7 100644
--- a/drivers/clk/renesas/rcar-usb2-clock-sel.c
+++ b/drivers/clk/renesas/rcar-usb2-clock-sel.c
@@ -160,7 +160,7 @@ static int rcar_usb2_clock_sel_probe(struct platform_device *pdev)
 	if (ret < 0)
 		return ret;
 
-	priv->rsts = devm_reset_control_array_get(dev, true, false);
+	priv->rsts = devm_reset_control_array_get_shared(dev);
 	if (IS_ERR(priv->rsts))
 		return PTR_ERR(priv->rsts);
 
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] clk: renesas: rcar-usb2-clock-sel: Replace devm_reset_control_array_get()
  2020-11-03  3:44 [PATCH] clk: renesas: rcar-usb2-clock-sel: Replace devm_reset_control_array_get() Yejune Deng
@ 2020-11-03  8:13 ` Geert Uytterhoeven
  0 siblings, 0 replies; 2+ messages in thread
From: Geert Uytterhoeven @ 2020-11-03  8:13 UTC (permalink / raw)
  To: Yejune Deng
  Cc: Michael Turquette, Stephen Boyd, Philipp Zabel, Linux-Renesas,
	linux-clk, Linux Kernel Mailing List

On Tue, Nov 3, 2020 at 4:45 AM Yejune Deng <yejune.deng@gmail.com> wrote:
> devm_reset_control_array_get_shared() looks more readable
>
> Signed-off-by: Yejune Deng <yejune.deng@gmail.com>

Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be>
i.e. will queue in renesas-clk-for-v5.11.

Gr{oetje,eeting}s,

                        Geert

-- 
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-11-03  8:14 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-03  3:44 [PATCH] clk: renesas: rcar-usb2-clock-sel: Replace devm_reset_control_array_get() Yejune Deng
2020-11-03  8:13 ` Geert Uytterhoeven

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.