All of lore.kernel.org
 help / color / mirror / Atom feed
* problem with driver with driver name and version
@ 2019-07-19 20:50 Kartik Kulkarni
  2019-07-22  8:20 ` Ardelean, Alexandru
  0 siblings, 1 reply; 2+ messages in thread
From: Kartik Kulkarni @ 2019-07-19 20:50 UTC (permalink / raw)
  To: linux-iio

Hello there,
I wanted to patch the driver for  ad7280a  found at
/opt/linux-kernel-dev/iio/drivers/staging/iio/adc and found a few
anomalies which I felt needed to be asked before the patch was
submitted.

1.
```
tatic struct spi_driver ad7280_driver = {
        .driver = {
                .name   = "ad7280",

...

```
the part of the device id says ad7280 instead of ad7280a which is the
name of the driver file and looking at the Datasheet there's different
datasheet for ad7280 and ad7280A and does not mention compatibility
with each other.(I might be wrong but one had spi interface for 48
channels and the other has spi interface for 300 channels so I think
it might not be compatible)

Note: The spi device id contains "ad7280a" and not "ad7280"
QUESTION:
Should I send a patch to correct the .compatible with ad7280a instead?
as a different patch and send another patch which I am working on
(about of_match which is not present) and add the of_match_array to
contain the device "ad7280a"

or is the file correct and I just send a patch about of_match_devices
with "ad7280"

Regards,
Kartik Kulkarni

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: problem with driver with driver name and version
  2019-07-19 20:50 problem with driver with driver name and version Kartik Kulkarni
@ 2019-07-22  8:20 ` Ardelean, Alexandru
  0 siblings, 0 replies; 2+ messages in thread
From: Ardelean, Alexandru @ 2019-07-22  8:20 UTC (permalink / raw)
  To: linux-iio, kartik.koolks

On Sat, 2019-07-20 at 02:20 +0530, Kartik Kulkarni wrote:
> [External]
> 
> Hello there,
> I wanted to patch the driver for  ad7280a  found at
> /opt/linux-kernel-dev/iio/drivers/staging/iio/adc and found a few
> anomalies which I felt needed to be asked before the patch was
> submitted.
> 
> 1.
> ```
> tatic struct spi_driver ad7280_driver = {
>         .driver = {
>                 .name   = "ad7280",

Makes sense to rename this to "ad7280a", so feel free to send a patch just for this.

> 
> ...
> 
> ```
> the part of the device id says ad7280 instead of ad7280a which is the
> name of the driver file and looking at the Datasheet there's different
> datasheet for ad7280 and ad7280A and does not mention compatibility
> with each other.(I might be wrong but one had spi interface for 48
> channels and the other has spi interface for 300 channels so I think
> it might not be compatible)
> 
> Note: The spi device id contains "ad7280a" and not "ad7280"
> QUESTION:
> Should I send a patch to correct the .compatible with ad7280a instead?
> as a different patch and send another patch which I am working on
> (about of_match which is not present) and add the of_match_array to
> contain the device "ad7280a"

The `of_match_table` patch should be it's own patch.
If you want a send a patch for this, the .compatible string should be "adi,ad7280a".
The `ad7280_id` table is correct.

> 
> or is the file correct and I just send a patch about of_match_devices
> with "ad7280"
> 
> Regards,
> Kartik Kulkarni

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2019-07-22  8:20 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-07-19 20:50 problem with driver with driver name and version Kartik Kulkarni
2019-07-22  8:20 ` Ardelean, Alexandru

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.