All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/3] cmd: dtimg: Rename to adtimg and refactor usage style
@ 2019-12-24 16:51 Eugeniu Rosca
  2019-12-24 16:51 ` [PATCH 1/3] dtimg/am57xx_evm_defconfig: Rename dtimg to adtimg Eugeniu Rosca
                   ` (3 more replies)
  0 siblings, 4 replies; 17+ messages in thread
From: Eugeniu Rosca @ 2019-12-24 16:51 UTC (permalink / raw)
  To: u-boot

The main focus of this series is to prepare the ground for:
 - adding the id/rev-based DT lookup in dtimg/adtimg [1]
 - adding the abootimg command [2]

To be more clear, the above topics are handled _outside_ of this series,
but they treat this series as hard dependency.

The per-patch motivation and testing are described meticulously
in each commit.

[1] https://patchwork.ozlabs.org/patch/1202580/
    ("cmd: dtimg: Get start and size based on --id and --rev")
[2] https://patchwork.ozlabs.org/patch/1182212/
    ("cmd: bootimg: Add bootimg command")

Eugeniu Rosca (3):
  dtimg/am57xx_evm_defconfig: Rename dtimg to adtimg
  cmd: adtimg: Rename internal symbols
  cmd: adtimg: Refactor usage style

 cmd/Kconfig                         |   4 +-
 cmd/Makefile                        |   2 +-
 cmd/adtimg.c                        | 242 ++++++++++++++++++++++++++++
 cmd/dtimg.c                         | 142 ----------------
 common/Makefile                     |   2 +-
 configs/am57xx_evm_defconfig        |   2 +-
 configs/am57xx_hs_evm_defconfig     |   2 +-
 configs/am57xx_hs_evm_usb_defconfig |   2 +-
 8 files changed, 249 insertions(+), 149 deletions(-)
 create mode 100644 cmd/adtimg.c
 delete mode 100644 cmd/dtimg.c

-- 
2.24.0

^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2020-07-08 17:26 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-12-24 16:51 [PATCH 0/3] cmd: dtimg: Rename to adtimg and refactor usage style Eugeniu Rosca
2019-12-24 16:51 ` [PATCH 1/3] dtimg/am57xx_evm_defconfig: Rename dtimg to adtimg Eugeniu Rosca
2020-01-07 16:49   ` Simon Glass
2020-01-07 17:13     ` Eugeniu Rosca
2020-01-10 21:50   ` Tom Rini
2019-12-24 16:51 ` [PATCH 2/3] cmd: adtimg: Rename internal symbols Eugeniu Rosca
2020-01-08 17:39   ` Simon Glass
2020-01-10 21:50   ` Tom Rini
2019-12-24 16:51 ` [PATCH 3/3] cmd: adtimg: Refactor usage style Eugeniu Rosca
2020-01-08 17:39   ` Simon Glass
2020-01-08 18:12     ` Eugeniu Rosca
2020-01-10 21:50   ` Tom Rini
2020-01-10 23:29     ` Eugeniu Rosca
2020-07-03 16:40       ` Patrick DELAUNAY
2020-07-06  6:46         ` Eugeniu Rosca
2020-07-08 17:26           ` Patrick DELAUNAY
2019-12-24 19:44 ` [PATCH 0/3] cmd: dtimg: Rename to adtimg and refactor " Sam Protsenko

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.