All of lore.kernel.org
 help / color / mirror / Atom feed
From: Simon Glass <sjg@chromium.org>
To: u-boot@lists.denx.de
Subject: [PATCH v7 0/9] dm: Add programmatic generation of ACPI tables (part A)
Date: Tue, 21 Apr 2020 15:37:37 -0600	[thread overview]
Message-ID: <CAPnjgZ0KgwS7cAQqHXdHzrZpTWPgOdMNSs49vvwTekOz_=i-dQ@mail.gmail.com> (raw)
In-Reply-To: <20200421174259.GP185537@smile.fi.intel.com>

Hi Andy,

On Tue, 21 Apr 2020 at 11:43, Andy Shevchenko
<andriy.shevchenko@linux.intel.com> wrote:
>
> On Sun, Apr 19, 2020 at 02:36:48PM -0600, Simon Glass wrote:
> > This is split from the original series in an attempt to get things applied
> > in chunks.
> >
> > v7 is just a rebase as requested
>
> So, overall I have no concerns, except that compatible string in ACPI seems
> half-baked solution and, due to PRP0001 awareness (my understanding that it
> should not be part of production devices), seems not needed right now.
> It means we should require to have _HID and/or _CID.

OK I am really not sure what to say about this. Let's deal with it
when we see the use of it later.

>
> Code looks fine to me, though.
>

OK good. I will send part B soon.

> > Changes in v7:
> > - Rebase to master
> >
> > Changes in v5:
> > - Drop bisectability changes
> >
> > Changes in v4:
> > - Put 'interrupts-extended' property on one line
> > - Rename acpi-probed to linux,probed
> > - Note that linux,probed is an out-of-tree feature
> > - Separate out the log newline
> > - Update comment in acpi_inc_align() to show the alignment
> > - Put back cast on table_compute_checksum()
> > - Rename list_fact() to list_fadt()
> > - Add a comment to dump_hdr()
> >
> > Changes in v3:
> > - Drop mention of PRIC
> > - Rename acpi,desc to acpi,ddn
> > - Correct description of acpi,probed
> > - Drop hid-descr-addr
> > - Just add the device.txt binding file in this patch
> > - Change the example to ELAN
> > - Add a pointer to information about acpi,compatible
> > - Rename acpi_align_large() to acpi_align64()
> > - Fix 'RSDP' typo
> > - Fix 'XDST' typo
> > - Move acpi_align_large() out of dm_test_acpi_setup_base_tables()
> > - Beef up the comment explaining how the unaligned address is used
> >
> > Changes in v2:
> > - Fix definition of HID
> > - Infer hid-over-i2c CID value
> > - Add the hid-over-i2c binding document
> > - Drop definition of ACPI_TABLE_CREATOR
> > - Make _acpi_write_dev_tables() static and switch argument order
> > - Generalise the ACPI function recursion with acpi_recurse_method()
> >
> > Simon Glass (9):
> >   acpi: Add a binding for ACPI settings in the device tree
> >   acpi: Add a method to write tables for a device
> >   acpi: Convert part of acpi_table to use acpi_ctx
> >   x86: Allow devices to write ACPI tables
> >   acpi: Drop code for missing XSDT from acpi_write_rsdp()
> >   acpi: Move acpi_add_table() to generic code
> >   acpi: Put table-setup code in its own function
> >   acpi: Move the xsdt pointer to acpi_ctx
> >   acpi: Add an acpi command
> >
> >  arch/sandbox/dts/test.dts              |   4 +
> >  arch/sandbox/include/asm/global_data.h |   1 +
> >  arch/x86/include/asm/global_data.h     |   1 +
> >  arch/x86/lib/acpi_table.c              | 239 +++++--------------------
> >  cmd/Kconfig                            |  14 ++
> >  cmd/Makefile                           |   1 +
> >  cmd/acpi.c                             | 186 +++++++++++++++++++
> >  doc/device-tree-bindings/device.txt    |  36 ++++
> >  drivers/core/acpi.c                    |  62 +++++++
> >  include/acpi/acpi_table.h              |  65 +++++++
> >  include/dm/acpi.h                      |  37 ++++
> >  lib/acpi/acpi_table.c                  | 174 +++++++++++++++++-
> >  test/dm/acpi.c                         | 238 +++++++++++++++++++++++-
> >  13 files changed, 855 insertions(+), 203 deletions(-)
> >  create mode 100644 cmd/acpi.c
> >  create mode 100644 doc/device-tree-bindings/device.txt
> >
> > --
> > 2.26.1.301.g55bc3eb7cb9-goog
> >
Regards,
Simon

  reply	other threads:[~2020-04-21 21:37 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-19 20:36 [PATCH v7 0/9] dm: Add programmatic generation of ACPI tables (part A) Simon Glass
2020-04-19 20:36 ` [PATCH v7 1/9] acpi: Add a binding for ACPI settings in the device tree Simon Glass
2020-04-21 12:25   ` Bin Meng
2020-04-21 12:29     ` Andy Shevchenko
2020-04-21 13:07   ` Antwort: " Wolfgang Wallner
2020-04-21 14:40     ` Andy Shevchenko
2020-04-21 14:56     ` Antwort: Re: " Wolfgang Wallner
2020-04-19 20:36 ` [PATCH v7 2/9] acpi: Add a method to write tables for a device Simon Glass
2020-04-19 20:36 ` [PATCH v7 3/9] acpi: Convert part of acpi_table to use acpi_ctx Simon Glass
2020-04-19 20:36 ` [PATCH v7 4/9] x86: Allow devices to write ACPI tables Simon Glass
2020-04-19 20:36 ` [PATCH v7 5/9] acpi: Drop code for missing XSDT from acpi_write_rsdp() Simon Glass
2020-04-19 20:36 ` [PATCH v7 6/9] acpi: Move acpi_add_table() to generic code Simon Glass
2020-04-19 20:36 ` [PATCH v7 7/9] acpi: Put table-setup code in its own function Simon Glass
2020-04-23  9:38   ` Bin Meng
2020-04-26 19:45     ` Simon Glass
2020-04-27  6:36     ` Antwort: " Wolfgang Wallner
2020-04-27  7:10       ` Bin Meng
2020-04-19 20:36 ` [PATCH v7 8/9] acpi: Move the xsdt pointer to acpi_ctx Simon Glass
2020-04-19 20:36 ` [PATCH v7 9/9] acpi: Add an acpi command Simon Glass
2020-04-21 17:42 ` [PATCH v7 0/9] dm: Add programmatic generation of ACPI tables (part A) Andy Shevchenko
2020-04-21 21:37   ` Simon Glass [this message]
2020-04-23  9:46     ` Bin Meng
2020-04-23  9:58       ` Bin Meng
2020-04-27  5:58         ` Bin Meng
2020-04-27 17:02           ` Simon Glass
2020-04-29 18:09 ` Heinrich Schuchardt
2020-05-01 13:14   ` Simon Glass

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAPnjgZ0KgwS7cAQqHXdHzrZpTWPgOdMNSs49vvwTekOz_=i-dQ@mail.gmail.com' \
    --to=sjg@chromium.org \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.