All of lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Sanders <Daniel.Sanders@imgtec.com>
To: David Daney <ddaney.cavm@gmail.com>
Cc: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>,
	"linux-mips@linux-mips.org" <linux-mips@linux-mips.org>,
	Ralf Baechle <ralf@linux-mips.org>,
	Paul Burton <Paul.Burton@imgtec.com>,
	Markos Chandras <Markos.Chandras@imgtec.com>,
	James Hogan <James.Hogan@imgtec.com>,
	"Behan Webster" <behanw@converseincode.com>
Subject: RE: [PATCH] MIPS: Changed current_thread_info() to an equivalent supported by both clang and GCC
Date: Sat, 10 Jan 2015 12:53:22 +0000	[thread overview]
Message-ID: <E484D272A3A61B4880CDF2E712E9279F458E8336@hhmail02.hh.imgtec.org> (raw)
In-Reply-To: <54B069D4.4090608@gmail.com>

> -----Original Message-----
> From: David Daney [mailto:ddaney.cavm@gmail.com]
> Sent: 09 January 2015 23:53
> To: Daniel Sanders
> Cc: Sergei Shtylyov; linux-mips@linux-mips.org; Ralf Baechle; Paul Burton;
> Markos Chandras; James Hogan; Behan Webster
> Subject: Re: [PATCH] MIPS: Changed current_thread_info() to an equivalent
> supported by both clang and GCC
> 
> On 01/09/2015 12:06 PM, Daniel Sanders wrote:
> >> -----Original Message-----
> >> From: David Daney [mailto:ddaney.cavm@gmail.com]
> [...]
> 
> >
> >>>>> Signed-off-by: Daniel Sanders <daniel.sanders@imgtec.com>
> >>>>
> >>>> [...]
> >>>>
> >>>>> diff --git a/arch/mips/include/asm/thread_info.h
> >>>> b/arch/mips/include/asm/thread_info.h
> >>>>> index 99eea59..2a2f3c4 100644
> >>>>> --- a/arch/mips/include/asm/thread_info.h
> >>>>> +++ b/arch/mips/include/asm/thread_info.h
> >>>>> @@ -58,11 +58,11 @@ struct thread_info {
> >>>>>     #define init_stack		(init_thread_union.stack)
> >>>>>
> >>>>>     /* How to get the thread information struct from C.  */
> >>>>> +register struct thread_info *current_gp_register asm("$28");
> >>>>
> >>>>       *static* missing?
> >>>>
> >>>> WBR, Sergei
> >>>
> >>> Combining 'register' and 'static' is invalid.
> >>
> >> Defining global variables in header files is also invalid.
> >
> > I agree with that statement but named register globals are not the same as
> normal global variables. In particular, they do not take up space in the data
> section and they do not have an entry in the symbol table. They can therefore
> be included in multiple objects without causing link errors.
> >
> 
> Well, the GCC manual seems to bless your usage, so I withdraw my
> objection on making this global.  But, changing the name to
> "current_gp_register" removes information about what it is used for.
> 
> Can you resend that patch so that it still has the name
> "__current_thread_info", and only moves it to the global scope?
> 
> Thanks,
> David Daney

Sure. I'll Cc you directly on the re-send.

The main reason I renamed it is that identifiers starting with '__' are reserved. It's pretty unlikely but it's possible that the name will conflict with a C implementation in the future.

  reply	other threads:[~2015-01-10 12:53 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-01-09 12:06 [PATCH] MIPS: Changed current_thread_info() to an equivalent supported by both clang and GCC Daniel Sanders
2015-01-09 12:06 ` Daniel Sanders
2015-01-09 12:17 ` Sergei Shtylyov
2015-01-09 13:23   ` Daniel Sanders
2015-01-09 17:26     ` David Daney
2015-01-09 20:06       ` Daniel Sanders
2015-01-09 23:29         ` Behan Webster
2015-01-09 23:52         ` David Daney
2015-01-10 12:53           ` Daniel Sanders [this message]
2015-01-16 14:37             ` Ralf Baechle
2015-01-16 15:05               ` Måns Rullgård
2015-01-16 15:05                 ` Måns Rullgård
2015-01-17 16:16               ` Daniel Sanders

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=E484D272A3A61B4880CDF2E712E9279F458E8336@hhmail02.hh.imgtec.org \
    --to=daniel.sanders@imgtec.com \
    --cc=James.Hogan@imgtec.com \
    --cc=Markos.Chandras@imgtec.com \
    --cc=Paul.Burton@imgtec.com \
    --cc=behanw@converseincode.com \
    --cc=ddaney.cavm@gmail.com \
    --cc=linux-mips@linux-mips.org \
    --cc=ralf@linux-mips.org \
    --cc=sergei.shtylyov@cogentembedded.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.