All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2] drm: Add description for scdc variable
@ 2017-03-25  9:21 Shashank Sharma
  2017-03-25 21:29 ` Daniel Vetter
  0 siblings, 1 reply; 5+ messages in thread
From: Shashank Sharma @ 2017-03-25  9:21 UTC (permalink / raw)
  To: dri-devel

This patch adds description about 'scdc' variable in drm_hdmi_info
structure, to fix this warning during doc-build.

"drm_connector.h:140: warning: No description found for parameter 'scdc'"

V2: Rebase

Cc: Daniel Vetter <daniel@ffwll.ch>
Signed-off-by: Shashank Sharma <shashank.sharma@intel.com>
---
 include/drm/drm_connector.h | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h
index f8b766d..9fba967 100644
--- a/include/drm/drm_connector.h
+++ b/include/drm/drm_connector.h
@@ -133,6 +133,8 @@ struct drm_scdc {
  * This information is available in CEA-861-F extension blocks (like HF-VSDB).
  */
 struct drm_hdmi_info {
+
+	/* @scdc: sink's scdc support and capabilities */
 	struct drm_scdc scdc;
 };
 
-- 
2.7.4

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH v2] drm: Add description for scdc variable
  2017-03-25  9:21 [PATCH v2] drm: Add description for scdc variable Shashank Sharma
@ 2017-03-25 21:29 ` Daniel Vetter
  2017-03-26  8:39   ` Sharma, Shashank
  0 siblings, 1 reply; 5+ messages in thread
From: Daniel Vetter @ 2017-03-25 21:29 UTC (permalink / raw)
  To: Shashank Sharma; +Cc: dri-devel

On Sat, Mar 25, 2017 at 11:21:29AM +0200, Shashank Sharma wrote:
> This patch adds description about 'scdc' variable in drm_hdmi_info
> structure, to fix this warning during doc-build.
> 
> "drm_connector.h:140: warning: No description found for parameter 'scdc'"
> 
> V2: Rebase
> 
> Cc: Daniel Vetter <daniel@ffwll.ch>
> Signed-off-by: Shashank Sharma <shashank.sharma@intel.com>

Since you're bikeshedding this to v4 already, might as well jump in too
:-)
> ---
>  include/drm/drm_connector.h | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h
> index f8b766d..9fba967 100644
> --- a/include/drm/drm_connector.h
> +++ b/include/drm/drm_connector.h
> @@ -133,6 +133,8 @@ struct drm_scdc {
>   * This information is available in CEA-861-F extension blocks (like HF-VSDB).
>   */
>  struct drm_hdmi_info {
> +

Please no empty line here.

> +	/* @scdc: sink's scdc support and capabilities */

One-line struct member kerneldoc works, but you need to prefix it with /**
like any other kernel-doc comment. See

https://dri.freedesktop.org/docs/drm/doc-guide/kernel-doc.html#in-line-member-documentation-comments

Cheers, Daniel

>  	struct drm_scdc scdc;
>  };
>  
> -- 
> 2.7.4
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* RE: [PATCH v2] drm: Add description for scdc variable
  2017-03-25 21:29 ` Daniel Vetter
@ 2017-03-26  8:39   ` Sharma, Shashank
  2017-03-28  6:08     ` Daniel Vetter
  0 siblings, 1 reply; 5+ messages in thread
From: Sharma, Shashank @ 2017-03-26  8:39 UTC (permalink / raw)
  To: Daniel Vetter; +Cc: dri-devel

Thanks, V5 will do the trick for sure :-)

Regards
Shashank
-----Original Message-----
From: Daniel Vetter [mailto:daniel.vetter@ffwll.ch] On Behalf Of Daniel Vetter
Sent: Saturday, March 25, 2017 11:30 PM
To: Sharma, Shashank <shashank.sharma@intel.com>
Cc: dri-devel@lists.freedesktop.org; Daniel Vetter <daniel@ffwll.ch>
Subject: Re: [PATCH v2] drm: Add description for scdc variable

On Sat, Mar 25, 2017 at 11:21:29AM +0200, Shashank Sharma wrote:
> This patch adds description about 'scdc' variable in drm_hdmi_info 
> structure, to fix this warning during doc-build.
> 
> "drm_connector.h:140: warning: No description found for parameter 'scdc'"
> 
> V2: Rebase
> 
> Cc: Daniel Vetter <daniel@ffwll.ch>
> Signed-off-by: Shashank Sharma <shashank.sharma@intel.com>

Since you're bikeshedding this to v4 already, might as well jump in too
:-)
> ---
>  include/drm/drm_connector.h | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h 
> index f8b766d..9fba967 100644
> --- a/include/drm/drm_connector.h
> +++ b/include/drm/drm_connector.h
> @@ -133,6 +133,8 @@ struct drm_scdc {
>   * This information is available in CEA-861-F extension blocks (like HF-VSDB).
>   */
>  struct drm_hdmi_info {
> +

Please no empty line here.

> +	/* @scdc: sink's scdc support and capabilities */

One-line struct member kerneldoc works, but you need to prefix it with /** like any other kernel-doc comment. See

https://dri.freedesktop.org/docs/drm/doc-guide/kernel-doc.html#in-line-member-documentation-comments

Cheers, Daniel

>  	struct drm_scdc scdc;
>  };
>  
> --
> 2.7.4
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH v2] drm: Add description for scdc variable
  2017-03-26  8:39   ` Sharma, Shashank
@ 2017-03-28  6:08     ` Daniel Vetter
  2017-03-28  6:19       ` Sharma, Shashank
  0 siblings, 1 reply; 5+ messages in thread
From: Daniel Vetter @ 2017-03-28  6:08 UTC (permalink / raw)
  To: Sharma, Shashank; +Cc: dri-devel

On Sun, Mar 26, 2017 at 08:39:51AM +0000, Sharma, Shashank wrote:
> Thanks, V5 will do the trick for sure :-)

Hm, where is v5?
-Daniel

> 
> Regards
> Shashank
> -----Original Message-----
> From: Daniel Vetter [mailto:daniel.vetter@ffwll.ch] On Behalf Of Daniel Vetter
> Sent: Saturday, March 25, 2017 11:30 PM
> To: Sharma, Shashank <shashank.sharma@intel.com>
> Cc: dri-devel@lists.freedesktop.org; Daniel Vetter <daniel@ffwll.ch>
> Subject: Re: [PATCH v2] drm: Add description for scdc variable
> 
> On Sat, Mar 25, 2017 at 11:21:29AM +0200, Shashank Sharma wrote:
> > This patch adds description about 'scdc' variable in drm_hdmi_info 
> > structure, to fix this warning during doc-build.
> > 
> > "drm_connector.h:140: warning: No description found for parameter 'scdc'"
> > 
> > V2: Rebase
> > 
> > Cc: Daniel Vetter <daniel@ffwll.ch>
> > Signed-off-by: Shashank Sharma <shashank.sharma@intel.com>
> 
> Since you're bikeshedding this to v4 already, might as well jump in too
> :-)
> > ---
> >  include/drm/drm_connector.h | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h 
> > index f8b766d..9fba967 100644
> > --- a/include/drm/drm_connector.h
> > +++ b/include/drm/drm_connector.h
> > @@ -133,6 +133,8 @@ struct drm_scdc {
> >   * This information is available in CEA-861-F extension blocks (like HF-VSDB).
> >   */
> >  struct drm_hdmi_info {
> > +
> 
> Please no empty line here.
> 
> > +	/* @scdc: sink's scdc support and capabilities */
> 
> One-line struct member kerneldoc works, but you need to prefix it with /** like any other kernel-doc comment. See
> 
> https://dri.freedesktop.org/docs/drm/doc-guide/kernel-doc.html#in-line-member-documentation-comments
> 
> Cheers, Daniel
> 
> >  	struct drm_scdc scdc;
> >  };
> >  
> > --
> > 2.7.4
> > 
> 
> -- 
> Daniel Vetter
> Software Engineer, Intel Corporation
> http://blog.ffwll.ch

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* RE: [PATCH v2] drm: Add description for scdc variable
  2017-03-28  6:08     ` Daniel Vetter
@ 2017-03-28  6:19       ` Sharma, Shashank
  0 siblings, 0 replies; 5+ messages in thread
From: Sharma, Shashank @ 2017-03-28  6:19 UTC (permalink / raw)
  To: Daniel Vetter; +Cc: Nikula, Jani, dri-devel

Here you go, https://patchwork.freedesktop.org/patch/146746/ 
Had to remove extra line in start, from V4. 
Confirmed with a make DOCBOOKS="" htmldocs, no more error for scdc. 

Regards
Shashank
-----Original Message-----
From: Daniel Vetter [mailto:daniel.vetter@ffwll.ch] On Behalf Of Daniel Vetter
Sent: Tuesday, March 28, 2017 9:09 AM
To: Sharma, Shashank <shashank.sharma@intel.com>
Cc: Daniel Vetter <daniel@ffwll.ch>; dri-devel@lists.freedesktop.org
Subject: Re: [PATCH v2] drm: Add description for scdc variable

On Sun, Mar 26, 2017 at 08:39:51AM +0000, Sharma, Shashank wrote:
> Thanks, V5 will do the trick for sure :-)

Hm, where is v5?
-Daniel

> 
> Regards
> Shashank
> -----Original Message-----
> From: Daniel Vetter [mailto:daniel.vetter@ffwll.ch] On Behalf Of 
> Daniel Vetter
> Sent: Saturday, March 25, 2017 11:30 PM
> To: Sharma, Shashank <shashank.sharma@intel.com>
> Cc: dri-devel@lists.freedesktop.org; Daniel Vetter <daniel@ffwll.ch>
> Subject: Re: [PATCH v2] drm: Add description for scdc variable
> 
> On Sat, Mar 25, 2017 at 11:21:29AM +0200, Shashank Sharma wrote:
> > This patch adds description about 'scdc' variable in drm_hdmi_info 
> > structure, to fix this warning during doc-build.
> > 
> > "drm_connector.h:140: warning: No description found for parameter 'scdc'"
> > 
> > V2: Rebase
> > 
> > Cc: Daniel Vetter <daniel@ffwll.ch>
> > Signed-off-by: Shashank Sharma <shashank.sharma@intel.com>
> 
> Since you're bikeshedding this to v4 already, might as well jump in 
> too
> :-)
> > ---
> >  include/drm/drm_connector.h | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git a/include/drm/drm_connector.h 
> > b/include/drm/drm_connector.h index f8b766d..9fba967 100644
> > --- a/include/drm/drm_connector.h
> > +++ b/include/drm/drm_connector.h
> > @@ -133,6 +133,8 @@ struct drm_scdc {
> >   * This information is available in CEA-861-F extension blocks (like HF-VSDB).
> >   */
> >  struct drm_hdmi_info {
> > +
> 
> Please no empty line here.
> 
> > +	/* @scdc: sink's scdc support and capabilities */
> 
> One-line struct member kerneldoc works, but you need to prefix it with 
> /** like any other kernel-doc comment. See
> 
> https://dri.freedesktop.org/docs/drm/doc-guide/kernel-doc.html#in-line
> -member-documentation-comments
> 
> Cheers, Daniel
> 
> >  	struct drm_scdc scdc;
> >  };
> >  
> > --
> > 2.7.4
> > 
> 
> --
> Daniel Vetter
> Software Engineer, Intel Corporation
> http://blog.ffwll.ch

--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2017-03-28  6:19 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-03-25  9:21 [PATCH v2] drm: Add description for scdc variable Shashank Sharma
2017-03-25 21:29 ` Daniel Vetter
2017-03-26  8:39   ` Sharma, Shashank
2017-03-28  6:08     ` Daniel Vetter
2017-03-28  6:19       ` Sharma, Shashank

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.