All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ocean HY1 He <hehy1@lenovo.com>
To: "Verma, Vishal L" <vishal.l.verma@intel.com>,
	"Williams, Dan J" <dan.j.williams@intel.com>,
	"ross.zwisler@linux.intel.com" <ross.zwisler@linux.intel.com>,
	"oceanhehy@gmail.com" <oceanhehy@gmail.com>,
	"Jiang, Dave" <dave.jiang@intel.com>,
	"lenb@kernel.org" <lenb@kernel.org>,
	"rjw@rjwysocki.net" <rjw@rjwysocki.net>
Cc: "linux-acpi@vger.kernel.org" <linux-acpi@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-nvdimm@lists.01.org" <linux-nvdimm@lists.01.org>
Subject: RE: [External]  Re: [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found
Date: Mon, 13 Aug 2018 02:53:24 +0000	[thread overview]
Message-ID: <HK0PR03MB31708EFDDA3F29C4A697956889390@HK0PR03MB3170.apcprd03.prod.outlook.com> (raw)
In-Reply-To: <1533944734.6054.38.camel@intel.com>



> -----Original Message-----
> From: Verma, Vishal L <vishal.l.verma@intel.com>
> Sent: Saturday, August 11, 2018 7:46 AM
> To: Williams, Dan J <dan.j.williams@intel.com>; ross.zwisler@linux.intel.com;
> oceanhehy@gmail.com; Jiang, Dave <dave.jiang@intel.com>; lenb@kernel.org;
> rjw@rjwysocki.net
> Cc: linux-kernel@vger.kernel.org; linux-nvdimm@lists.01.org; linux-
> acpi@vger.kernel.org; Ocean HY1 He <hehy1@lenovo.com>
> Subject: [External] Re: [PATCH v2] ACPI: nfit: remove redundant assignment if
> nfit_mem found
> 
> 
> On Thu, 2018-08-02 at 04:44 -0400, oceanhehy@gmail.com wrote:
> > From: Ocean He <hehy1@lenovo.com>
> >
> > When nfit_mem is found via list_for_each_entry, it has already been
> > assigned valid value. There is no need to assign it again in the
> > following
> > codes.
> >
> > Signed-off-by: Ocean He <hehy1@lenovo.com>
> > ---
> > v1: https://patchwork.kernel.org/patch/10553277/
> > v2: Sorry for noise. I got an email problem, so I have to resend to
> > loop
> > linux-nvdimm@lists.01.org.
> >
> >  drivers/acpi/nfit/core.c | 4 +---
> >  1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c
> > index 7c47900..85dde54 100644
> > --- a/drivers/acpi/nfit/core.c
> > +++ b/drivers/acpi/nfit/core.c
> > @@ -1048,9 +1048,7 @@ static int __nfit_mem_init(struct
> > acpi_nfit_desc *acpi_desc,
> >  				break;
> >  			}
> >
> > -		if (found)
> > -			nfit_mem = found;
> > -		else {
> > +		if (!found) {
> 
> Hi Ocean,
> 
> While this is technically correct, the old way was easier to read. We
> loop through and find the matching handle. If we found one, then
> nfit_mem was whatever was found. If not, we allocate it.
> 
> With this change, one has to go grok the list_for_.. loop to figure out
> where nfit_mem is coming from. I'd personally prefer to keep the
> existing way..
> 
Hi Verma,

You're right that it took me some time to find out where nfit_mem
was found, when I look these codes at first.

It's reasonable to keep the existing way for well readability.

Thanks,
Ocean.
> >  			nfit_mem = devm_kzalloc(acpi_desc->dev,
> >  					sizeof(*nfit_mem),
> > GFP_KERNEL);
> >  			if (!nfit_mem)
_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

WARNING: multiple messages have this Message-ID (diff)
From: Ocean HY1 He <hehy1-6jq1YtArVR3QT0dZR+AlfA@public.gmane.org>
To: "Verma,
	Vishal L"
	<vishal.l.verma-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org>,
	"Williams,
	Dan J" <dan.j.williams-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org>,
	"ross.zwisler-VuQAYsv1563Yd54FQh9/CA@public.gmane.org"
	<ross.zwisler-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>,
	"oceanhehy-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org"
	<oceanhehy-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>,
	"Jiang,
	Dave" <dave.jiang-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org>,
	"lenb-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org"
	<lenb-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org>,
	"rjw-LthD3rsA81gm4RdzfppkhA@public.gmane.org"
	<rjw-LthD3rsA81gm4RdzfppkhA@public.gmane.org>
Cc: "linux-acpi-u79uwXL29TY76Z2rM5mHXA@public.gmane.org"
	<linux-acpi-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>,
	"linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org"
	<linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>,
	"linux-nvdimm-hn68Rpc1hR1g9hUCZPvPmw@public.gmane.org"
	<linux-nvdimm-hn68Rpc1hR1g9hUCZPvPmw@public.gmane.org>
Subject: RE: [External]  Re: [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found
Date: Mon, 13 Aug 2018 02:53:24 +0000	[thread overview]
Message-ID: <HK0PR03MB31708EFDDA3F29C4A697956889390@HK0PR03MB3170.apcprd03.prod.outlook.com> (raw)
In-Reply-To: <1533944734.6054.38.camel-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org>



> -----Original Message-----
> From: Verma, Vishal L <vishal.l.verma-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org>
> Sent: Saturday, August 11, 2018 7:46 AM
> To: Williams, Dan J <dan.j.williams-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org>; ross.zwisler-VuQAYsv1563Yd54FQh9/CA@public.gmane.org;
> oceanhehy-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org; Jiang, Dave <dave.jiang-ral2JQCrhuEAvxtiuMwx3w@public.gmane.org>; lenb-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org;
> rjw-LthD3rsA81gm4RdzfppkhA@public.gmane.org
> Cc: linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org; linux-nvdimm-hn68Rpc1hR1g9hUCZPvPmw@public.gmane.org; linux-
> acpi-u79uwXL29TY76Z2rM5mHXA@public.gmane.org; Ocean HY1 He <hehy1-6jq1YtArVR3QT0dZR+AlfA@public.gmane.org>
> Subject: [External] Re: [PATCH v2] ACPI: nfit: remove redundant assignment if
> nfit_mem found
> 
> 
> On Thu, 2018-08-02 at 04:44 -0400, oceanhehy-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org wrote:
> > From: Ocean He <hehy1-6jq1YtArVR3QT0dZR+AlfA@public.gmane.org>
> >
> > When nfit_mem is found via list_for_each_entry, it has already been
> > assigned valid value. There is no need to assign it again in the
> > following
> > codes.
> >
> > Signed-off-by: Ocean He <hehy1-6jq1YtArVR3QT0dZR+AlfA@public.gmane.org>
> > ---
> > v1: https://patchwork.kernel.org/patch/10553277/
> > v2: Sorry for noise. I got an email problem, so I have to resend to
> > loop
> > linux-nvdimm-hn68Rpc1hR1TeqIcxkLZrQ@public.gmane.org
> >
> >  drivers/acpi/nfit/core.c | 4 +---
> >  1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c
> > index 7c47900..85dde54 100644
> > --- a/drivers/acpi/nfit/core.c
> > +++ b/drivers/acpi/nfit/core.c
> > @@ -1048,9 +1048,7 @@ static int __nfit_mem_init(struct
> > acpi_nfit_desc *acpi_desc,
> >  				break;
> >  			}
> >
> > -		if (found)
> > -			nfit_mem = found;
> > -		else {
> > +		if (!found) {
> 
> Hi Ocean,
> 
> While this is technically correct, the old way was easier to read. We
> loop through and find the matching handle. If we found one, then
> nfit_mem was whatever was found. If not, we allocate it.
> 
> With this change, one has to go grok the list_for_.. loop to figure out
> where nfit_mem is coming from. I'd personally prefer to keep the
> existing way..
> 
Hi Verma,

You're right that it took me some time to find out where nfit_mem
was found, when I look these codes at first.

It's reasonable to keep the existing way for well readability.

Thanks,
Ocean.
> >  			nfit_mem = devm_kzalloc(acpi_desc->dev,
> >  					sizeof(*nfit_mem),
> > GFP_KERNEL);
> >  			if (!nfit_mem)

WARNING: multiple messages have this Message-ID (diff)
From: Ocean HY1 He <hehy1@lenovo.com>
To: "Verma, Vishal L" <vishal.l.verma@intel.com>,
	"Williams, Dan J" <dan.j.williams@intel.com>,
	"ross.zwisler@linux.intel.com" <ross.zwisler@linux.intel.com>,
	"oceanhehy@gmail.com" <oceanhehy@gmail.com>,
	"Jiang, Dave" <dave.jiang@intel.com>,
	"lenb@kernel.org" <lenb@kernel.org>,
	"rjw@rjwysocki.net" <rjw@rjwysocki.net>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-nvdimm@lists.01.org" <linux-nvdimm@lists.01.org>,
	"linux-acpi@vger.kernel.org" <linux-acpi@vger.kernel.org>
Subject: RE: [External]  Re: [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found
Date: Mon, 13 Aug 2018 02:53:24 +0000	[thread overview]
Message-ID: <HK0PR03MB31708EFDDA3F29C4A697956889390@HK0PR03MB3170.apcprd03.prod.outlook.com> (raw)
In-Reply-To: <1533944734.6054.38.camel@intel.com>



> -----Original Message-----
> From: Verma, Vishal L <vishal.l.verma@intel.com>
> Sent: Saturday, August 11, 2018 7:46 AM
> To: Williams, Dan J <dan.j.williams@intel.com>; ross.zwisler@linux.intel.com;
> oceanhehy@gmail.com; Jiang, Dave <dave.jiang@intel.com>; lenb@kernel.org;
> rjw@rjwysocki.net
> Cc: linux-kernel@vger.kernel.org; linux-nvdimm@lists.01.org; linux-
> acpi@vger.kernel.org; Ocean HY1 He <hehy1@lenovo.com>
> Subject: [External] Re: [PATCH v2] ACPI: nfit: remove redundant assignment if
> nfit_mem found
> 
> 
> On Thu, 2018-08-02 at 04:44 -0400, oceanhehy@gmail.com wrote:
> > From: Ocean He <hehy1@lenovo.com>
> >
> > When nfit_mem is found via list_for_each_entry, it has already been
> > assigned valid value. There is no need to assign it again in the
> > following
> > codes.
> >
> > Signed-off-by: Ocean He <hehy1@lenovo.com>
> > ---
> > v1: https://patchwork.kernel.org/patch/10553277/
> > v2: Sorry for noise. I got an email problem, so I have to resend to
> > loop
> > linux-nvdimm@lists.01.org.
> >
> >  drivers/acpi/nfit/core.c | 4 +---
> >  1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c
> > index 7c47900..85dde54 100644
> > --- a/drivers/acpi/nfit/core.c
> > +++ b/drivers/acpi/nfit/core.c
> > @@ -1048,9 +1048,7 @@ static int __nfit_mem_init(struct
> > acpi_nfit_desc *acpi_desc,
> >  				break;
> >  			}
> >
> > -		if (found)
> > -			nfit_mem = found;
> > -		else {
> > +		if (!found) {
> 
> Hi Ocean,
> 
> While this is technically correct, the old way was easier to read. We
> loop through and find the matching handle. If we found one, then
> nfit_mem was whatever was found. If not, we allocate it.
> 
> With this change, one has to go grok the list_for_.. loop to figure out
> where nfit_mem is coming from. I'd personally prefer to keep the
> existing way..
> 
Hi Verma,

You're right that it took me some time to find out where nfit_mem
was found, when I look these codes at first.

It's reasonable to keep the existing way for well readability.

Thanks,
Ocean.
> >  			nfit_mem = devm_kzalloc(acpi_desc->dev,
> >  					sizeof(*nfit_mem),
> > GFP_KERNEL);
> >  			if (!nfit_mem)

  reply	other threads:[~2018-08-13  2:53 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-08-02  8:44 [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found oceanhehy
2018-08-02  8:44 ` oceanhehy
2018-08-10 23:45 ` Verma, Vishal L
2018-08-10 23:45   ` Verma, Vishal L
2018-08-10 23:45   ` Verma, Vishal L
2018-08-13  2:53   ` Ocean HY1 He [this message]
2018-08-13  2:53     ` [External] " Ocean HY1 He
2018-08-13  2:53     ` Ocean HY1 He

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=HK0PR03MB31708EFDDA3F29C4A697956889390@HK0PR03MB3170.apcprd03.prod.outlook.com \
    --to=hehy1@lenovo.com \
    --cc=dan.j.williams@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=oceanhehy@gmail.com \
    --cc=rjw@rjwysocki.net \
    --cc=ross.zwisler@linux.intel.com \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.