All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
@ 2016-08-23  4:42 ` Dexuan Cui
  0 siblings, 0 replies; 10+ messages in thread
From: Dexuan Cui @ 2016-08-23  4:42 UTC (permalink / raw)
  To: Bjorn Helgaas, linux-pci, gregkh, KY Srinivasan, linux-kernel,
	devel, olaf, apw, jasowang, vkuznets, Haiyang Zhang,
	Hadden Hoppert, helgaas, Stephen Hemminger


1. use zero-length array to make the code more readable.
2. remove an unused struct member.
3. small error handling improvement to some error cases.

Dexuan Cui (5):
  PCI: hv: use zero-length message in struct pci_packet
  PCI: hv: use pci_function_description[0] in struct definitions
  PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
  PCI: hv: hv_compose_msi_msg: handle the 'ret' value
  PCI: hv: hv_pci_generic_compl(): handle the error case

 drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++---------------------
 1 file changed, 29 insertions(+), 27 deletions(-)

-- 
2.7.4

^ permalink raw reply	[flat|nested] 10+ messages in thread

* [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
@ 2016-08-23  4:42 ` Dexuan Cui
  0 siblings, 0 replies; 10+ messages in thread
From: Dexuan Cui @ 2016-08-23  4:42 UTC (permalink / raw)
  To: Bjorn Helgaas, linux-pci, gregkh, KY Srinivasan, linux-kernel,
	devel, olaf, apw, jasowang, vkuznets, Haiyang Zhang,
	Hadden Hoppert, helgaas, Stephen Hemminger


1. use zero-length array to make the code more readable.
2. remove an unused struct member.
3. small error handling improvement to some error cases.

Dexuan Cui (5):
  PCI: hv: use zero-length message in struct pci_packet
  PCI: hv: use pci_function_description[0] in struct definitions
  PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
  PCI: hv: hv_compose_msi_msg: handle the 'ret' value
  PCI: hv: hv_pci_generic_compl(): handle the error case

 drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++-----------------=
----
 1 file changed, 29 insertions(+), 27 deletions(-)

--=20
2.7.4

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
  2016-08-23  4:42 ` Dexuan Cui
  (?)
@ 2016-09-06 15:40 ` Bjorn Helgaas
  2016-09-06 17:06     ` KY Srinivasan
  -1 siblings, 1 reply; 10+ messages in thread
From: Bjorn Helgaas @ 2016-09-06 15:40 UTC (permalink / raw)
  To: Dexuan Cui
  Cc: Bjorn Helgaas, linux-pci, gregkh, KY Srinivasan, linux-kernel,
	devel, olaf, apw, jasowang, vkuznets, Haiyang Zhang,
	Hadden Hoppert, Stephen Hemminger

On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> 
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
> 
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case
> 
>  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++---------------------
>  1 file changed, 29 insertions(+), 27 deletions(-)

I'm waiting for an ack from the Hyper-V maintainers:

  Hyper-V CORE AND DRIVERS
  M:      "K. Y. Srinivasan" <kys@microsoft.com>
  M:      Haiyang Zhang <haiyangz@microsoft.com>
  L:      devel@linuxdriverproject.org
  S:      Maintained
  ...
  F:      drivers/pci/host/pci-hyperv.c
  ...

^ permalink raw reply	[flat|nested] 10+ messages in thread

* RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
  2016-08-23  4:42 ` Dexuan Cui
@ 2016-09-06 17:05   ` KY Srinivasan
  -1 siblings, 0 replies; 10+ messages in thread
From: KY Srinivasan @ 2016-09-06 17:05 UTC (permalink / raw)
  To: Dexuan Cui, Bjorn Helgaas, linux-pci, gregkh, linux-kernel,
	devel, olaf, apw, jasowang, vkuznets, Haiyang Zhang,
	Hadden Hoppert, helgaas, Stephen Hemminger



> -----Original Message-----
> From: Dexuan Cui
> Sent: Tuesday, August 23, 2016 10:13 AM
> To: Bjorn Helgaas <bhelgaas@google.com>; linux-pci@vger.kernel.org;
> gregkh@linuxfoundation.org; KY Srinivasan <kys@microsoft.com>; linux-
> kernel@vger.kernel.org; devel@linuxdriverproject.org; olaf@aepfle.de;
> apw@canonical.com; jasowang@redhat.com; vkuznets@redhat.com; Haiyang
> Zhang <haiyangz@microsoft.com>; Hadden Hoppert
> <haddenh@microsoft.com>; helgaas@kernel.org; Stephen Hemminger
> <sthemmin@microsoft.com>
> Subject: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
> 
> 
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
> 
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case

Acked-by: KY Srinivasan <kys@microsoft.com>

K. Y

^ permalink raw reply	[flat|nested] 10+ messages in thread

* RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
@ 2016-09-06 17:05   ` KY Srinivasan
  0 siblings, 0 replies; 10+ messages in thread
From: KY Srinivasan @ 2016-09-06 17:05 UTC (permalink / raw)
  To: Dexuan Cui, Bjorn Helgaas, linux-pci, gregkh, linux-kernel,
	devel, olaf, apw, jasowang, vkuznets, Haiyang Zhang,
	Hadden Hoppert, helgaas, Stephen Hemminger



> -----Original Message-----
> From: Dexuan Cui
> Sent: Tuesday, August 23, 2016 10:13 AM
> To: Bjorn Helgaas <bhelgaas@google.com>; linux-pci@vger.kernel.org;
> gregkh@linuxfoundation.org; KY Srinivasan <kys@microsoft.com>; linux-
> kernel@vger.kernel.org; devel@linuxdriverproject.org; olaf@aepfle.de;
> apw@canonical.com; jasowang@redhat.com; vkuznets@redhat.com; Haiyang
> Zhang <haiyangz@microsoft.com>; Hadden Hoppert
> <haddenh@microsoft.com>; helgaas@kernel.org; Stephen Hemminger
> <sthemmin@microsoft.com>
> Subject: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
>=20
>=20
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
>=20
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case

Acked-by: KY Srinivasan <kys@microsoft.com>

K. Y

^ permalink raw reply	[flat|nested] 10+ messages in thread

* RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
  2016-09-06 15:40 ` Bjorn Helgaas
@ 2016-09-06 17:06     ` KY Srinivasan
  0 siblings, 0 replies; 10+ messages in thread
From: KY Srinivasan @ 2016-09-06 17:06 UTC (permalink / raw)
  To: Bjorn Helgaas, Dexuan Cui
  Cc: Bjorn Helgaas, linux-pci, gregkh, linux-kernel, devel, olaf, apw,
	jasowang, vkuznets, Haiyang Zhang, Hadden Hoppert,
	Stephen Hemminger



> -----Original Message-----
> From: Bjorn Helgaas [mailto:helgaas@kernel.org]
> Sent: Tuesday, September 6, 2016 9:11 PM
> To: Dexuan Cui <decui@microsoft.com>
> Cc: Bjorn Helgaas <bhelgaas@google.com>; linux-pci@vger.kernel.org;
> gregkh@linuxfoundation.org; KY Srinivasan <kys@microsoft.com>; linux-
> kernel@vger.kernel.org; devel@linuxdriverproject.org; olaf@aepfle.de;
> apw@canonical.com; jasowang@redhat.com; vkuznets@redhat.com; Haiyang
> Zhang <haiyangz@microsoft.com>; Hadden Hoppert
> <haddenh@microsoft.com>; Stephen Hemminger <sthemmin@microsoft.com>
> Subject: Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
> 
> On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> >
> > 1. use zero-length array to make the code more readable.
> > 2. remove an unused struct member.
> > 3. small error handling improvement to some error cases.
> >
> > Dexuan Cui (5):
> >   PCI: hv: use zero-length message in struct pci_packet
> >   PCI: hv: use pci_function_description[0] in struct definitions
> >   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
> >   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
> >   PCI: hv: hv_pci_generic_compl(): handle the error case
> >
> >  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++--------------------
> -
> >  1 file changed, 29 insertions(+), 27 deletions(-)
> 
> I'm waiting for an ack from the Hyper-V maintainers:

I have Acked these patches.

K. Y
> 
>   Hyper-V CORE AND DRIVERS
>   M:      "K. Y. Srinivasan" <kys@microsoft.com>
>   M:      Haiyang Zhang <haiyangz@microsoft.com>
>   L:      devel@linuxdriverproject.org
>   S:      Maintained
>   ...
>   F:      drivers/pci/host/pci-hyperv.c
>   ...

^ permalink raw reply	[flat|nested] 10+ messages in thread

* RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
@ 2016-09-06 17:06     ` KY Srinivasan
  0 siblings, 0 replies; 10+ messages in thread
From: KY Srinivasan @ 2016-09-06 17:06 UTC (permalink / raw)
  To: Bjorn Helgaas, Dexuan Cui
  Cc: Bjorn Helgaas, linux-pci, gregkh, linux-kernel, devel, olaf, apw,
	jasowang, vkuznets, Haiyang Zhang, Hadden Hoppert,
	Stephen Hemminger



> -----Original Message-----
> From: Bjorn Helgaas [mailto:helgaas@kernel.org]
> Sent: Tuesday, September 6, 2016 9:11 PM
> To: Dexuan Cui <decui@microsoft.com>
> Cc: Bjorn Helgaas <bhelgaas@google.com>; linux-pci@vger.kernel.org;
> gregkh@linuxfoundation.org; KY Srinivasan <kys@microsoft.com>; linux-
> kernel@vger.kernel.org; devel@linuxdriverproject.org; olaf@aepfle.de;
> apw@canonical.com; jasowang@redhat.com; vkuznets@redhat.com; Haiyang
> Zhang <haiyangz@microsoft.com>; Hadden Hoppert
> <haddenh@microsoft.com>; Stephen Hemminger <sthemmin@microsoft.com>
> Subject: Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
>=20
> On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> >
> > 1. use zero-length array to make the code more readable.
> > 2. remove an unused struct member.
> > 3. small error handling improvement to some error cases.
> >
> > Dexuan Cui (5):
> >   PCI: hv: use zero-length message in struct pci_packet
> >   PCI: hv: use pci_function_description[0] in struct definitions
> >   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
> >   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
> >   PCI: hv: hv_pci_generic_compl(): handle the error case
> >
> >  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++-------------=
-------
> -
> >  1 file changed, 29 insertions(+), 27 deletions(-)
>=20
> I'm waiting for an ack from the Hyper-V maintainers:

I have Acked these patches.

K. Y
>=20
>   Hyper-V CORE AND DRIVERS
>   M:      "K. Y. Srinivasan" <kys@microsoft.com>
>   M:      Haiyang Zhang <haiyangz@microsoft.com>
>   L:      devel@linuxdriverproject.org
>   S:      Maintained
>   ...
>   F:      drivers/pci/host/pci-hyperv.c
>   ...

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
  2016-08-23  4:42 ` Dexuan Cui
                   ` (2 preceding siblings ...)
  (?)
@ 2016-09-06 17:24 ` Bjorn Helgaas
  2016-09-07  1:56     ` Dexuan Cui
  -1 siblings, 1 reply; 10+ messages in thread
From: Bjorn Helgaas @ 2016-09-06 17:24 UTC (permalink / raw)
  To: Dexuan Cui
  Cc: Bjorn Helgaas, linux-pci, gregkh, KY Srinivasan, linux-kernel,
	devel, olaf, apw, jasowang, vkuznets, Haiyang Zhang,
	Hadden Hoppert, Stephen Hemminger

On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> 
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
> 
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case
> 
>  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++---------------------
>  1 file changed, 29 insertions(+), 27 deletions(-)

Applied with KY's ack to pci/host-hv for v4.9, thanks!

^ permalink raw reply	[flat|nested] 10+ messages in thread

* RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
  2016-09-06 17:24 ` Bjorn Helgaas
@ 2016-09-07  1:56     ` Dexuan Cui
  0 siblings, 0 replies; 10+ messages in thread
From: Dexuan Cui @ 2016-09-07  1:56 UTC (permalink / raw)
  To: Bjorn Helgaas
  Cc: Bjorn Helgaas, linux-pci, gregkh, KY Srinivasan, linux-kernel,
	devel, olaf, apw, jasowang, vkuznets, Haiyang Zhang,
	Hadden Hoppert, Stephen Hemminger, Jake Oshins

> From: Bjorn Helgaas [mailto:helgaas@kernel.org]
> Sent: Wednesday, September 7, 2016 1:25
> To: Dexuan Cui <decui@microsoft.com>
> Cc: Bjorn Helgaas <bhelgaas@google.com>; linux-pci@vger.kernel.org;
> gregkh@linuxfoundation.org; KY Srinivasan <kys@microsoft.com>; linux-
> kernel@vger.kernel.org; devel@linuxdriverproject.org; olaf@aepfle.de;
> apw@canonical.com; jasowang@redhat.com; vkuznets@redhat.com; Haiyang
> Zhang <haiyangz@microsoft.com>; Hadden Hoppert
> <haddenh@microsoft.com>; Stephen Hemminger <sthemmin@microsoft.com>
> Subject: Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
> 
> On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> >
> > 1. use zero-length array to make the code more readable.
> > 2. remove an unused struct member.
> > 3. small error handling improvement to some error cases.
> >
> > Dexuan Cui (5):
> >   PCI: hv: use zero-length message in struct pci_packet
> >   PCI: hv: use pci_function_description[0] in struct definitions
> >   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
> >   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
> >   PCI: hv: hv_pci_generic_compl(): handle the error case
> >
> >  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++--------------------
> -
> >  1 file changed, 29 insertions(+), 27 deletions(-)
> 
> Applied with KY's ack to pci/host-hv for v4.9, thanks!

Thanks!

BTW, it looks I forgot to CC Jake Oshins somehow... sorry for that.

@Jake: these are just small cleanups. :-)

Thanks,
-- Dexuan

^ permalink raw reply	[flat|nested] 10+ messages in thread

* RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
@ 2016-09-07  1:56     ` Dexuan Cui
  0 siblings, 0 replies; 10+ messages in thread
From: Dexuan Cui @ 2016-09-07  1:56 UTC (permalink / raw)
  To: Bjorn Helgaas
  Cc: Bjorn Helgaas, linux-pci, gregkh, KY Srinivasan, linux-kernel,
	devel, olaf, apw, jasowang, vkuznets, Haiyang Zhang,
	Hadden Hoppert, Stephen Hemminger, Jake Oshins

> From: Bjorn Helgaas [mailto:helgaas@kernel.org]
> Sent: Wednesday, September 7, 2016 1:25
> To: Dexuan Cui <decui@microsoft.com>
> Cc: Bjorn Helgaas <bhelgaas@google.com>; linux-pci@vger.kernel.org;
> gregkh@linuxfoundation.org; KY Srinivasan <kys@microsoft.com>; linux-
> kernel@vger.kernel.org; devel@linuxdriverproject.org; olaf@aepfle.de;
> apw@canonical.com; jasowang@redhat.com; vkuznets@redhat.com; Haiyang
> Zhang <haiyangz@microsoft.com>; Hadden Hoppert
> <haddenh@microsoft.com>; Stephen Hemminger <sthemmin@microsoft.com>
> Subject: Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
>=20
> On Tue, Aug 23, 2016 at 04:42:41AM +0000, Dexuan Cui wrote:
> >
> > 1. use zero-length array to make the code more readable.
> > 2. remove an unused struct member.
> > 3. small error handling improvement to some error cases.
> >
> > Dexuan Cui (5):
> >   PCI: hv: use zero-length message in struct pci_packet
> >   PCI: hv: use pci_function_description[0] in struct definitions
> >   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
> >   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
> >   PCI: hv: hv_pci_generic_compl(): handle the error case
> >
> >  drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++-------------=
-------
> -
> >  1 file changed, 29 insertions(+), 27 deletions(-)
>=20
> Applied with KY's ack to pci/host-hv for v4.9, thanks!

Thanks!

BTW, it looks I forgot to CC Jake Oshins somehow... sorry for that.

@Jake: these are just small cleanups. :-)

Thanks,
-- Dexuan

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2016-09-07  1:56 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-23  4:42 [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups Dexuan Cui
2016-08-23  4:42 ` Dexuan Cui
2016-09-06 15:40 ` Bjorn Helgaas
2016-09-06 17:06   ` KY Srinivasan
2016-09-06 17:06     ` KY Srinivasan
2016-09-06 17:05 ` KY Srinivasan
2016-09-06 17:05   ` KY Srinivasan
2016-09-06 17:24 ` Bjorn Helgaas
2016-09-07  1:56   ` Dexuan Cui
2016-09-07  1:56     ` Dexuan Cui

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.