All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] Make code more readable by not using the return value of the WARN() macro. Set ret variable in an undefined case.
@ 2011-05-23 11:07 Hans Petter Selasky
  2011-05-23 18:22 ` Guennadi Liakhovetski
  0 siblings, 1 reply; 5+ messages in thread
From: Hans Petter Selasky @ 2011-05-23 11:07 UTC (permalink / raw)
  To: linux-media; +Cc: Mauro Carvalho Chehab

[-- Attachment #1: Type: text/plain, Size: 6 bytes --]

--HPS

[-- Attachment #2: dvb-usb-0005.patch --]
[-- Type: text/x-patch, Size: 1237 bytes --]

From 94b88b92763f9309018ba04c200a8842ce1ff0ed Mon Sep 17 00:00:00 2001
From: Hans Petter Selasky <hselasky@c2i.net>
Date: Mon, 23 May 2011 13:07:08 +0200
Subject: [PATCH] Make code more readable by not using the return value of the WARN() macro. Set ret variable in an undefined case.

Signed-off-by: Hans Petter Selasky <hselasky@c2i.net>
---
 drivers/media/video/sr030pc30.c |    5 ++++-
 1 files changed, 4 insertions(+), 1 deletions(-)

diff --git a/drivers/media/video/sr030pc30.c b/drivers/media/video/sr030pc30.c
index c901721..6cc64c9 100644
--- a/drivers/media/video/sr030pc30.c
+++ b/drivers/media/video/sr030pc30.c
@@ -726,8 +726,10 @@ static int sr030pc30_s_power(struct v4l2_subdev *sd, int on)
 	const struct sr030pc30_platform_data *pdata = info->pdata;
 	int ret;
 
-	if (WARN(pdata == NULL, "No platform data!\n"))
+	if (pdata == NULL) {
+		WARN(1, "No platform data!\n");
 		return -ENOMEM;
+	}
 
 	/*
 	 * Put sensor into power sleep mode before switching off
@@ -746,6 +748,7 @@ static int sr030pc30_s_power(struct v4l2_subdev *sd, int on)
 	if (on) {
 		ret = sr030pc30_base_config(sd);
 	} else {
+		ret = 0;
 		info->curr_win = NULL;
 		info->curr_fmt = NULL;
 	}
-- 
1.7.1.1


^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2011-05-26  6:21 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-05-23 11:07 [PATCH] Make code more readable by not using the return value of the WARN() macro. Set ret variable in an undefined case Hans Petter Selasky
2011-05-23 18:22 ` Guennadi Liakhovetski
2011-05-23 19:04   ` Hans Petter Selasky
2011-05-26  0:03     ` Mauro Carvalho Chehab
2011-05-26  6:21       ` Guennadi Liakhovetski

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.