All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] cpupower: Bump soname version
@ 2016-06-10  0:56 Ben Hutchings
  2023-05-09 18:50 ` Salvatore Bonaccorso
  0 siblings, 1 reply; 6+ messages in thread
From: Ben Hutchings @ 2016-06-10  0:56 UTC (permalink / raw)
  To: Thomas Renninger; +Cc: linux-pm

[-- Attachment #1: Type: text/plain, Size: 1076 bytes --]

Several functions in the libcpupower API are renamed or removed in
Linux 4.7.  This is an backward-incompatible ABI change, so the
library soname should change from libcpupower.so.0 to
libcpupower.so.1.

Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
I have to say the choice of variable names here is rather confusing.
LIB_MIN is used for the soname version, which would normally be the
*major* part of the version.

I'll send a second patch that switches to more conventional library
versioning.

Ben.

 tools/power/cpupower/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile
index 8358863259c5..0b85f5915ce8 100644
--- a/tools/power/cpupower/Makefile
+++ b/tools/power/cpupower/Makefile
@@ -64,7 +64,7 @@ DESTDIR ?=
 
 VERSION=			$(shell ./utils/version-gen.sh)
 LIB_MAJ=			0.0.1
-LIB_MIN=			0
+LIB_MIN=			1
 
 PACKAGE =			cpupower
 PACKAGE_BUGREPORT =		linux-pm@vger.kernel.org

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 811 bytes --]

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] cpupower: Bump soname version
  2016-06-10  0:56 [PATCH] cpupower: Bump soname version Ben Hutchings
@ 2023-05-09 18:50 ` Salvatore Bonaccorso
  2023-05-09 22:10   ` Shuah Khan
  0 siblings, 1 reply; 6+ messages in thread
From: Salvatore Bonaccorso @ 2023-05-09 18:50 UTC (permalink / raw)
  To: Thomas Renninger, linux-pm; +Cc: Ben Hutchings, Shuah Khan

Hi Thomas,

On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote:
> Several functions in the libcpupower API are renamed or removed in
> Linux 4.7.  This is an backward-incompatible ABI change, so the
> library soname should change from libcpupower.so.0 to
> libcpupower.so.1.
> 
> Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
> Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
> ---
> I have to say the choice of variable names here is rather confusing.
> LIB_MIN is used for the soname version, which would normally be the
> *major* part of the version.
> 
> I'll send a second patch that switches to more conventional library
> versioning.
> 
> Ben.
> 
>  tools/power/cpupower/Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile
> index 8358863259c5..0b85f5915ce8 100644
> --- a/tools/power/cpupower/Makefile
> +++ b/tools/power/cpupower/Makefile
> @@ -64,7 +64,7 @@ DESTDIR ?=
>  
>  VERSION=			$(shell ./utils/version-gen.sh)
>  LIB_MAJ=			0.0.1
> -LIB_MIN=			0
> +LIB_MIN=			1
>  
>  PACKAGE =			cpupower
>  PACKAGE_BUGREPORT =		linux-pm@vger.kernel.org

Repinging this patch. Thomas, we are shipping it in Debian since, and
I'm wondering if the patch did just felt trough the cracks.

Regards,
Salvatore

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] cpupower: Bump soname version
  2023-05-09 18:50 ` Salvatore Bonaccorso
@ 2023-05-09 22:10   ` Shuah Khan
  2023-05-12 19:57     ` Salvatore Bonaccorso
  0 siblings, 1 reply; 6+ messages in thread
From: Shuah Khan @ 2023-05-09 22:10 UTC (permalink / raw)
  To: Salvatore Bonaccorso, Thomas Renninger, linux-pm
  Cc: Ben Hutchings, Shuah Khan, Shuah Khan

On 5/9/23 12:50, Salvatore Bonaccorso wrote:
> Hi Thomas,
> 
> On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote:
>> Several functions in the libcpupower API are renamed or removed in
>> Linux 4.7.  This is an backward-incompatible ABI change, so the
>> library soname should change from libcpupower.so.0 to
>> libcpupower.so.1.
>>
>> Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
>> Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
>> ---
>> I have to say the choice of variable names here is rather confusing.
>> LIB_MIN is used for the soname version, which would normally be the
>> *major* part of the version.
>>
>> I'll send a second patch that switches to more conventional library
>> versioning.
>>
>> Ben.
>>
>>   tools/power/cpupower/Makefile | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile
>> index 8358863259c5..0b85f5915ce8 100644
>> --- a/tools/power/cpupower/Makefile
>> +++ b/tools/power/cpupower/Makefile
>> @@ -64,7 +64,7 @@ DESTDIR ?=
>>   
>>   VERSION=			$(shell ./utils/version-gen.sh)
>>   LIB_MAJ=			0.0.1
>> -LIB_MIN=			0
>> +LIB_MIN=			1
>>   
>>   PACKAGE =			cpupower
>>   PACKAGE_BUGREPORT =		linux-pm@vger.kernel.org
> 
> Repinging this patch. Thomas, we are shipping it in Debian since, and
> I'm wondering if the patch did just felt trough the cracks.
> 

Please resend the patch for review.

thanks,
-- Shuah


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] cpupower: Bump soname version
  2023-05-09 22:10   ` Shuah Khan
@ 2023-05-12 19:57     ` Salvatore Bonaccorso
  2023-05-17 17:53       ` Shuah Khan
  0 siblings, 1 reply; 6+ messages in thread
From: Salvatore Bonaccorso @ 2023-05-12 19:57 UTC (permalink / raw)
  To: Shuah Khan; +Cc: Thomas Renninger, linux-pm, Ben Hutchings, Shuah Khan

Hi Shuah,

Apologies for the delay!

On Tue, May 09, 2023 at 04:10:05PM -0600, Shuah Khan wrote:
> On 5/9/23 12:50, Salvatore Bonaccorso wrote:
> > Hi Thomas,
> > 
> > On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote:
> > > Several functions in the libcpupower API are renamed or removed in
> > > Linux 4.7.  This is an backward-incompatible ABI change, so the
> > > library soname should change from libcpupower.so.0 to
> > > libcpupower.so.1.
> > > 
> > > Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
> > > Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
> > > ---
> > > I have to say the choice of variable names here is rather confusing.
> > > LIB_MIN is used for the soname version, which would normally be the
> > > *major* part of the version.
> > > 
> > > I'll send a second patch that switches to more conventional library
> > > versioning.
> > > 
> > > Ben.
> > > 
> > >   tools/power/cpupower/Makefile | 2 +-
> > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > > 
> > > diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile
> > > index 8358863259c5..0b85f5915ce8 100644
> > > --- a/tools/power/cpupower/Makefile
> > > +++ b/tools/power/cpupower/Makefile
> > > @@ -64,7 +64,7 @@ DESTDIR ?=
> > >   VERSION=			$(shell ./utils/version-gen.sh)
> > >   LIB_MAJ=			0.0.1
> > > -LIB_MIN=			0
> > > +LIB_MIN=			1
> > >   PACKAGE =			cpupower
> > >   PACKAGE_BUGREPORT =		linux-pm@vger.kernel.org
> > 
> > Repinging this patch. Thomas, we are shipping it in Debian since, and
> > I'm wondering if the patch did just felt trough the cracks.
> > 
> 
> Please resend the patch for review.

Here is the patch again for a fresh review on it. If you want me to
send it standalone with '[RESEND PATCH]' I can do that as well.

Regards,
Salvatore

From 9091eb3294bad8f7d79eaff8f52ebeb02cc7d210 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 9 Jun 2016 23:35:08 +0100
Subject: [PATCH] cpupower: Bump soname version

Several functions in the libcpupower API are renamed or removed in
Linux 4.7.  This is an backward-incompatible ABI change, so the
library soname should change from libcpupower.so.0 to
libcpupower.so.1.

Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Signed-off-by: Salvatore Bonaccorso <carnil@debian.org>
---
 tools/power/cpupower/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile
index 59bfa05dec5d..dc531805a570 100644
--- a/tools/power/cpupower/Makefile
+++ b/tools/power/cpupower/Makefile
@@ -53,7 +53,7 @@ DESTDIR ?=
 
 VERSION:=			$(shell ./utils/version-gen.sh)
 LIB_MAJ=			0.0.1
-LIB_MIN=			0
+LIB_MIN=			1
 
 PACKAGE =			cpupower
 PACKAGE_BUGREPORT =		linux-pm@vger.kernel.org
-- 
2.40.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] cpupower: Bump soname version
  2023-05-12 19:57     ` Salvatore Bonaccorso
@ 2023-05-17 17:53       ` Shuah Khan
  2023-05-17 19:12         ` Salvatore Bonaccorso
  0 siblings, 1 reply; 6+ messages in thread
From: Shuah Khan @ 2023-05-17 17:53 UTC (permalink / raw)
  To: Salvatore Bonaccorso
  Cc: Thomas Renninger, linux-pm, Ben Hutchings, Shuah Khan, Shuah Khan

On 5/12/23 13:57, Salvatore Bonaccorso wrote:
> Hi Shuah,
> 
> Apologies for the delay!
> 
> On Tue, May 09, 2023 at 04:10:05PM -0600, Shuah Khan wrote:
>> On 5/9/23 12:50, Salvatore Bonaccorso wrote:
>>> Hi Thomas,
>>>
>>> On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote:
>>>> Several functions in the libcpupower API are renamed or removed in
>>>> Linux 4.7.  This is an backward-incompatible ABI change, so the
>>>> library soname should change from libcpupower.so.0 to
>>>> libcpupower.so.1.
>>>>
>>>> Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
>>>> Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
>>>> ---
>>>> I have to say the choice of variable names here is rather confusing.
>>>> LIB_MIN is used for the soname version, which would normally be the
>>>> *major* part of the version.
>>>>
>>>> I'll send a second patch that switches to more conventional library
>>>> versioning.
>>>>
>>>> Ben.
>>>>
>>>>    tools/power/cpupower/Makefile | 2 +-
>>>>    1 file changed, 1 insertion(+), 1 deletion(-)
>>>>
>>>> diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile
>>>> index 8358863259c5..0b85f5915ce8 100644
>>>> --- a/tools/power/cpupower/Makefile
>>>> +++ b/tools/power/cpupower/Makefile
>>>> @@ -64,7 +64,7 @@ DESTDIR ?=
>>>>    VERSION=			$(shell ./utils/version-gen.sh)
>>>>    LIB_MAJ=			0.0.1
>>>> -LIB_MIN=			0
>>>> +LIB_MIN=			1
>>>>    PACKAGE =			cpupower
>>>>    PACKAGE_BUGREPORT =		linux-pm@vger.kernel.org
>>>
>>> Repinging this patch. Thomas, we are shipping it in Debian since, and
>>> I'm wondering if the patch did just felt trough the cracks.
>>>
>>
>> Please resend the patch for review.
> 
> Here is the patch again for a fresh review on it. If you want me to
> send it standalone with '[RESEND PATCH]' I can do that as well.
> 

Yes please resend with RESEND tag. I won't be able to apply the patch
when it is included in the reply.

thanks,
-- Shuah


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] cpupower: Bump soname version
  2023-05-17 17:53       ` Shuah Khan
@ 2023-05-17 19:12         ` Salvatore Bonaccorso
  0 siblings, 0 replies; 6+ messages in thread
From: Salvatore Bonaccorso @ 2023-05-17 19:12 UTC (permalink / raw)
  To: Shuah Khan; +Cc: Thomas Renninger, linux-pm, Ben Hutchings, Shuah Khan

Hi,

On Wed, May 17, 2023 at 11:53:59AM -0600, Shuah Khan wrote:
> On 5/12/23 13:57, Salvatore Bonaccorso wrote:
> > Hi Shuah,
> > 
> > Apologies for the delay!
> > 
> > On Tue, May 09, 2023 at 04:10:05PM -0600, Shuah Khan wrote:
> > > On 5/9/23 12:50, Salvatore Bonaccorso wrote:
> > > > Hi Thomas,
> > > > 
> > > > On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote:
> > > > > Several functions in the libcpupower API are renamed or removed in
> > > > > Linux 4.7.  This is an backward-incompatible ABI change, so the
> > > > > library soname should change from libcpupower.so.0 to
> > > > > libcpupower.so.1.
> > > > > 
> > > > > Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
> > > > > Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
> > > > > ---
> > > > > I have to say the choice of variable names here is rather confusing.
> > > > > LIB_MIN is used for the soname version, which would normally be the
> > > > > *major* part of the version.
> > > > > 
> > > > > I'll send a second patch that switches to more conventional library
> > > > > versioning.
> > > > > 
> > > > > Ben.
> > > > > 
> > > > >    tools/power/cpupower/Makefile | 2 +-
> > > > >    1 file changed, 1 insertion(+), 1 deletion(-)
> > > > > 
> > > > > diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile
> > > > > index 8358863259c5..0b85f5915ce8 100644
> > > > > --- a/tools/power/cpupower/Makefile
> > > > > +++ b/tools/power/cpupower/Makefile
> > > > > @@ -64,7 +64,7 @@ DESTDIR ?=
> > > > >    VERSION=			$(shell ./utils/version-gen.sh)
> > > > >    LIB_MAJ=			0.0.1
> > > > > -LIB_MIN=			0
> > > > > +LIB_MIN=			1
> > > > >    PACKAGE =			cpupower
> > > > >    PACKAGE_BUGREPORT =		linux-pm@vger.kernel.org
> > > > 
> > > > Repinging this patch. Thomas, we are shipping it in Debian since, and
> > > > I'm wondering if the patch did just felt trough the cracks.
> > > > 
> > > 
> > > Please resend the patch for review.
> > 
> > Here is the patch again for a fresh review on it. If you want me to
> > send it standalone with '[RESEND PATCH]' I can do that as well.
> > 
> 
> Yes please resend with RESEND tag. I won't be able to apply the patch
> when it is included in the reply.

Thanks for your patience! Just resent the patch as requested:
https://lore.kernel.org/linux-pm/20230517191019.643031-1-carnil@debian.org/

Regards,
Salvatore

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2023-05-17 19:13 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-06-10  0:56 [PATCH] cpupower: Bump soname version Ben Hutchings
2023-05-09 18:50 ` Salvatore Bonaccorso
2023-05-09 22:10   ` Shuah Khan
2023-05-12 19:57     ` Salvatore Bonaccorso
2023-05-17 17:53       ` Shuah Khan
2023-05-17 19:12         ` Salvatore Bonaccorso

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.