All of lore.kernel.org
 help / color / mirror / Atom feed
From: Rodrigo Vivi <rodrigo.vivi@intel.com>
To: "Souza, Jose" <jose.souza@intel.com>
Cc: "Dugast, Francois" <francois.dugast@intel.com>,
	"intel-xe@lists.freedesktop.org" <intel-xe@lists.freedesktop.org>
Subject: Re: [Intel-xe] [PATCH v2 05/14] drm/xe/uapi: Align on a common way to return arrays (memory regions)
Date: Tue, 28 Nov 2023 15:51:13 -0500	[thread overview]
Message-ID: <ZWZSwQXvcAB5v9fW@intel.com> (raw)
In-Reply-To: <3c34b03bd2bab567ca6891b095332a2f2b4ddc29.camel@intel.com>

On Fri, Nov 24, 2023 at 06:19:47PM +0000, Souza, Jose wrote:
> On Wed, 2023-11-22 at 14:38 +0000, Francois Dugast wrote:
> > The uAPI provides queries which return arrays of elements. As of now
> > the format used in the struct is different depending on which element
> > is queried. Fix this for memory regions by applying the pattern below:
> > 
> >     struct drm_xe_query_Xs {
> >        __u32 num_Xs;
> >        struct drm_xe_X Xs[];
> >        ...
> >     }
> > 
> > This removes "query" in the name of struct drm_xe_query_mem_region
> > as it is not returned from the query IOCTL. There is no functional
> > change.
> > 
> > v2: Only rename drm_xe_query_mem_region to drm_xe_mem_region
> >     (José Roberto de Souza)
> > 
> > Signed-off-by: Francois Dugast <francois.dugast@intel.com>
> > ---
> >  drivers/gpu/drm/xe/xe_query.c | 36 ++++++++++++++++++-----------------
> >  include/uapi/drm/xe_drm.h     | 12 ++++++------
> >  2 files changed, 25 insertions(+), 23 deletions(-)
> > 
> > diff --git a/drivers/gpu/drm/xe/xe_query.c b/drivers/gpu/drm/xe/xe_query.c
> > index 0cbfeaeb1330..f321ed4d3b0b 100644
> > --- a/drivers/gpu/drm/xe/xe_query.c
> > +++ b/drivers/gpu/drm/xe/xe_query.c
> > @@ -240,11 +240,11 @@ static size_t calc_mem_regions_size(struct xe_device *xe)
> >  		if (ttm_manager_type(&xe->ttm, i))
> >  			num_managers++;
> >  
> > -	return offsetof(struct drm_xe_query_mem_regions, regions[num_managers]);
> > +	return offsetof(struct drm_xe_query_mem_regions, mem_regions[num_managers]);
> >  }
> >  
> >  static int query_mem_regions(struct xe_device *xe,
> > -			     struct drm_xe_device_query *query)
> > +			    struct drm_xe_device_query *query)
> >  {
> >  	size_t size = calc_mem_regions_size(xe);
> >  	struct drm_xe_query_mem_regions *usage;
> > @@ -265,36 +265,38 @@ static int query_mem_regions(struct xe_device *xe,
> >  		return -ENOMEM;
> >  
> >  	man = ttm_manager_type(&xe->ttm, XE_PL_TT);
> > -	usage->regions[0].mem_class = DRM_XE_MEM_REGION_CLASS_SYSMEM;
> > -	usage->regions[0].instance = 0;
> > -	usage->regions[0].min_page_size = PAGE_SIZE;
> > -	usage->regions[0].total_size = man->size << PAGE_SHIFT;
> > +	usage->mem_regions[0].mem_class = DRM_XE_MEM_REGION_CLASS_SYSMEM;
> 
> nit: can you also rename 'usage' to something else, it was named 'usage' because of the old query name.

my bad for having forgotten this 'usage' in here. Let's fix that in a follow-up after this series is merged.

Reviewed-by: Rodrigo Vivi <rodrigo.vivi@intel.com>

> 
> 
> > +	usage->mem_regions[0].instance = 0;
> > +	usage->mem_regions[0].min_page_size = PAGE_SIZE;
> > +	usage->mem_regions[0].total_size = man->size << PAGE_SHIFT;
> >  	if (perfmon_capable())
> > -		usage->regions[0].used = ttm_resource_manager_usage(man);
> > -	usage->num_regions = 1;
> > +		usage->mem_regions[0].used = ttm_resource_manager_usage(man);
> > +	usage->num_mem_regions = 1;
> >  
> >  	for (i = XE_PL_VRAM0; i <= XE_PL_VRAM1; ++i) {
> >  		man = ttm_manager_type(&xe->ttm, i);
> >  		if (man) {
> > -			usage->regions[usage->num_regions].mem_class =
> > +			usage->mem_regions[usage->num_mem_regions].mem_class =
> >  				DRM_XE_MEM_REGION_CLASS_VRAM;
> > -			usage->regions[usage->num_regions].instance =
> > -				usage->num_regions;
> > -			usage->regions[usage->num_regions].min_page_size =
> > +			usage->mem_regions[usage->num_mem_regions].instance =
> > +				usage->num_mem_regions;
> > +			usage->mem_regions[usage->num_mem_regions].min_page_size =
> >  				xe->info.vram_flags & XE_VRAM_FLAGS_NEED64K ?
> >  				SZ_64K : PAGE_SIZE;
> > -			usage->regions[usage->num_regions].total_size =
> > +			usage->mem_regions[usage->num_mem_regions].total_size =
> >  				man->size;
> >  
> >  			if (perfmon_capable()) {
> >  				xe_ttm_vram_get_used(man,
> > -						     &usage->regions[usage->num_regions].used,
> > -						     &usage->regions[usage->num_regions].cpu_visible_used);
> > +						     &usage->mem_regions
> > +						     [usage->num_mem_regions].used,
> > +						     &usage->mem_regions
> > +						     [usage->num_mem_regions].cpu_visible_used);
> >  			}
> >  
> > -			usage->regions[usage->num_regions].cpu_visible_size =
> > +			usage->mem_regions[usage->num_mem_regions].cpu_visible_size =
> >  				xe_ttm_vram_get_cpu_visible_size(man);
> > -			usage->num_regions++;
> > +			usage->num_mem_regions++;
> >  		}
> >  	}
> >  
> > diff --git a/include/uapi/drm/xe_drm.h b/include/uapi/drm/xe_drm.h
> > index da10d946930b..a9bbdf141fe2 100644
> > --- a/include/uapi/drm/xe_drm.h
> > +++ b/include/uapi/drm/xe_drm.h
> > @@ -182,10 +182,10 @@ enum drm_xe_memory_class {
> >  };
> >  
> >  /**
> > - * struct drm_xe_query_mem_region - Describes some region as known to
> > + * struct drm_xe_mem_region - Describes some region as known to
> >   * the driver.
> >   */
> > -struct drm_xe_query_mem_region {
> > +struct drm_xe_mem_region {
> >  	/**
> >  	 * @mem_class: The memory class describing this region.
> >  	 *
> > @@ -322,12 +322,12 @@ struct drm_xe_query_engine_cycles {
> >   * struct drm_xe_query_mem_regions in .data.
> >   */
> >  struct drm_xe_query_mem_regions {
> > -	/** @num_regions: number of memory regions returned in @regions */
> > -	__u32 num_regions;
> > +	/** @num_mem_regions: number of memory regions returned in @mem_regions */
> > +	__u32 num_mem_regions;
> >  	/** @pad: MBZ */
> >  	__u32 pad;
> > -	/** @regions: The returned regions for this device */
> > -	struct drm_xe_query_mem_region regions[];
> > +	/** @mem_regions: The returned memory regions for this device */
> > +	struct drm_xe_mem_region mem_regions[];
> >  };
> >  
> >  /**
> 

  reply	other threads:[~2023-11-28 20:51 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-11-22 14:38 [Intel-xe] [PATCH v2 00/14] uAPI Alignment - Cleanup and future proof Francois Dugast
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 01/14] drm/xe: Extend drm_xe_vm_bind_op Francois Dugast
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 02/14] drm/xe/uapi: Separate bo_create placement from flags Francois Dugast
2023-11-29 19:36   ` Welty, Brian
2023-11-29 20:41     ` Rodrigo Vivi
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 03/14] drm/xe: Make DRM_XE_DEVICE_QUERY_ENGINES future proof Francois Dugast
2023-11-28 21:17   ` Matthew Brost
2023-11-29 16:54     ` Rodrigo Vivi
2023-11-29 12:35       ` Matthew Brost
2023-11-29 20:04         ` Souza, Jose
2023-11-29 22:52           ` Rodrigo Vivi
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 04/14] drm/xe/uapi: Reject bo creation of unaligned size Francois Dugast
2023-11-24 18:15   ` Souza, Jose
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 05/14] drm/xe/uapi: Align on a common way to return arrays (memory regions) Francois Dugast
2023-11-24 18:19   ` Souza, Jose
2023-11-28 20:51     ` Rodrigo Vivi [this message]
2023-11-29 12:33       ` Francois Dugast
2023-11-30 20:53   ` Dixit, Ashutosh
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 06/14] drm/xe/uapi: Align on a common way to return arrays (gt) Francois Dugast
2023-11-28 20:51   ` Rodrigo Vivi
2023-11-29 18:30   ` Matt Roper
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 07/14] drm/xe/uapi: Align on a common way to return arrays (engines) Francois Dugast
2023-11-28 20:56   ` Rodrigo Vivi
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 08/14] drm/xe/uapi: Split xe_sync types from flags Francois Dugast
2023-11-28 21:19   ` Matthew Brost
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 09/14] drm/xe/uapi: Kill tile_mask Francois Dugast
2023-11-29  9:07   ` Matthew Brost
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 10/14] drm/xe/uapi: Crystal Reference Clock updates Francois Dugast
2023-11-24 18:38   ` Souza, Jose
2023-11-29 14:08     ` Francois Dugast
2023-11-29 18:33       ` Souza, Jose
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 11/14] drm/xe/uapi: Remove bogus engine list from the wait_user_fence IOCTL Francois Dugast
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 12/14] drm/xe/uapi: Add Tile ID information to the GT info query Francois Dugast
2023-11-24 18:45   ` Souza, Jose
2023-11-27 14:08     ` Francois Dugast
2023-11-27 14:20       ` Souza, Jose
2023-11-29 18:33         ` Souza, Jose
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 13/14] drm/xe/uapi: Fix various struct padding for 64b alignment Francois Dugast
2023-11-29 17:02   ` Souza, Jose
2023-11-29 17:39     ` Francois Dugast
2023-11-22 14:38 ` [Intel-xe] [PATCH v2 14/14] drm/xe/uapi: Move xe_exec after xe_exec_queue Francois Dugast
2023-11-29 18:34   ` Souza, Jose
2023-11-23 14:14 ` [Intel-xe] ✓ CI.Patch_applied: success for uAPI Alignment - Cleanup and future proof (rev5) Patchwork
2023-11-23 14:14 ` [Intel-xe] ✗ CI.checkpatch: warning " Patchwork
2023-11-23 14:15 ` [Intel-xe] ✓ CI.KUnit: success " Patchwork
2023-11-23 14:23 ` [Intel-xe] ✓ CI.Build: " Patchwork
2023-11-23 14:23 ` [Intel-xe] ✗ CI.Hooks: failure " Patchwork
2023-11-23 14:24 ` [Intel-xe] ✓ CI.checksparse: success " Patchwork
2023-11-23 15:01 ` [Intel-xe] ✗ CI.BAT: failure " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZWZSwQXvcAB5v9fW@intel.com \
    --to=rodrigo.vivi@intel.com \
    --cc=francois.dugast@intel.com \
    --cc=intel-xe@lists.freedesktop.org \
    --cc=jose.souza@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.