All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/28] staging: unisys: More updates to make the code more readable.
@ 2017-08-30 17:36 David Kershner
  2017-08-30 17:36 ` [PATCH 01/28] staging: unisys: use the kernel min define David Kershner
                   ` (27 more replies)
  0 siblings, 28 replies; 29+ messages in thread
From: David Kershner @ 2017-08-30 17:36 UTC (permalink / raw)
  To: gregkh, driverdev-devel, sparmaintainer, jes.sorensen

Checkpatch cleanups and other misc cleanups.

David Binder (3):
  staging: unisys: visornic: Fix up existing function comments.
  staging: unisys: visornic: Fix miscellaneous block comment format issues.
  staging: unisys: visornic: Remove unnecessary return values

David Kershner (21):
  staging: unisys: use the kernel min define
  staging: unisys: visorbus: Clean up vmcall address function.
  staging: unisys: visorbus: Fix parameter alignment.
  staging: unisys: visorbus: Convert macros to functions.
  staging: unisys: visorbus: Use __func__ instead of name.
  staging: unisys: Don't check for null before getting driver device.
  staging: unisys: include: Add comment next to mutex.
  staging: unisys: visorbus: Consolidate controlvm channel creation.
  staging: unisys: visorbus: Remove useless comment.
  staging: unisys: visorbus: Remove useless initialization.
  staging: unisys: visorbus: Remove check for valid parm_addr.
  staging: unisys: visorbus: Split else if blocks into multiple if.
  staging: unisys: Change data to point to visor_controlvm_parameters_header.
  staging: unisys: visorbus: Remove useless else clause in visorutil_spar_detect.
  staging: unisys: visorbus: remove uneeded initializations
  staging: unisys: visorbus: Move parser functions location in file.
  staging: unisys: visorchipset: Shorten parser_init_byte_stream.
  staging: unisys: visorbus: use all 80 characters for multi-line messages
  staging: unisys: Use size of channel defined in the channel.
  staging: unisys: visorbus: just check for GUID
  staging: unisys: visorbus: Fix up GUID definition

Sameer Wadgaonkar (4):
  staging: unisys: visorbus: visorchipset.c: Fix bug in parser_init_byte_stream.
  staging: unisys: visorbus: visorbus_main.c: Fix return values for checks in visorbus_register_visor_driver.
  staging: unisys: visorbus: remove EXPORT_SYMBOL_GPL for visor_check_channel
  staging: unisys: change pr_err to dev_err in visor_check_channel

 drivers/staging/unisys/include/iochannel.h         |   3 +-
 drivers/staging/unisys/include/visorbus.h          |  16 +-
 drivers/staging/unisys/visorbus/visorbus_main.c    |  54 +-
 drivers/staging/unisys/visorbus/visorbus_private.h |  10 +-
 drivers/staging/unisys/visorbus/visorchannel.c     |  81 +--
 drivers/staging/unisys/visorbus/visorchipset.c     | 261 +++-----
 drivers/staging/unisys/visornic/visornic_main.c    | 451 ++++++--------
 7 files changed, 386 insertions(+), 490 deletions(-)

base-commit: 423a8a6eac2432a50e7ca4e4342a41ad3cf951e7
-- 
git-series 0.9.1
_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply	[flat|nested] 29+ messages in thread

end of thread, other threads:[~2017-08-30 17:37 UTC | newest]

Thread overview: 29+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-08-30 17:36 [PATCH 00/28] staging: unisys: More updates to make the code more readable David Kershner
2017-08-30 17:36 ` [PATCH 01/28] staging: unisys: use the kernel min define David Kershner
2017-08-30 17:36 ` [PATCH 02/28] staging: unisys: visorbus: visorchipset.c: Fix bug in parser_init_byte_stream David Kershner
2017-08-30 17:36 ` [PATCH 03/28] staging: unisys: visorbus: visorbus_main.c: Fix return values for checks in visorbus_register_visor_driver David Kershner
2017-08-30 17:36 ` [PATCH 04/28] staging: unisys: visornic: Fix up existing function comments David Kershner
2017-08-30 17:36 ` [PATCH 05/28] staging: unisys: visornic: Fix miscellaneous block comment format issues David Kershner
2017-08-30 17:36 ` [PATCH 06/28] staging: unisys: visorbus: Clean up vmcall address function David Kershner
2017-08-30 17:36 ` [PATCH 07/28] staging: unisys: visorbus: Fix parameter alignment David Kershner
2017-08-30 17:36 ` [PATCH 08/28] staging: unisys: visorbus: Convert macros to functions David Kershner
2017-08-30 17:36 ` [PATCH 09/28] staging: unisys: visorbus: Use __func__ instead of name David Kershner
2017-08-30 17:36 ` [PATCH 10/28] staging: unisys: Don't check for null before getting driver device David Kershner
2017-08-30 17:36 ` [PATCH 11/28] staging: unisys: include: Add comment next to mutex David Kershner
2017-08-30 17:36 ` [PATCH 12/28] staging: unisys: visorbus: Consolidate controlvm channel creation David Kershner
2017-08-30 17:36 ` [PATCH 13/28] staging: unisys: visorbus: Remove useless comment David Kershner
2017-08-30 17:36 ` [PATCH 14/28] staging: unisys: visorbus: Remove useless initialization David Kershner
2017-08-30 17:36 ` [PATCH 15/28] staging: unisys: visorbus: Remove check for valid parm_addr David Kershner
2017-08-30 17:36 ` [PATCH 16/28] staging: unisys: visorbus: Split else if blocks into multiple if David Kershner
2017-08-30 17:36 ` [PATCH 17/28] staging: unisys: Change data to point to visor_controlvm_parameters_header David Kershner
2017-08-30 17:36 ` [PATCH 18/28] staging: unisys: visorbus: Remove useless else clause in visorutil_spar_detect David Kershner
2017-08-30 17:36 ` [PATCH 19/28] staging: unisys: visorbus: remove uneeded initializations David Kershner
2017-08-30 17:36 ` [PATCH 20/28] staging: unisys: visorbus: Move parser functions location in file David Kershner
2017-08-30 17:36 ` [PATCH 21/28] staging: unisys: visorchipset: Shorten parser_init_byte_stream David Kershner
2017-08-30 17:36 ` [PATCH 22/28] staging: unisys: visorbus: use all 80 characters for multi-line messages David Kershner
2017-08-30 17:36 ` [PATCH 23/28] staging: unisys: visornic: Remove unnecessary return values David Kershner
2017-08-30 17:36 ` [PATCH 24/28] staging: unisys: Use size of channel defined in the channel David Kershner
2017-08-30 17:36 ` [PATCH 25/28] staging: unisys: visorbus: just check for GUID David Kershner
2017-08-30 17:36 ` [PATCH 26/28] staging: unisys: visorbus: Fix up GUID definition David Kershner
2017-08-30 17:36 ` [PATCH 27/28] staging: unisys: visorbus: remove EXPORT_SYMBOL_GPL for visor_check_channel David Kershner
2017-08-30 17:36 ` [PATCH 28/28] staging: unisys: change pr_err to dev_err in visor_check_channel David Kershner

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.