All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v4 00/23] More SH4 clean ups
@ 2021-10-28 19:27 BALATON Zoltan
  2021-10-28 19:27 ` [PATCH v4 04/23] hw/sh4/r2d: Use error_report instead of fprintf to stderr BALATON Zoltan
                   ` (22 more replies)
  0 siblings, 23 replies; 41+ messages in thread
From: BALATON Zoltan @ 2021-10-28 19:27 UTC (permalink / raw)
  To: qemu-devel; +Cc: Peter Maydell, Richard Henderson, Magnus Damm, Yoshinori Sato

Based-on: <cover.1635036053.git.balaton@eik.bme.hu>
^ (hw/sh4: Codeing style fixes)

Continuing the clean up stared in previous series. This got big enough
for now so I'll wait until these are merged (hopefully before the
freeze) before going on so I don't have to carry them in my tree. Only
plan to submit another version if needed from review otherwise that's
it for now.

v4: Drop changes from fprintf before abort() as Philippe said, only
change sh_serial now which can use hw_error instead; missed two more
debug printfs in sh_timer that I've also added now; some more clean ups

v3: Correct mistakes found in review, drop size change of sh_intc
iomem as that was wrong so only rename it, more clean ups

v2: separate sh_serial trace events, split QOM-ify patch for easier
review and some more patches to clean up sh_intc a bit

Regards,

BALATON Zoltan (23):
  hw/sh4: Fix typos in a comment
  hw/char/sh_serial: Use hw_error instead of fprintf and abort
  hw/sh4: Change debug printfs to traces
  hw/sh4/r2d: Use error_report instead of fprintf to stderr
  hw/char/sh_serial: Rename type sh_serial_state to SHSerialState
  hw/char/sh_serial: QOM-ify
  hw/char/sh_serial: Add device id to trace output
  hw/intc/sh_intc: Use existing macro instead of local one
  hw/intc/sh_intc: Turn some defines into an enum
  hw/intc/sh_intc: Rename iomem region
  hw/intc/sh_intc: Drop another useless macro
  hw/intc/sh_intc: Move sh_intc_register() closer to its only user
  hw/intc/sh_intc: Remove excessive parenthesis
  hw/intc/sh_intc: Use array index instead of pointer arithmetics
  hw/intc/sh_intc: Inline and drop sh_intc_source() function
  hw/intc/sh_intc: Replace abort() with g_assert_not_reached()
  hw/intc/sh_intc: Avoid using continue in loops
  hw/intc/sh_intc: Simplify allocating sources array
  hw/intc/sh_intc: Remove unneeded local variable initialisers
  hw/timer/sh_timer: Rename sh_timer_state to SHTimerState
  hw/timer/sh_timer: Fix format strings and remove casts
  hw/timer/sh_timer: Do not wrap lines that are not too long
  hw/timer/sh_timer: Fix timer memory region size

 hw/char/sh_serial.c   | 151 +++++++++--------
 hw/char/trace-events  |   4 +
 hw/intc/sh_intc.c     | 369 +++++++++++++++++-------------------------
 hw/intc/trace-events  |   8 +
 hw/sh4/r2d.c          |   5 +-
 hw/sh4/sh7750.c       |  74 ++++++---
 hw/sh4/trace-events   |   3 +
 hw/sh4/trace.h        |   1 +
 hw/timer/sh_timer.c   |  66 +++-----
 hw/timer/trace-events |   5 +
 include/hw/sh4/sh.h   |   9 +-
 meson.build           |   1 +
 12 files changed, 331 insertions(+), 365 deletions(-)
 create mode 100644 hw/sh4/trace-events
 create mode 100644 hw/sh4/trace.h

-- 
2.21.4



^ permalink raw reply	[flat|nested] 41+ messages in thread

end of thread, other threads:[~2021-10-29 13:47 UTC | newest]

Thread overview: 41+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-10-28 19:27 [PATCH v4 00/23] More SH4 clean ups BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 04/23] hw/sh4/r2d: Use error_report instead of fprintf to stderr BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 22/23] hw/timer/sh_timer: Do not wrap lines that are not too long BALATON Zoltan
2021-10-29  5:48   ` Philippe Mathieu-Daudé
2021-10-28 19:27 ` [PATCH v4 13/23] hw/intc/sh_intc: Remove excessive parenthesis BALATON Zoltan
2021-10-29  5:39   ` Philippe Mathieu-Daudé
2021-10-28 19:27 ` [PATCH v4 20/23] hw/timer/sh_timer: Rename sh_timer_state to SHTimerState BALATON Zoltan
2021-10-29  5:47   ` Philippe Mathieu-Daudé
2021-10-28 19:27 ` [PATCH v4 21/23] hw/timer/sh_timer: Fix format strings and remove casts BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 18/23] hw/intc/sh_intc: Simplify allocating sources array BALATON Zoltan
2021-10-29  5:46   ` Philippe Mathieu-Daudé
2021-10-29 11:59     ` BALATON Zoltan
2021-10-29 12:41       ` Philippe Mathieu-Daudé
2021-10-28 19:27 ` [PATCH v4 15/23] hw/intc/sh_intc: Inline and drop sh_intc_source() function BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 17/23] hw/intc/sh_intc: Avoid using continue in loops BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 03/23] hw/sh4: Change debug printfs to traces BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 19/23] hw/intc/sh_intc: Remove unneeded local variable initialisers BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 23/23] hw/timer/sh_timer: Fix timer memory region size BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 11/23] hw/intc/sh_intc: Drop another useless macro BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 14/23] hw/intc/sh_intc: Use array index instead of pointer arithmetics BALATON Zoltan
2021-10-29  5:43   ` Philippe Mathieu-Daudé
2021-10-28 19:27 ` [PATCH v4 01/23] hw/sh4: Fix typos in a comment BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 16/23] hw/intc/sh_intc: Replace abort() with g_assert_not_reached() BALATON Zoltan
2021-10-29  5:41   ` Philippe Mathieu-Daudé
2021-10-28 19:27 ` [PATCH v4 08/23] hw/intc/sh_intc: Use existing macro instead of local one BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 05/23] hw/char/sh_serial: Rename type sh_serial_state to SHSerialState BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 12/23] hw/intc/sh_intc: Move sh_intc_register() closer to its only user BALATON Zoltan
2021-10-29  5:40   ` Philippe Mathieu-Daudé
2021-10-28 19:27 ` [PATCH v4 07/23] hw/char/sh_serial: Add device id to trace output BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 10/23] hw/intc/sh_intc: Rename iomem region BALATON Zoltan
2021-10-29  5:36   ` Philippe Mathieu-Daudé
2021-10-28 19:27 ` [PATCH v4 09/23] hw/intc/sh_intc: Turn some defines into an enum BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 02/23] hw/char/sh_serial: Use hw_error instead of fprintf and abort BALATON Zoltan
2021-10-29  5:38   ` Philippe Mathieu-Daudé
2021-10-29  6:00     ` Thomas Huth
2021-10-29 12:01     ` BALATON Zoltan
2021-10-28 19:27 ` [PATCH v4 06/23] hw/char/sh_serial: QOM-ify BALATON Zoltan
2021-10-29  6:05   ` Philippe Mathieu-Daudé
2021-10-29 12:15     ` BALATON Zoltan
2021-10-29 13:25       ` Philippe Mathieu-Daudé
2021-10-29 13:44         ` BALATON Zoltan

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.