All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/2] Test improvements
@ 2022-04-09  2:44 Glenn Washburn
  2022-04-09  2:44 ` [PATCH 1/2] tests: Disable blkid cache usage Glenn Washburn
  2022-04-09  2:44 ` [PATCH 2/2] tests: Give grub-fs-tester temp directory a better name Glenn Washburn
  0 siblings, 2 replies; 6+ messages in thread
From: Glenn Washburn @ 2022-04-09  2:44 UTC (permalink / raw)
  To: Daniel Kiper, grub-devel; +Cc: Glenn Washburn

A couple improvements to the grub-fs-tester. I was seeing the issue with
the blkid cache when running many parallel UML instances.

Glenn

Glenn Washburn (2):
  tests: Disable blkid cache usage
  tests: Give grub-fs-tester temp directory a better name

 tests/util/grub-fs-tester.in | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

-- 
2.25.1



^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH 1/2] tests: Disable blkid cache usage
  2022-04-09  2:44 [PATCH 0/2] Test improvements Glenn Washburn
@ 2022-04-09  2:44 ` Glenn Washburn
  2022-04-09  2:44 ` [PATCH 2/2] tests: Give grub-fs-tester temp directory a better name Glenn Washburn
  1 sibling, 0 replies; 6+ messages in thread
From: Glenn Washburn @ 2022-04-09  2:44 UTC (permalink / raw)
  To: Daniel Kiper, grub-devel; +Cc: Glenn Washburn

Using the blkid cache can cause issues when running many file system tests
in parallel. We do not need it, as its only there to improve performance,
and using the cache does not provide significant performance improvements.

Signed-off-by: Glenn Washburn <development@efficientek.com>
---
 tests/util/grub-fs-tester.in | 1 +
 1 file changed, 1 insertion(+)

diff --git a/tests/util/grub-fs-tester.in b/tests/util/grub-fs-tester.in
index 65633c7f81..868199109f 100644
--- a/tests/util/grub-fs-tester.in
+++ b/tests/util/grub-fs-tester.in
@@ -1,6 +1,7 @@
 #!@BUILD_SHEBANG@
 
 set -e
+export BLKID_FILE=/dev/null
 
 fs="$1"
 
-- 
2.25.1



^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 2/2] tests: Give grub-fs-tester temp directory a better name
  2022-04-09  2:44 [PATCH 0/2] Test improvements Glenn Washburn
  2022-04-09  2:44 ` [PATCH 1/2] tests: Disable blkid cache usage Glenn Washburn
@ 2022-04-09  2:44 ` Glenn Washburn
  2022-04-14 16:32   ` Daniel Kiper
  1 sibling, 1 reply; 6+ messages in thread
From: Glenn Washburn @ 2022-04-09  2:44 UTC (permalink / raw)
  To: Daniel Kiper, grub-devel; +Cc: Glenn Washburn

Instead of "tmp" the name is prefixed by the name of the scripts (eg.
grub-fs-tester). A timestamp is added in the name to allow for easily
seeing a chronological sorting of runs and the name of the filesystem
being tested. The random component is set to the minimal possible, 3
characters, because the timestamp should provide enough uniqueness.

Signed-off-by: Glenn Washburn <development@efficientek.com>
---
 tests/util/grub-fs-tester.in | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tests/util/grub-fs-tester.in b/tests/util/grub-fs-tester.in
index 868199109f..02edcf897f 100644
--- a/tests/util/grub-fs-tester.in
+++ b/tests/util/grub-fs-tester.in
@@ -7,7 +7,7 @@ fs="$1"
 
 GRUBFSTEST="@builddir@/grub-fstest"
 
-tempdir=`mktemp -d "${TMPDIR:-/tmp}/tmp.XXXXXXXXXX"` ||
+tempdir=`mktemp -d "${TMPDIR:-/tmp}/${0##*/}.$(date '+%Y%m%d%H%M%S%N').${fs}.XXX"` ||
 { echo "Failed to make temporary directory"; exit 99; }
 
 # xorriso -as mkisofs options to ignore locale when processing file names and
-- 
2.25.1



^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH 2/2] tests: Give grub-fs-tester temp directory a better name
  2022-04-09  2:44 ` [PATCH 2/2] tests: Give grub-fs-tester temp directory a better name Glenn Washburn
@ 2022-04-14 16:32   ` Daniel Kiper
  2022-04-18  4:47     ` Glenn Washburn
  0 siblings, 1 reply; 6+ messages in thread
From: Daniel Kiper @ 2022-04-14 16:32 UTC (permalink / raw)
  To: Glenn Washburn; +Cc: grub-devel

On Sat, Apr 09, 2022 at 02:44:47AM +0000, Glenn Washburn wrote:
> Instead of "tmp" the name is prefixed by the name of the scripts (eg.
> grub-fs-tester). A timestamp is added in the name to allow for easily
> seeing a chronological sorting of runs and the name of the filesystem
> being tested. The random component is set to the minimal possible, 3
> characters, because the timestamp should provide enough uniqueness.
>
> Signed-off-by: Glenn Washburn <development@efficientek.com>
> ---
>  tests/util/grub-fs-tester.in | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/tests/util/grub-fs-tester.in b/tests/util/grub-fs-tester.in
> index 868199109f..02edcf897f 100644
> --- a/tests/util/grub-fs-tester.in
> +++ b/tests/util/grub-fs-tester.in
> @@ -7,7 +7,7 @@ fs="$1"
>
>  GRUBFSTEST="@builddir@/grub-fstest"
>
> -tempdir=`mktemp -d "${TMPDIR:-/tmp}/tmp.XXXXXXXXXX"` ||
> +tempdir=`mktemp -d "${TMPDIR:-/tmp}/${0##*/}.$(date '+%Y%m%d%H%M%S%N').${fs}.XXX"` ||

I would just s/XXX/tmp/. Otherwise LGTM...

For both patches Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>

Daniel


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 2/2] tests: Give grub-fs-tester temp directory a better name
  2022-04-14 16:32   ` Daniel Kiper
@ 2022-04-18  4:47     ` Glenn Washburn
  2022-04-26 12:35       ` Daniel Kiper
  0 siblings, 1 reply; 6+ messages in thread
From: Glenn Washburn @ 2022-04-18  4:47 UTC (permalink / raw)
  To: Daniel Kiper; +Cc: grub-devel

On 4/14/22 16:32, Daniel Kiper wrote:
> On Sat, Apr 09, 2022 at 02:44:47AM +0000, Glenn Washburn wrote:
>> Instead of "tmp" the name is prefixed by the name of the scripts (eg.
>> grub-fs-tester). A timestamp is added in the name to allow for easily
>> seeing a chronological sorting of runs and the name of the filesystem
>> being tested. The random component is set to the minimal possible, 3
>> characters, because the timestamp should provide enough uniqueness.
>>
>> Signed-off-by: Glenn Washburn <development@efficientek.com>
>> ---
>>   tests/util/grub-fs-tester.in | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/tests/util/grub-fs-tester.in b/tests/util/grub-fs-tester.in
>> index 868199109f..02edcf897f 100644
>> --- a/tests/util/grub-fs-tester.in
>> +++ b/tests/util/grub-fs-tester.in
>> @@ -7,7 +7,7 @@ fs="$1"
>>
>>   GRUBFSTEST="@builddir@/grub-fstest"
>>
>> -tempdir=`mktemp -d "${TMPDIR:-/tmp}/tmp.XXXXXXXXXX"` ||
>> +tempdir=`mktemp -d "${TMPDIR:-/tmp}/${0##*/}.$(date '+%Y%m%d%H%M%S%N').${fs}.XXX"` ||
> 
> I would just s/XXX/tmp/. Otherwise LGTM...

mktemp fails with "too few X's in template" if the minimum number of X's 
(which is 3) are not provided.

> For both patches Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
> 
> Daniel

Glenn


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 2/2] tests: Give grub-fs-tester temp directory a better name
  2022-04-18  4:47     ` Glenn Washburn
@ 2022-04-26 12:35       ` Daniel Kiper
  0 siblings, 0 replies; 6+ messages in thread
From: Daniel Kiper @ 2022-04-26 12:35 UTC (permalink / raw)
  To: Glenn Washburn; +Cc: grub-devel

On Mon, Apr 18, 2022 at 04:47:21AM +0000, Glenn Washburn wrote:
> On 4/14/22 16:32, Daniel Kiper wrote:
> > On Sat, Apr 09, 2022 at 02:44:47AM +0000, Glenn Washburn wrote:
> > > Instead of "tmp" the name is prefixed by the name of the scripts (eg.
> > > grub-fs-tester). A timestamp is added in the name to allow for easily
> > > seeing a chronological sorting of runs and the name of the filesystem
> > > being tested. The random component is set to the minimal possible, 3
> > > characters, because the timestamp should provide enough uniqueness.
> > >
> > > Signed-off-by: Glenn Washburn <development@efficientek.com>
> > > ---
> > >   tests/util/grub-fs-tester.in | 2 +-
> > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/tests/util/grub-fs-tester.in b/tests/util/grub-fs-tester.in
> > > index 868199109f..02edcf897f 100644
> > > --- a/tests/util/grub-fs-tester.in
> > > +++ b/tests/util/grub-fs-tester.in
> > > @@ -7,7 +7,7 @@ fs="$1"
> > >
> > >   GRUBFSTEST="@builddir@/grub-fstest"
> > >
> > > -tempdir=`mktemp -d "${TMPDIR:-/tmp}/tmp.XXXXXXXXXX"` ||
> > > +tempdir=`mktemp -d "${TMPDIR:-/tmp}/${0##*/}.$(date '+%Y%m%d%H%M%S%N').${fs}.XXX"` ||
> >
> > I would just s/XXX/tmp/. Otherwise LGTM...
>
> mktemp fails with "too few X's in template" if the minimum number of X's
> (which is 3) are not provided.

Ugh... Well, I should read mktemp man first. Sorry for the noise.
Applied without change...

Thank you for fixing this.

Daniel


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2022-04-26 12:36 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-04-09  2:44 [PATCH 0/2] Test improvements Glenn Washburn
2022-04-09  2:44 ` [PATCH 1/2] tests: Disable blkid cache usage Glenn Washburn
2022-04-09  2:44 ` [PATCH 2/2] tests: Give grub-fs-tester temp directory a better name Glenn Washburn
2022-04-14 16:32   ` Daniel Kiper
2022-04-18  4:47     ` Glenn Washburn
2022-04-26 12:35       ` Daniel Kiper

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.