All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v5 0/6] arm64: Cleanup ioremap() and support ioremap_prot()
@ 2022-06-07 12:50 ` Kefeng Wang
  0 siblings, 0 replies; 45+ messages in thread
From: Kefeng Wang @ 2022-06-07 12:50 UTC (permalink / raw)
  To: catalin.marinas, will, akpm, linux-arm-kernel, linux-kernel
  Cc: linux-mm, hch, arnd, anshuman.khandual, Kefeng Wang

1. Enhance generic ioremap to make it more useful.
2. Let's arm64 use GENERIC_IOREMAP to cleanup code.
3. Support HAVE_IOREMAP_PROT on arm64, which enable generic_access_phys(),
   it is useful when debug(eg, gdb) via access_process_vm device memory
   infrastructure.

v5:
- break long lines(> 80 cols), per Christoph Hellwig
- move is_vmalloc_addr() check from arm64 into generic ioremap, per
  Christoph Hellwig
- make arm64's ioremap_cache as an inline function, per Christoph
- keep changes simple, make ioremap/iounmap_allowed return bool, per
  Baoquan He
- simplify use 'void *' instead of 'void __iomem *' in iounmap, then
  drop __force annotation

v4:
- update based on v5.19-rc1
- add generic arch_ioremap/arch_iounmap define, per Andrew Monrton
- simply return an int for arch_ioremap and rename arch_ioremap/arch_iounmap
  to a better name, ioremap_allowed/iounmap_allowed, per Arnd Bergmann
- add __force annotation to slince sparse warning in vunmap() 

Note, 
1) after the renaming, the arm's change(patch1) is not the necessary
   dependence for the following changes, but as a cleanup, still post
   it here, hope it go in via the arm64 tree with reset of the series
   directly if no object.
2) the changes in this version only influence on patch4/5, so retain
   the ack/review.

v3:
- add cleanup patch to kill ARM's unused arch_iounmap(the naming will be
  used in GENERIC_IOREMAP) and add comments for arch_ioremap/arch_iounmap
  hooks, per Anshuman Khandual
- collect ack/review 

v2:
- s/addr/phys_addr in ioremap_prot, suggested by Andrew Morton 
- rename arch_ioremap/iounmap_check to arch_ioremap/iounmap
  and change return value, per Christoph Hellwig and Andrew Morton
- and use 'ifndef arch_ioremap' instead of weak function, per Arnd Bergmann
- collect ack/review

Kefeng Wang (6):
  ARM: mm: kill unused runtime hook arch_iounmap()
  mm: ioremap: Use more sensibly name in ioremap_prot()
  mm: ioremap: Setup phys_addr of struct vm_struct
  mm: ioremap: Add ioremap/iounmap_allowed()
  arm64: mm: Convert to GENERIC_IOREMAP
  arm64: Add HAVE_IOREMAP_PROT support

 .../features/vm/ioremap_prot/arch-support.txt |  2 +-
 arch/arm/include/asm/io.h                     |  4 +-
 arch/arm/mm/ioremap.c                         |  9 +-
 arch/arm/mm/nommu.c                           |  9 +-
 arch/arm64/Kconfig                            |  2 +
 arch/arm64/include/asm/io.h                   | 24 +++--
 arch/arm64/include/asm/pgtable.h              | 10 +++
 arch/arm64/kernel/acpi.c                      |  2 +-
 arch/arm64/mm/hugetlbpage.c                   | 10 ---
 arch/arm64/mm/ioremap.c                       | 90 ++-----------------
 include/asm-generic/io.h                      | 29 +++++-
 mm/ioremap.c                                  | 26 ++++--
 12 files changed, 90 insertions(+), 127 deletions(-)

-- 
2.35.3


^ permalink raw reply	[flat|nested] 45+ messages in thread

end of thread, other threads:[~2022-06-27 13:02 UTC | newest]

Thread overview: 45+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-06-07 12:50 [PATCH v5 0/6] arm64: Cleanup ioremap() and support ioremap_prot() Kefeng Wang
2022-06-07 12:50 ` Kefeng Wang
2022-06-07 12:50 ` [PATCH v5 1/6] ARM: mm: kill unused runtime hook arch_iounmap() Kefeng Wang
2022-06-07 12:50   ` Kefeng Wang
2022-06-07 15:40   ` Russell King (Oracle)
2022-06-07 15:40     ` Russell King (Oracle)
2022-06-14  5:47   ` kernel test robot
2022-06-14  5:47     ` kernel test robot
2022-06-14  6:12     ` Kefeng Wang
2022-06-14  6:12       ` Kefeng Wang
2022-06-14  6:12       ` Kefeng Wang
2022-06-07 12:50 ` [PATCH v5 2/6] mm: ioremap: Use more sensibly name in ioremap_prot() Kefeng Wang
2022-06-07 12:50   ` Kefeng Wang
2022-06-08  4:16   ` Baoquan He
2022-06-08  4:16     ` Baoquan He
2022-06-08  7:22     ` Baoquan He
2022-06-08  7:22       ` Baoquan He
2022-06-08  6:09   ` Christoph Hellwig
2022-06-08  6:09     ` Christoph Hellwig
2022-06-08  7:04   ` Baoquan He
2022-06-08  7:04     ` Baoquan He
2022-06-10  9:22   ` [PATCH v5 resend 2/6] mm: ioremap: Use more sensible " Kefeng Wang
2022-06-10  9:22     ` Kefeng Wang
2022-06-07 12:50 ` [PATCH v5 3/6] mm: ioremap: Setup phys_addr of struct vm_struct Kefeng Wang
2022-06-07 12:50   ` Kefeng Wang
2022-06-07 12:50 ` [PATCH v5 4/6] mm: ioremap: Add ioremap/iounmap_allowed() Kefeng Wang
2022-06-07 12:50   ` Kefeng Wang
2022-06-08  4:18   ` Baoquan He
2022-06-08  4:18     ` Baoquan He
2022-06-08  6:10   ` Christoph Hellwig
2022-06-08  6:10     ` Christoph Hellwig
2022-06-07 12:50 ` [PATCH v5 5/6] arm64: mm: Convert to GENERIC_IOREMAP Kefeng Wang
2022-06-07 12:50   ` Kefeng Wang
2022-06-07 12:50 ` [PATCH v5 6/6] arm64: Add HAVE_IOREMAP_PROT support Kefeng Wang
2022-06-07 12:50   ` Kefeng Wang
2022-06-14  3:21 ` [PATCH v5 0/6] arm64: Cleanup ioremap() and support ioremap_prot() Kefeng Wang
2022-06-14  3:21   ` Kefeng Wang
2022-06-27 11:06   ` Kefeng Wang
2022-06-27 11:06     ` Kefeng Wang
2022-06-27 11:14     ` Will Deacon
2022-06-27 11:14       ` Will Deacon
2022-06-27 11:19       ` Kefeng Wang
2022-06-27 11:19         ` Kefeng Wang
2022-06-27 13:00 ` Will Deacon
2022-06-27 13:00   ` Will Deacon

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.