All of lore.kernel.org
 help / color / mirror / Atom feed
* [GIT PULL] omapdrm changes for v4.13 v2
@ 2017-06-02  8:48 Tomi Valkeinen
  2017-06-03  1:31 ` Dave Airlie
  0 siblings, 1 reply; 3+ messages in thread
From: Tomi Valkeinen @ 2017-06-02  8:48 UTC (permalink / raw)
  To: Dave Airlie, DRI Development; +Cc: Laurent Pinchart


[-- Attachment #1.1.1: Type: text/plain, Size: 7683 bytes --]

Hi Dave,

Here's second attempt for omapdrm changes for v4.13. The first version conflicts
with the latest drm-next due to the DRM_ROTATE flag changes. This one is rebased
on top of the latest drm-next.

 Tomi


The following changes since commit 2a1720376adda5ecf8e636fbfb05339c7dad1c55:

  Backmerge tag 'v4.12-rc3' into drm-next (2017-05-30 15:54:15 +1000)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/tomba/linux.git tags/omapdrm-4.13-v2

for you to fetch changes up to cc8dd7661ccc2d8dc88921da8e6cc7c2fcdb0341:

  drm/omap: fix tiled buffer stride calculations (2017-06-02 11:09:34 +0300)

----------------------------------------------------------------
omapdrm changes for v4.13

* dmabuf fence support
* TILER rotation fixes
* big pile of various cleanups and refactorings

----------------------------------------------------------------
Laurent Pinchart (24):
      drm: omapdrm: Handle events when enabling/disabling CRTCs
      drm: omapdrm: Use DRM core's atomic commit helper
      drm: omapdrm: Remove legacy buffer synchronization support
      drm: omapdrm: Store the Z order in the plane state zpos field
      drm: omapdrm: Remove custom plane state
      drm: omapdrm: Add zpos property
      drm: omapdrm: Remove remap argument to omap_gem_get_paddr()
      drm: omapdrm: Rename occurrences of paddr to dma_addr
      drm: omapdrm: Rename omap_gem_(get|put)_paddr() to omap_gem_(un)pin()
      drm: omapdrm: Lower indentation level in omap_gem_dma_sync_buffer()
      drm: omapdrm: Rename the omap_gem_object addrs field to dma_addrs
      drm: omapdrm: Rename GEM DMA sync functions
      drm: omapdrm: Fix incorrect usage of the term 'cache coherency'
      drm: omapdrm: DMA-unmap pages for all buffer types when freeing buffers
      drm: omapdrm: Map pages for DMA in DMA_TO_DEVICE direction
      drm: omapdrm: Take GEM object reference when exporting dmabuf
      drm: omapdrm: Remove duplicate error messages when mapping memory
      drm: omapdrm: Drop support for non-DT devices
      drm: omapdrm: Remove unused dss_get_core_pdev() function
      drm: omapdrm: Remove unused default display name support
      drm: omapdrm: Infer the OMAP version from the SoC family
      drm: omapdrm: dpi: Remove platform driver
      drm: omapdrm: sdi: Remove platform driver
      drm/omap: Remove unused omap_dss_find_output() function

Tomi Valkeinen (40):
      drm/omap: add new connector types
      drm/omap: remove unused ovl_enabled()
      drm/omap: remove ovl_set_channel_out
      drm/omap: remove read_irqenable()
      drm/omap: 64bit compile fixes
      drm/omap: define compat_ioctl
      drm/omap: panel-dpi: remove non-DT support
      drm/omap: acx565akm: remove non-DT support
      drm/omap: connector-analog-tv: remove non-DT support
      drm/omap: connector-dvi/hdmi: remove extra include
      drm/omap: sdi: remove legacy set_datapairs
      drm/omap: venc: remove set_type & invert_vid_out_polarity
      drm/omap: remove recommended_bpp
      drm/omap: dpi: remove legacy data_lines
      drm/omap: remove rfbi
      drm/omap: remove unused get_dimensions()
      drm/omap: remove legacy get_resolution
      drm/omap: remove unused fields
      drm/omap: remove omap_overlay & omap_overlay_manager
      drm/omap: fix setting & clearing DOUBLESTRIDE
      drm/omap: remove CLUT
      drm/omap: ratelimit OCP error
      drm/omap: remove dma & vrfb rotation
      drm/omap: cleanup offset calculation
      drm/omap: add format_is_yuv() helper
      drm/omap: remove unneeded prototypes
      drm/omap: change supported_modes to an array
      drm/omap: use u32 instead of enum omap_color_mode
      drm/omap: use DRM_FORMAT_* instead of OMAP_DSS_COLOR_*
      drm/omap: remove omap_framebuffer_get_formats()
      drm/omap: cleanup formats array
      drm/omap: rename color_mode to fourcc
      drm/omap: add drm_rotation_to_tiler helper()
      drm/omap: remove omap_drm_win
      drm/omap: use DRM_MODE_ROTATE_* instead of OMAP_DSS_ROT_*
      drm/omap: DRM_MODE_REFLECT_* instead of mirror boolean
      drm/omap: pass rotation to dispc
      drm/omap: fix YUV422 rotation with TILER
      drm/omap: fix YUV422 90/270 rotation with mirroring
      drm/omap: fix tiled buffer stride calculations

 .../gpu/drm/omapdrm/displays/connector-analog-tv.c |   51 +-
 drivers/gpu/drm/omapdrm/displays/connector-dvi.c   |    3 -
 drivers/gpu/drm/omapdrm/displays/connector-hdmi.c  |    3 -
 drivers/gpu/drm/omapdrm/displays/encoder-opa362.c  |   10 -
 drivers/gpu/drm/omapdrm/displays/encoder-tfp410.c  |    4 -
 drivers/gpu/drm/omapdrm/displays/panel-dpi.c       |   83 +-
 drivers/gpu/drm/omapdrm/displays/panel-dsi-cm.c    |   10 -
 .../omapdrm/displays/panel-lgphilips-lb035q02.c    |    7 -
 .../drm/omapdrm/displays/panel-nec-nl8048hl11.c    |    6 -
 .../drm/omapdrm/displays/panel-sharp-ls037v7dw01.c |    7 -
 .../drm/omapdrm/displays/panel-sony-acx565akm.c    |   49 +-
 .../drm/omapdrm/displays/panel-tpo-td028ttec1.c    |    5 -
 .../drm/omapdrm/displays/panel-tpo-td043mtea1.c    |    6 -
 drivers/gpu/drm/omapdrm/dss/Kconfig                |   13 -
 drivers/gpu/drm/omapdrm/dss/Makefile               |    1 -
 drivers/gpu/drm/omapdrm/dss/core.c                 |   41 -
 drivers/gpu/drm/omapdrm/dss/dispc.c                |  707 ++++---------
 drivers/gpu/drm/omapdrm/dss/display.c              |   62 +-
 drivers/gpu/drm/omapdrm/dss/dpi.c                  |  106 --
 drivers/gpu/drm/omapdrm/dss/dsi.c                  |  118 +--
 drivers/gpu/drm/omapdrm/dss/dss.c                  |   14 +-
 drivers/gpu/drm/omapdrm/dss/dss.h                  |   11 -
 drivers/gpu/drm/omapdrm/dss/dss_features.c         |  179 ++--
 drivers/gpu/drm/omapdrm/dss/dss_features.h         |    6 +-
 drivers/gpu/drm/omapdrm/dss/hdmi4.c                |    8 +-
 drivers/gpu/drm/omapdrm/dss/hdmi4_core.c           |    9 +-
 drivers/gpu/drm/omapdrm/dss/hdmi5.c                |    8 +-
 drivers/gpu/drm/omapdrm/dss/hdmi5_core.c           |    9 +-
 drivers/gpu/drm/omapdrm/dss/hdmi_phy.c             |    9 +-
 drivers/gpu/drm/omapdrm/dss/hdmi_pll.c             |    9 +-
 drivers/gpu/drm/omapdrm/dss/hdmi_wp.c              |   12 +-
 drivers/gpu/drm/omapdrm/dss/omapdss.h              |  226 +---
 drivers/gpu/drm/omapdrm/dss/output.c               |   13 -
 drivers/gpu/drm/omapdrm/dss/rfbi.c                 | 1083 --------------------
 drivers/gpu/drm/omapdrm/dss/sdi.c                  |   61 --
 drivers/gpu/drm/omapdrm/dss/venc.c                 |   53 +-
 drivers/gpu/drm/omapdrm/dss/video-pll.c            |   20 +-
 drivers/gpu/drm/omapdrm/omap_crtc.c                |   30 +-
 drivers/gpu/drm/omapdrm/omap_dmm_tiler.c           |    2 +-
 drivers/gpu/drm/omapdrm/omap_drv.c                 |  191 +---
 drivers/gpu/drm/omapdrm/omap_drv.h                 |   41 +-
 drivers/gpu/drm/omapdrm/omap_fb.c                  |  201 ++--
 drivers/gpu/drm/omapdrm/omap_fbdev.c               |   15 +-
 drivers/gpu/drm/omapdrm/omap_gem.c                 |  429 +++-----
 drivers/gpu/drm/omapdrm/omap_gem_dmabuf.c          |   36 +-
 drivers/gpu/drm/omapdrm/omap_irq.c                 |    8 +-
 drivers/gpu/drm/omapdrm/omap_plane.c               |  126 +--
 drivers/video/fbdev/omap2/omapfb/dss/core.c        |    2 -
 include/linux/platform_data/omapdss.h              |    1 -
 include/uapi/drm/omap_drm.h                        |    4 +-
 50 files changed, 705 insertions(+), 3403 deletions(-)
 delete mode 100644 drivers/gpu/drm/omapdrm/dss/rfbi.c


[-- Attachment #1.2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

[-- Attachment #2: Type: text/plain, Size: 160 bytes --]

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [GIT PULL] omapdrm changes for v4.13 v2
  2017-06-02  8:48 [GIT PULL] omapdrm changes for v4.13 v2 Tomi Valkeinen
@ 2017-06-03  1:31 ` Dave Airlie
  2017-06-05  6:34   ` Tomi Valkeinen
  0 siblings, 1 reply; 3+ messages in thread
From: Dave Airlie @ 2017-06-03  1:31 UTC (permalink / raw)
  To: Tomi Valkeinen; +Cc: DRI Development, Laurent Pinchart

On 2 June 2017 at 18:48, Tomi Valkeinen <tomi.valkeinen@ti.com> wrote:
> Hi Dave,
>
> Here's second attempt for omapdrm changes for v4.13. The first version conflicts
> with the latest drm-next due to the DRM_ROTATE flag changes. This one is rebased
> on top of the latest drm-next.

As much as I dislike rebases (hope you tested), I did try and pull the
original yesterday, saw conflict nightmare, and held off until I had
more brain bandwidth to look. Thanks for providing a clean pull in the
meantime, read my mind!

Dave.
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [GIT PULL] omapdrm changes for v4.13 v2
  2017-06-03  1:31 ` Dave Airlie
@ 2017-06-05  6:34   ` Tomi Valkeinen
  0 siblings, 0 replies; 3+ messages in thread
From: Tomi Valkeinen @ 2017-06-05  6:34 UTC (permalink / raw)
  To: Dave Airlie; +Cc: DRI Development, Laurent Pinchart


[-- Attachment #1.1.1: Type: text/plain, Size: 1116 bytes --]

On 03/06/17 04:31, Dave Airlie wrote:
> On 2 June 2017 at 18:48, Tomi Valkeinen <tomi.valkeinen@ti.com> wrote:
>> Hi Dave,
>>
>> Here's second attempt for omapdrm changes for v4.13. The first version conflicts
>> with the latest drm-next due to the DRM_ROTATE flag changes. This one is rebased
>> on top of the latest drm-next.
> 
> As much as I dislike rebases (hope you tested), I did try and pull the
> original yesterday, saw conflict nightmare, and held off until I had
> more brain bandwidth to look. Thanks for providing a clean pull in the
> meantime, read my mind!

Yes, the conflict was quite messy. Of course there had to be a
DRM_ROTATE flag rename just at the same time when I did a major rotate
rework for omapdrm =).

I guess you could pull the first version, and solve the conflict by
taking the omapdrm code from the second pull request. But, while I also
dislike rebases like this (yes, I tested and compared the diff to the
first pull request), I'm not sure if that would buy us much.

In any case, I'll do a second round of testing when the pull is in drm-next.

 Tomi


[-- Attachment #1.2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

[-- Attachment #2: Type: text/plain, Size: 160 bytes --]

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2017-06-05  6:35 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-06-02  8:48 [GIT PULL] omapdrm changes for v4.13 v2 Tomi Valkeinen
2017-06-03  1:31 ` Dave Airlie
2017-06-05  6:34   ` Tomi Valkeinen

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.