All of lore.kernel.org
 help / color / mirror / Atom feed
From: Marcus Wolf <marcus.wolf@smarthome-wolf.de>
To: "Simon Sandström" <simon@nikanor.nu>, gregkh@linuxfoundation.org
Cc: linux@Wolf-Entwicklungen.de, devel@driverdev.osuosl.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 06/11] staging: pi433: Split rf69_set_crc_enabled into two functions
Date: Wed, 6 Dec 2017 11:05:22 +0200	[thread overview]
Message-ID: <d8308dc7-f9da-f01e-de39-59780603f879@smarthome-wolf.de> (raw)
In-Reply-To: <20171205220849.5486-7-simon@nikanor.nu>



Am 06.12.2017 um 00:08 schrieb Simon Sandström:
> Splits rf69_set_crc_enabled(dev, enabled) into
> rf69_enable_crc(dev) and rf69_disable_crc(dev).
> 
> Signed-off-by: Simon Sandström <simon@nikanor.nu>
> ---
>   drivers/staging/pi433/pi433_if.c | 22 ++++++++++++++++++++--
>   drivers/staging/pi433/rf69.c     | 18 ++++++------------
>   drivers/staging/pi433/rf69.h     |  4 ++--
>   3 files changed, 28 insertions(+), 16 deletions(-)
> 
> diff --git a/drivers/staging/pi433/pi433_if.c b/drivers/staging/pi433/pi433_if.c
> index 2ae19ac565d1..614eec7dd904 100644
> --- a/drivers/staging/pi433/pi433_if.c
> +++ b/drivers/staging/pi433/pi433_if.c
> @@ -216,7 +216,16 @@ rf69_set_rx_cfg(struct pi433_device *dev, struct pi433_rx_cfg *rx_cfg)
>   			return ret;
>   	}
>   	SET_CHECKED(rf69_set_adressFiltering(dev->spi, rx_cfg->enable_address_filtering));
> -	SET_CHECKED(rf69_set_crc_enable	    (dev->spi, rx_cfg->enable_crc));
> +
> +	if (rx_cfg->enable_crc == OPTION_ON) {
> +		ret = rf69_enable_crc(dev->spi);
> +		if (ret < 0)
> +			return ret;
> +	} else {
> +		ret = rf69_disable_crc(dev->spi);
> +		if (ret < 0)
> +			return ret;
> +	}

Why don't you use SET_CHECKED(...)?

I stil don't like this kind of changes - and not using SET_CHECKED makes 
it even worse, since that further increases code length.

The idea was to have the configuration as compact, as you can see in the 
receiver config section. It's a pitty that the packet config already 
needs such a huge number of exceptions due to technical reasons. We 
shouldn't further extend the numbers of exceptions and shouldn't extend 
the number of lines for setting a reg.

Initially this function was just like
set_rx_cfg()
{
     SET_CHECKED(...)
     SET_CHECKED(...)
     SET_CHECKED(...)
     SET_CHECKED(...)
}

It should be easy,
* to survey, which chip settings are touched, if set_rx_cfg is called.
* to survey, that all params of the rx_cfg struct are taken care of.

The longer the function gets, the harder it is, to service it.
I really would be happy, if we don't go this way.


Anyway, please keep the naming convention of rf69.c:

rf69 -set/get - action
-> rf69_set_crc_enable

Thanks,

Marcus

  reply	other threads:[~2017-12-06  9:05 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-12-05 22:08 [PATCH v2 00/11] Fix indentation and CamelCase issue in staging/pi433 Simon Sandström
2017-12-05 22:08 ` [PATCH v2 01/11] staging: pi433: Fix indentation in rf69_enum.h Simon Sandström
2017-12-05 22:08 ` [PATCH v2 02/11] staging: pi433: Capitalize constant definitions Simon Sandström
2017-12-05 22:08 ` [PATCH v2 03/11] staging: pi433: Rename variable in struct pi433_rx_cfg Simon Sandström
2017-12-05 22:08 ` [PATCH v2 04/11] staging: pi433: Rename enum optionOnOff in rf69_enum.h Simon Sandström
2017-12-06  9:46   ` Marcus Wolf
2017-12-06 10:23     ` Dan Carpenter
2017-12-06 10:31       ` Marcus Wolf
2017-12-06 10:44         ` Dan Carpenter
2017-12-06 11:07           ` Marcus Wolf
2017-12-06 19:57           ` Simon Sandström
2017-12-06 22:17             ` Marcus Wolf
2017-12-07  9:41               ` Dan Carpenter
2017-12-05 22:08 ` [PATCH v2 05/11] staging: pi433: Rename enum modShaping " Simon Sandström
2017-12-05 22:08 ` [PATCH v2 06/11] staging: pi433: Split rf69_set_crc_enabled into two functions Simon Sandström
2017-12-06  9:05   ` Marcus Wolf [this message]
2017-12-06  9:37     ` Dan Carpenter
2017-12-06 10:07       ` Marcus Wolf
2017-12-06 15:11         ` Greg KH
2017-12-06 10:36       ` Marcus Wolf
2017-12-06 15:16   ` Greg KH
2017-12-06 20:27     ` Simon Sandström
2017-12-05 22:08 ` [PATCH v2 07/11] staging: pi433: Split rf69_set_sync_enabled " Simon Sandström
2017-12-05 22:08 ` [PATCH v2 08/11] staging: pi433: Remove enum data_mode Simon Sandström
2017-12-06  9:11   ` Marcus Wolf
2017-12-06 12:47     ` Dan Carpenter
2017-12-07  9:47       ` staging: pi433: Plans from Smarthome-Wolf Marcus Wolf
2017-12-05 22:08 ` [PATCH v2 09/11] staging: pi433: Combine all rf69_set_amplifier_x() Simon Sandström
2017-12-06  9:43   ` Marcus Wolf
2017-12-05 22:08 ` [PATCH v2 10/11] staging: pi433: Move enum option_on_off to pi433_if.h Simon Sandström
2017-12-05 22:08 ` [PATCH v2 11/11] staging: pi433: Remove SET_CHECKED usage from pi433_probe Simon Sandström

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d8308dc7-f9da-f01e-de39-59780603f879@smarthome-wolf.de \
    --to=marcus.wolf@smarthome-wolf.de \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@Wolf-Entwicklungen.de \
    --cc=simon@nikanor.nu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.