All of lore.kernel.org
 help / color / mirror / Atom feed
From: Nikolay Aleksandrov <razor@blackwall.org>
To: Petr Machata <petrm@nvidia.com>,
	"David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
	Roopa Prabhu <roopa@nvidia.com>,
	netdev@vger.kernel.org
Cc: bridge@lists.linux-foundation.org, Ido Schimmel <idosch@nvidia.com>
Subject: Re: [PATCH net-next 12/16] selftests: forwarding: lib: Add helpers for checksum handling
Date: Sun, 29 Jan 2023 12:10:22 +0200	[thread overview]
Message-ID: <dbcb7016-2473-0586-b6e2-2a42fca2b7f7@blackwall.org> (raw)
In-Reply-To: <3ca0fe4de1f701befbc874e4b672c90aee602199.1674752051.git.petrm@nvidia.com>

On 26/01/2023 19:01, Petr Machata wrote:
> In order to generate IGMPv3 and MLDv2 packets on the fly, we will need
> helpers to calculate the packet checksum.
> 
> The approach presented in this patch revolves around payload templates
> for mausezahn. These are mausezahn-like payload strings (01:23:45:...)
> with possibly one 2-byte sequence replaced with the word PAYLOAD. The
> main function is payload_template_calc_checksum(), which calculates
> RFC 1071 checksum of the message. There are further helpers to then
> convert the checksum to the payload format, and to expand it.
> 
> For IPv6, MLDv2 message checksum is computed using a pseudoheader that
> differs from the header used in the payload itself. The fact that the
> two messages are different means that the checksum needs to be
> returned as a separate quantity, instead of being expanded in-place in
> the payload itself. Furthermore, the pseudoheader includes a length of
> the message. Much like the checksum, this needs to be expanded in
> mausezahn format. And likewise for number of addresses for (S,G)
> entries. Thus we have several places where a computed quantity needs
> to be presented in the payload format. Add a helper u16_to_bytes(),
> which will be used in all these cases.
> 
> Signed-off-by: Petr Machata <petrm@nvidia.com>
> ---
>  tools/testing/selftests/net/forwarding/lib.sh | 56 +++++++++++++++++++
>  1 file changed, 56 insertions(+)
> 

Acked-by: Nikolay Aleksandrov <razor@blackwall.org>



WARNING: multiple messages have this Message-ID (diff)
From: Nikolay Aleksandrov <razor@blackwall.org>
To: Petr Machata <petrm@nvidia.com>,
	"David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
	Roopa Prabhu <roopa@nvidia.com>,
	netdev@vger.kernel.org
Cc: Ido Schimmel <idosch@nvidia.com>, bridge@lists.linux-foundation.org
Subject: Re: [Bridge] [PATCH net-next 12/16] selftests: forwarding: lib: Add helpers for checksum handling
Date: Sun, 29 Jan 2023 12:10:22 +0200	[thread overview]
Message-ID: <dbcb7016-2473-0586-b6e2-2a42fca2b7f7@blackwall.org> (raw)
In-Reply-To: <3ca0fe4de1f701befbc874e4b672c90aee602199.1674752051.git.petrm@nvidia.com>

On 26/01/2023 19:01, Petr Machata wrote:
> In order to generate IGMPv3 and MLDv2 packets on the fly, we will need
> helpers to calculate the packet checksum.
> 
> The approach presented in this patch revolves around payload templates
> for mausezahn. These are mausezahn-like payload strings (01:23:45:...)
> with possibly one 2-byte sequence replaced with the word PAYLOAD. The
> main function is payload_template_calc_checksum(), which calculates
> RFC 1071 checksum of the message. There are further helpers to then
> convert the checksum to the payload format, and to expand it.
> 
> For IPv6, MLDv2 message checksum is computed using a pseudoheader that
> differs from the header used in the payload itself. The fact that the
> two messages are different means that the checksum needs to be
> returned as a separate quantity, instead of being expanded in-place in
> the payload itself. Furthermore, the pseudoheader includes a length of
> the message. Much like the checksum, this needs to be expanded in
> mausezahn format. And likewise for number of addresses for (S,G)
> entries. Thus we have several places where a computed quantity needs
> to be presented in the payload format. Add a helper u16_to_bytes(),
> which will be used in all these cases.
> 
> Signed-off-by: Petr Machata <petrm@nvidia.com>
> ---
>  tools/testing/selftests/net/forwarding/lib.sh | 56 +++++++++++++++++++
>  1 file changed, 56 insertions(+)
> 

Acked-by: Nikolay Aleksandrov <razor@blackwall.org>



  reply	other threads:[~2023-01-29 10:10 UTC|newest]

Thread overview: 90+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-26 17:01 [PATCH net-next 00/16] bridge: Limit number of MDB entries per port, port-vlan Petr Machata
2023-01-26 17:01 ` [Bridge] " Petr Machata
2023-01-26 17:01 ` [PATCH net-next 01/16] net: bridge: Set strict_start_type at two policies Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-26 19:18   ` Stephen Hemminger
2023-01-26 19:18     ` [Bridge] " Stephen Hemminger
2023-01-26 20:27     ` Nikolay Aleksandrov
2023-01-26 20:27       ` [Bridge] " Nikolay Aleksandrov
2023-01-29  9:09   ` Nikolay Aleksandrov
2023-01-29  9:09     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 02/16] net: bridge: Add extack to br_multicast_new_port_group() Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29  9:09   ` Nikolay Aleksandrov
2023-01-29  9:09     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 03/16] net: bridge: Move extack-setting " Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29  9:09   ` Nikolay Aleksandrov
2023-01-29  9:09     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 04/16] net: bridge: Add br_multicast_del_port_group() Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29  9:11   ` Nikolay Aleksandrov
2023-01-29  9:11     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 05/16] net: bridge: Change a cleanup in br_multicast_new_port_group() to goto Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29  9:11   ` Nikolay Aleksandrov
2023-01-29  9:11     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 06/16] net: bridge: Add a tracepoint for MDB overflows Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-26 17:53   ` Steven Rostedt
2023-01-26 17:53     ` [Bridge] " Steven Rostedt
2023-01-27 14:29     ` Petr Machata
2023-01-27 14:29       ` [Bridge] " Petr Machata
2023-01-30 15:50     ` Petr Machata
2023-01-30 15:50       ` [Bridge] " Petr Machata
2023-01-30 23:23       ` Steven Rostedt
2023-01-30 23:23         ` [Bridge] " Steven Rostedt
2023-01-26 17:01 ` [PATCH net-next 07/16] net: bridge: Maintain number of MDB entries in net_bridge_mcast_port Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29  9:40   ` Nikolay Aleksandrov
2023-01-29  9:40     ` [Bridge] " Nikolay Aleksandrov
2023-01-29 16:55   ` Nikolay Aleksandrov
2023-01-29 16:55     ` [Bridge] " Nikolay Aleksandrov
2023-01-30  8:08     ` Ido Schimmel
2023-01-30  8:08       ` [Bridge] " Ido Schimmel
2023-01-30  8:56       ` Nikolay Aleksandrov
2023-01-30  8:56         ` [Bridge] " Nikolay Aleksandrov
2023-01-30 15:02     ` Petr Machata
2023-01-30 15:02       ` [Bridge] " Petr Machata
2023-01-26 17:01 ` [PATCH net-next 08/16] net: bridge: Add netlink knobs for number / maximum MDB entries Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:07   ` Nikolay Aleksandrov
2023-01-29 10:07     ` [Bridge] " Nikolay Aleksandrov
2023-01-29 14:58     ` Ido Schimmel
2023-01-29 14:58       ` [Bridge] " Ido Schimmel
2023-01-30 11:07     ` Petr Machata
2023-01-30 11:07       ` [Bridge] " Petr Machata
2023-01-26 17:01 ` [PATCH net-next 09/16] selftests: forwarding: Move IGMP- and MLD-related functions to lib Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:08   ` Nikolay Aleksandrov
2023-01-29 10:08     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 10/16] selftests: forwarding: bridge_mdb: Fix a typo Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:09   ` Nikolay Aleksandrov
2023-01-29 10:09     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 11/16] selftests: forwarding: lib: Add helpers for IP address handling Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:09   ` Nikolay Aleksandrov
2023-01-29 10:09     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 12/16] selftests: forwarding: lib: Add helpers for checksum handling Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:10   ` Nikolay Aleksandrov [this message]
2023-01-29 10:10     ` Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 13/16] selftests: forwarding: lib: Parameterize IGMPv3/MLDv2 generation Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:10   ` Nikolay Aleksandrov
2023-01-29 10:10     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 14/16] selftests: forwarding: lib: Allow list of IPs for IGMPv3/MLDv2 Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:11   ` Nikolay Aleksandrov
2023-01-29 10:11     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 15/16] selftests: forwarding: lib: Add helpers to build IGMP/MLD leave packets Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:11   ` Nikolay Aleksandrov
2023-01-29 10:11     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 17:01 ` [PATCH net-next 16/16] selftests: forwarding: bridge_mdb_max: Add a new selftest Petr Machata
2023-01-26 17:01   ` [Bridge] " Petr Machata
2023-01-29 10:12   ` Nikolay Aleksandrov
2023-01-29 10:12     ` [Bridge] " Nikolay Aleksandrov
2023-01-26 20:28 ` [PATCH net-next 00/16] bridge: Limit number of MDB entries per port, port-vlan Nikolay Aleksandrov
2023-01-26 20:28   ` [Bridge] " Nikolay Aleksandrov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=dbcb7016-2473-0586-b6e2-2a42fca2b7f7@blackwall.org \
    --to=razor@blackwall.org \
    --cc=bridge@lists.linux-foundation.org \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=idosch@nvidia.com \
    --cc=kuba@kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    --cc=petrm@nvidia.com \
    --cc=roopa@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.