All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] scripts/add_maintainers.pl: add -o as an alternative to --patchdir
@ 2022-04-21 14:35 Elliott Mitchell
  2022-04-22  5:18 ` Juergen Gross
  0 siblings, 1 reply; 2+ messages in thread
From: Elliott Mitchell @ 2022-04-21 14:35 UTC (permalink / raw)
  To: xen-devel
  Cc: Andrew Cooper, George Dunlap, Jan Beulich, Julien Grall,
	Stefano Stabellini, Wei Liu

This matches the output directory option used by `git format-patch`.  I
suspect I'm not the only one who finds matching `git format-patch` more
intuitive, than -d for directory.

Signed-off-by: Elliott Mitchell <ehem+xen@m5p.com>
---
 scripts/add_maintainers.pl | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/scripts/add_maintainers.pl b/scripts/add_maintainers.pl
index 5a6d0f631b..380e8da22a 100755
--- a/scripts/add_maintainers.pl
+++ b/scripts/add_maintainers.pl
@@ -32,7 +32,7 @@ $get_maintainer =~ s/add_maintainers/get_maintainer/;
 my $usage = <<EOT;
 OPTIONS:
 --------
-USAGE: $tool [options] (--patchdir | -d) <patchdir>
+USAGE: $tool [options] (--patchdir | -d | -o) <patchdir>
 
   --reroll-count <n> | -v <n>
     Choose patch files for specific version. This results into the
@@ -223,7 +223,7 @@ my $patch_ext           = ".patch";
 my $maintainers         = "MAINTAINERS";
 
 if (!GetOptions(
-                'd|patchdir=s'     => \$patch_dir,
+                'd|o|patchdir=s'   => \$patch_dir,
                 'v|reroll-count=i' => \$rerollcount,
                 'p|patchcc=s'      => \$plocation,
                 'c|covercc=s'      => \$clocation,
-- 
2.30.2



^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] scripts/add_maintainers.pl: add -o as an alternative to --patchdir
  2022-04-21 14:35 [PATCH] scripts/add_maintainers.pl: add -o as an alternative to --patchdir Elliott Mitchell
@ 2022-04-22  5:18 ` Juergen Gross
  0 siblings, 0 replies; 2+ messages in thread
From: Juergen Gross @ 2022-04-22  5:18 UTC (permalink / raw)
  To: Elliott Mitchell, xen-devel
  Cc: Andrew Cooper, George Dunlap, Jan Beulich, Julien Grall,
	Stefano Stabellini, Wei Liu


[-- Attachment #1.1.1: Type: text/plain, Size: 377 bytes --]

On 21.04.22 16:35, Elliott Mitchell wrote:
> This matches the output directory option used by `git format-patch`.  I
> suspect I'm not the only one who finds matching `git format-patch` more
> intuitive, than -d for directory.

Thank you for doing that!

> Signed-off-by: Elliott Mitchell <ehem+xen@m5p.com>

Reviewed-by: Juergen Gross <jgross@suse.com>


Juergen

[-- Attachment #1.1.2: OpenPGP public key --]
[-- Type: application/pgp-keys, Size: 3149 bytes --]

[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 495 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2022-04-22  5:19 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-04-21 14:35 [PATCH] scripts/add_maintainers.pl: add -o as an alternative to --patchdir Elliott Mitchell
2022-04-22  5:18 ` Juergen Gross

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.