All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2] staging: greybus: power_supply: use struct_size() helper
@ 2019-04-17 18:44 Gustavo A. R. Silva
  2019-04-18  6:27 ` Johan Hovold
  2019-04-18  8:59 ` Rui Miguel Silva
  0 siblings, 2 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2019-04-17 18:44 UTC (permalink / raw)
  To: Rui Miguel Silva, Johan Hovold, Alex Elder, Greg Kroah-Hartman
  Cc: greybus-dev, devel, linux-kernel, Gustavo A. R. Silva

Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes, in particular in the
context in which this code is being used.

So, replace code of the following form:

sizeof(*resp) + props_count * sizeof(struct gb_power_supply_props_desc)

with:

struct_size(resp, props, props_count)

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
---
Changes in v2:
 - Rebase on top of 47830c1127ef ("staging: greybus: power_supply: fix prop-descriptor request size")

 drivers/staging/greybus/power_supply.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/greybus/power_supply.c b/drivers/staging/greybus/power_supply.c
index ae5c0285a942..34b40a409ea3 100644
--- a/drivers/staging/greybus/power_supply.c
+++ b/drivers/staging/greybus/power_supply.c
@@ -520,8 +520,8 @@ static int gb_power_supply_prop_descriptors_get(struct gb_power_supply *gbpsy)
 
 	op = gb_operation_create(connection,
 				 GB_POWER_SUPPLY_TYPE_GET_PROP_DESCRIPTORS,
-				 sizeof(*req), sizeof(*resp) + props_count *
-				 sizeof(struct gb_power_supply_props_desc),
+				 sizeof(*req),
+				 struct_size(resp, props, props_count),
 				 GFP_KERNEL);
 	if (!op)
 		return -ENOMEM;
-- 
2.21.0


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] staging: greybus: power_supply: use struct_size() helper
  2019-04-17 18:44 [PATCH v2] staging: greybus: power_supply: use struct_size() helper Gustavo A. R. Silva
@ 2019-04-18  6:27 ` Johan Hovold
  2019-04-18 14:26   ` Gustavo A. R. Silva
  2019-04-18  8:59 ` Rui Miguel Silva
  1 sibling, 1 reply; 4+ messages in thread
From: Johan Hovold @ 2019-04-18  6:27 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Rui Miguel Silva, Johan Hovold, Alex Elder, Greg Kroah-Hartman,
	greybus-dev, devel, linux-kernel

On Wed, Apr 17, 2019 at 01:44:40PM -0500, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
> 
> So, replace code of the following form:
> 
> sizeof(*resp) + props_count * sizeof(struct gb_power_supply_props_desc)
> 
> with:
> 
> struct_size(resp, props, props_count)
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
> ---
> Changes in v2:
>  - Rebase on top of 47830c1127ef ("staging: greybus: power_supply: fix prop-descriptor request size")

Thanks for rebasing.

Reviewed-by: Johan Hovold <johan@kernel.org>

Johan

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] staging: greybus: power_supply: use struct_size() helper
  2019-04-17 18:44 [PATCH v2] staging: greybus: power_supply: use struct_size() helper Gustavo A. R. Silva
  2019-04-18  6:27 ` Johan Hovold
@ 2019-04-18  8:59 ` Rui Miguel Silva
  1 sibling, 0 replies; 4+ messages in thread
From: Rui Miguel Silva @ 2019-04-18  8:59 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Johan Hovold, Alex Elder, Greg Kroah-Hartman, greybus-dev, devel,
	linux-kernel

Oi Gustavo,
Thanks for the patch, and the rebasing.

On Wed 17 Apr 2019 at 19:44, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded 
> version
> in order to avoid any potential type mistakes, in particular in 
> the
> context in which this code is being used.
>
> So, replace code of the following form:
>
> sizeof(*resp) + props_count * sizeof(struct 
> gb_power_supply_props_desc)
>
> with:
>
> struct_size(resp, props, props_count)
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>

Reviewed-by: Rui Miguel Silva <rmfrfs@gmail.com>

---
Cheers,
	Rui


> ---
> Changes in v2:
>  - Rebase on top of 47830c1127ef ("staging: greybus: 
>  power_supply: fix prop-descriptor request size")
>
>  drivers/staging/greybus/power_supply.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/greybus/power_supply.c 
> b/drivers/staging/greybus/power_supply.c
> index ae5c0285a942..34b40a409ea3 100644
> --- a/drivers/staging/greybus/power_supply.c
> +++ b/drivers/staging/greybus/power_supply.c
> @@ -520,8 +520,8 @@ static int 
> gb_power_supply_prop_descriptors_get(struct gb_power_supply 
> *gbpsy)
>  
>  	op = gb_operation_create(connection,
>  				 GB_POWER_SUPPLY_TYPE_GET_PROP_DESCRIPTORS,
> -				 sizeof(*req), sizeof(*resp) + 
> props_count *
> -				 sizeof(struct 
> gb_power_supply_props_desc),
> +				 sizeof(*req),
> +				 struct_size(resp, props, 
> props_count),
>  				 GFP_KERNEL);
>  	if (!op)
>  		return -ENOMEM;


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] staging: greybus: power_supply: use struct_size() helper
  2019-04-18  6:27 ` Johan Hovold
@ 2019-04-18 14:26   ` Gustavo A. R. Silva
  0 siblings, 0 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2019-04-18 14:26 UTC (permalink / raw)
  To: Johan Hovold
  Cc: Rui Miguel Silva, Alex Elder, Greg Kroah-Hartman, greybus-dev,
	devel, linux-kernel



On 4/18/19 1:27 AM, Johan Hovold wrote:
> On Wed, Apr 17, 2019 at 01:44:40PM -0500, Gustavo A. R. Silva wrote:
>> Make use of the struct_size() helper instead of an open-coded version
>> in order to avoid any potential type mistakes, in particular in the
>> context in which this code is being used.
>>
>> So, replace code of the following form:
>>
>> sizeof(*resp) + props_count * sizeof(struct gb_power_supply_props_desc)
>>
>> with:
>>
>> struct_size(resp, props, props_count)
>>
>> This code was detected with the help of Coccinelle.
>>
>> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
>> ---
>> Changes in v2:
>>  - Rebase on top of 47830c1127ef ("staging: greybus: power_supply: fix prop-descriptor request size")
> 
> Thanks for rebasing.
> 

Glad to help. :)

> Reviewed-by: Johan Hovold <johan@kernel.org>
> 

Thanks
--
Gustavo

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2019-04-18 14:26 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-04-17 18:44 [PATCH v2] staging: greybus: power_supply: use struct_size() helper Gustavo A. R. Silva
2019-04-18  6:27 ` Johan Hovold
2019-04-18 14:26   ` Gustavo A. R. Silva
2019-04-18  8:59 ` Rui Miguel Silva

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.