Alsa-Devel Archive on lore.kernel.org
 help / color / Atom feed
* support the Roland UA-4FX2 card
@ 2020-10-13 17:43 kalashnikov-HJ4JGG
  0 siblings, 0 replies; 3+ messages in thread
From: kalashnikov-HJ4JGG @ 2020-10-13 17:43 UTC (permalink / raw)
  To: alsa-devel

Hello
i am juan and i am trying to use this (Roland UA-4FX2) sound card on 
linux, I posted this on the github and they recommended to put it on 
this mailing list.

from
https://github.com/alsa-project/alsa-lib/issues/81

hi

i'm trying to use this audio card with a Raspberry pi and y get this 
from the command dmesg on linux console

```
usb 3-2: new high-speed USB device number 6 using xhci_hcd
usb 3-2: New USB device found, idVendor=0582, idProduct=01e2, bcdDevice= 
0.2b
usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 3-2: Product: UA-4FX2
usb 3-2: Manufacturer: ROLAND
mc: Linux media interface: v0.10
usbcore: registered new interface driver snd-usb-audio
usb 3-2: Unable to change format on ep #8e: already in use
usb 3-2: Unable to change format on ep #8e: already in use
:
:
```

and when i try to select the device on a program get this

```
ALSA lib pcm.c:2642:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2642:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2642:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:869:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type 
for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type 
for card
```
it seems that the card is not supported by ALSA lib.
How is the procedure to add new cards to the driver?

How can I help to do this?

Thank you


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: support the Roland UA-4FX2 card
  2020-09-24  1:35 ` GitHub issues - opened
@ 2020-09-24 15:59   ` František Kučera
  0 siblings, 0 replies; 3+ messages in thread
From: František Kučera @ 2020-09-24 15:59 UTC (permalink / raw)
  To: alsa-devel

Hi,

some other Roland UA-* cards are supported:

 - https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/sound/usb/quirks-table.h?id=14335d8b9e1a2bf006f9d969a103f9731cabb210#n510
 - https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/sound/usb/quirks-table.h?id=14335d8b9e1a2bf006f9d969a103f9731cabb210#n1752

it is probably needed to add similar block of code for UA-4FX2.

You may also try whether an existing "quirk" would work with your card - through quirk_alias:

https://www.kernel.org/doc/html/v5.1/sound/alsa-configuration.html?highlight=quirk_alias#module-snd-usb-audio

Franta


^ permalink raw reply	[flat|nested] 3+ messages in thread

* support the Roland UA-4FX2 card
       [not found] <1600911332298629999-webhooks-bot@alsa-project.org>
@ 2020-09-24  1:35 ` GitHub issues - opened
  2020-09-24 15:59   ` František Kučera
  0 siblings, 1 reply; 3+ messages in thread
From: GitHub issues - opened @ 2020-09-24  1:35 UTC (permalink / raw)
  To: alsa-devel

alsa-project/alsa-lib issue #81 was opened from kalashnikov2:

hi

i'm trying to use this audio card with a Raspberry pi and y get this from the command dmesg on linux console

```
usb 3-2: new high-speed USB device number 6 using xhci_hcd
usb 3-2: New USB device found, idVendor=0582, idProduct=01e2, bcdDevice= 0.2b
usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 3-2: Product: UA-4FX2
usb 3-2: Manufacturer: ROLAND
mc: Linux media interface: v0.10
usbcore: registered new interface driver snd-usb-audio
usb 3-2: Unable to change format on ep #8e: already in use
usb 3-2: Unable to change format on ep #8e: already in use
:
:
```

and when i try to select the device on a program get this

```
ALSA lib pcm.c:2642:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2642:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2642:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:869:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
```
it seems that the card is not supported by ALSA lib.
How is the procedure to add new cards to the driver?

How can I help to do this?

Thank you

Issue URL     : https://github.com/alsa-project/alsa-lib/issues/81
Repository URL: https://github.com/alsa-project/alsa-lib

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-13 17:43 support the Roland UA-4FX2 card kalashnikov-HJ4JGG
     [not found] <1600911332298629999-webhooks-bot@alsa-project.org>
2020-09-24  1:35 ` GitHub issues - opened
2020-09-24 15:59   ` František Kučera

Alsa-Devel Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/alsa-devel/0 alsa-devel/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 alsa-devel alsa-devel/ https://lore.kernel.org/alsa-devel \
		alsa-devel@alsa-project.org
	public-inbox-index alsa-devel

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.alsa-project.alsa-devel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git