Alsa-Devel Archive on lore.kernel.org
 help / color / Atom feed
* Headset microphone not detected
@ 2020-07-16 18:31 Ujjwal Sharma
  2020-07-30  6:16 ` Ujjwal Sharma
  0 siblings, 1 reply; 2+ messages in thread
From: Ujjwal Sharma @ 2020-07-16 18:31 UTC (permalink / raw)
  To: alsa-devel


[-- Attachment #1: Type: text/plain, Size: 1142 bytes --]

Hi everyone!

I am unable to get my headset microphone to work, and that's really
puzzling to me since the headphone speakers show up as plugged and work
perfectly (pulseaudio shows the headset microphone as unplugged).

I reported this issue to the SOF issue tracker on GitHub and they
pointed out that it's an ALSA issue. Here's the mentioned thread:
https://github.com/thesofproject/sof/issues/3164.

My alsa_info.sh: https://pastebin.com/raw/K99520LA

Some snippets from there that might be interesting:

[ 7612.883978] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for
DAI Digital Codec DAI
[ 7612.883986] snd_hda_codec_realtek ehdaudio0D0: ASoC: can't open DAI
Digital Codec DAI: -22
[ 7612.883992] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for
DAI Digital Codec DAI
[ 7612.883998]  Digital Playback and Capture: ASoC: BE open failed -22
[ 7612.884002]  HDA Digital: ASoC: failed to start some BEs -22

state.sofhdadsp {
....
		name 'Headset Jack'
		value false
...
		name 'Mic Jack'
		value false

I cannot possibly understand what's wrong. Is it a bug in the codecs?

Thanks,
Ujjwal


[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Headset microphone not detected
  2020-07-16 18:31 Headset microphone not detected Ujjwal Sharma
@ 2020-07-30  6:16 ` Ujjwal Sharma
  0 siblings, 0 replies; 2+ messages in thread
From: Ujjwal Sharma @ 2020-07-30  6:16 UTC (permalink / raw)
  To: alsa-devel


[-- Attachment #1: Type: text/plain, Size: 1427 bytes --]

On 7/17/20 12:01 AM, Ujjwal Sharma wrote:
> Hi everyone!
> 
> I am unable to get my headset microphone to work, and that's really
> puzzling to me since the headphone speakers show up as plugged and work
> perfectly (pulseaudio shows the headset microphone as unplugged).
> 
> I reported this issue to the SOF issue tracker on GitHub and they
> pointed out that it's an ALSA issue. Here's the mentioned thread:
> https://github.com/thesofproject/sof/issues/3164.
> 
> My alsa_info.sh: https://pastebin.com/raw/K99520LA
> 
> Some snippets from there that might be interesting:
> 
> [ 7612.883978] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for
> DAI Digital Codec DAI
> [ 7612.883986] snd_hda_codec_realtek ehdaudio0D0: ASoC: can't open DAI
> Digital Codec DAI: -22
> [ 7612.883992] snd_hda_codec_realtek ehdaudio0D0: didn't find PCM for
> DAI Digital Codec DAI
> [ 7612.883998]  Digital Playback and Capture: ASoC: BE open failed -22
> [ 7612.884002]  HDA Digital: ASoC: failed to start some BEs -22
> 
> state.sofhdadsp {
> ....
> 		name 'Headset Jack'
> 		value false
> ...
> 		name 'Mic Jack'
> 		value false
> 
> I cannot possibly understand what's wrong. Is it a bug in the codecs?

Hi all!

Any help with this? I still cannot manage to fix this myself.

Thanks,
Ujjwal

-- 
Ujjwal "Ryzokuken" Sharma (he/him)

Compilers Hacker, Node.js Core Collaborator and Speaker


[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-16 18:31 Headset microphone not detected Ujjwal Sharma
2020-07-30  6:16 ` Ujjwal Sharma

Alsa-Devel Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/alsa-devel/0 alsa-devel/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 alsa-devel alsa-devel/ https://lore.kernel.org/alsa-devel \
		alsa-devel@alsa-project.org
	public-inbox-index alsa-devel

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.alsa-project.alsa-devel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git