ath11k.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* Re: [PATCH v2 00/21] MHI changes for v5.10
       [not found] <20200928040951.18207-1-manivannan.sadhasivam@linaro.org>
@ 2020-09-29 15:28 ` Manivannan Sadhasivam
  2020-09-29 16:13   ` Greg KH
  0 siblings, 1 reply; 2+ messages in thread
From: Manivannan Sadhasivam @ 2020-09-29 15:28 UTC (permalink / raw)
  To: gregkh; +Cc: jhugo, linux-arm-msm, bbhatt, linux-kernel, hemantk, ath11k, kvalo

Hi Greg,

On Mon, Sep 28, 2020 at 09:39:30AM +0530, Manivannan Sadhasivam wrote:
> Hi Greg,
> 
> Here is the MHI series for v5.10 cycle. Most of the patches are cleanups
> in the MHI stack. Notable changes are below:
> 
> * Saving the client device hardware information obtained through the BHI
>   protocol. This information will be exposed through sysfs to make use in
>   the userland applications.
> * Introduce sysfs entries to read the serial number and OEM PK hash values
>   of the client device obtained from BHI protocol. Relevant API documentation
>   is also added.
> * Introduce debugfs entries to show MHI states, events, channels, register
>   state etc... to aid debug.
> * Remove the channel name from MHI device name as the device is not specific
>   to channels. Used generic names instead!
> * Fix the warning reported by Kbuild bot by using append (+=) Kbuild rule
>   to the mhi/core Makefile.
> * Introduce APIs to allocate and free MHI controllers. This is done to make
>   sure that the allocated structs are initialized to NULL before passing to
>   the MHI core.
> * Remove the requirement to have a dedicated IRQ for each event ring.
>   The MHI controllers can now use a single IRQ for all event rings.
> * Remove the auto-start option for MHI channels. This is done to avoid
>   receiving spurious uplink from MHI client device when the client driver
>   is not up. The corresponding qrtr change is also included with Dave's ACK.
> 
> Please consider merging!
> 

Can you please drop the below two patches while applying this series?

bus: mhi: Remove auto-start option
net: qrtr: Start MHI channels during init

We realized that without these patches, net-next will be broken for QCA6390.
Proper way to handle this is by using an immutable branch or by carrying the
ath11k change through MHI tree. We decided to handle this in next merge window.

Or if you prefer to have a next revision of the series without these patches
I can send it. Please let me know!

Thanks,
Mani

> Thanks,
> Mani
> 
> Changes in v2:
> 
> * Clubbed both series (take one and two) onto a single one
> * Used dev_groups to manage sysfs attributes
> * Merged the debugfs fix patch with the debugfs patch
> * Dropped MAX_MTU patch for now
> 
> Bhaumik Bhatt (12):
>   bus: mhi: core: Remove double occurrence for mhi_ctrl_ev_task()
>     declaration
>   bus: mhi: core: Abort suspends due to outgoing pending packets
>   bus: mhi: core: Use helper API to trigger a non-blocking host resume
>   bus: mhi: core: Trigger host resume if suspended during
>     mhi_device_get()
>   bus: mhi: core: Use generic name field for an MHI device
>   bus: mhi: core: Introduce helper function to check device state
>   bus: mhi: core: Introduce counters to track MHI device state
>     transitions
>   bus: mhi: core: Read and save device hardware information from BHI
>   bus: mhi: core: Introduce APIs to allocate and free the MHI controller
>   bus: mhi: Fix entries based on Kconfig coding style
>   bus: mhi: core: Introduce debugfs entries for MHI
>   bus: mhi: core: Introduce sysfs entries for MHI
> 
> Clark Williams (1):
>   bus: mhi: Remove include of rwlock_types.h
> 
> Hemant Kumar (1):
>   bus: mhi: core: Add const qualifier to MHI config information
> 
> Loic Poulain (5):
>   bus: mhi: core: Allow shared IRQ for event rings
>   bus: mhi: Remove unused nr_irqs_req variable
>   bus: mhi: debugfs: Print channel context read-pointer
>   bus: mhi: Remove auto-start option
>   net: qrtr: Start MHI channels during init
> 
> Manivannan Sadhasivam (1):
>   bus: mhi: core: Fix the building of MHI module
> 
> Randy Dunlap (1):
>   bus: mhi: fix doubled words and struct image_info kernel-doc
> 
>  Documentation/ABI/stable/sysfs-bus-mhi |  21 ++
>  MAINTAINERS                            |   1 +
>  drivers/bus/mhi/Kconfig                |  20 +-
>  drivers/bus/mhi/core/Makefile          |   3 +-
>  drivers/bus/mhi/core/boot.c            |  17 +-
>  drivers/bus/mhi/core/debugfs.c         | 411 +++++++++++++++++++++++++
>  drivers/bus/mhi/core/init.c            |  96 ++++--
>  drivers/bus/mhi/core/internal.h        |  38 ++-
>  drivers/bus/mhi/core/main.c            |  27 +-
>  drivers/bus/mhi/core/pm.c              |  28 +-
>  include/linux/mhi.h                    |  53 +++-
>  net/qrtr/mhi.c                         |   5 +
>  12 files changed, 644 insertions(+), 76 deletions(-)
>  create mode 100644 Documentation/ABI/stable/sysfs-bus-mhi
>  create mode 100644 drivers/bus/mhi/core/debugfs.c
> 
> -- 
> 2.17.1
> 

-- 
ath11k mailing list
ath11k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath11k

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH v2 00/21] MHI changes for v5.10
  2020-09-29 15:28 ` [PATCH v2 00/21] MHI changes for v5.10 Manivannan Sadhasivam
@ 2020-09-29 16:13   ` Greg KH
  0 siblings, 0 replies; 2+ messages in thread
From: Greg KH @ 2020-09-29 16:13 UTC (permalink / raw)
  To: Manivannan Sadhasivam
  Cc: jhugo, linux-arm-msm, bbhatt, linux-kernel, hemantk, ath11k, kvalo

On Tue, Sep 29, 2020 at 08:58:34PM +0530, Manivannan Sadhasivam wrote:
> Hi Greg,
> 
> On Mon, Sep 28, 2020 at 09:39:30AM +0530, Manivannan Sadhasivam wrote:
> > Hi Greg,
> > 
> > Here is the MHI series for v5.10 cycle. Most of the patches are cleanups
> > in the MHI stack. Notable changes are below:
> > 
> > * Saving the client device hardware information obtained through the BHI
> >   protocol. This information will be exposed through sysfs to make use in
> >   the userland applications.
> > * Introduce sysfs entries to read the serial number and OEM PK hash values
> >   of the client device obtained from BHI protocol. Relevant API documentation
> >   is also added.
> > * Introduce debugfs entries to show MHI states, events, channels, register
> >   state etc... to aid debug.
> > * Remove the channel name from MHI device name as the device is not specific
> >   to channels. Used generic names instead!
> > * Fix the warning reported by Kbuild bot by using append (+=) Kbuild rule
> >   to the mhi/core Makefile.
> > * Introduce APIs to allocate and free MHI controllers. This is done to make
> >   sure that the allocated structs are initialized to NULL before passing to
> >   the MHI core.
> > * Remove the requirement to have a dedicated IRQ for each event ring.
> >   The MHI controllers can now use a single IRQ for all event rings.
> > * Remove the auto-start option for MHI channels. This is done to avoid
> >   receiving spurious uplink from MHI client device when the client driver
> >   is not up. The corresponding qrtr change is also included with Dave's ACK.
> > 
> > Please consider merging!
> > 
> 
> Can you please drop the below two patches while applying this series?
> 
> bus: mhi: Remove auto-start option
> net: qrtr: Start MHI channels during init
> 
> We realized that without these patches, net-next will be broken for QCA6390.
> Proper way to handle this is by using an immutable branch or by carrying the
> ath11k change through MHI tree. We decided to handle this in next merge window.
> 
> Or if you prefer to have a next revision of the series without these patches
> I can send it. Please let me know!

Please just send a new series, that way I "know" I got it right.

thanks,

greg k-h

-- 
ath11k mailing list
ath11k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath11k

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-09-29 16:13 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <20200928040951.18207-1-manivannan.sadhasivam@linaro.org>
2020-09-29 15:28 ` [PATCH v2 00/21] MHI changes for v5.10 Manivannan Sadhasivam
2020-09-29 16:13   ` Greg KH

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).