bpf.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Daniel Borkmann <daniel@iogearbox.net>
To: Andrii Nakryiko <andriin@fb.com>,
	andrii.nakryiko@gmail.com, kernel-team@fb.com, ast@fb.com,
	netdev@vger.kernel.org, bpf@vger.kernel.org
Subject: Re: [PATCH v5 bpf-next 0/4] capture integers in BTF type info for map defs
Date: Fri, 5 Jul 2019 23:15:48 +0200	[thread overview]
Message-ID: <86f8f511-655c-bf9e-8d78-f2e3f65efdb9@iogearbox.net> (raw)
In-Reply-To: <20190705155012.3539722-1-andriin@fb.com>

On 07/05/2019 05:50 PM, Andrii Nakryiko wrote:
> This patch set implements an update to how BTF-defined maps are specified. The
> change is in how integer attributes, e.g., type, max_entries, map_flags, are
> specified: now they are captured as part of map definition struct's BTF type
> information (using array dimension), eliminating the need for compile-time
> data initialization and keeping all the metadata in one place.
> 
> All existing selftests that were using BTF-defined maps are updated, along
> with some other selftests, that were switched to new syntax.
> 
> v4->v5:
> - revert sample_map_ret0.c, which is loaded with iproute2 (kernel test robot);
> v3->v4:
> - add acks;
> - fix int -> uint type in commit message;
> v2->v3:
> - rename __int into __uint (Yonghong);
> v1->v2:
> - split bpf_helpers.h change from libbpf change (Song).
> 
> Andrii Nakryiko (4):
>   libbpf: capture value in BTF type info for BTF-defined map defs
>   selftests/bpf: add __uint and __type macro for BTF-defined maps
>   selftests/bpf: convert selftests using BTF-defined maps to new syntax
>   selftests/bpf: convert legacy BPF maps to BTF-defined ones
> 
>  tools/lib/bpf/libbpf.c                        |  58 +++++----
>  tools/testing/selftests/bpf/bpf_helpers.h     |   3 +
>  tools/testing/selftests/bpf/progs/bpf_flow.c  |  28 ++---
>  .../selftests/bpf/progs/get_cgroup_id_kern.c  |  26 ++---
>  .../testing/selftests/bpf/progs/netcnt_prog.c |  20 ++--
>  tools/testing/selftests/bpf/progs/pyperf.h    |  90 +++++++-------
>  .../selftests/bpf/progs/socket_cookie_prog.c  |  13 +--
>  .../bpf/progs/sockmap_verdict_prog.c          |  48 ++++----
>  .../testing/selftests/bpf/progs/strobemeta.h  |  68 +++++------
>  .../selftests/bpf/progs/test_btf_newkv.c      |  13 +--
>  .../bpf/progs/test_get_stack_rawtp.c          |  39 +++----
>  .../selftests/bpf/progs/test_global_data.c    |  37 +++---
>  tools/testing/selftests/bpf/progs/test_l4lb.c |  65 ++++-------
>  .../selftests/bpf/progs/test_l4lb_noinline.c  |  65 ++++-------
>  .../selftests/bpf/progs/test_map_in_map.c     |  30 ++---
>  .../selftests/bpf/progs/test_map_lock.c       |  26 ++---
>  .../testing/selftests/bpf/progs/test_obj_id.c |  12 +-
>  .../bpf/progs/test_select_reuseport_kern.c    |  67 ++++-------
>  .../bpf/progs/test_send_signal_kern.c         |  26 ++---
>  .../bpf/progs/test_sock_fields_kern.c         |  78 +++++--------
>  .../selftests/bpf/progs/test_spin_lock.c      |  36 +++---
>  .../bpf/progs/test_stacktrace_build_id.c      |  55 ++++-----
>  .../selftests/bpf/progs/test_stacktrace_map.c |  52 +++------
>  .../selftests/bpf/progs/test_tcp_estats.c     |  13 +--
>  .../selftests/bpf/progs/test_tcpbpf_kern.c    |  26 ++---
>  .../selftests/bpf/progs/test_tcpnotify_kern.c |  28 ++---
>  tools/testing/selftests/bpf/progs/test_xdp.c  |  26 ++---
>  .../selftests/bpf/progs/test_xdp_loop.c       |  26 ++---
>  .../selftests/bpf/progs/test_xdp_noinline.c   |  81 +++++--------
>  .../selftests/bpf/progs/xdp_redirect_map.c    |  12 +-
>  .../testing/selftests/bpf/progs/xdping_kern.c |  12 +-
>  .../selftests/bpf/test_queue_stack_map.h      |  30 ++---
>  .../testing/selftests/bpf/test_sockmap_kern.h | 110 +++++++++---------
>  33 files changed, 559 insertions(+), 760 deletions(-)

LGTM, applied, thanks! Shouldn't we also move __uint and __type macros
into libbpf as otherwise people tend to redefine this over and over?

  parent reply	other threads:[~2019-07-05 21:15 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-05 15:50 [PATCH v5 bpf-next 0/4] capture integers in BTF type info for map defs Andrii Nakryiko
2019-07-05 15:50 ` [PATCH v5 bpf-next 1/4] libbpf: capture value in BTF type info for BTF-defined " Andrii Nakryiko
2019-07-05 15:50 ` [PATCH v5 bpf-next 2/4] selftests/bpf: add __uint and __type macro for BTF-defined maps Andrii Nakryiko
2019-07-05 15:50 ` [PATCH v5 bpf-next 3/4] selftests/bpf: convert selftests using BTF-defined maps to new syntax Andrii Nakryiko
2019-07-05 15:50 ` [PATCH v5 bpf-next 4/4] selftests/bpf: convert legacy BPF maps to BTF-defined ones Andrii Nakryiko
2019-07-05 21:15 ` Daniel Borkmann [this message]
2019-07-06  3:49   ` [PATCH v5 bpf-next 0/4] capture integers in BTF type info for map defs Andrii Nakryiko
2019-07-09 20:27   ` Edward Cree
2019-07-09 21:39     ` Andrii Nakryiko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=86f8f511-655c-bf9e-8d78-f2e3f65efdb9@iogearbox.net \
    --to=daniel@iogearbox.net \
    --cc=andrii.nakryiko@gmail.com \
    --cc=andriin@fb.com \
    --cc=ast@fb.com \
    --cc=bpf@vger.kernel.org \
    --cc=kernel-team@fb.com \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).