bpf.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH bpf-next 1/2] libbpf: Deprecate bpf_{map,program}__{prev,next} APIs
@ 2021-09-06 16:54 Hengqi Chen
  2021-09-06 16:54 ` [PATCH bpf-next 2/2] selftests/bpf: Replace bpf_{map,program}__next with bpf_object__next_{map,program} Hengqi Chen
  2021-09-09  4:44 ` [PATCH bpf-next 1/2] libbpf: Deprecate bpf_{map,program}__{prev,next} APIs Andrii Nakryiko
  0 siblings, 2 replies; 4+ messages in thread
From: Hengqi Chen @ 2021-09-06 16:54 UTC (permalink / raw)
  To: bpf; +Cc: ast, daniel, andrii, yhs, john.fastabend, hengqi.chen

Deprecate bpf_{map,program}__{prev,next} APIs. Replace them with
a new set of APIs named bpf_object__{prev,next}_{program,map} which
follow the libbpf API naming convention. No functionality changes.

Closes: https://github.com/libbpf/libbpf/issues/296
Signed-off-by: Hengqi Chen <hengqi.chen@gmail.com>
---
 tools/lib/bpf/libbpf.c   | 24 ++++++++++++++++++------
 tools/lib/bpf/libbpf.h   | 30 ++++++++++++++++++++----------
 tools/lib/bpf/libbpf.map |  4 ++++
 3 files changed, 42 insertions(+), 16 deletions(-)

diff --git a/tools/lib/bpf/libbpf.c b/tools/lib/bpf/libbpf.c
index 88d8825fc6f6..8d82853fb4a0 100644
--- a/tools/lib/bpf/libbpf.c
+++ b/tools/lib/bpf/libbpf.c
@@ -7347,7 +7347,7 @@ int bpf_object__pin_maps(struct bpf_object *obj, const char *path)
 	return 0;

 err_unpin_maps:
-	while ((map = bpf_map__prev(map, obj))) {
+	while ((map = bpf_object__prev_map(map, obj))) {
 		if (!map->pin_path)
 			continue;

@@ -7427,7 +7427,7 @@ int bpf_object__pin_programs(struct bpf_object *obj, const char *path)
 	return 0;

 err_unpin_programs:
-	while ((prog = bpf_program__prev(prog, obj))) {
+	while ((prog = bpf_object__prev_program(prog, obj))) {
 		char buf[PATH_MAX];
 		int len;

@@ -7666,8 +7666,11 @@ __bpf_program__iter(const struct bpf_program *p, const struct bpf_object *obj,
 	return &obj->programs[idx];
 }

+__attribute__((alias("bpf_object__next_program")))
+struct bpf_program *bpf_program__next(struct bpf_program *prev, const struct bpf_object *obj);
+
 struct bpf_program *
-bpf_program__next(struct bpf_program *prev, const struct bpf_object *obj)
+bpf_object__next_program(struct bpf_program *prev, const struct bpf_object *obj)
 {
 	struct bpf_program *prog = prev;

@@ -7678,8 +7681,11 @@ bpf_program__next(struct bpf_program *prev, const struct bpf_object *obj)
 	return prog;
 }

+__attribute__((alias("bpf_object__prev_program")))
+struct bpf_program *bpf_program__prev(struct bpf_program *next, const struct bpf_object *obj);
+
 struct bpf_program *
-bpf_program__prev(struct bpf_program *next, const struct bpf_object *obj)
+bpf_object__prev_program(struct bpf_program *next, const struct bpf_object *obj)
 {
 	struct bpf_program *prog = next;

@@ -8698,8 +8704,11 @@ __bpf_map__iter(const struct bpf_map *m, const struct bpf_object *obj, int i)
 	return &obj->maps[idx];
 }

+__attribute__((alias("bpf_object__next_map")))
+struct bpf_map *bpf_map__next(const struct bpf_map *prev, const struct bpf_object *obj);
+
 struct bpf_map *
-bpf_map__next(const struct bpf_map *prev, const struct bpf_object *obj)
+bpf_object__next_map(const struct bpf_map *prev, const struct bpf_object *obj)
 {
 	if (prev == NULL)
 		return obj->maps;
@@ -8707,8 +8716,11 @@ bpf_map__next(const struct bpf_map *prev, const struct bpf_object *obj)
 	return __bpf_map__iter(prev, obj, 1);
 }

+__attribute__((alias("bpf_object__prev_map")))
+struct bpf_map *bpf_map__prev(const struct bpf_map *next, const struct bpf_object *obj);
+
 struct bpf_map *
-bpf_map__prev(const struct bpf_map *next, const struct bpf_object *obj)
+bpf_object__prev_map(const struct bpf_map *next, const struct bpf_object *obj)
 {
 	if (next == NULL) {
 		if (!obj->nr_maps)
diff --git a/tools/lib/bpf/libbpf.h b/tools/lib/bpf/libbpf.h
index f177d897c5f7..e6aab4cd263b 100644
--- a/tools/lib/bpf/libbpf.h
+++ b/tools/lib/bpf/libbpf.h
@@ -186,16 +186,22 @@ LIBBPF_API int libbpf_find_vmlinux_btf_id(const char *name,

 /* Accessors of bpf_program */
 struct bpf_program;
-LIBBPF_API struct bpf_program *bpf_program__next(struct bpf_program *prog,
+LIBBPF_API LIBBPF_DEPRECATED("bpf_program__next() is deprecated, use bpf_object__next_program() instead")
+struct bpf_program *bpf_program__next(struct bpf_program *prog,
 						 const struct bpf_object *obj);
+LIBBPF_API struct bpf_program *bpf_object__next_program(struct bpf_program *prog,
+							const struct bpf_object *obj);

-#define bpf_object__for_each_program(pos, obj)		\
-	for ((pos) = bpf_program__next(NULL, (obj));	\
-	     (pos) != NULL;				\
-	     (pos) = bpf_program__next((pos), (obj)))
+#define bpf_object__for_each_program(pos, obj)			\
+	for ((pos) = bpf_object__next_program(NULL, (obj));	\
+	     (pos) != NULL;					\
+	     (pos) = bpf_object__next_program((pos), (obj)))

-LIBBPF_API struct bpf_program *bpf_program__prev(struct bpf_program *prog,
+LIBBPF_API LIBBPF_DEPRECATED("bpf_program__prev() is deprecated, use bpf_object__prev_program() instead")
+struct bpf_program *bpf_program__prev(struct bpf_program *prog,
 						 const struct bpf_object *obj);
+LIBBPF_API struct bpf_program *bpf_object__prev_program(struct bpf_program *prog,
+							const struct bpf_object *obj);

 typedef void (*bpf_program_clear_priv_t)(struct bpf_program *, void *);

@@ -495,16 +501,20 @@ bpf_object__find_map_fd_by_name(const struct bpf_object *obj, const char *name);
 LIBBPF_API struct bpf_map *
 bpf_object__find_map_by_offset(struct bpf_object *obj, size_t offset);

+LIBBPF_API LIBBPF_DEPRECATED("bpf_map__next() is deprecated, use bpf_object__next_map() instead")
+struct bpf_map *bpf_map__next(const struct bpf_map *map, const struct bpf_object *obj);
 LIBBPF_API struct bpf_map *
-bpf_map__next(const struct bpf_map *map, const struct bpf_object *obj);
+bpf_object__next_map(const struct bpf_map *map, const struct bpf_object *obj);
 #define bpf_object__for_each_map(pos, obj)		\
-	for ((pos) = bpf_map__next(NULL, (obj));	\
+	for ((pos) = bpf_object__next_map(NULL, (obj));	\
 	     (pos) != NULL;				\
-	     (pos) = bpf_map__next((pos), (obj)))
+	     (pos) = bpf_object__next_map((pos), (obj)))
 #define bpf_map__for_each bpf_object__for_each_map

+LIBBPF_API LIBBPF_DEPRECATED("bpf_map__prev() is deprecated, use bpf_object__prev_map() instead")
+struct bpf_map *bpf_map__prev(const struct bpf_map *map, const struct bpf_object *obj);
 LIBBPF_API struct bpf_map *
-bpf_map__prev(const struct bpf_map *map, const struct bpf_object *obj);
+bpf_object__prev_map(const struct bpf_map *map, const struct bpf_object *obj);

 /* get/set map FD */
 LIBBPF_API int bpf_map__fd(const struct bpf_map *map);
diff --git a/tools/lib/bpf/libbpf.map b/tools/lib/bpf/libbpf.map
index bbc53bb25f68..0c6d510e7747 100644
--- a/tools/lib/bpf/libbpf.map
+++ b/tools/lib/bpf/libbpf.map
@@ -378,6 +378,10 @@ LIBBPF_0.5.0 {
 		bpf_program__attach_tracepoint_opts;
 		bpf_program__attach_uprobe_opts;
 		bpf_object__gen_loader;
+		bpf_object__next_map;
+		bpf_object__next_program;
+		bpf_object__prev_map;
+		bpf_object__prev_program;
 		btf__load_from_kernel_by_id;
 		btf__load_from_kernel_by_id_split;
 		btf__load_into_kernel;
--
2.30.2

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH bpf-next 2/2] selftests/bpf: Replace bpf_{map,program}__next with bpf_object__next_{map,program}
  2021-09-06 16:54 [PATCH bpf-next 1/2] libbpf: Deprecate bpf_{map,program}__{prev,next} APIs Hengqi Chen
@ 2021-09-06 16:54 ` Hengqi Chen
  2021-09-09  4:47   ` Andrii Nakryiko
  2021-09-09  4:44 ` [PATCH bpf-next 1/2] libbpf: Deprecate bpf_{map,program}__{prev,next} APIs Andrii Nakryiko
  1 sibling, 1 reply; 4+ messages in thread
From: Hengqi Chen @ 2021-09-06 16:54 UTC (permalink / raw)
  To: bpf; +Cc: ast, daniel, andrii, yhs, john.fastabend, hengqi.chen

Replace deprecated bpf_{map,program}__next APIs with newly added
bpf_object__next_{map,program} APIs, so that no compilation warnings
emit.

Signed-off-by: Hengqi Chen <hengqi.chen@gmail.com>
---
 tools/testing/selftests/bpf/prog_tests/btf.c              | 2 +-
 tools/testing/selftests/bpf/prog_tests/fexit_bpf2bpf.c    | 2 +-
 tools/testing/selftests/bpf/prog_tests/select_reuseport.c | 2 +-
 tools/testing/selftests/bpf/prog_tests/tcp_rtt.c          | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/tools/testing/selftests/bpf/prog_tests/btf.c b/tools/testing/selftests/bpf/prog_tests/btf.c
index 649f87382c8d..77b297f6c003 100644
--- a/tools/testing/selftests/bpf/prog_tests/btf.c
+++ b/tools/testing/selftests/bpf/prog_tests/btf.c
@@ -4268,7 +4268,7 @@ static void do_test_file(unsigned int test_num)
 	if (CHECK(err, "obj: %d", err))
 		return;

-	prog = bpf_program__next(NULL, obj);
+	prog = bpf_object__next_program(NULL, obj);
 	if (CHECK(!prog, "Cannot find bpf_prog")) {
 		err = -1;
 		goto done;
diff --git a/tools/testing/selftests/bpf/prog_tests/fexit_bpf2bpf.c b/tools/testing/selftests/bpf/prog_tests/fexit_bpf2bpf.c
index 73b4c76e6b86..68205b172a7d 100644
--- a/tools/testing/selftests/bpf/prog_tests/fexit_bpf2bpf.c
+++ b/tools/testing/selftests/bpf/prog_tests/fexit_bpf2bpf.c
@@ -288,7 +288,7 @@ static void test_fmod_ret_freplace(void)
 	if (CHECK(err, "freplace_obj_load", "err %d\n", err))
 		goto out;

-	prog = bpf_program__next(NULL, freplace_obj);
+	prog = bpf_object__next_program(NULL, freplace_obj);
 	freplace_link = bpf_program__attach_trace(prog);
 	if (!ASSERT_OK_PTR(freplace_link, "freplace_attach_trace"))
 		goto out;
diff --git a/tools/testing/selftests/bpf/prog_tests/select_reuseport.c b/tools/testing/selftests/bpf/prog_tests/select_reuseport.c
index 4efd337d6a3c..55957b42bc23 100644
--- a/tools/testing/selftests/bpf/prog_tests/select_reuseport.c
+++ b/tools/testing/selftests/bpf/prog_tests/select_reuseport.c
@@ -114,7 +114,7 @@ static int prepare_bpf_obj(void)
 	err = bpf_object__load(obj);
 	RET_ERR(err, "load bpf_object", "err:%d\n", err);

-	prog = bpf_program__next(NULL, obj);
+	prog = bpf_object__next_program(NULL, obj);
 	RET_ERR(!prog, "get first bpf_program", "!prog\n");
 	select_by_skb_data_prog = bpf_program__fd(prog);
 	RET_ERR(select_by_skb_data_prog < 0, "get prog fd",
diff --git a/tools/testing/selftests/bpf/prog_tests/tcp_rtt.c b/tools/testing/selftests/bpf/prog_tests/tcp_rtt.c
index d207e968e6b1..4957e391e111 100644
--- a/tools/testing/selftests/bpf/prog_tests/tcp_rtt.c
+++ b/tools/testing/selftests/bpf/prog_tests/tcp_rtt.c
@@ -109,7 +109,7 @@ static int run_test(int cgroup_fd, int server_fd)
 		return -1;
 	}

-	map = bpf_map__next(NULL, obj);
+	map = bpf_object__next_map(NULL, obj);
 	map_fd = bpf_map__fd(map);

 	err = bpf_prog_attach(prog_fd, cgroup_fd, BPF_CGROUP_SOCK_OPS, 0);
--
2.30.2

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH bpf-next 1/2] libbpf: Deprecate bpf_{map,program}__{prev,next} APIs
  2021-09-06 16:54 [PATCH bpf-next 1/2] libbpf: Deprecate bpf_{map,program}__{prev,next} APIs Hengqi Chen
  2021-09-06 16:54 ` [PATCH bpf-next 2/2] selftests/bpf: Replace bpf_{map,program}__next with bpf_object__next_{map,program} Hengqi Chen
@ 2021-09-09  4:44 ` Andrii Nakryiko
  1 sibling, 0 replies; 4+ messages in thread
From: Andrii Nakryiko @ 2021-09-09  4:44 UTC (permalink / raw)
  To: Hengqi Chen
  Cc: bpf, Alexei Starovoitov, Daniel Borkmann, Andrii Nakryiko,
	Yonghong Song, john fastabend

On Mon, Sep 6, 2021 at 9:55 AM Hengqi Chen <hengqi.chen@gmail.com> wrote:
>
> Deprecate bpf_{map,program}__{prev,next} APIs. Replace them with
> a new set of APIs named bpf_object__{prev,next}_{program,map} which
> follow the libbpf API naming convention. No functionality changes.
>
> Closes: https://github.com/libbpf/libbpf/issues/296

I'm hesitant about using Closes: as if it was a proper Linux tag.
Let's stick to using it in a reference:

   [0] Closes: ...


> Signed-off-by: Hengqi Chen <hengqi.chen@gmail.com>
> ---
>  tools/lib/bpf/libbpf.c   | 24 ++++++++++++++++++------
>  tools/lib/bpf/libbpf.h   | 30 ++++++++++++++++++++----------
>  tools/lib/bpf/libbpf.map |  4 ++++
>  3 files changed, 42 insertions(+), 16 deletions(-)
>
> diff --git a/tools/lib/bpf/libbpf.c b/tools/lib/bpf/libbpf.c
> index 88d8825fc6f6..8d82853fb4a0 100644
> --- a/tools/lib/bpf/libbpf.c
> +++ b/tools/lib/bpf/libbpf.c
> @@ -7347,7 +7347,7 @@ int bpf_object__pin_maps(struct bpf_object *obj, const char *path)
>         return 0;
>
>  err_unpin_maps:
> -       while ((map = bpf_map__prev(map, obj))) {
> +       while ((map = bpf_object__prev_map(map, obj))) {
>                 if (!map->pin_path)
>                         continue;
>
> @@ -7427,7 +7427,7 @@ int bpf_object__pin_programs(struct bpf_object *obj, const char *path)
>         return 0;
>
>  err_unpin_programs:
> -       while ((prog = bpf_program__prev(prog, obj))) {
> +       while ((prog = bpf_object__prev_program(prog, obj))) {
>                 char buf[PATH_MAX];
>                 int len;
>
> @@ -7666,8 +7666,11 @@ __bpf_program__iter(const struct bpf_program *p, const struct bpf_object *obj,
>         return &obj->programs[idx];
>  }
>
> +__attribute__((alias("bpf_object__next_program")))
> +struct bpf_program *bpf_program__next(struct bpf_program *prev, const struct bpf_object *obj);
> +
>  struct bpf_program *
> -bpf_program__next(struct bpf_program *prev, const struct bpf_object *obj)
> +bpf_object__next_program(struct bpf_program *prev, const struct bpf_object *obj)

I think for bpf_object__next_program it makes more sense to have obj
as the first argument (it's a "method" of bpf_object, after all). So
you can't have bpf_program__next aliased to bpf_object__next_program,
you have to add a small wrapper function. Same for other new APIs.

>  {
>         struct bpf_program *prog = prev;
>
> @@ -7678,8 +7681,11 @@ bpf_program__next(struct bpf_program *prev, const struct bpf_object *obj)
>         return prog;
>  }
>

[...]

> diff --git a/tools/lib/bpf/libbpf.h b/tools/lib/bpf/libbpf.h
> index f177d897c5f7..e6aab4cd263b 100644
> --- a/tools/lib/bpf/libbpf.h
> +++ b/tools/lib/bpf/libbpf.h
> @@ -186,16 +186,22 @@ LIBBPF_API int libbpf_find_vmlinux_btf_id(const char *name,
>
>  /* Accessors of bpf_program */
>  struct bpf_program;
> -LIBBPF_API struct bpf_program *bpf_program__next(struct bpf_program *prog,
> +LIBBPF_API LIBBPF_DEPRECATED("bpf_program__next() is deprecated, use bpf_object__next_program() instead")

We shouldn't deprecate API until the replacement API was already
released as part of an official libbpf release. I suggest to wait
until the LIBBPF_DEPRECATE_SINCE ([0]) patch lands first, and then
using that here to deprecate those APIs starting from 0.7 (because we
are now developing 0.6 libbpf).

  [0] https://patchwork.kernel.org/project/netdevbpf/patch/20210908213226.1871016-1-andrii@kernel.org/

> +struct bpf_program *bpf_program__next(struct bpf_program *prog,
>                                                  const struct bpf_object *obj);
> +LIBBPF_API struct bpf_program *bpf_object__next_program(struct bpf_program *prog,
> +                                                       const struct bpf_object *obj);
>

[...]

>  /* get/set map FD */
>  LIBBPF_API int bpf_map__fd(const struct bpf_map *map);
> diff --git a/tools/lib/bpf/libbpf.map b/tools/lib/bpf/libbpf.map
> index bbc53bb25f68..0c6d510e7747 100644
> --- a/tools/lib/bpf/libbpf.map
> +++ b/tools/lib/bpf/libbpf.map
> @@ -378,6 +378,10 @@ LIBBPF_0.5.0 {
>                 bpf_program__attach_tracepoint_opts;
>                 bpf_program__attach_uprobe_opts;
>                 bpf_object__gen_loader;
> +               bpf_object__next_map;
> +               bpf_object__next_program;
> +               bpf_object__prev_map;
> +               bpf_object__prev_program;

For next revision, please add the LIBBPF_0.6.0 section, libbpf 0.5 was
just released today, so we are now moving into the v0.6 development
cycle. Thanks!

>                 btf__load_from_kernel_by_id;
>                 btf__load_from_kernel_by_id_split;
>                 btf__load_into_kernel;
> --
> 2.30.2

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH bpf-next 2/2] selftests/bpf: Replace bpf_{map,program}__next with bpf_object__next_{map,program}
  2021-09-06 16:54 ` [PATCH bpf-next 2/2] selftests/bpf: Replace bpf_{map,program}__next with bpf_object__next_{map,program} Hengqi Chen
@ 2021-09-09  4:47   ` Andrii Nakryiko
  0 siblings, 0 replies; 4+ messages in thread
From: Andrii Nakryiko @ 2021-09-09  4:47 UTC (permalink / raw)
  To: Hengqi Chen
  Cc: bpf, Alexei Starovoitov, Daniel Borkmann, Andrii Nakryiko,
	Yonghong Song, john fastabend

On Mon, Sep 6, 2021 at 9:55 AM Hengqi Chen <hengqi.chen@gmail.com> wrote:
>
> Replace deprecated bpf_{map,program}__next APIs with newly added
> bpf_object__next_{map,program} APIs, so that no compilation warnings
> emit.
>
> Signed-off-by: Hengqi Chen <hengqi.chen@gmail.com>
> ---

LGTM, but the subject for this patch (and a few others you've
submitted) is very long. I think the recommendation is to keep them
shorter than 78 characters or something like that. Maybe use something
like "selftests/bpf: switch to new new bpf_object__next_program APIs"?

>  tools/testing/selftests/bpf/prog_tests/btf.c              | 2 +-
>  tools/testing/selftests/bpf/prog_tests/fexit_bpf2bpf.c    | 2 +-
>  tools/testing/selftests/bpf/prog_tests/select_reuseport.c | 2 +-
>  tools/testing/selftests/bpf/prog_tests/tcp_rtt.c          | 2 +-
>  4 files changed, 4 insertions(+), 4 deletions(-)
>

[...]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-09-09  4:47 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-06 16:54 [PATCH bpf-next 1/2] libbpf: Deprecate bpf_{map,program}__{prev,next} APIs Hengqi Chen
2021-09-06 16:54 ` [PATCH bpf-next 2/2] selftests/bpf: Replace bpf_{map,program}__next with bpf_object__next_{map,program} Hengqi Chen
2021-09-09  4:47   ` Andrii Nakryiko
2021-09-09  4:44 ` [PATCH bpf-next 1/2] libbpf: Deprecate bpf_{map,program}__{prev,next} APIs Andrii Nakryiko

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).