dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
From: Gwan-gyeong Mun <gwan-gyeong.mun@intel.com>
To: Andrzej Hajda <andrzej.hajda@intel.com>,
	<intel-gfx@lists.freedesktop.org>
Cc: thomas.hellstrom@linux.intel.com, jani.nikula@intel.com,
	dri-devel@lists.freedesktop.org, chris@chris-wilson.co.uk,
	airlied@linux.ie, matthew.auld@intel.com, mchehab@kernel.org,
	nirmoy.das@intel.com
Subject: Re: [Intel-gfx] [PATCH v5 1/7] drm: Move and add a few utility macros into drm util header
Date: Tue, 26 Jul 2022 11:20:27 +0300	[thread overview]
Message-ID: <0c6c5424-09d7-e4e7-eee1-84b56e31b278@intel.com> (raw)
In-Reply-To: <9c20e45e-1b51-68b9-7a23-a651ac59a2f7@intel.com>



On 7/25/22 2:36 PM, Andrzej Hajda wrote:
> On 25.07.2022 11:25, Gwan-gyeong Mun wrote:
>> It moves overflows_type utility macro into drm util header from 
>> i915_utils
>> header. The overflows_type can be used to catch the truncation between 
>> data
>> types. And it adds safe_conversion() macro which performs a type 
>> conversion
>> (cast) of an source value into a new variable, checking that the
>> destination is large enough to hold the source value.
>> And it adds exact_type and exactly_pgoff_t macro to catch type mis-match
>> while compiling.
>>
>> v3: Add is_type_unsigned() macro (Mauro)
>>      Modify overflows_type() macro to consider signed data types (Mauro)
>>      Fix the problem that safe_conversion() macro always returns true
>> v4: Fix kernel-doc markups
>>
>> Signed-off-by: Gwan-gyeong Mun <gwan-gyeong.mun@intel.com>
>> Cc: Thomas Hellström <thomas.hellstrom@linux.intel.com>
>> Cc: Matthew Auld <matthew.auld@intel.com>
>> Cc: Nirmoy Das <nirmoy.das@intel.com>
>> Cc: Jani Nikula <jani.nikula@intel.com>
>> Reviewed-by: Mauro Carvalho Chehab <mchehab@kernel.org>
>> ---
>>   drivers/gpu/drm/i915/i915_utils.h |  5 +-
>>   include/drm/drm_util.h            | 77 +++++++++++++++++++++++++++++++
>>   2 files changed, 78 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/i915/i915_utils.h 
>> b/drivers/gpu/drm/i915/i915_utils.h
>> index c10d68cdc3ca..345e5b2dc1cd 100644
>> --- a/drivers/gpu/drm/i915/i915_utils.h
>> +++ b/drivers/gpu/drm/i915/i915_utils.h
>> @@ -32,6 +32,7 @@
>>   #include <linux/types.h>
>>   #include <linux/workqueue.h>
>>   #include <linux/sched/clock.h>
>> +#include <drm/drm_util.h>
>>   #ifdef CONFIG_X86
>>   #include <asm/hypervisor.h>
>> @@ -111,10 +112,6 @@ bool i915_error_injected(void);
>>   #define range_overflows_end_t(type, start, size, max) \
>>       range_overflows_end((type)(start), (type)(size), (type)(max))
>> -/* Note we don't consider signbits :| */
>> -#define overflows_type(x, T) \
>> -    (sizeof(x) > sizeof(T) && (x) >> BITS_PER_TYPE(T))
>> -
>>   #define ptr_mask_bits(ptr, n) ({                    \
>>       unsigned long __v = (unsigned long)(ptr);            \
>>       (typeof(ptr))(__v & -BIT(n));                    \
>> diff --git a/include/drm/drm_util.h b/include/drm/drm_util.h
>> index 79952d8c4bba..1de9ee5704fa 100644
>> --- a/include/drm/drm_util.h
>> +++ b/include/drm/drm_util.h
>> @@ -62,6 +62,83 @@
>>    */
>>   #define for_each_if(condition) if (!(condition)) {} else
>> +/**
>> + * is_type_unsigned - helper for checking data type which is an 
>> unsigned data
>> + * type or not
>> + * @x: The data type to check
>> + *
>> + * Returns:
>> + * True if the data type is an unsigned data type, false otherwise.
>> + */
>> +#define is_type_unsigned(x) ((typeof(x))-1 >= (typeof(x))0)
>> +
>> +/**
>> + * overflows_type - helper for checking the truncation between data 
>> types
>> + * @x: Source for overflow type comparison
>> + * @T: Destination for overflow type comparison
>> + *
>> + * It compares the values and size of each data type between the 
>> first and
>> + * second argument to check whether truncation can occur when 
>> assigning the
>> + * first argument to the variable of the second argument.
>> + * Source and Destination can be used with or without sign bit.
>> + * Composite data structures such as union and structure are not 
>> considered.
>> + * Enum data types are not considered.
>> + * Floating point data types are not considered.
>> + *
>> + * Returns:
>> + * True if truncation can occur, false otherwise.
>> + */
>> +
>> +#define overflows_type(x, T) \
>> +    (is_type_unsigned(x) ? \
>> +        is_type_unsigned(T) ? \
>> +            (sizeof(x) > sizeof(T) && (x) >> BITS_PER_TYPE(T)) ? 1 : 0 \
>> +            : (sizeof(x) >= sizeof(T) && (x) >> (BITS_PER_TYPE(T) - 
>> 1)) ? 1 : 0 \
>> +    : is_type_unsigned(T) ? \
>> +        ((x) < 0) ? 1 : (sizeof(x) > sizeof(T) && (x) >> 
>> BITS_PER_TYPE(T)) ? 1 : 0 \
>> +        : (sizeof(x) > sizeof(T)) ? \
>> +            ((x) < 0) ? (((x) * -1) >> BITS_PER_TYPE(T)) ? 1 : 0 \
>> +                : ((x) >> BITS_PER_TYPE(T)) ? 1 : 0 \
>> +            : 0)
> 
> 
> It became quite big and hard to read. I wonder if we could not just 
> check the effects of the conversion, sth like:
> #define overflows_type(x, T) ((T)(x) != (x))
> 
Yes, this macro is a bit difficult to read because it takes into account 
multiple situations. I left a comment with the relevant details in reply 
to the previous patch so that you could check the details of the macro.

And the macro you commented is not satisfactory in all use cases where 
the overflows_type() macro is used.
If you refer to the bottom part of the link below, you can check the 
pseudo code of this macro and test scenarios of the use cases covered by 
this macro. (It also includes the test code.)
https://patchwork.freedesktop.org/patch/492374/?series=104704&rev=3

Br,
G.G.

> Regards
> Andrzej
> 
> 
>> +
>> +/**
>> + * exact_type - break compile if source type and destination value's 
>> type are
>> + * not the same
>> + * @T: Source type
>> + * @n: Destination value
>> + *
>> + * It is a helper macro for a poor man's -Wconversion: only allow 
>> variables of
>> + * an exact type. It determines whether the source type and 
>> destination value's
>> + * type are the same while compiling, and it breaks compile if two 
>> types are
>> + * not the same
>> + */
>> +#define exact_type(T, n) \
>> +    BUILD_BUG_ON(!__builtin_constant_p(n) && 
>> !__builtin_types_compatible_p(T, typeof(n)))
>> +
>> +/**
>> + * exactly_pgoff_t - helper to check if the type of a value is pgoff_t
>> + * @n: value to compare pgoff_t type
>> + *
>> + * It breaks compile if the argument value's type is not pgoff_t type.
>> + */
>> +#define exactly_pgoff_t(n) exact_type(pgoff_t, n)
>> +
>> +/**
>> + * safe_conversion - perform a type conversion (cast) of an source 
>> value into
>> + * a new variable, checking that the destination is large enough to 
>> hold the
>> + * source value.
>> + * @ptr: Destination pointer address
>> + * @value: Source value
>> + *
>> + * Returns:
>> + * If the value would overflow the destination, it returns false.
>> + */
>> +#define safe_conversion(ptr, value) ({ \
>> +    typeof(value) __v = (value); \
>> +    typeof(ptr) __ptr = (ptr); \
>> +    overflows_type(__v, *__ptr) ? 0 : ((*__ptr = 
>> (typeof(*__ptr))__v), 1); \
>> +})
>> +
>>   /**
>>    * drm_can_sleep - returns true if currently okay to sleep
>>    *
> 

  reply	other threads:[~2022-07-26  8:21 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-25  9:25 [PATCH v5 0/7] Fixes integer overflow or integer truncation issues in page lookups, ttm place configuration and scatterlist creation Gwan-gyeong Mun
2022-07-25  9:25 ` [PATCH v5 1/7] drm: Move and add a few utility macros into drm util header Gwan-gyeong Mun
2022-07-25 11:36   ` [Intel-gfx] " Andrzej Hajda
2022-07-26  8:20     ` Gwan-gyeong Mun [this message]
2022-07-27 10:26   ` Andi Shyti
2022-08-03 14:05     ` Jani Nikula
2022-08-04  9:06       ` Andi Shyti
2022-08-09  8:31         ` Gwan-gyeong Mun
2022-07-25  9:25 ` [PATCH v5 2/7] drm/i915/gem: Typecheck page lookups Gwan-gyeong Mun
2022-07-25 11:50   ` [Intel-gfx] " Andrzej Hajda
2022-07-25  9:25 ` [PATCH v5 3/7] drm/i915: Check for integer truncation on scatterlist creation Gwan-gyeong Mun
2022-07-25 11:51   ` [Intel-gfx] " Andrzej Hajda
2022-07-25  9:25 ` [PATCH v5 4/7] drm/i915: Check for integer truncation on the configuration of ttm place Gwan-gyeong Mun
2022-07-25 11:53   ` [Intel-gfx] " Andrzej Hajda
2022-08-03 14:13   ` Jani Nikula
2022-07-25  9:25 ` [PATCH v5 5/7] drm/i915: Check if the size is too big while creating shmem file Gwan-gyeong Mun
2022-07-25 11:59   ` [Intel-gfx] " Andrzej Hajda
2022-07-25  9:25 ` [PATCH v5 6/7] drm/i915: Use error code as -E2BIG when the size of gem ttm object is too large Gwan-gyeong Mun
2022-07-25 12:01   ` [Intel-gfx] " Andrzej Hajda
2022-07-25  9:25 ` [PATCH v5 7/7] drm/i915: Remove truncation warning for large objects Gwan-gyeong Mun
2022-07-25 12:02   ` [Intel-gfx] " Andrzej Hajda

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0c6c5424-09d7-e4e7-eee1-84b56e31b278@intel.com \
    --to=gwan-gyeong.mun@intel.com \
    --cc=airlied@linux.ie \
    --cc=andrzej.hajda@intel.com \
    --cc=chris@chris-wilson.co.uk \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=jani.nikula@intel.com \
    --cc=matthew.auld@intel.com \
    --cc=mchehab@kernel.org \
    --cc=nirmoy.das@intel.com \
    --cc=thomas.hellstrom@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).