dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
* [PATCH libdrm] xf86drm: correct the OpenBSD DRM_MAJOR define
@ 2015-07-18 21:20 Jonathan Gray
  2015-07-20 16:06 ` Emil Velikov
  0 siblings, 1 reply; 5+ messages in thread
From: Jonathan Gray @ 2015-07-18 21:20 UTC (permalink / raw)
  To: dri-devel; +Cc: emil.l.velikov

As far as I can tell no OpenBSD platform ever used 81
for a drm major.  While the value was added to libdrm in 2003
or earlier drm didn't appear in OpenBSD till 2007.

Of the OpenBSD platforms that support drm amd64/macppc/sparc64
use a major of 87, i386 uses 88.

Signed-off-by: Jonathan Gray <jsg@jsg.id.au>
---
 xf86drm.c | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/xf86drm.c b/xf86drm.c
index 7d7f9c7..a2c549c 100644
--- a/xf86drm.c
+++ b/xf86drm.c
@@ -72,9 +72,11 @@
 #define DRM_MAJOR 34
 #endif
 
-# ifdef __OpenBSD__
-#  define DRM_MAJOR 81
-# endif
+#if defined(__OpenBSD__) && defined(__i386__)
+#define DRM_MAJOR 88
+#elif defined(__OpenBSD__)
+#define DRM_MAJOR 87
+#endif
 
 #ifndef DRM_MAJOR
 #define DRM_MAJOR 226		/* Linux */
-- 
2.4.5

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH libdrm] xf86drm: correct the OpenBSD DRM_MAJOR define
  2015-07-18 21:20 [PATCH libdrm] xf86drm: correct the OpenBSD DRM_MAJOR define Jonathan Gray
@ 2015-07-20 16:06 ` Emil Velikov
  2015-07-20 16:15   ` Jonathan Gray
  2015-07-20 17:12   ` [PATCH libdrm v2] " Jonathan Gray
  0 siblings, 2 replies; 5+ messages in thread
From: Emil Velikov @ 2015-07-20 16:06 UTC (permalink / raw)
  To: Jonathan Gray; +Cc: ML dri-devel

On 18 July 2015 at 22:20, Jonathan Gray <jsg@jsg.id.au> wrote:
> As far as I can tell no OpenBSD platform ever used 81
> for a drm major.  While the value was added to libdrm in 2003
> or earlier drm didn't appear in OpenBSD till 2007.
>
> Of the OpenBSD platforms that support drm amd64/macppc/sparc64
> use a major of 87, i386 uses 88.
>
> Signed-off-by: Jonathan Gray <jsg@jsg.id.au>
> ---
>  xf86drm.c | 8 +++++---
>  1 file changed, 5 insertions(+), 3 deletions(-)
>
> diff --git a/xf86drm.c b/xf86drm.c
> index 7d7f9c7..a2c549c 100644
> --- a/xf86drm.c
> +++ b/xf86drm.c
> @@ -72,9 +72,11 @@
>  #define DRM_MAJOR 34
>  #endif
>
> -# ifdef __OpenBSD__
> -#  define DRM_MAJOR 81
> -# endif
> +#if defined(__OpenBSD__) && defined(__i386__)
> +#define DRM_MAJOR 88
> +#elif defined(__OpenBSD__)
> +#define DRM_MAJOR 87
> +#endif
>
Bikeshed: any objections if we cascade the ifdef statements ?

Thanks
Emil
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH libdrm] xf86drm: correct the OpenBSD DRM_MAJOR define
  2015-07-20 16:06 ` Emil Velikov
@ 2015-07-20 16:15   ` Jonathan Gray
  2015-07-20 16:26     ` Emil Velikov
  2015-07-20 17:12   ` [PATCH libdrm v2] " Jonathan Gray
  1 sibling, 1 reply; 5+ messages in thread
From: Jonathan Gray @ 2015-07-20 16:15 UTC (permalink / raw)
  To: Emil Velikov; +Cc: ML dri-devel

On Mon, Jul 20, 2015 at 05:06:09PM +0100, Emil Velikov wrote:
> On 18 July 2015 at 22:20, Jonathan Gray <jsg@jsg.id.au> wrote:
> > As far as I can tell no OpenBSD platform ever used 81
> > for a drm major.  While the value was added to libdrm in 2003
> > or earlier drm didn't appear in OpenBSD till 2007.
> >
> > Of the OpenBSD platforms that support drm amd64/macppc/sparc64
> > use a major of 87, i386 uses 88.
> >
> > Signed-off-by: Jonathan Gray <jsg@jsg.id.au>
> > ---
> >  xf86drm.c | 8 +++++---
> >  1 file changed, 5 insertions(+), 3 deletions(-)
> >
> > diff --git a/xf86drm.c b/xf86drm.c
> > index 7d7f9c7..a2c549c 100644
> > --- a/xf86drm.c
> > +++ b/xf86drm.c
> > @@ -72,9 +72,11 @@
> >  #define DRM_MAJOR 34
> >  #endif
> >
> > -# ifdef __OpenBSD__
> > -#  define DRM_MAJOR 81
> > -# endif
> > +#if defined(__OpenBSD__) && defined(__i386__)
> > +#define DRM_MAJOR 88
> > +#elif defined(__OpenBSD__)
> > +#define DRM_MAJOR 87
> > +#endif
> >
> Bikeshed: any objections if we cascade the ifdef statements ?

Do you mean indent the defines or have the entire block
undef ifdef __OpenBSD__?  Either way would be fine with me.
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH libdrm] xf86drm: correct the OpenBSD DRM_MAJOR define
  2015-07-20 16:15   ` Jonathan Gray
@ 2015-07-20 16:26     ` Emil Velikov
  0 siblings, 0 replies; 5+ messages in thread
From: Emil Velikov @ 2015-07-20 16:26 UTC (permalink / raw)
  To: Jonathan Gray; +Cc: ML dri-devel

On 20 July 2015 at 17:15, Jonathan Gray <jsg@jsg.id.au> wrote:
> On Mon, Jul 20, 2015 at 05:06:09PM +0100, Emil Velikov wrote:
>> On 18 July 2015 at 22:20, Jonathan Gray <jsg@jsg.id.au> wrote:
>> > As far as I can tell no OpenBSD platform ever used 81
>> > for a drm major.  While the value was added to libdrm in 2003
>> > or earlier drm didn't appear in OpenBSD till 2007.
>> >
>> > Of the OpenBSD platforms that support drm amd64/macppc/sparc64
>> > use a major of 87, i386 uses 88.
>> >
>> > Signed-off-by: Jonathan Gray <jsg@jsg.id.au>
>> > ---
>> >  xf86drm.c | 8 +++++---
>> >  1 file changed, 5 insertions(+), 3 deletions(-)
>> >
>> > diff --git a/xf86drm.c b/xf86drm.c
>> > index 7d7f9c7..a2c549c 100644
>> > --- a/xf86drm.c
>> > +++ b/xf86drm.c
>> > @@ -72,9 +72,11 @@
>> >  #define DRM_MAJOR 34
>> >  #endif
>> >
>> > -# ifdef __OpenBSD__
>> > -#  define DRM_MAJOR 81
>> > -# endif
>> > +#if defined(__OpenBSD__) && defined(__i386__)
>> > +#define DRM_MAJOR 88
>> > +#elif defined(__OpenBSD__)
>> > +#define DRM_MAJOR 87
>> > +#endif
>> >
>> Bikeshed: any objections if we cascade the ifdef statements ?
>
> Do you mean indent the defines or have the entire block
> undef ifdef __OpenBSD__?  Either way would be fine with me.

Cascade seems like the wrong term here - here is what I meant:

 #ifdef __OpenBSD__
+#ifdef __i386__
+#define DRM_MAJOR 88
+#else
+#define DRM_MAJOR 87
 #endif
+#endif /* __OpenBSD__ */

-Emil
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH libdrm v2] xf86drm: correct the OpenBSD DRM_MAJOR define
  2015-07-20 16:06 ` Emil Velikov
  2015-07-20 16:15   ` Jonathan Gray
@ 2015-07-20 17:12   ` Jonathan Gray
  1 sibling, 0 replies; 5+ messages in thread
From: Jonathan Gray @ 2015-07-20 17:12 UTC (permalink / raw)
  To: dri-devel; +Cc: emil.l.velikov

As far as I can tell no OpenBSD platform ever used 81
for a drm major.  While the value was added to libdrm in 2003
or earlier drm didn't appear in OpenBSD till 2007.

Of the OpenBSD platforms that support drm amd64/macppc/sparc64
use a major of 87, i386 uses 88.

v2: rearrange ifdefs as suggested by Emil.

Signed-off-by: Jonathan Gray <jsg@jsg.id.au>
---
 xf86drm.c | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/xf86drm.c b/xf86drm.c
index c365778..47b2af3 100644
--- a/xf86drm.c
+++ b/xf86drm.c
@@ -82,9 +82,13 @@
 #define DRM_MAJOR 34
 #endif
 
-# ifdef __OpenBSD__
-#  define DRM_MAJOR 81
-# endif
+#ifdef __OpenBSD__
+#ifdef __i386__
+#define DRM_MAJOR 88
+#else
+#define DRM_MAJOR 87
+#endif
+#endif /* __OpenBSD__ */
 
 #ifndef DRM_MAJOR
 #define DRM_MAJOR 226		/* Linux */
-- 
2.4.5

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2015-07-20 17:12 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-07-18 21:20 [PATCH libdrm] xf86drm: correct the OpenBSD DRM_MAJOR define Jonathan Gray
2015-07-20 16:06 ` Emil Velikov
2015-07-20 16:15   ` Jonathan Gray
2015-07-20 16:26     ` Emil Velikov
2015-07-20 17:12   ` [PATCH libdrm v2] " Jonathan Gray

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).