dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: Hans de Goede <hdegoede@redhat.com>
Cc: David Airlie <airlied@linux.ie>,
	Christian Kellner <ckellner@redhat.com>,
	Javier Martinez Canillas <javierm@redhat.com>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	Nitin Joshi1 <njoshi1@lenovo.com>,
	Rajat Jain <rajatja@google.com>,
	Mark Pearson <mpearson@lenovo.com>,
	Benjamin Berg <bberg@redhat.com>
Subject: Re: RFC: Drm-connector properties managed by another driver / privacy screen support
Date: Wed, 15 Apr 2020 19:54:23 +0200	[thread overview]
Message-ID: <20200415175423.GJ3456981@phenom.ffwll.local> (raw)
In-Reply-To: <794191aa-e92d-d44c-f4ff-72fd6c9bf0e7@redhat.com>

On Wed, Apr 15, 2020 at 03:02:53PM +0200, Hans de Goede wrote:
> Hi,
> 
> On 4/15/20 2:01 PM, Daniel Vetter wrote:
> > On Wed, Apr 15, 2020 at 01:39:23PM +0200, Hans de Goede wrote:
> > > Hi,
> > > 
> > > On 4/15/20 12:22 PM, Daniel Vetter wrote:
> > > > On Wed, Apr 15, 2020 at 12:11 PM Hans de Goede <hdegoede@redhat.com> wrote:
> > > > > 
> > > > > Hi,
> > > > > 
> > > > > On 4/15/20 11:52 AM, Daniel Vetter wrote:
> > > 
> > > <snip>
> > > 
> > > > > > iv. What every SoC subsystem does:
> > > > > > 
> > > > > > - lcdshadow drivers register drivers
> > > > > > - drm drivers look them up
> > > > > > - if stuff isn't there yet, we delay loading with EPROBE_DEFER until
> > > > > > the entire thing is assembled.
> > > > > > 
> > > > > > That's what we're doing already for other standardized components like
> > > > > > drm_bridge or drm_panel, and I think that's also the right approach
> > > > > > for backlight and anything else like that. Hand-rolling our own
> > > > > > EPROBE_DEFER handling, or some other duct-tape monsters imo just leads
> > > > > > to real pain. Also, with EPROBE_DEFER we have one standard way of
> > > > > > building a driver from component, which spans subsystems and is also
> > > > > > the underlying magic that makes stuff like component.c work.
> > > > > 
> > > > > On the SoCs we have devicetree telling us what components there
> > > > > are, so we can wait for them to show up. The only way to figure out
> > > > > if the lcdshadow thing is there on a ThinkPad is asking thinkpad_acpi,
> > > > > or duplicating a lot of code from thinkpad_acpi. Edit:
> > > > > also see below for a possible solution.
> > > > 
> > > > Yup it sucks. I think all we can do is have a small acpi match
> > > > function (which yes will duplicate some of the thinkpad_acpi driver
> > > > logic) to re-create that information and give us a "should we have a
> > > > lcdshadow driver for this $pci_device" answer.
> > > 
> > > Ok, so questions about this solution:
> > > 
> > > 1. Where should that match-function live ?
> > > 
> > > 2. An acpi_thinkpad derived match-function will only be able to
> > >     answer if there is an lcdshadow device/driver for the internal
> > >     panel. It will not be able to tie this info to a certain PCI
> > >     device. My plan is to pass NULL as dev_name when registering
> > >     the lcdshadow-device and have lcdshadow_get(dev, <connector-name>)
> > >     skip device-name matching (consider everything a match) for
> > >     lcdshadow-devices registered with NULL as dev_name.
> > > 
> > >     So I guess in this case the mini match function should just
> > >     ignore the passed in device?
> > 
> > Yeah I think we can't really avoid that. I also expect that we'll need
> > ACPI and dt versions of this, and driver needs to know which one to call.
> > Since at least in a dt world the driver knows exactly for which dt node it
> > needs a lcdshadow driver for (with the phandle stuff), so we can be a lot
> > more strict.
> > 
> > For the acpi version I'm not even sure we can do more than provide the
> > struct device * pointer of the gpu. I think if we ever get more than 1
> > lcdshadow driver on acpi systems we can add more stuff later on, for now
> > I'd just leave that out.
> > 
> > So maybe
> > 
> > acpi_lcdshadow_get(struct device *dev);
> > 
> > of_lcdshadow_get(struct device_node *np);
> > 
> > And with maybe a future plan to add some kind of enum or whatever to
> > acpi_lcdshadow_get(). Both would return either the lcdshadow pointer, or
> > an PTR_ERR() so that we could encode EPROBE_DEFER vs ENOENT.
> 
> Ok, note I plan to only implement the acpi version for now, I do
> expect some non ACPI/x86 devices to show up with his feature
> eventually but I believe it is best to implement this once
> those actually show up. Esp. since this will also involve adding
> some devicetree bindings for this.

ofc, just wanted to lay out the entire thing. The DT version needs some
good bikeshed on the dt schema first anyway (so that the helper can decode
that directly).

> > We might also want a low-level lcdshadow_get() which only returns ENOENT
> > when the driver isn't there, and which leaves "do we really need one?" to
> > higher levels to answer.
> 
> Right, so my latest idea on that is indeed a high-level lcdshadow_get()
> which takes a struct device * and a connector-name and which never
> returns EPROBE_DEFER.
> 
> As for leaving things to the higher levels to answer, as explained
> in my other follow-up email I think that we should probably add a
> lcdshadow_probe_defer() helper for this and call that early on
> in the PCI-driver probe functions for the 3 major x86 GPU drivers.
> Does that sound ok to you?

Uh ... not pretty. There's still a lifetime problem that strictly speaking
there's nothing stopping the other driver from getting unloaded between
your _probe_defer and the subsequent _get. I think fixing this properly
(and screaming a bit at the error code, oh well) is better.

> > I'd also lean towards putting lcdshadow headers/interfaces into
> > drivers/gpu,
> 
> Ack, I think we should even make this drm specific and prefix it with
> drm_ so that we get drm_lcdshadow_foo as functions, just to make
> clear that this is maintained together with the other drm bits.

I want to avoid the impression that I'm on an evil plan to take over the
entire world, but personally very happy with a drm_ prefix for this.

> But my question about "where should this live" was mainly about
> the light weight match helpers you suggested to use to figure out
> if the device supports lcdshadow at all (and we thus should wait
> for a driver) or not. E.g. I can see us adding a:
> 
> drivers/gpu/drm/drm_lcdshadow.c
> 
> file for the core bits and then maybe a:
> 
> drivers/gpu/drm/drm_lcdshadow_detect.c
> 
> file with the light weight match helpers, with each helper
> wrapped in #if IS_ENABLED(CONFIG_THINKPAD_ACPI), etc. ?

I'd expect it's all going to be so tiny that separate file wont make much
sense. Thus far we're simply adding the 1-2 of_ helpers to the
corresponding file, with an #ifdef CONFIG_OF around them. It's ok enough.

> > with driver implementations all over.
> 
> Ack.
> 
> Regards,
> 
> Hans
> 

Cheers, Daniel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2020-04-15 17:54 UTC|newest]

Thread overview: 54+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-15  9:42 RFC: Drm-connector properties managed by another driver / privacy screen support Hans de Goede
2020-04-15  9:52 ` Daniel Vetter
2020-04-15 10:11   ` Hans de Goede
2020-04-15 10:22     ` Daniel Vetter
2020-04-15 11:39       ` Hans de Goede
2020-04-15 11:56         ` Hans de Goede
2020-04-15 12:01         ` Daniel Vetter
2020-04-15 13:02           ` Hans de Goede
2020-04-15 17:54             ` Daniel Vetter [this message]
2020-04-15 18:19               ` Hans de Goede
2020-04-15 18:29                 ` Daniel Vetter
2020-04-15 19:50                   ` Hans de Goede
2020-04-16  6:46                     ` Daniel Vetter
2020-04-15 15:28 ` Jani Nikula
2020-04-15 15:40   ` Hans de Goede
2020-04-15 17:14     ` [External] " Mark Pearson
2020-04-15 18:06       ` Hans de Goede
2020-04-15 19:20     ` Rajat Jain
2020-04-15 21:10       ` Jani Nikula
2020-04-15 21:21         ` Hans de Goede
2020-04-15 21:51           ` [External] " Mark Pearson
2020-04-17  9:05         ` Pekka Paalanen
2020-04-17  9:02     ` Pekka Paalanen
2020-04-17 11:55       ` Jani Nikula
2020-04-17 14:18         ` Daniel Vetter
2020-04-17 14:54           ` Benjamin Berg
2020-04-21 12:37         ` Hans de Goede
2020-04-21 12:40           ` Daniel Vetter
2020-04-21 14:46           ` Pekka Paalanen
2020-04-23 18:21             ` Rajat Jain
2020-04-24  7:40               ` Pekka Paalanen
2020-04-24  8:24                 ` Hans de Goede
2020-04-24  9:08                   ` Pekka Paalanen
2020-04-24 10:32                     ` Hans de Goede
2020-04-17 14:17       ` Daniel Vetter
2020-04-20  8:27         ` Operating KMS UAPI (Re: RFC: Drm-connector properties managed by another driver / privacy screen support) Pekka Paalanen
2020-04-20 10:04           ` Pekka Paalanen
2020-04-20 10:18             ` Simon Ser
2020-04-21 12:15             ` Daniel Vetter
2020-04-21 14:33               ` Pekka Paalanen
2020-04-21 14:39                 ` Simon Ser
2020-04-23 15:01                 ` Daniel Vetter
2020-04-24  8:32                   ` Pekka Paalanen
2020-04-28 14:51                     ` Daniel Vetter
2020-04-29 10:07                       ` Pekka Paalanen
2020-04-30 13:53                         ` Daniel Vetter
2020-05-04  9:49                           ` Pekka Paalanen
2020-05-04 11:00                             ` Daniel Vetter
2020-05-04 12:22                               ` Pekka Paalanen
2020-05-05  8:48                                 ` Daniel Vetter
2020-05-07  9:03                                   ` Pekka Paalanen
2020-04-20 10:15           ` Simon Ser
2020-04-20 12:22             ` Pekka Paalanen
2020-04-20 12:33               ` Simon Ser

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200415175423.GJ3456981@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=airlied@linux.ie \
    --cc=bberg@redhat.com \
    --cc=ckellner@redhat.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=hdegoede@redhat.com \
    --cc=javierm@redhat.com \
    --cc=mpearson@lenovo.com \
    --cc=njoshi1@lenovo.com \
    --cc=rajatja@google.com \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).